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1
Overview

RFTerm allows users to connect to applications running on IBM® 3270, AS/400 and VT hosts from a Microsoft® Windows® 
equipped mobile computer over a wireless TCP/IP data network.

RFTerm can be used to directly communicate with host applications.  Users can connect and log on to the host applications 
without the need for an intermediary device.

Assumptions
This reference guide assumes you have working knowledge of:

• Microsoft Windows user interface metaphor and terminology.
• Stylus based touch screen navigation terminology.
• Basic knowledge of concepts and terms for wireless networking.
• Basic operations and requirements of the host applications you want to access with terminal emulation clients.

Conventions Used in this Guide
This guide uses the following typographical conventions:

• All user actions and interactions with the application are in bold, as in Session > Configure.
• All text associated with sample or configuration files is presented in a special font:

# This is a sample configuration file for…
# #################################################
[options]
recursion=true
silent=true
checkonly=false

Supported Devices
The following devices support RFTerm:

• Tecton (Windows CE 6.0, Windows Mobile 6.5)
• Thor VM1 (Windows CE 6.0, Windows Embedded Standard 2009)
• Thor VM2 (Windows CE 6.0, Windows Embedded Standard 2009, Windows 7, Windows Embedded Standard 7)
• Thor VM3 (Windows Embedded Compact 7, Windows 7, Windows Embedded Standard 7, Windows 10)
• Thor VX8 and Thor VX9 (Windows XP, Windows 7, Windows Embedded Standard 2009)
• Marathon (Windows XP, Windows 7, Windows Embedded Standard 2009)
• Dolphin 70e Black (Windows Embedded Handheld 6.5) as part of the Honeywell Wearable Solution

RFTerm was also supported on several obsolete devices.  Keymaps for obsolete devices may be included in Key Maps (page 9-
1).
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About RFTerm
Information about RFTerm can be viewed by selecting File > About.

The About screen contains important information about RFTerm, including:

• The platform on which RFTerm is installed (Windows XP, Windows CE, etc)
• The revision level of RFTerm
• Copyrights and licensing information.  Click the PuTTY License button, if present, to display the PuTTY License (PuTTY is 

used for SSH).

Click the OK button to dismiss the About screen.

Feature Highlights

SSH Protocol
When using Secure Shell (SSH), a connection is established to an SSH server and Telnet traffic is tunneled or port for-
warded through the SSH connection.  RFTerm supports SSH version 2.

For outgoing traffic from RFTerm:

• SSH client (built into RFTerm) listens on a local IP port for Telnet traffic
• SSH client encrypts the Telnet traffic and sends it to the SSH server
• The SSH server decrypts the Telnet traffic and forwards the traffic to the Telnet host.

For incoming traffic to RFTerm:

• The SSH server receives Telnet traffic from the host application, encrypts the traffic and sends it to the SSH client (built 
into RFTerm)

• The SSH client decrypts the traffic and passes it to the RFTerm Telnet session.  

Encryption methods are auto negotiated between the client software (RFTerm) and the SSH server.  Supported encryption 
methods include:

• AES (Rijndael) - 256, 192, or 128-bit SDCTR or CBC 
• Arcfour (RC4) - 256 or 128-bit stream cipher 
• Blowfish - 256-bit SDCTR or 128-bit CBC 
• Triple-DES - 168-bit SDCTR or CBC 
• Single-DES - 56-bit CBC 

Note: Arcfour and Single DES are not very secure.  A warning box is displayed if either of these encryption methods is 
selected.

There are two message boxes that may be displayed for SSH server host keys:

• If the key does not exist in the registry, a message box asks if you want to add the key and connect to the SSH server.
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• A message box is displayed if the SSH server host key changes.

If SSH is not enabled, transmission is over an unencrypted Telnet connection.

Multiple Host Sessions
RFTerm supports up to four simultaneous pre-defined host sessions.  All sessions run under a single application process.  
Interactive, per session configuration settings are maintained.  Users may connect with any permutation of 3270, 5250 or 
VT host sessions.  HotKeys and menu context are available to jump between these sessions.  

Swapping Between Sessions
Various HotKeys are defined to allow the user to swap to a specified session or to jump to the next connected session.

A Session Menu can be enabled to display information on configured sessions.

HotSpots
A HotSpot is an invisible field on the mobile client screen where a user can tap with a stylus to execute a function.  A 
HotSpot allows a user to interact with the host application with minimal need for the special key pads.  Instead the user can 
directly tap on the text in the display to invoke the desired operation.  

Screen Panning
Panning allows an additional row and column on the display by providing an alternative to horizontal and vertical scroll bars.  
Imagine the host application screen as a large sheet under the display on the hand-held device.  Screen Panning allows 
users to “tap” and “drag” this sheet in any direction to move hidden areas of the host display into view on the hand-held 
device without the use of scroll bars.

Configurable KeyBar
The configurable KeyBar allows users to customize a set of soft buttons to control and invoke any host specific keys or 
emulator operation.  Users can select from a set of pre-defined KeyBar templates.  In addition they can also configure up to 
four custom templates of their own.  Users can navigate between a selected set of templates.

SmartPads
All host applications have specific keyboard requirements.  The SmartPad is a floating button pad which provides support 
for special emulation host keys.  Depending upon the current configured host emulation type, the appropriate SmartPad for 
that emulation is displayed.  The SmartPad supports all the popular 3270, 5250 and VT host keys.

Note: This option is not available devices with a Microsoft® Windows XP, Windows 7, Windows 10, or Windows Embedded 
Standard operating system.

Access Control
Access Control allows administrators to prevent users from changing the TE configuration for deployed devices.  Adminis-
trators can require a password to change the session configuration and application settings.  

Device Lockdown
Lockdown allows administrators to prevent users from exiting the TE client.  Lockdown also prevents users from running 
any other application on the device.

Configurable Fonts
This option allows users to increase or decrease the font sizes of displayed text.

Color Schemes
Support for color displays.  A color scheme is a collection of colors mapped to a set of screen display attributes.  Users can 
select from pre-defined color schemes or create a custom scheme based upon their preferences.  Applications dynamically 
detect LCD displays to self configure for a two color scheme (Black on White).
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Automatic Login
Users can configure one or more host sessions to automatically launch when the TE application is started.  Pre-defined 
login scripts can be configured to launch automatically and log into the host system.  

Automatic Session Persistence
Latest values of session configuration are automatically saved for every session.  

Dynamic Cursor View Modes
Multiple cursor modes are available to support automatic scrolling, so that the cursor / input field is visible.  These view 
modes are configurable on a per client session basis.  The screen display window will “track” and follow the cursor.  

Text InputTool
The Text InputTool improves upon the typical Windows CE/Windows Embedded Compact soft keypad by sending complete 
text strings to the display window at the current cursor location.  A user can cache often-used text strings in the InputTool.

Note: This option is not available devices with a Microsoft® Windows XP, Windows 7, Windows 10, or Windows Embedded 
Standard operating system.

Device / LU Name Support
For IBM emulations (3270 and 5250), logical unit device name resource configuration is supported.  This is used during 
connection negotiations.

Automatic Re-connection
If for some reason the network connection to the host is lost, the user can configure the session to automatically attempt to 
re-connect to the host.

Full VT220 Support
This includes support for multinational character sets and NRC support.  

VT Line Mode
This is a special optimization for VT host sessions.  Data is buffered locally within the device prior to sending it to the host.  
Line mode optimizes usage of the network bandwidth and host resources.

VT Answerback String
This is a configurable text string that certain host applications require to identify the mobile client.  

HotKeys
Predefined HotKeys, shortcuts, are available to interact with and invoke application operations.

Block Mode
Block mode communication is a communication mode that enables the device to send an entire block of data to the host at 
one time.  Block mode greatly reduces RF traffic by sending data in this way.  Block mode minimizes RF overhead better 
than the other modes.  Thus, block mode supports more users on an RF channel and allows faster response time.

Local echo is a process that allows each character to display locally at the device as the user presses the keys.  The host 
does not see these characters until the user presses the [Enter] key.

Note: In most cases, operations using programming tools that include screen painters cannot use block mode 
communication.  Screen painters or designers usually come with programming tools such as Oracle, Ingress, 
Informix, and Powerhouse, which normally use character mode communications.

Programmable Function Keys
User can configure all available function keys, and the 4 arrow keys, to perform text and control character inputs.  Control 
characters and characters not accessible from the keyboard can be represented using Hat Encoding (page 6-7).
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Printing
User can print the screen for any session using the shortcut key [Ctrl] [Alt] [P], or by sending print commands to the client 
from the host in 5250 and ANSI sessions.

Help
User can display frequently used RFTerm shortcut keys and support contact information by pressing [Ctrl] [H].

Double Byte Support
RFTerm supports Simplified Chinese, Traditional Chinese, Korean and Japanese font sets for VT emulations based upon 
TELNET data being received in standard DBCS format.

Installation
To verify the version of RFTerm currently installed, see the About RFTerm (page 1-2) panel.

Your device may require special installation procedures.  Review the information below for details.

Installation Note
Evaluation copies of RFTerm allow the user to Connect eleven (11) times.  The Software License Agreement dialog 
appears after each connect request and before the connection is activated.  Select either Accept or Reject to continue.  
When the counter reaches 0, you cannot use the RFTerm Connect function until the evaluation version of RFTerm is acti-
vated.

Initial Installation (Windows CE, Windows Embedded Compact, or Windows Mobile)
For devices with a Windows CE, Windows Embedded Compact, or Windows Mobile operating system, use the procedures 
listed below.  RFTerm may already be installed on the device.

1. Launch the RFTerm cab file.

2. Launch RFTerm to complete the installation.  

Note: For RFTerm to persist after a device restart, place the RFTerm.cab file in the \System folder.

Upgrading from an Earlier Version of RFTerm 
When you upgrade RFTerm to a new release version, you must begin with a clean registry.  Use the procedures listed 
below for devices equipped with Windows CE, Windows Embedded Compact, or Windows Mobile.

1. Exit RFTerm if it is currently running.

2. Open the registry editor.

3. Delete the entire registry key HKEY_LOCAL_MACHINE\SOFTWARE\LXE\RFTerm.

4. Do not delete the LXE key or any other items under it except RFTerm.

5. Launch the RFTerm cab file.

6. Launch RFTerm to complete the installation.  

Installation (All Other Windows Operating Systems)
For devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard operating system, the following 
steps must be taken to ensure RFTerm can read and write to the registry before initial installation or upgrading to a newer 
revision:

1. Log on as the Administrator.

2. Open the registry editor.

3. Delete the entire registry key HKEY_LOCAL_MACHINE\SOFTWARE\HSM\RFTerm or 
HKEY_LOCAL_MACHINE\SOFTWARE\LXE\RFTerm (key name/location depends on equipment type and RFTerm 
revision level).
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4. Do not delete the HSM or LXE key or any other items under it except RFTerm.

5. Browse to the location of the RFTermSetupWN.msi file, double-click on the file and follow the setup wizard prompts.

6. Launch RFTerm for the initial time as the administrator.  For devices with Windows 7, Windows Embedded Standard 7, 
or Windows 10 right click on the RFTerm icon and select Run as administrator.

7. This will create the RFTerm registry with guest privileges.

Quick Start
This section is for advanced users who can comfortably navigate within Windows and Windows CE and are familiar with host 
terminal emulation details.  Follow these steps to connect to your host application with minimal configuration setup.  For details 
on various configuration parameters, it is recommended that you read through the following sections.

1. Make sure the mobile network settings are configured.  If you are connecting over wireless LAN, make sure your device is 
communicating with the Access Point.  If you are connecting via WWAN, make sure your device has an active connection.  
Details on configuring the mobile network settings can be found in the reference guide for the mobile device.

2. If the RFTerm splash screen does not automatically appear after startup or rebooting, go to Start > Programs, and select 
Honeywell RFTerm or double-click the RFTerm icon on the Windows desktop.

3. Select Session > Configure from the application menu and select the Host Type that you require.  This will depend on the 
type of host system that you are trying to connect to; i.e.  3270 mainframe, AS/400 5250 server or VT host.  

4. Enter the Host Address of the host system to which you wish to connect.  This may either be a DNS name or an IP address 
of the host system.

5. Update the Telnet Port number, if your host application is configured to listen on a specific port.  If not, just use the default 
Telnet port.

6. Select OK.

7. Select Session > Connect from the application menu or tap the Connect button on the Command Bar.  Upon a successful 
connection, you should see the host application screen displayed.  

8. During the connection process, the following popup dialog appears:
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RFTerm Screen Sizes
The RFTerm screen displays are designed to function on most Windows-based computers, regardless of the physical 
screen size.

RFTerm menus and editing parameters, save and exit options are available on-screen, where needed, regardless of the 
size of the screen.  On-screen they may look or be named differently from one device to the other yet they will perform the 
same function when activated.

RFTerm uses a one-quarter screen, switchable 
between horizontal or vertical orientation on the 
Windows Embedded Handheld equipped Dolphin 
70e Black.

RFTerm uses a one-quarter screen, horizontally 
oriented on the HX2.

RFTerm uses a one-quarter screen, vertically 
oriented on the Windows CE equipped MX7 Tecton, 
MX8 and MX9.

RFTerm uses a one-quarter screen, vertically 
oriented on the Windows Mobile equipped MX7 
Tecton, MX8 and MX9.
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This guide makes the assumption that the user or systems administrator is familiar with Microsoft Windows standard navi-
gation/performance for each of their devices running RFTerm.

Therefore, the sections that follow describe only those Windows capabilities that are unique to RFTerm.

Important Notes
For Devices with a Windows Mobile or Windows Embedded Handheld operating system:

• The MenuBar is displayed at the bottom of the Windows Mobile screen and cannot be led to the top of the screen.
• By default, the KeyBar is hidden but can be accessed from the MenuBar using the KeyBar icon.
• When accessed, the KeyBar is displayed above the MenuBar.  Clicking the KeyBar icon again hides the KeyBar.
• The ToolBar is not available on devices with a Windows Mobile operating system.

For Devices with a Windows XP, Windows 7, Windos 10, or Windows Embedded Standard operating system:

• SmartPads, Text InputTool, and Hide/Display All Bars are not available on devices with a Windows XP, Windows 7 or 
Windows Embedded Standard operating system.

• The MenuBar is displayed at the top of the screen for these devices and cannot be led to the bottom of the screen.

RFTerm uses a one-half screen, horizontally oriented 
on the MX3Plus, MX3X, VX3Plus, VX3X and VX6.

RFTerm uses a full screen on the Thor VM2, Thor 
VM3, VX7, Thor VX8 and Thor VX9.

RFTerm uses a WVGA full screen on the Thor VM1 
and Marathon.
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Quick Tips
Screen Panning
• For all connected sessions (3270, 5250 and VT), you can “tap-and-drag” the display screen in any direction with your 

stylus.  Just make sure that HotSpots are enabled in Options1 (page 2-6).

HotSpots
• For all connected sessions (3270, 5250 and VT), you can “double tap” anywhere on the screen to invoke an Enter 

(or Send) operation.
• To use HotSpots, you can directly tap the function key text string on the display rather than use a SmartPad.  Refer 

to HotSpots (page 4-10) for details.

Predefined HotKeys (Shortcuts)
• Almost every application operation has a HotKey associated with it.  HotKeys provide an efficient alternative to 

invoke an operation or action.  Refer to HotKey Shortcuts (page 4-12).

Readability
• For more screen real estate, you can minimize the application menu.  You can also move open windows to anywhere 

on the screen (unless the windows are locked to prevent edit).
• You can select different background, foreground and attribute colors for enhanced visual readability.  For mobile 

clients with LCD display screens, the default color scheme is automatically detected and configured to “Bright White” 
for optimal readability.

Data Input
• If you have the same data strings that you input all the time, you can cache it in the data input tool.  You can then 

“send” the text string to the emulator with a single stylus tap.  Refer toText InputTool (page 4-8).

Note: This option is not available on devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded 
Standard operating system.

Configurable KeyBar
• The soft KeyBar can be configured to perform most emulator and host operations with a single stylus tap.  Refer to 

Configurable KeyBar (page 4-4).

Access Control
• You can prevent a user from changing the TE configuration by specifying an access password.  Refer to Access 

Control / Device Lockdown (page 4-11).

Application ToolBar
• An integrated ToolBar is provided for touch screen navigation.  
• Refer to RFTerm ToolBar (page 9-1) to identify the function for the icons that are included in the different application 

touch KeyBars.

Miscellaneous
• The RFTerm emulator will automatically save configuration settings for the four most recent sessions, S1 - S4 as 

displayed in the menu.  The configuration settings are saved in the mobile client registry.  Refer to the mobile client 
reference guide for instruction.

• To launch RFTerm automatically, refer to the reference guide for the device.
• Support tools and procedures are available to provide deployment configurations to self-install and restore 

application and mobile client configurations during a cold boot.  
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2
RFTerm Settings

This section describes application wide settings.  All these parameters may be set using the application settings dialogs 
accessed from the File > Settings application menu.  Parameters configured through the File > Settings dialog apply to all ter-
minal emulation sessions.

Display
The client screen display may be configured to optimize screen available area and readability.  These options may be configured 
for connected or non-connected host sessions.  HotKeys are available to le the options on and off.  

• From the application menu, select File > Settings.
• A Settings dialog box is displayed.  
• Choose the Display tab.  

Parameters
Menu

ToolBars, KeyBars, Shortcut Keys and Windows Mobile
By default, the ToolBar button function is configured as part of the KeyBar on devices with a Windows Mobile oper-
ating system so the checkbox for the ToolBar does not exist on the Settings > Display tab.  

ToolBar buttons can be removed from the KeyBar on devices with a Windows Mobile operating system.

ToolBar buttons can be hidden by using [Ctrl][Shift][K] which makes the entire KeyBar hidden on devices with a 
Windows Mobile operating system.

The Hide ToolBar shortcut key [Ctrl][Shift][T] is not available on devices with a Windows Mobile operating sys-
tem.

Hide All Bars
Checking this box will hide the file menu, the KeyBar and the ToolBar.  Pressing [Ctrl][Shift][L] alternates 
between the hidden and visible states.  This will override each individual item listed below.  

Not available on devices with a Windows Mobile operating system.

For Microsoft Windows 7, Windows Embedded 7, and Windows 10:

It is necessary to run to run RFTerm as an administrator when modifying these settings because RFTerm must be able to 
access and make changes to the Windows registry.  

Rather than selecting to run as administrator each time, right click on the RFTerm  icon and select Properties.  Tap the 
Compatibility tab and check Run this program as an administrator.  This modification affects the current user only un-
less Change settings for all users is tapped before changing the privilege level.

!
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Disable/Hide MenuBar
Checking this box will hide the MenuBar on devices with a Windows CE or Windows Embedded Compact operat-
ing system.  Pressing [Ctrl][Shift][M] alternates between the hidden and visible states.  

When the MenuBar is hidden, the KeyBar is displayed on the bottom row, where the MenuBar is normally shown.  
When MenuBar is led on, the KeyBar is displayed on the row above the MenuBar.

Checking this box disables the MenuBar on devices with a Microsoft Windows XP, Windows 7, Windows 10, or 
Windows Embedded Standard operating system.

Note: This parameter is titled Disable MenuBar on devices with a Microsoft Windows XP, Windows 7, Windows 
10, or Windows Embedded Standard operating system and Hide MenuBar on devices with a Windows CE, 
Windows Embedded Compact, or Windows Mobile operating system.  

Hide KeyBar
Checking this box will hide the KeyBar.  The default is checked (hide KeyBar).  Click the K icon on the MenuBar to 
launch the KeyBar.  Pressing [Ctrl][Shift][K] will alternate between the hidden and visible states.  

When the MenuBar is hidden, the KeyBar is displayed on the bottom row, where the MenuBar is normally shown.  
When MenuBar is led on, the KeyBar is displayed on the row above the MenuBar.

On devices equipped with Windows Mobile, the ToolBar buttons can be hidden by using [Ctrl][Shift][K] and the 
entire KeyBar is hidden on these devices.

Hide ToolBar
Checking this box will hide the ToolBar.  Pressing [Ctrl][Shift][T] alternates between the hidden and visible states.

Not available on devices with a Windows Mobile operating system.

(Menu) at Bottom
Checking this box will move the menu to the bottom of the screen.  Pressing [Ctrl][Shift][B] alternates the loca-
tion between the top and bottom of the screen.

Note: This option is not available on devices with a Microsoft Windows XP, Windows 7, Window 10, or Windows 
Embedded Standard operating system.

Hide OIA (IBM only)
Checking this box will le hiding of the OIA or the Operator Information Area.  This option applies only to IBM 3270 
and 5250 emulations.  

Pressing [Ctrl][Shift][O] or [Alt] [T] alternates between the hidden and visible states.  

Scroll Bars
Hide Vertical Scroll Bars
Checking this box will hide the vertical scroll bar.  Pressing [Ctrl][Shift][V] alternates between the hide and visible 
states.

Hide Horizontal Scroll Bars
Checking this box will hide the horizontal scroll bar.  Pressing [Ctrl][Shift][H] alternates between the hide and vis-
ible states.

Disable Touch Screen
When checked, this option prevents the user from inadvertently moving the cursor via the touch screen.  The touch 
screen within the RFTerm display portion of the screen is disabled while still allowing RFTerm HotSpots to function 
using touch.  Items such as scroll bars and menu items still are accessible via the touch screen.  

The default value for Disable Touch Screen is “Not Disabled” (blank).
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Shortcuts
Keypress shortcuts can be enabled or disabled from the Shortcuts tab.

• All shortcut keys can be enabled or disabled at once.  Shortcut keys can be disabled or enabled individually as well.  

• From the application menu, select File > Settings.
• A Settings dialog box is displayed.  
• Choose the Shortcuts tab 

Parameters
Jump to Inactive Sessions
When the Jump to Inactive Sessions item is selected, the user can use the shortcut key sequence [Ctrl] [Shift] [J] to 
jump to an inactive session that has a host name specified.  The inactive session remains dormant when discon-
nected, but when it becomes the active session again, it automatically attempts to reconnect and run the Autologin 
script.

Disable Shortcut Keys
When the Disable Shortcut Keys item is checked, RFTerm prevents the user from accessing all shortcut keys with the 
exception of Session, Configure and Application Exit shortcut keys.  This also activates the “Allow Session Shortcuts” 
check box.  F1, F2, F3, and F4 function keys remain active.  Refer to RFTerm ToolBar (page 9-1) for a complete list of 
RFTerm shortcut keys.

Buttons
Select All
Click this button to disable all shortcut keys, in the list, at once.  Click a shortcut key checkbox to enable the 
individual shortcut while the rest remain disabled (checked).  The Select All button has no effect on the Jump 
to Inactive Sessions checkbox.

Clear All
Click this button to enable all shortcut keys, in the list, at once.  Click a shortcut key checkbox to disable 
(check) the individual shortcut while the rest remain enabled.  The Clear All button has no effect on the Jump 
to Inactive Sessions checkbox.
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Shortcuts Active Until Disabled
The shortcut is disabled when the checkbox has a check mark.  Refer to HotKey Shortcuts (page 4-12) for a com-
plete list of default HotKeys.  

Note: Depending on mobile client screen size constraints, the parameter name may be abbreviated based on the 
parameter names shown in the list that follows.  

Parameter Shortcut Key Description

Configure [Ctrl][Shift][N] Configure a host connection

Settings [Ctrl][Shift][E] Configure application settings.

Connect [Ctrl][Shift][C] Connect to the host 
(Manual Reconnect shortcut)

Status [Ctrl][Shift][2] Display or hide Status Window.
(Not supported on Windows Mobile)

Decrease Font [Ctrl][Shift][Down Arrow] Decrease font size

Disconnect [Ctrl][Shift][D] Disconnect a connected host session 
(Manual Disconnect shortcut)

le HScroll [Ctrl][Shift][H] Display or hide horizontal scroll bar

le SmartPad [Ctrl][Shift][P] Display or hide SmartPad
(Not supported on Windows XP, Windows 7, Windows 10, 
or Windows Embedded Standard)

le InputPad [Ctrl][Shift][I] Display or hide Text InputTool
(Not supported on Windows XP, Windows 7, Windows 10, 
or Windows Embedded Standard)

le MenuBar [Ctrl][Shift][M] Display or hide MenuBar
(Not supported on Windows XP, Windows 7, Windows 10, 
or Windows Embedded Standard)

Move All Bars [Ctrl][Shift][B] Display all bars at the bottom
(Not supported on Windows XP, Windows 7, Windows 10, 
or Windows Embedded Standard)

le All Bars [Ctrl][Shift][L] Display or Hide all bars (Menu, Tool, Key)

le ToolBar [Ctrl][Shift][T] Display or Hide ToolBar

le KeyBar [Ctrl][Shift][K] Display or Hide KeyBar

le VScroll [Ctrl][Shift][V] Display or Hide vertical scroll bar

Increase Font [Ctrl][Shift][Up Arrow] Increase font size

Next Session [Ctrl][Shift][J] Jump to next connected host 
(Session Control shortcut)

Scroll Down [Shift][Down Arrow] Scroll down one row

Scroll Left [Shift][Left Arrow] Scroll left one column

Scroll Right [Shift][Right Arrow] Scroll right one column

Scroll Up [Shift][Up Arrow] Scroll up one row

le Bold [Ctrl][Shift][1] le between bold and normal font

Print Screen [Ctrl][Alt][P] Print the screen of the active session

Program Help [Ctrl][H] Display frequently used shortcuts

Jump to Session 1 [Ctrl][Alt][1] Jump to Session 1

Jump to Session 2 [Ctrl][Alt][2] Jump to Session 2

Jump to Session 3 [Ctrl][Alt][3] Jump to Session 3

Jump to Session 4 [Ctrl][Alt][4] Jump to Session 4
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Note: Depending on the mobile device screen and font size constraints, the segment area used by an Advance 
Down, Advance Left, Advance Right or Advance Up key sequence is approximately one-quarter of the total 
area available.

Show Session Menu [Ctrl][Alt][0] Display Session Host Menu (if enabled) over top of a 
connected session

Session Save [Ctrl][Shift][S] Invoke the session save dialog

Exit RFTerm [Ctrl][Shift][X] Exit the emulator

le OIA Bar [Ctrl][Shift][O] or [Alt][T] Hide and unhide status bar (OIA)

Advance Down [Ctrl][Down Arrow] Scroll down one row segment (see Note below)

Advance Left [Ctrl][Left Arrow] Scroll left one column segment (see Note below)

Advance Right [Ctrl][Right Arrow] Scroll right one column segment (see Note below)

Advance Up [Ctrl][Up Arrow] Scroll up one row segment (see Note below)

le Status [Ctrl][Shift][2] Display or hide status icons
(must be enabled on the Settings > Status tab first)
(Not supported on Windows Mobile, Windows XP, Windows 
7, Windows 10, or Windows Embedded Standard)

Parameter Shortcut Key Description
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Options1
General options may be configured and updated from the Options1 tab.

Note: This tab was previously labeled Options.

• From the application menu, select File > Settings.
• A Settings dialog box is displayed.  
• Choose the Options1 tab 

Parameters
Access Control

Hide Start Menu 
When the Hide Start Menu item is selected, RFTerm prevents the user from accessing functionalities within the 
task bar.

With Windows XP, Windows 7, Windows 10, or Windows Embedded Standard
This feature makes the application full-screen and also disables window resizing.

While this option hides the Start Menu, it cannot prevent the user from accessing the Start Menu via the Win-
dows key.

With Windows Mobile
When the Hide Start Menu / Disable Start Menu item is selected, neither the Start Menu nor the OK button 
responds to a stylus tap.  Use an Enter keypress to close the Settings and Configure window.

Disable App Exit 
When enabled, this option disables the application exit button and the [Alt][X] shortcut key.  This prevents the user 
from exiting the application.  

Exit Now 
This button is enabled only when the Disable App Exit option is checked.  It allows the administrator to save the 
configuration and exit when Disable App Exit is checked.  Typical use would be for an administrator to set all con-
figuration settings including a config password and exit the application using this button.  Subsequently, users will 
not be able to exit the application and the config password will be required to change the configuration.  

Config Password 
The Config Password button prompts the user for a dialog access password.  When a password is set, users must 
enter this password prior to viewing and modifying the session and settings configuration.  This capability enables 
administrators to prevent users from changing the application configuration settings in controlled environments.
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Confirm Disconnect
When enabled, the user is prompted before every attempt to disconnect an active session.

Enable HotSpots
Checking this box will enable HotSpots and Screen Panning on mobile clients with touch screens.  A HotSpot is a field 
on the screen where a user can tap with a stylus to execute a function.  This allows a user to interact with a host appli-
cation with minimal need for special keys.  Checking this box is a requirement for the Enlarge HotSpots parameter.

For example

A simple example might be the use of F Keys.  An operation associated with an F key might be displayed on the screen 
as “F1 = Help”.  RFTerm automatically detects this as a HotSpot and will simulate an F1 key being pressed on the key-
board when you tap on the F1 text on the screen display.  Refer to HotSpots (page 4-10) for further details.

Note: Reprogramming the function keys using the Fn Keys tab under the Configure dialog alters the operation of a 
function key HotSpot.  

Enlarge HotSpots
Prerequisite:

Enable HotSpots must be enabled (checked).

Checking this box increases the size of the HotSpot area, slightly, radiating from the center of the HotSpot.  If a screen 
does not have a HotSpot area, this parameter setting is ignored until a screen is presented that has a HotSpot area.  
For example, enlarging the HotSpot area may assist clicking the correct HotSpot even if the mobile client is being jos-
tled by outside influences.

When Enable HotSpots is disabled, the Enlarge HotSpots parameter is dimmed and cannot be activated.

Check Network Status
This setting determines if RFTerm continuously monitors the network connection.

Note: This option is not available on devices equipped with a Windows Mobile or Windows Embedded Handheld 
operating system.

If the checkbox is checked (enabled) RFTerm polls the network adapter every two seconds to verify the network status.  
If the network adapter is not connected, a dialog box is displayed.  

Two conditions must be present for network polling to occur:

1. The Check Network Status checkbox must be checked.

2. There must be at least one active session.  

There is no user input on the popup notification.  The popup box is displayed until the network connection is re-estab-
lished and the user is restricted from entering any data into or exiting from RFTerm while the notification is present.  
Once network connection is reestablished, the notification automatically is dismissed.

If the checkbox is unchecked (disabled) RFTerm does not monitor the network connection.  The Out of Range notifica-
tion is not displayed until a data transmission fails.  This is the default selection.
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The user is present with a popup dialog.  The Retry button attempts to reconnect to the network.  The Cancel button 
exits RFTerm.

Note: There is no Cancel button if the application is locked down by disabling application exit and/or by hiding the start 
menu.  You must either re-establish the connection to the host or have the administrator intervene.

Disable Scan On Exit Focus
When checked, this option turns off the scanner when RFTerm is no longer the application in focus.  When RFTerm 
returns to focus, the scanner is turned back on.

When disabled, the scanner remains active at all times.

The default is disabled.

KeyBars
This button is used to configure the KeyBar.  KeyBar configuration consists of both the KeyBar Cycle and any Custom 
KeyBars.  The KeyBar function keys can be reprogrammed using the Fn Keys tab under the Configure dialog.

Note: The KeyBars button was previously labeled Config Keys.

KeyBar Cycle
A KeyBar is the set of keys visible at one time.  The KeyBar Cycle is a collection of KeyBars that can be visible.  
The user “cycles” through the collection of KeyBars by tapping the arrow buttons on either end of the current Key-
Bar.  Each key on the KeyBar is associated with a host or emulator operation.  Users are allowed a maximum of 
eighteen KeyBars, four of which can be customized.  The same KeyBar may be added multiple times to the Key-
Bar Cycle.  

Custom Bar
A Custom KeyBar (Custom Keys 1 through Custom Keys 4) can also be included in the KeyBar Cycle.  Tapping 
the Custom Bar tab allows the user to configure a custom KeyBar.  There are over 180 buttons to choose from, 
refer to RFTerm ToolBar (page 9-1) for available choices.



2 - 9

To edit a Custom KeyBar

• In the KeyBar Cycle tab, add a Custom Bar to the KeyBar Cycle
• In the Custom Bar tab, select the Custom Bar that you want to configure
• Select the Key or operation that you want to appear on this custom bar
• Tap Add to Above.  The selected key / operation will appear in the list.
• Delete unwanted keys by selecting them and tapping Delete.

You can add up to a maximum of 8 key buttons on each Custom Bar (fewer on some devices).  The entry for Pre-
vious KeyBar cannot be removed and must exist in each KeyBar to allow for “cycling” between KeyBars.  Typi-
cally, the last key should be Next KeyBar for cycling to the next KeyBar.

One powerful capability of the KeyBar is the ability to associate keys with the Text InputTool.  Key entries Input 1 
through Input 20 are tied to the corresponding twenty entries in the Text InputTool.  Thus if you have a text string 
configured in the data input tool, this string can be submitted to the host application by tapping on the Input X key 
in a Custom KeyBar.  Tapping this key will send the complete text string to the current cursor location.  For VT cli-
ent sessions, escape sequences can be added to the Text InputTool text.  This allows users to configure custom 
escape sequences as required by their host applications.

Escape sequences can be entered into the Text InputTool in the following format:

\e = Escape
\n = Newline
\r = Enter or Return
\t = Tab
\xDD = Hexadecimal value

Note: The list of keys that are available for a Custom KeyBar includes “Escape”.  The Escape icon is identical for 
VT Escape and 3270 Escape, both listed in RFTerm ToolBar (page 9-1) icon listing.  When setting up a 
Custom KeyBar for VT or IBM, and VT Escape or 3270 Escape is required, select the “Escape” icon.
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Options2
Determines the behavior of RFTerm in certain circumstances.

• From the application menu, select File > Settings.
• A Settings dialog box is displayed.  
• Choose the Options2 tab 

Parameters
Respond DONT encryption
Determines the behavior of RFTerm response to WILL encryption.

• When checked, RFTerm responds DONT.
• When unchecked, RFTerm responds WONT.

The default is unchecked (WONT).

Focus Control
Determines if RFTerm remains the focus window when another dialog attempts to grab focus.

• Normal - RFTerm does not override.  (default)
• Foreground - RFTerm forces the focus back to RFTerm if a “Backup Battery Low” dialog grabs focus.

Script File
Note: This option pertains to the Marathon computer with all available operating systems.  This parameter has no effect 

on other devices.

If Freefloat Link One is not active (or not installed) an error message may be displayed when trying to set this option.

• Specify the script file used to determine the Freefloat Link One wedge mode.
• Using Default script.txt - The script file provided with Freefloat Link One is used.  Only Keyboard mode may be 

selected for the wedge when this script file is used.  (default)
• Using RFTerm script.txt - The RFTerm script file is used.  Either Keyboard or Subscriber/Block mode may be 

selected for the wedge when this script file is used.  
• Copy RFTerm script.txt - Selecting this option copies the RFTerm supplied script.txt over the currently used 

script.txt file.  If the copy fails, an error message is displayed.

To use the RFTerm script file:

1. Select the Copy RFTerm script.txt option.

2. Confirm that you wish to copy the file and select Start > Shutdown > Restart when propmted to reboot the RFTerm.

3. After the RFTerm has restarted, return to this screen and verify Using RFTerm script.txt is selected.  If not, select it.
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4. The Wedge Mode (see below) can now be changed as desired.

Wedge Mode
Note: Freefloat Link One Wedge is used on the Thor VM1 and Thor VM2 equipped with a Windows Embedded 

Standard Operating System and all Marathon operating systems.  This parameter has no effect on other devices.

Determines the mode for the Freefloat Link One wedge.

• Keyboard - Data from the integrated scanner is passed through the keyboard buffer.  This is the only option available 
if the default script.txt is selected.  (default)

• Subscriber/Block - Data from the scanner is transmitted in subscriber/block mode.  This method can be much faster 
than keyboard mode.  Using RFTerm script.txt must be selected first or an error is displayed and the remains in 
Keyboard mode.

Spcl Settings
This feature is designed for Honeywell support debugging use only.
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Options3
Allows the size and position of the RFTerm window to be specified.  By default, RFTerm is displayed in a full window.

Note: This tab was previously labeled Win Size.

Note: There are no configurable options on this screen for devices equipped with a Windows Mobile, Windows XP, Windows 7, 
Windows 10, or Windows Embedded Standard operating system.  Window Size cannot be adjusted for these devices.

• From the application menu, select File > Settings.
• A Settings dialog box is displayed.  
• Choose the Options3 tab 

By default, RFTerm is displayed in a full window (all four settings are 0).  There is no error checking for the specified ranges 
except:

• Valid entries for each parameter are 0 through 999
• The smallest window size is 60x60 pixels regardless of the specified values.

Parameters
Origin X
Specifies the number of pixels to the right of the left origin point to place the left edge of the RFTerm window.  Valid 
entries are 0 through 999.  Default is 0.
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Origin Y
Specifies the number of pixels below the top origin point to place the top edge of the RFTerm window.  Valid entries are 
0 through 999.  Default is 0.

Width Reduction
Specifies the number of pixels to the left of the right side screen limit to place the right edge of the RFTerm window.  
Valid entries are 0 through 999.  Default is 0.

Height Reduction
Specifies the number of pixels above the bottom screen limit to place the bottom edge of the RFTerm window.  Valid 
entries are 0 through 999.  Default is 0.

Virtual Keyboard
Dolphin 70e Black only.

Determines the format of the virtual keyboard to be displayed.  In addition to the traditional Windows SIP, the Dolphin 
70e Black supports several custom virtual keyboards:

• None - Do not display a virtual keyboard
• Num Left - Display a numeric only virtual keyboard on the left side of the screen
• Num Right - Display a numeric only virtual keyboard on the left side of the screen
• Qwerty - Display a QWERTY virtual keyboard
• Emulator - Display an HX2-style virtual keyboard
• SIP - Default.   Display the standard Windows SIP.

Note: The host can also send commands to switch the virtual keyboard.  See Virtual Keyboards (page 9-12).

VK Orientation
Dolphin 70e Black only.

Determines the orientation of the display:

• 0 Deg - Display is not rotated (portrait mode).
• 90 Deg - Display is rotated 90º (landscape mode).
• 180 Deg - Display is rotated 180º (portrait mode).
• 270 Deg - Display is rotated 270º (landscape mode).

Note: Display orientation can also be set outside of RFTerm using the Dolphin Power Tools.
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Sounds
Sounds may be configured for various events.

The Alarm on Match Text only sounds when a form is sent to RFTerm from the host.  Entering data or moving the cursor around 
on the screen does not cause extra beeps when the alarm text remains unchanged.  When the user exits and then returns to the 
Alarm on Match Text menu, another beep will occur.

Note: Before selecting a user-installed sound or WAV file to be played on a mobile client, the appropriate WAV file or sound file 
must be available in the mobile device operating system persistent folder on the storage card.  This will ensure the WAV 
file is saved instead of discarded when the device is rebooted.

If there is no WAV file in the folder, the text boxes are blank.  When there is a WAV file in the folder, the Good Beep/Bad Beep 
and Alarm Sound drop down boxes are preset with the default value <DEFAULT> until changed.  

• From the application menu, select File > Settings.
• A Settings dialog box will be displayed.
• Choose the Sounds tab.

Note: The Good Sound pulldown list was previously labeled Good Beep.  The Bad Sound pulldown list was previously labeled 
Bad Beep.  The Match Text / Sound Key textbox was previous labeled Alarm on Match Text.  The Alarm on Match Text 
textbox only accepts Match Text.  It does not accept Sound Keys.

Parameters
Good Sound
Select the sound from the drop-down box to play when an event such as a good scan occurs.  Valid entries are deter-
mined by the available WAV files, plus <NONE> (no sound) and <DEFAULT> (default Windows event sound).  The 
default is <DEFAULT>.

Note: Before enabling the Good Sound, verify that “Good Scan” sounds are disabled on the mobile client using the 
device’s control panel applet (e.g., Volume and Sounds Properties and/or Scanner Properties).  When Good 
Scan sounds are enabled in RFTerm and on the mobile client, there may be double sounds emitted by the mobile 
client during a “Good Beep” function.

Bad Sound
Select the sound from the drop-down box to play when an error such as a bad scan occurs.  Valid entries are deter-
mined by the available WAV files, plus <NONE> (no sound) and <DEFAULT> (default Windows event sound).  The 
default is <DEFAULT>.

Note: Before enabling the Bad Sound verify that “Bad Scan” sounds are disabled on the mobile client using the client’s 
Control Panel applet (e.g., Volume and Sounds Properties and/or Scanner Properties).  When Bad Scan sounds 
are enabled in RFTerm and on the mobile client, there may be double sounds emitted by the mobile client during 
a “Bad Beep” function.
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Beep on Error
When the Windows System Sound (Exclamation Point) is desired as the Bad Beep sound, the user must change 
the WAV file associated with the Operating System on the mobile client (e.g.  “Volume and Sounds”).  See the 
mobile client specific Reference Guide.

Alarm Sound
Select the sound from the drop-down box to play when a when text shown in “Match Text” is displayed.  Valid entries 
are determined by the available WAV files, plus <NONE> (no sound) and <DEFAULT> (default Windows event sound).  
The default is <DEFAULT>.

Note: Before enabling the Alarm Sound Wav, verify that all sounds are disabled on the mobile client using the client’s 
Control Panel applet (e.g., Volume and Sounds Properties).  When Alarm Sounds are enabled in RFTerm and 
on the mobile client, there may be double sounds emitted by the mobile client during an RFTerm Alarm function.

Match Text / Sound Key
Specify the Match Text or Sound Keys.  Both may be specified in this textbox; however the Match Text must be speci-
fied first.  See below for examples.

Match Text
Enter the text to be displayed on the user’s screen (for example, “Login”) when a response from the user is 
desired.  The default is blank.

After playing the Alarm Sound WAV and displaying the Match Text, RFTerm then waits for a user response.

Sound Key
Use Sound Key to map various sound causes to the three available sounds.

The Sound Key string is three characters:

The first character is $.

The second character is the cause of the sound:

M for Match

H for Host

U for User

S for Good Scan

L for Laser Error or Bad Scan.

The third character is the sound played:

G for Good Sound

B for Bad Sound

A for Alarm Sound.

Examples

$HA means to assign Host initiated sounds to the Alarm sound

$MA means to assign the Match string sound to the Alarm sound

$LB means to assign the Laser error (scan error) to the Bad sound

$SG means to assign the good Scan sound to Good sound

$UA means to assign User initiated sounds to the Alarm sound.

$HA$LB$SG - Multiple sounds can be assigned by entering Sound Keys consecutively.

Login$HA$MA$UA - Match Text can be used with Sound Keys as long as the Match Text comes before the 
Sound Keys in the string.



2 - 16

Alarm Position
Enter the row and column starting position for the Alarm on Match Text to be displayed on the user’s screen.  The 
default is Row=0 Column=0.

The alarm sounds when it discovers the Alarm on Match Text at the specified row and column.  The alarm does not 
sound when the Alarm on Match Text is located at any other position.

Sound Events
Host initiated sounds can be triggered by:

• a TN5250/TN3270 message with the Alarm bit set
• a VT220 “bell” command
• a *B string

User initiated sounds are triggered by:

• the user moving the cursor outside a field and trying to enter data
• the user trying to enter a letter into a numeric only field
• the user trying to enter data during input inhibit.



2 - 17

Status
Status information is split into two categories.

Status icons that show connection information, the battery level and the state of the keyboard modifier keys may be displayed.

Status icons are not available on devices equipped with a Windows Mobile operating system.

A session menu can be displayed that shows all configured sessions.

Parameters
Status Icons

Orientation
Determines if the status icons are active and, if active, the orientation of the status display.

Valid options are:

• None - Do not display the status icons
• Horizontal - Display the status icons with a horizontal orientation
• Vertical - Display the status icons with a vertical orientation
• Large Horizontal - Display larger status icons with a horizontal orientation
• Large Vertical - Display larger status icons with a vertical orientation.

The default is None (status icons not displayed).

Location
If enabled, determines the location of the status icons on the RFTerm screen.  Valid options are:

• Top-Left
• Top-Right
• Bottom-Left
• Bottom-Right

The default is Bottom-Right.

Color
Determines if the status icons are displayed in color (default) or monotone.  The examples below are the color 
icons.
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WAN
WWAN signal strength is indicated by a four bar icon with a W.

Con
Displays the status of the connection to the host.

WiFi
Signal strength for 802.11 radio is indicated by a four bar icon.

Bat
Battery power is indicated by a battery icon or a plug icon.

Key
The status of certain keypress states are indicated.

Excellent signal strength

Good signal strength

Fair signal strength

Poor signal strength

No signal

No currently connected session

Session connected

Excellent signal strength

Good signal strength

Fair signal strength

Poor signal strength

No signal

Excellent battery strength

Good battery strength

Fair battery strength

Poor battery strength

External power source connected

None of the states below are active.

The Alt   keypress state is active

The Ctl keypress state is active

The Shift keypress state is active

The CapsLock (or CAPS) keypress state is active
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Session Menu
The Session Menu parameters provide options for displaying and swapping between sessions.

Host Menu
When enabled, the Host Menu displays information on sessions on the RFTerm “idle” screen.  The Host Menu can 
also be displayed in front of an actively connected session by pressing [Ctrl][Alt][0].  When the Session Menu is 
displayed, pressing keys 1 through 4 switches to that session:

• If the selected session is not connected, selecting the session starts that session.  If the connection fails, the 
Host Menu is displayed again.  

• If the selected session is already connected, selecting returns the user back to that session.

When a session is selected, the Host Menu is dismissed.  When a session is ended by a regular sign off, the Ses-
sion Menu is automatically displayed, if enabled.

Information displayed, from left to right is:

• Active session indicator:

>> for active

__ for inactive

• Session ID, i.e.  S1
• Connection status:

C for connected

_ for not connected

• Host Name, as entered on Session > Configure screen (optional)
• Host IP Address, as entered on Session > Configure screen

Session Start Control
Session Start Control is provided so the user has control over whether or not an auto login session starts.

When enabled, Session Start Control displays a confirmation box before starting the session selected from the 
Host Menu.  When the popup is displayed:

• Clicking OK or pressing Enter starts the session.
• Clicking the X or pressing ESC cancels the session start and returns the user to the Host Menu.

Since auto login sessions may start as soon as the session is selected.  By providing the option to start or cancel 
the session, the user is provided a rest-point where it is safe to switch off the device without having any open 

When disabled, the auto login sessions start without the user having any input.

Logging
The logging feature is designed for Honeywell field service use only.



2 - 20

Com1 and Com2
Note: Com1 and Com2 tabs replace the previous Serial Data tab.  With the Com1 and Com2 tabs, each COM port can be 

independently configured,

The options for Com1 and Com2 are the same.

• From the application menu, select File > Settings.  
• A Settings dialog box will be displayed.

• Choose the Com1 or Com2 tab.

Should RFTerm be unable to apply any of the COM Port settings, a popup dialog will appear., such as the one below: 

COM ports available are dependent on the configuration of the mobile device. 

Parameters
Usage
Select the desired communication configuration for the selected COM port:

• Input - The COM port is configured for input only (default).
• I/O - The COM port is configured for bi-directional communications
• In/Print - The COM port is configured for input and the print settings are controlled from the dialog box displayed by 

selecting File > Print Setup > Direct Serial (page 4-6).
• Off - The COM port is disabled.

Baud Rate
Specifies the baud rate at which the COM port operates.  The default is 9600.

Data Bits
Specifies the number of data bits to be used.  It is one of the following values: 7, or 8 (default).

Timeout
Specifies port timeout in seconds.  The default is 10.
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Parity
Specifies the parity scheme to be used.  It is one of the following values: even, mark, none (default), odd and space.

Stop Bits
Specifies the number of stop bits to be used.  It is one of the following values: 1 (default), or 2.

DTR Control
Specifies the data-terminal-ready flow control.  The options are enable (default), disable and handshake.

RTS Control
Specifies the request-to-send flow control.  The options are enable (default), disable, handshake and toggle.

CTS Out
Specifies if the CTS (clear-to-send) signal is monitored for output flow control.  The default is disabled (unchecked).

DSR Out
Specifies if the DSR (data-set-ready) signal is monitored for output flow control.  The default is disabled (unchecked).

XonXoff Xmit
Specifies if XON/XOFF flow control is used during transmission. The default is enabled (checked).

XonXoff Recv
Specifies if XON/XOFF flow control is used during reception. The default is enabled (checked).

Stored Forms
A stored form is a combination of valid ANSI/DEC/LXE commands and text that, when executed by RFTerm and displayed on 
the screen, appears as a fill-in form.  

For all devices with a Windows CE, Windows Embedded Compact, or Windows Mobile operating system

RFTerm places the commands and text that comprise the form in the System/LXE/RFTerm/Stored Forms folder.

For all devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard operating system

RFTerm places the commands and text that comprise the form in the Windows/LXE/Stored Forms folder.

Creating Stored Forms
Stored forms are written by the host application programmer and sent from the host to the mobile client.  You cannot create 
a form from the mobile client.  

The maximum number of stored forms supported by RFTerm is 100 and the maximum size of each stored form is 2K.  The 
/Stored Forms folder is not automatically cleared upon a mobile client cold boot.

See also: Forms (page 6-3) for command codes for stored forms.



2 - 22



3 - 1

3
Session Configuration

This section describes various configuration parameters for setting host connections.  All these parameters may be set using 
the application configuration dialogs accessed from the Session > Configure application menu.  Except for “Connection” 
parameters, you can change or update any other parameters at any time, whether the host session is connected or discon-
nected.

All configuration attributes are associated with the currently active session.  Every session can have a different set of configura-
tion attributes.  

Connection
The following figures show the Connection tab of the host session configuration dialog.

For Microsoft Windows 7, Windows 10, and Windows Embedded 7:

It is necessary to run to run RFTerm as an administrator when modifying these settings because RFTerm must be able to 
access and make changes to the Windows registry.  

Rather than selecting to run as administrator each time, right click on the RFTerm  icon and select Properties.  Tap the 
Compatibility tab and check Run this program as an administrator.  This modification affects the current user only un-
less Change settings for all users is tapped before changing the privilege level.

!
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Note: The dialogs dynamically change depending upon the current selection of “Host Type”.  

1. From the application menu, Select Session > Configure or tap the Configure button on the ToolBar.

2. A Configure dialog box is displayed.  

3. Choose the Connection tab.  

Prerequisites for Connection
Before you make a host connection, you will, at a minimum, need to know:

• the alias name or IP address and 
• the port number of the host system

to properly set up your host session.  

Note: There are several new tabs available on the Sessions > Configure screen.  

Parameters
Host Type 
This is the terminal emulation type required by the host.  Your choices are 3270,  or VT220.  You may select only one 
emulation type for the session.  Other connection options may change depending upon the host emulation type 
selected.  

Host Address
This is the address of a host system or an intermediate gateway managing connections to the host system.  Enter 
either the numeric IP address or the alias name, using up to 64 characters.  This option is case-sensitive.

Host Name
Host name is a field used to identify the session in the Session Menu.  Host name is comprised of alphanumeric char-
acters.  No host name resolving is performed.

Terminal Device
This is the client type string that determines the specific client to emulate.  For 3270 emulations only model 2 screen 
geometry is supported.  VT220 supports VT52, VT100 and VT220 terminal types.  Each host emulation type has its 
own default terminal type.

Telnet Port
This is the TCP socket port number to be used to connect to the host system.  The default is 23.  The range is between 
0 and 65535.
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Reset Defaults
Tap this button to reset all parameters for the selected session to their default values.

3270, 5250, VT Config

This button, which changes with the Host Type selection, opens a configuration dialog for 3270, 5250 or VT emulation 
settings.  

KeepAlive
Checking the KeepAlive box will send a message to the host every 2 hours (approximately).  If the host responds, 
RFTerm knows the host is still present and will keep the socket open.  If the host does not respond to repeated Keep-
Alive messages, RFTerm will close the connection to the host.  The KeepAlive Interval default value is approximately 2 
hours.  

By default, KeepAlive is enabled.

Auto Reconnect
Checking this box will cause RFTerm to automatically attempt to reconnect to the host should the connection be termi-
nated by the user or the host, other than signal loss.

Retry on Signal Loss
This option enables an automatic reconnection attempt for this session should the signal be lost.  This option is valid 
for both RF (802.11) and WWAN connections to the host

VT Configuration (page 3-4) 5250 Configuration (page 3-12) 3270 Configuration (page 3-17)
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VT Configuration
Keys

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select VT220 as the Host Type, press the VT Config button.
• Choose the Keys tab.

Parameters
Backspace
When in character mode, this option configures the backspace key to send either the Delete character or the 
Backspace character.  The default is Send Delete character.

Enter Key
This option configures the Enter key to send either a carriage return or a carriage return and line feed.  The 
default is Send Carriage Return.

Keyboard
Specifies the international ASCII character set for use with the VT220 emulation.  The default is North Ameri-
can.
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Screen

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select VT220 as the Host Type, press the VT Config button.
• Choose the Screen tab.

Parameters
Background
This option controls the background shade for VT host sessions.  The default is Dark.

Columns
This option specifies the number of columns to be set for the VT host session to be 80 or 132.  The default 
column value is 80 columns.  See also: Answerback Columns (page 3-9).

Local Echo
Use this option to select the local echo mode (when in character mode).  The default is Off.

• Off - Local echo is off
• On - Local echo is on.  Typed text is echoed locally on the mobile client.
• On CR - Local echo is on.  Typed text is echoed locally on the mobile client.  CR is added to incoming LF.

Note: previous versions had a Local Echo checkbox which enabled local echo when checked.

Autowrap
Check this option to enable automatic wrapping of text once it reaches the maximum column width.  The 
default is Enabled (checked).

LF Option
Use this option to control the handling line feed (LF) handling.  The default is Normal.

• Normal - No special handling is performed.
• LFisCRLF - LF is converted to CRLF is the LF is not already paired with a CR.

Screen Update
Controls the fast screen update enhancement.

• Normal - rapid (fast) update enhancements are used.  This is the default.
• Rapid 1 - Half second timer for last update, packet count of 3 to begin fast update
• Rapid 2 - Half second timer for last update, packet count of 5 to begin fast update
• Rapid 3 - One second timer for last update, packet count of 3 to begin fast update
• Rapid 4 - One second timer for last update, packet count of 5 to begin fast update
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Options

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select VT220 as the Host Type, press the VT Config button.
• Choose the Options tab.

Parameters
C1 Controls
The C1 Controls option allows the user to select 7 bit or 8 bit ASCII control sequences for the host session.  
The default is Send 7-bit.

User Preference Supplemental
This is the user preferred supplemental character set.  The default is DEC.

Auto Transmit
Checking this box will cause the entire screen to be sent to the host after the user exits the last field on the 
screen.  Before sending the data, the Auto Transmit function evaluates the final cursor movement.  If the final 
cursor movement was caused by a backspace or backtab, the screen is not sent to the host.  Note that arrow 
keys have no effect on Auto Transmit.  The default is blank.

Inclusive End Prot Area
When checked, the End Of Protected Area command is inclusive when a second field exists on the screen, so 
that the last location does not become unprotected.  The default is unchecked.
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Send/Receive Mode
The default is Character.

• Always Block - RFTerm will remain in Block mode during and after logon.  The host can override the 
current mode.

• Always Character - RFTerm will remain in Character mode during and after logon.  The host can override 
the current mode.

• Always Line - RFTerm will remain in Line mode during and after logon.  The host can override the current 
mode.

• Block - RFTerm starts in Character mode until a logon connection occurs, and then it remains in Block 
mode.  The host can override the current mode.  A function key press performs an Autosend.

• Character - RFTerm starts in Character mode until a logon connection occurs, and then it remains in 
Character mode.  The host can override the current mode.

• Key Buf Char - Character mode with a buffer.  The buffer captures incoming messages and forwards them 
for processing.  If a character fails to be processed, the buffer reattempts processing the buffer contents.

• Line - RFTerm starts in Character mode until a logon connection occurs, and then it remains in Line mode.  
The host can override the current mode.  A function key press performs an Autosend.
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Answerback

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select VT220 as the Host Type, press the VT Config button.
• Choose the Answerback tab.

Parameters
Use LXE Format
When this parameter is enabled (checked), the following options to modify the Honeywell formatted string are 
available and the Answerback string cannot be directly edited.

When this parameter is disabled (blank), the user can edit the Answerback string as described in Answerback 
Message (page 3-9).  Other parameters on this dialog box cannot be edited (dimmed).  Use IP Address and 
Zero Pad are Enabled by default.

Use Secondary ID
Secondary ID and IP Address are mutually exclusive.  Checking one disables the controls for the other.  The 
default Secondary ID is 4 zeros “0000” in alphanumeric format.  This is an alternate method to identify the cli-
ent with a 4-digit number.  It is automatically padded with zeros if it contains fewer than 4 characters.  

Honeywell Session Management

To use RFTerm with any of the Honeywell Session Management products, the Answerback string must be for-
matted to include a Secondary ID.

Special Formatting

Special formatting characters are available to insert device specific ID components into the Secondary ID por-
tion of the answerback string.  Refer to Special Formatting for Answerback String (page 3-9) for details.

Use IP Address 
Instructs RFTerm to use the IP Address of the device in the Answerback string.  This parameter is disabled 
when Use Honeywell Format and Use Secondary ID are enabled.  This is the default.

Zero Pad
When Zero Pad is enabled (checked), any of the four numbers in the IP address less than 100 will be padded 
with leading zeros.  For example, with Zero Pad disabled (blank), an IP address is generated as 1.16.253.42.  
With Zero Pad enabled, the IP address is generated as 001.016.253.042.
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Row
The default is Full Screen.

• None - When selected, sends nothing for the row field in the Answerback string.
• Full Screen - When selected, sends 24 for rows in the Answerback string.
• Specify - Allows the row information to be set according to the customer’s needs.  Two characters 

maximum.

Columns
The default is None.

• None - When selected, sends nothing for the column field in the Answerback string.
• Full Screen - The setting established in the Columns parameter (80 or 132) on the VT Configuration > 

Screen tab sets the column size for the Answerback string.
• Specify - Refer to VT Configuration > Screen > Columns parameter.  Allows the column size, based on 

the setting in the Columns parameter, to be adjusted according to the customer’s needs.  Three characters 
maximum.

See also: Screen > Columns (page 3-5).

Display
The user may press this button at any time to view the answerback string with the selected options.

Note:  The string cannot be edited by the user when Use LXE Format is enabled (checked).

Answerback Message
Host applications may query the VT client for a text message answerback response.  This response may be 
used to identify the client.  The answerback string is automatically generated when requested by the host 
using the ENQ command, or by pressing the Display button.  The default format contains the following items 
after LXE/q/:

• The number of rows currently visible on the screen.
• The current release number of RFTerm, same as in the About Box.
• The IP address of the device, or an optional secondary ID.  The default uses the IP address.
• Optionally, the number of columns currently visible on the screen.

If Use LXE Format is unchecked, the Answerback Message is an entry field.

Special formatting characters are available to insert device specific ID components into the answerback 
string.  See below for details.

Special Formatting for Answerback String
The user can enter the % character in either the Secondary ID textbox (when the LXE format is enabled) or 
directly in the Answerback Message textbox (when the LXE formatting is disabled) to indicate how to retrieve and 
format the portion of the data source to be included in the Answerback string.  

The % is followed by a string of special characters in the format %vwwyyz

Where:

v must be one of the following values:

ww is the two digit minimum display width.  

yy is the two digit precision, the number of digits to display.

v value Result

0 The string is zero padded.

<space> The string is space padded.

: The next character is not to be formatted and is copied without processing into the string.  Special 
formatting resumes if another % symbol is encountered in the string.

; Formatting is stopped for the remainder of the string.  In this case, the initial “%” and the “;” 
characters are deleted from the string and all other characters are shifted to the left.
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• If the minimum display width (ww) is greater than the precision (yy) then the string is padded with either zeros 
or spaces (depending on the value for v).

• When counting digits of precision (yy), only the actual hexadecimal digits are counted.  Delimiters such as the 
period (in an IP or MAC address) or the dash (GUID) are not counted as digits of precision and are not displayed 
in the result.  

• If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is less 
than the available digits in the ID selected, the number of digits returned is the digits of precision.

• If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is 
greater than the available digits in the ID selected, the number of digits returned is the greater of the available 
digits or the minimum display width.

• The maximum value is 31 for display width (ww) and digits of precision (yy).

z must be one of the following values:

Note: If the above rules are broken (ww or yy are not two digits, y is an invalid value, etc.) the special formatting 
is abandoned and the string is filled with *ERROR*.

Examples

Refer to the following examples for a device with IP address: 10.10.1.23, GUID: 415B1AF5-561F-373D-A244-
80250E3CA123, MAC address: 00:0F:F8:01:23:45 and no Wavelink TID assigned to the device:

z value Result

I Indicates the device’s IP address is used to identify the device.  If the IP address is not available, a 
string of padding characters results.

G Indicates the GUID is used to identify the device.  The conversion beings with the rightmost 
character of the GUID and counts to the left.  If a GUID is not available from the operating system, 
RFTerm generates and stores the GUID in a non-volatile location eliminating the need to generate 
the GUID more than once.

M Indicates the MAC address is used to identify the device.  The conversion begins with the rightmost 
character of the MAC address and moves to the left.  Colons are ignored during the conversion.  If 
the MAC address is not available, a string of padding characters results.

T Indicates the Wavelink Avalanche TID is used to identify the device.  If the TID is not available, a 
string of padding characters results.

String Entered Resolves to

ABC%00808I ABC01010123

ABC% 0808I ABC 1010123

ABC%00804I ABC00000123

ABC%00408I ABC1010123

ABC%00301I ABC003

ABC%01012I ABC0001010123

ABC%00404G ABCA123

ABC%00303M ABC345

ABC%00404T ABC0000

ABC%0404T *ERROR*

ABC%;XYZ ABCXYZ

ABC%;%X%Y%Z ABC%X%Y%Z

%:%ABC%00303I %ABC123

ABC%:%% 0303I ABC% 23
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Compatibility

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select VT220 as the Host Type, press the VT Config button.
• Choose the Compatibility tab.

Parameters
SEM (Select Editing Extent Mode for VT220) 
The session will use the default SEM assignment unless it is overridden by the host.  The default is 0 (dis-
play).  

Valid values are: 0 = display, 1 = row, 2 = field, 3 = area.

Select DEC Special Graphics into G1
The default is Disabled (unchecked).  This option, when enabled, forces the mobile device to be in graphics 
mode at all times.  

Unlock Keyboard Before End of Data Stream
When unchecked (disabled), the keyboard is locked until the end of the data stream is processed.  This is the 
default behavior.

When checked (enabled), the keyboard is not locked while the data stream is processed.

Clear Tabs on Clear Screen
Determines if tabs will be cleared when the clear screen command “ESC[2J” is used.  The default is None.

Valid values are: 

• None - Does not clear any preset tabs.
• Cursor Only - Clears only the preset cursor tabs.
• Column Only - Clears only the preset column tabs.
• Cursor and Col - Clears both cursor and column preset tabs.
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5250 Configuration
Options

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select 5250 as the Host Type, press the 5250 Config button.
• Choose the Options tab.

Parameters
Device / LU#
This is an optional IBM parameter.  It represents a dedicated LU number or name on the server that you might 
want to connect through.  Default is blank.

Special Formatting

Special formatting characters are available to insert device specific ID components into the Device / LU# 
string.  Refer to Special Formatting for Device / LU# String (page 3-13).

Auto Transmit
This selection determines the auto transmit behavior of RFTerm.

• Off - Auto transmit is disabled.  This is the default.
• Last field & pos - This option causes the entire screen to be sent to the host based on data being entered 

into the last field and the last position of the field, thereby causing a field exit.  The Auto Transmit function 
evaluates the final cursor movement.  If the final cursor movement was caused by a backspace or backtab, 
the screen is not sent to the host.  Note that arrow keys have no effect on Auto Transmit.

• Last field & exit - This option causes the entire screen to be sent to the host based on the occurrence of 
a field exit data in the last field.

• Scan last field - This option causes the entire screen to be sent to the host when data is scanned into the 
last field.  The data does not have to fill the field to trigger the transmit.

Note: This parameter was previously a check box.  Auto transmit was either disabled (unchecked) or enabled 
for transmit on last field and position (checked).

Tab = Field Exit
Determines the behavior of the Tab key:

• None - Tab does not behave as Field Exit.
• Field Exit - Tab behaves has field exit except when in a signed numeric field.
• Field Exit Signed Only - Tab behaves has field exit when in a signed numeric field
• Field Plus Signed Only - Tab behaves has field plus when in a signed numeric field
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Status Line Visible
When Status Line Visible is checked, the status line is displayed on the last viewable row of the mobile client’s 
screen.  Default is blank.

Support ANSI Login
Checking this box will enable the 5250 session to perform as a limited VT emulation until an IBM terminal type 
is negotiated with the host.  Default is blank.

Auto Enter
When Auto Enter is checked, an Enter command is sent to the host after a print.  Default is blank.

Field Exit on Scan
When Field Exit on Scan is checked, RFTerm performs a Field Exit automatically if a field is being exited due 
to a bar code scan.  Default is blank.

Special Formatting for Device / LU# String
The user can enter the % character in the Device / LU# textbox to indicate how to retrieve and format the portion 
of the data source to be included in the Device / LU# string.  

The % is followed by a string of special characters in the format %vwwyyz

Where:

v must be one of the following values:

ww is the two digit minimum display width.  

yy is the two digit precision, the number of digits to display.

• If the minimum display width (ww) is greater than the precision (yy) then the string is padded with either zeros 
or spaces (depending on the value for v).

• When counting digits of precision (yy), only the actual hexadecimal digits are counted.  Delimiters such as the 
period (in an IP or MAC address) or the dash (GUID) are not counted as digits of precision and are not displayed 
in the result.  

• If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is less 
than the available digits in the ID selected, the number of digits returned is the digits of precision.

• If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is 
greater than the available digits in the ID selected, the number of digits returned is the greater of the available 
digits or the minimum display width.

• The maximum value is 31 for display width (ww) and digits of precision (yy).

z must be one of the following values:

v value Result

0 The string is zero padded.

<space> The string is space padded.

: The next character is not to be formatted and is copied without processing into the string.  Special 
formatting resumes if another % symbol is encountered in the string.

; Formatting is stopped for the remainder of the string.  In this case, the initial “%” and the “;” 
characters are deleted from the string and all other characters are shifted to the left.

z value Result

I Indicates the device’s IP address is used to identify the device.  If the IP address is not available, a 
string of padding characters results.

G Indicates the GUID is used to identify the device.  The conversion beings with the rightmost 
character of the GUID and counts to the left.  If a GUID is not available from the operating system, 
RFTerm generates and stores the GUID in a non-volatile location eliminating the need to generate 
the GUID more than once.
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Note: If the above rules are broken (ww or yy are not two digits, y is an invalid value, etc.) the special formatting 
is abandoned and the string is filled with *ERROR*.

Examples

Refer to the following examples for a device with IP address: 10.10.1.23, GUID: 415B1AF5-561F-373D-A244-
80250E3CA123, MAC address: 00:0F:F8:01:23:45 and no Wavelink TID assigned to the device:

M Indicates the MAC address is used to identify the device.  The conversion begins with the rightmost 
character of the MAC address and moves to the left.  Colons are ignored during the conversion.  If 
the MAC address is not available, a string of padding characters results.

T Indicates the Wavelink Avalanche TID is used to identify the device.  If the TID is not available, a 
string of padding characters results.

String Entered Resolves to

ABC%00808I ABC01010123

ABC% 0808I ABC 1010123

ABC%00804I ABC00000123

ABC%00408I ABC1010123

ABC%00301I ABC003

ABC%01012I ABC0001010123

ABC%00404G ABCA123

ABC%00303M ABC345

ABC%00404T ABC0000

ABC%0404T *ERROR*

ABC%;XYZ ABCXYZ

ABC%;%X%Y%Z ABC%X%Y%Z

%:%ABC%00303I %ABC123

ABC%:%% 0303I ABC% 23

z value Result



3 - 15

Compatibility
Note: Previous versions had a Scanner Always On option.  This function has been replaced by the Scan Control 

option on the Barcode (page 3-24) tab.

Note: Previous versions had a Auto Clear Field checkbox.  This has been replaced by a pulldown list.

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select 5250 as the Host Type, press the 5250 Config button.
• Choose the Compatibility tab.

Parameters
Block PF key Inhibit
Enable (check) this checkbox to allow all 5250 PF keys to send.  Disable (blank) to block PF key inhibit and 
data will not be sent when a PF key is pressed.  

The default is disabled.

Block Negative Response for Message Buffer in Use
Enable (check) this checkbox to block a negative response from being sent to the host when the mobile client 
message buffer is in use at the same time the host sends a command.  The default is disabled (blank).

For example, a write to display command is received from the host but the mobile client buffer is being used 
for a message, so RFTerm sends back a negative response.  The host interprets the response as user data.

Auto Clear Field
Select the desired option for auto clearing of the input field when the user moves the cursor to a field.  

• No - The field is not cleared.
• Yes - The field is cleared when the user enters data (default).
• Yes except arrow - The field is cleared when the user enters data, however if the previous keypress was 

an arrow key, the field is not cleared.

Block Send Data Aid Invite
If not checked (default), the invite and pending read are set for the Send Data Aid.

If checked (blocked) then the invite and pending read are not set for Send Data Aid.

The default is disabled (not checked).
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Reject On Restore Screen
When checked, RFTerm executes a CmdClearUnit command to clear the screen when a CmdRestoreScreen 
is received.

The default is unchecked, the CmdClearUnit is not executed on CmdRestoreScreen.

Cursor Home
Determines the behavior for cursor home.  The default is Default.

Valid options are

• Default - Cursor is not repositioned.
• Next - Locates the cursor to the next field location.
• Current - Locates the cursor at the current field position.
• Home - Locates the cursor at the origin position (upper left corner).
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3270 Configuration
Options

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select 3270 as the Host Type, press the 3270 Config button.
• Choose the Options tab.

Parameters
Device / LU#
This is an optional IBM parameter.  It represents a dedicated LU number or name on the server that you might 
want to connect through.  Default is blank.

Special Formatting

Special formatting characters are available to insert device specific ID components into the Device / LU# 
string.  Refer tp Special Formatting for Device / LU# String (page 3-18).

EAB
This is an optional 3270 terminal emulation parameter.  If checked, this will allocate an Enhanced Attribute 
Buffer.  EAB support allows for advanced display features such as color and highlighting.  Default is Enabled.

Auto Transmit
Checking this box will cause the entire screen to be sent to the host after the user exits the last field on the 
screen.  Before sending the data, the Auto Transmit function evaluates the final cursor movement.  If the final 
cursor movement was caused by a backspace or backtab, the screen is not sent to the host.  Note that arrow 
keys have no effect on Auto Transmit.  Default is blank.

Status Line Visible
When Status Line Visible is checked, the status line is displayed on the last viewable row of the mobile client’s 
screen.  Default is blank.

Auto Enter
When Auto Enter is checked, all data will be sent to the host when all fields are completed.  Valid for Block 
and Line mode.  Default is blank.

Support TN3270E
When Support TN3270E is enabled, only Basic TN3270E (as defined in Section 9 of RFC 2355) host 
requests are supported.  The default value is “checked” or enabled.  Note that Full 3270E is not supported by 
RFTerm.  Default is Enabled.



3 - 18

Special Formatting for Device / LU# String
The user can enter the % character in the Device / LU# textbox to indicate how to retrieve and format the portion 
of the data source to be included in the Device / LU# string.  

The % is followed by a string of special characters in the format %vwwyyz

Where:

v must be one of the following values:

ww is the two digit minimum display width.  

yy is the two digit precision, the number of digits to display.

• If the minimum display width (ww) is greater than the precision (yy) then the string is padded with either zeros 
or spaces (depending on the value for v).

• When counting digits of precision (yy), only the actual hexadecimal digits are counted.  Delimiters such as the 
period (in an IP or MAC address) or the dash (GUID) are not counted as digits of precision and are not displayed 
in the result.  

• If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is less 
than the available digits in the ID selected, the number of digits returned is the digits of precision.

• If the selected precision (yy) is greater than the minimum display width (ww) and the selected precision is 
greater than the available digits in the ID selected, the number of digits returned is the greater of the available 
digits or the minimum display width.

• The maximum value is 31 for display width (ww) and digits of precision (yy).

z must be one of the following values:

Note: If the above rules are broken (ww or yy are not two digits, y is an invalid value, etc.) the special formatting 
is abandoned and the string is filled with *ERROR*.

v value Result

0 The string is zero padded.

<space> The string is space padded.

: The next character is not to be formatted and is copied without processing into the string.  Special 
formatting resumes if another % symbol is encountered in the string.

; Formatting is stopped for the remainder of the string.  In this case, the initial “%” and the “;” 
characters are deleted from the string and all other characters are shifted to the left.

z value Result

I Indicates the device’s IP address is used to identify the device.  If the IP address is not available, a 
string of padding characters results.

G Indicates the GUID is used to identify the device.  The conversion beings with the rightmost 
character of the GUID and counts to the left.  If a GUID is not available from the operating system, 
RFTerm generates and stores the GUID in a non-volatile location eliminating the need to generate 
the GUID more than once.

M Indicates the MAC address is used to identify the device.  The conversion begins with the rightmost 
character of the MAC address and moves to the left.  Colons are ignored during the conversion.  If 
the MAC address is not available, a string of padding characters results.

T Indicates the Wavelink Avalanche TID is used to identify the device.  If the TID is not available, a 
string of padding characters results.
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Examples

Refer to the following examples for a device with IP address: 10.10.1.23, GUID: 415B1AF5-561F-373D-A244-
80250E3CA123, MAC address: 00:0F:F8:01:23:45 and no Wavelink TID assigned to the device:

String Entered Resolves to

ABC%00808I ABC01010123

ABC% 0808I ABC 1010123

ABC%00804I ABC00000123

ABC%00408I ABC1010123

ABC%00301I ABC003

ABC%01012I ABC0001010123

ABC%00404G ABCA123

ABC%00303M ABC345

ABC%00404T ABC0000

ABC%0404T *ERROR*

ABC%;XYZ ABCXYZ

ABC%;%X%Y%Z ABC%X%Y%Z

%:%ABC%00303I %ABC123

ABC%:%% 0303I ABC% 23
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Compatibility
Note: Previous versions had a Scanner Always On option.  This function has been replaced by the Scan Control 

option on the Barcode (page 3-24) tab.

Note: Previous versions had a Auto Clear Field checkbox.  This has been replaced by a pulldown list.

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Connection tab.
• Select 3270 as the Host Type, press the 3270 Config button.
• Choose the Compatibility tab.

Parameters
Clear to EOL
The default value is Disabled (unchecked).  Enable (check) this parameter to force the RFTerm 3270 TE to 
clear displayable text to the end of line or to the end of field attribute when writing displayable text from the 
host.  Hidden attributes are removed.

Auto Clear Field
Select the desired option for auto clearing of the input field when the user moves the cursor to a field.

• No - The field is not cleared.
• Yes - The field is cleared when the user enters data (default).
• Yes except arrow - The field is cleared when the user enters data, however if the previous keypress was 

an arrow key, the field is not cleared.

Order Prog Tab Erase
Determines if the 3270 screen is erased upon an error notification from the host:

• Normal - The erase does not occur for the Order Program Tab command (default).
• Erase - The erase does occur for the Order Program Tab command.

Null Format Control Order
This option determines how to handle a Null Format Control Order:

• Process - The beginning character in a field is erased after entering data and pressing send (default).
• Ignore - Prevents the erasing of the initial character in the field.
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Font

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Font tab.

The default font is “Courier New” and the default style is “Normal”.  The default font may change based on the operating system 
and installed fonts on the mobile client.

Parameters
Font
The drop down box contains the name of a fixed-width True Type font that is used to display the text on the screen.  
The fonts listed are pre-installed in the mobile client or installed by the end-user.  RFTerm supports double byte fonts.

For more information on installed fonts, see the equipment specific reference guide.

Style
This is the weight setting of the selected font.  Available weights are: Default, Thin, Light, Normal, Medium, Bold, 
XBold, Heavy.  The default is Normal.

Pointsize
Allows the pointsize of the selected font to be specified.  The default is 10, valid values are from 6 to 72.  If the Specify 
Rows and Columns checkbox is checked, Pointsize is calculated by RFTerm and this control is disabled (grayed out).

Specify Rows and Columns
The default is disabled (unchecked).  Select this option to specify the rows and columns to fit the display using the 
Rows: and Cols: boxes.  Using the specified rows and columns, RFTerm calculates the pointsize for the fonts.  When 
this option is selected, the Pointsize control is disabled.
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Colors
Traditional Windows color scheme is the default.  Predefined color schemes are available to enhance visual readability of the 
display text on the mobile client.  Further, mobile clients may be used in different lighting environments.  

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box is displayed.
• Choose the Colors tab 

In addition to predefined color schemes, a “Custom” color scheme may be used to configure various display attributes to suit the 
user’s personal preferences.  

Parameters
Scheme
To select a predefined color scheme, choose one from the Scheme drop down box.  The sample box will change to 
reflect the current selected attribute foreground and background colors.  The following pre-defined color schemes are 
available.

• Traditional - This is the traditional IBM terminal “green screen” color scheme.
• Black on White - Used primarily on devices with monochrome LCD displays.
• White on Black - Inverse of black on white.
• Factory - This color scheme is optimized for factory lighting and color displays.
• Custom - This scheme allows the user to alter various attributes.

Attribute
This is a list of mobile client display attributes, including Bold, for which colors may be changed as part of creating a 
Custom color scheme.  

Sample Attribute
This is a sample box that shows the foreground and background color of the currently selected attribute.  

Intense
This check box, when selected, applies the custom color to the Intense version of the selected attribute.  This option 
applies to 3270 emulations.  
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Select Color
This button invokes the Color dialog to select a color for an attribute.  

Custom Color Scheme
To create a custom color scheme, select the attribute from the attribute list box.  

• Choose the attribute, whose color is to be changed.
• Tap the Select Color...  button.  
• The Color dialog appears.  
• Select the desired color for the attribute.  Click OK.  
• The Sample box will change to reflect the newly selected color.  
• For updating colors associated with the Intense mode of an attribute, check the Intense box then select the desired 

color.  
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Barcode
Bar code scanner options are provided for easy manipulation of data streams input through the serial port.

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box will be displayed.
• Choose the Barcode tab.

For devices with a Windows CE or Windows Mobile operating system
Additional bar code manipulation features are available using the Honeywell Scanner Wedge or DC Wedge for Windows 
CE and Windows Mobile based devices.  Refer to your device reference guide for additional details.  If bar code manipula-
tion is defined in both the Scanner or DC Wedge and in RFTerm, the actions defined in the Scanner or DC Wedge are exe-
cuted first, followed by actions defined in RFTerm.  Honeywell recommends using the Scanner/DC Wedge for bar code 
manipulation unless emulation-specific actions are required.

Thor VM1 and Thor VM2 with Windows Embedded Standard Operating System
• RFTerm cannot perform the advanced bar code processing on this tab.  Instead use Freefloat Link*One to process the 

bar code data.  Information on using Link*One can be found at www.freefloat.com.
• Configure Link*One for the serial or Bluetooth bar code scanner.
• RFTerm must be configured to NOT use the same COM port as specified in Link*One.

Thor VX8 and Thor VX9
• RFTerm cannot perform the advanced bar code processing on this tab.  Instead use WLinq to process the bar code data.  

Information on using WLInq is included in the Thor VX8 and Thor VX9 reference guides.
• RFTerm must be configured to NOT use the same Usage (page 2-20) as specified in WLinq.
• Configure WLinq for the serial or Bluetooth bar code scanner.

Thor VM3
Use Enterprise Settings to configure bar code processing.  See the Thor VM3 User’s Guide for details.

Parameters
Left Justify
When checked, the Left Justify option shifts the cursor to the leftmost position of the current input field before any serial 
input data is displayed on the screen.

Truncate
The Truncate option instructs RFTerm to discard any serial input data that would be beyond the end of the current field.

http://www.freefloat.com/
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Clear Data
The Clear Data option automatically erases all data from the current cursor location to the end of the current field 
before any serial input data is displayed.

Auto Advance
When checked, the Auto Advance option automatically moves the cursor to the beginning of the next input field after 
displaying all data input through the serial port.

Fast Scan
When unchecked, there is a 200 millisecond delay to allow the scanner to interpret and forward data and for the scan-
ner wedge to place the data into the buffer and notify RFTerm the data is available.  This is the default.

If a user performs multiple rapid scans, and subsequent scans are performed before the 200 millisecond delay has 
expired, some scans may be dropped.  Check this option to reduce the delay to 10 milliseconds.  

Use Field Exit
The Use Field Exit feature is only available for 5250 emulations and only when the Auto Advance box is checked.  
Checking both boxes will cause RFTerm to append Field Exit to the scanned bar code.  

Scan Control
This option allows the behavior of the scanner to be configured during Input Inhibit or keyboard lock.

The valid options are:

• PowOff1&3 - Power is shut off to COM ports 1 and 3 during Input Inhibit or keyboard lock.  This option is the default.
• PowOn1&3 - Power is not shut off to COM ports 1 and 3 during Input Inhibit or keyboard lock.
• Disable1 - Power is shut off to COM ports 1 and 3 during Input Inhibit or keyboard lock and the LS3408 scanner 

attached to COM1 is disabled (see note below).
• Disable3 - Power is shut off to COM ports 1 and 3 during Input Inhibit or keyboard lock and the LS3408 scanner 

attached to COM1 is disabled (see note below.

Note: Disable1 and Disable3 may require an upgrade to your computer's software load and a firmware update for the 
LS3408 scanner.

Barcode Preamble 
This option will automatically insert the requested data at the head of the incoming data stream before it is displayed.  
Control characters and characters not accessible from the keyboard can be represented using Hat Encoding (page 6-
7).

Barcode Postamble 
This option will automatically insert the requested data at the tail of the incoming data stream before it is displayed.  
Control characters and characters not accessible from the keyboard can be represented using Hat Encoding (page 6-
7).

Send Key 
When checked, the Send Key option allows for a designated character in a bar code scan to automatically send an 
[Enter] command, provided it is the last printable character in the bar code.



3 - 26

Character Mapping
The Character Mapping option is used to setup a non-printable character to be incorporated into a bar code and inter-
preted by RFTerm as one of 16 predefined actions.  

Character mappings are unique to each session, persistent when RFTerm is closed and reset if a client session setting 
is reset to its Default values.  The default value for all programmable key codes is Accept.  

For example, to map NULL to a Tab, click the down arrow in the Character text box.  Select NULL.  Click the down 
arrow in the Action text box.  Select Tab.  Click the Add button.  The mapping list changes to show NULL mapped to 
Tab.

Options available from the Action drop down menu are:

• Accept
• NULL
• Backspace
• Tab
• Line Feed 
• Vertical Tab
• Form Feed
• Carriage Return
• Data Link Escape
• File Separator
• Group Separator 
• Record Separator
• Unit Separator 
• Enter (Send) 
• Space
• Ignore (Drop)
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Character Stripping

Default values are Code ID = *, Pre-Strip = 0 and Post-Strip = 0.  The asterisk (*) is a wildcard character.  Click the OK 
button to save any changes/additions.  Click the Cancel button or the X button to ignore any changes made.

Code ID Stripping
When Code ID Stripping is checked, the first character is stripped.  When not checked, character stripping occurs 
based on the values in the Pre-Strip category.  

Code ID
Code ID matches are based on this ID.  The asterisk (*) is the default - which means match any character.

Pre-Strip
The Pre-Strip option removes the requested number of characters from the head of the incoming data stream 
before it is displayed.

Post-Strip
The Post-Strip option removes the requested number of characters from the tail of the incoming data stream 
before it is displayed.
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Cursor
Cursor options are provided for easy identification of input fields.  You may configure cursor type and auto-scrolling options for 
the session.

• From the application menu, select Session > Configure.  
• A Configure dialog box is displayed.  
• Choose the Cursor tab 

Note: Automatic scrolling options have expanded.  The Lock Position option has been replaced by a pull down list with additional 
choices.  The Keep Cursor Centered and Keep Cursor Visible checkboxes have been replaced by enhanced pull down 
list choices.

Parameters
Cursor Options
This option allows you to change the cursor appearance.  The default is Full Block.  Three options are available:

• Full Block - The cursor appears as a full character block
• Half Block - The cursor appears as a bottom half block
• Underline - The cursor appears as an underscore line
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Automatic Scrolling
This option enables automatic scrolling so the current cursor position is always visible.  This option is helpful on mobile 
clients with small screens.  The default is None.  The following auto-scrolling options are available: 

• None - No automatic scrolling is performed, except those caused by host app (commands) or the device user (via 
mouse or scroll bar).  (default)

• Lock Position - The scroll bars are locked and the screen position is maintained limiting the viewing area.
• Smart Lock - Allows movement and viewing outside the locked region but a Send or Host update shifts the screen 

back to the Smart Lock position.  
• Cursor Centered - The cursor is always as close as possible to the center of the screen.  When scrolling limits are 

reached, the cursor will move toward the edge of the client display.
• Cursor Centered NS - Same as above, except the cursor is “Non Stick” (NS).  The NS selection allows the user to 

move the screen around, without a put back to cursor centered.  Pressing the escape key will cause a cursor 
centering screen adjustment.  

• Cursor Visible - The cursor is always visible.  The display is scrolled vertically and horizontally to prevent the cursor 
from moving out of view.  

• Cursor Visible NS - Same as above, except the cursor is “Non Stick” (NS).  The NS selection allows the user to 
move the screen around, without a put back to cursor visible.  Pressing the escape key will cause a cursor visible 
screen adjustment.

• Origin - Cursor is forced to the top left corner (origin) in most cases of screen updates and screen shifting.

Note: Unless the user is connected and viewing a scrollable area, the Lock Position and Smart Lock selections are 
undefined and automatic scrolling is forced back to None.
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Print Data Map
Send and receive data on the same serial port on a per session basis, regardless of print setup.  See also Direct Serial (page 4-
6).

• From the application menu, select Session > Configure.  
• A Configure dialog box is displayed.  
• Choose the Print Data Map tab.

Note: The serial port configuration parameters are now located at Com1 and Com2 (page 2-20).

Note: Previous versions may have “Pass thru CR” and “EOT as Null” instead of the expanded “Non-display char conversions” 
and “Pass thru exception” options.

Parameters
Non-Display Char Conversion
Allows selected treatment of non-displayable characters (0x0 through 0x1F) when printing:

• Space - Non-display characters are passed through as a space (default).
• None - No conversion is performed on the non-display characters.
• Null - Non-display characters are passed through as a null.
• Deleted - Non-display characters are deleted.

See Pass Thru Exceptions (below) for exceptions to the conversion process.

Pass Thru Exceptions
The following exceptions are provided for the Non-Display Character Conversion rule selected above.

CR as CR
Enable (check) for pass through carriage return.  This option passes through both CR and LF.

Default is disabled (blank).

EOT as NULL
Enable (check) to replace EOT (End of Text) with a Null character.

The default is disabled (blank); EOT is a Space character.

Start Print
Allows a start string to be specified to begin screen printing (output data to the com port).  The string can contain a 
maximum of five characters.  When the Start Print field contains data, the emulation searches for the specified Start 
Print and End Print strings in the display buffer each time data is received.  If the Start Print string is found, the screen 
data is sent to the com port until the end of display buffer or until the End Print string (see below) is reached.
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This feature is in addition to the *P command, detailed elsewhere in this manual.

The default is no entry, so Start Print is disabled.

End Print
Allows an ending string to be specified to terminate screen printing (output data to the com port).  When the Start Print 
option is used (see above) screen printing continues until the end of the display buffer unless the End Print string is 
specified.

The End Print string can contain a maximum of five characters.  When the Start Print field contains data, the emulation 
searches for the specified Start Print and End Print strings in the display buffer each time data is received.  If the End 
Print string is found, only the data beginning with the Start Print string and ending with the End Print string is printed.  If 
the End Print string is not found, all data from the Start Print string until the end of the display buffer is printed.

If there is no Start Print string specified, any entry in the End Print field is ignored.

The default is no entry, so End Print is disabled.
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Auto Login 
Use this option to create automatic login scripts.

Note: Previous versions had an Auto Login Enabled checkbox which is replaced by the Auto pulldown list.

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.  
• A Configure dialog box is displayed.  
• Choose the Auto Login tab.

Parameters
Auto
Determines if the connection to the session and login are done automatically.

• None - RFTerm does not connect to the session or login automatically.
• Connect Only - RFTerm connects to the session automatically, but does not login automatically.  Once connected, 

the user must manually login.
• Login Only - RFTerm does not connect to the session automatically, but does login automatically once a manual 

connection to a session is established.  If no prompt or reply is specified, RFTerm waits at the client login screen, 
and proceeds to connect to the next auto login enabled session.  Should a session fail to connect, the client is 
prompted with a popup dialog requesting a retry or cancel.

• Conn & Log - Both the connection to the session and login are performed automatically by RFTerm.  If no prompt 
or reply is specified, RFTerm waits at the client login screen, and proceeds to connect to the next auto login enabled 
session.  Should a session fail to connect, the client is prompted with a popup dialog requesting a retry or cancel.

The default is None.

Autologin Process
When an option with autologin is selected, RFTerm automatically logs in after the session is connected.  The con-
nection may either be automatic or manual, depending on the option selected.  Once the session is connected, if 
no prompt or reply is specified, RFTerm waits at the client login screen, and proceeds to connect to the next auto 
login enabled session.  Should a session fail to connect, the client is prompted with a popup dialog requesting a 
retry or cancel.  

Timeout
Enter how long RFTerm will wait for the session to connect and find the prompt string.  The default is the standard 
RFTerm 30 second connection timeout.
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Prompt
Enter the string to search for after RFTerm connects to the auto login enabled session.  The prompts must be con-
tained on successive screens or the reply will not be sent.  The prompts are case sensitive.  Leaving the Prompt blank 
but filling in data for the matching Reply will cause the Reply to be performed regardless of the screen data received 
from the host.  

You can enter up to four Prompt/Reply pairs for 3270 and 5250 sessions and six Prompt/Reply pairs for ANSI sessions.  

Reply
Enter the string, or action, to place at the current cursor location when RFTerm finds the Prompt string.  Control char-
acters and non-printable characters can be represented using Hat Encoding (page 6-7).  The Replies are case sensi-
tive.  This data will only be sent to the host if the Reply ends in a carriage return.  Maximum of 64 characters.

Note: For 3270 mobile devices, ATTN, CLR, ESC and SYSRQ must be contained within curly brackets { }.
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Fn Keys (Function Key Programming)
Allows for programming all available function keys and the 4 arrow keys.

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.  
• A Configure dialog box is displayed.  
• Choose the Fn Keys tab.

Parameters
Function Key Combo Box
Select the function key you wish to program.  There are currently 40 selections for ANSI emulations and 24 each for 
3270 and 5250 sessions.  Most ANSI function keys have default values.  The 4 arrow keys are also available for pro-
gramming for all emulations.

Function Key Edit Box
Enter the keystrokes for that function key to perform.  Control characters and characters not accessible from the key-
board can be represented using Hat Encoding (page 6-7).  Maximum number of characters is 64.

Add
Adds the entry to the function key table.

Clear
Clears the entry in the function key table for the function key highlighted in the function key combo box.

Disable Blank Keys
The default value for Disable Blank Keys is Blank or empty.  This option is available for all emulations.  

When the Disable Blank Keys checkbox is disabled (empty), all blank/unassigned function keys send nothing when 
pressed.  

When the Disable Blank Keys checkbox is enabled (checked), then all blank function keys will send the default data for 
that function key.  

Enable (check) the Disable Blank Keys checkbox to cause all blank function keys to send the default data for that func-
tion key.  

Explanations:

• An unassigned key, such as F5, can send data assigned to another key, such as F18.  Enable this value if you want 
unassigned keys to send nothing.

• In ANSI, an F5 keypress (when the F5 key is empty or unprogrammed) will send F18 data (the default value for an 
empty F5 key).  The F18 data will be either the assigned default for an empty F18 or the user entered data for a non-
empty F18.
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Keybd

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box is displayed.
• Choose the Keybd tab.

Parameters
Default Key Map
When selected, the current operating system default keyboard/keypad function key mapping is in effect.

PC Style Keyboard (IBM only)
When selected, function keys [Shift] [F1] through [Shift] [F12] will map to [F13] through [F24].

The default function key mapping is [Shift] [F1] through [Shift] [F4] will map to [F21] through [F24].

HX2 Function Key Enable
Note: Applies to HX2 with Alpha Mode 3 Tap keyboard only.

When unchecked, F11 - F19 ([Blue] plus [1 - 9]) are used to implement RFTerm functions such as Connect/Discon-
nect, Hide Bars, etc.  This behavior means a F11 - F19 keypress is not sent to the application, but instead performs a 
specified RFTerm function.

When checked, virtual keys F11 - F19 ([Blue] plus [1 - 9]) are no longer mapped to RFTerm functions but are mapped 
to F11 - F19.  Other keypress combinations should be assigned by the user to the RFTerm function.
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Two Key Function Keys
When unchecked, the standard Key Maps (page 9-1) for each device apply for F1 through F40.  This is the default.

When checked, the following key maps replace the standard key maps for F1 through F40:

F1 and... Produces Ctrl or
F2 and... Produces F3 and... Produces F4 and... Produces

1 F1 1 F11 1 F21 1 F31

2 F2 2 F12 2 F22 2 F32

3 F3 3 F13 3 F23 3 F33

4 F4 4 F14 4 F24 4 F34

5 F5 5 F15 5 F25 5 F35

6 F6 6 F16 6 F26 6 F36

7 F7 7 F17 7 F27 7 F37

8 F8 8 F18 8 F28 8 F38

9 F9 9 F19 9 F29 9 F39

10 F10 10 F20 10 F30 10 F40
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Compatibility

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box is displayed.
• Choose the Compatibility tab.

Parameters
Multi beep on good scan
Enables a multiple beep on a good scan.  Default is disabled, a single beep on good scan.

Disable *P
When checked, the *P (IBM print command) is disabled.  By default this option is unchecked (*P is treated as the IBM 
print command).

Continuous Retries Without Prompt
When checked, RFTerm performs continuous retries on the initial auto connect and any auto reconnect after losing a 
connection.  

The default is unchecked, no continuous retries without prompting.

A message is displayed on initial connect and on reconnect.  No user action is required to begin the connect or recon-
nect process.  

If the connection cannot be established, an error message is displayed.  Again, no user input is required and RFTerm 
continues to retry the connection.
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The retry process continues until:

• A connection is established.
• The user presses [Control] + [D] to end the retry process.

Show Input Error Message
When checked, RFTerm displays a message if the user attempts to input data, either by keypad or scanner, during 
Input Inhibit or XCLock.

The default is unchecked, no message is displayed.
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SSH
Note: SSH credentials were previously entered on the SSH Auth tab.  They are now accessed from this tab using the Configure 

button.

• From the application menu, select Session > Configure or tap the Configure button on the ToolBar.
• A Configure dialog box is displayed.
• Choose the SSH tab.

Parameters
SSH Select
Select the type of connection:

• None - Telnet is used without SSH.
• Shell - A direct connection is made to the SSH server.  Not supported with IBM 3270 or IBM 5250 emulations.
• Tunnel - A connection is established to an SSH server and Telnet traffic is tunneled or port forwarded through the 

SSH connection.  

SSH Server Address
Enter the address of the SSH server.

SSH Server Port
Enter the port for the SSH server.

Authorization
Select the type of authorization:

• User+Pswd - Specify a user and password.
• Key File - Specify a User Key File and passphrase.

Configure...
After selecting the desired type of Authorization, click the Configure...  button to enter the appropriate credentials.

User Authorization
User authentication requires a user name and password.  If the user authorization credentials are not entered on 
this screen, the user is prompted to enter the user name and password at the time of connection.



3 - 40

User
Enter the user name for SSH authentication.

Password
Enter the password for SSH authentication.

Private Key File
Private key file authentication requires a user name, a private user key file and an optional passphrase for the key 
file.

User
Enter the user name for SSH authentication.

Passphrase
An optional passphrase may be required to use the private key.  If a passphrase was specified when the key 
file was created, but no passphrase is entered on this screen, the user is prompted for the credentials at the 
time of connection.

User Key File
Only one private key file is stored per session.  Use the Browse...  and OK buttons to locate and select the 
private key file.

The private key file is generated on the server side and imported into RFTerm.  Once generated, copy the key 
file to the RFTerm device.  For computers running a Windows CE or Windows Embedded Compact operating 
system, the key file must be stored under the \System folder to persist after a reboot.

Browse...
Clicking this button opens an explorer window to locate the key file.  By default, only PuTTY private key files 
are displayed in the explorer window.  Putty private key files are generated using the PuTTY Key Generator.  
The PuTTY Key Generator is installed as part of Honeywell's Telnet Manager.  Refer to the Telnet Manager 
Reference guide for more details.
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OK
After using the Browse...  button to locate and select a key file, the file location and name are displayed in the 
User Key text box.  Click the OK button to save the private key information and exit the private key screen.

Advanced...
Click the Advanced...  button to manage server keys, keep alives, rekey intervals, etc.

Server Keys
The host key list is global, meaning a Host Key accepted for any session is displayed in all sessions.

When connecting to an SSH session, if the Host is not already in the Global Allowed Host Key list, a warning is 
displayed.



3 - 42

The following options are available:

Yes - The key is added to the Global Allowed Host Key list and the connection continues.  Use this option for a 
trusted host.

No - The key is not added to the Global Allowed Host Key list, however, the connection is allowed just this one 
time.

Cancel - The key is not added to the Global Allowed Host Key list and no connection is allowed.

Delete
Select an entry from the Global Allowed Host Key list and tap the Delete button to delete a host key entry.

Allow Connection to Unlisted Host (global)
When selected, only hosts included in the Global Allowed Host Key listing are available for connection.  

Before removing the checkmark from this option, first connect to any desired hosts so they are in the Allowed 
list.  Once all desired hosts are included, then uncheck this item to prevent connection to any other hosts.

Misc

Keep Alive Ping Interval
Use this option to manage SSH Keep Alive messages.  The default is 0 minutes (no SSH Keep Alive mes-
sages).  Any value greater than 0 (whole numbers only) sends SSH Keep Alive messages after the specified 
number of minutes.

TCP level Keep Alive is enabled on the Connection (page 3-1) tab.

Rekey After MB of Data
The session key is negotiated at session startup.  Because the longer a key is used, the greater the chances 
the connection may be successfully attacked, an option is provided to force a new key exchange (from the cli-
ent side) after the specified MB of data is exchanged.

The default is 0 MB, no rekey is enabled after a certain amount of data is transferred.  Any value greater than 
0 (whole numbers only) forces a rekey after that amount of data has been transferred.  No data passes 
through the SSH connection while the rekeying takes place.  

Note: The server may also enable rekeying, so rekeying may still happen even if this option and the one below 
are disabled.

Rekey After Minutes
The session key is negotiated at session startup.  Because the longer a key is used, the greater the chances 
the connection may be successfully attacked, an option is provided to force a new key exchange (from the cli-
ent side) after the specified number of minutes.
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The default is 0 minutes, no rekey is enabled after a certain time period.  Any value greater than 0 (whole 
numbers only) forces a rekey after that length of time.  No data passes through the SSH connection while the 
rekeying takes place.  

Note: The server may also enable rekeying, so rekeying may still happen even if this option and the one above 
are disabled.

Compression
When enabled, data compression is used.  By default, compression is disabled.
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4
Session Interaction

Honeywell RFTerm allows up to four simultaneous host client sessions.  Although each of these client sessions may be discon-
nected or connected, only one session is in the foreground at any time.  The session in the foreground is the active session and 
receives all user interaction.  Connected sessions in the background maintain their host session connections and update their 
(hidden) screen content.  

Multiple Sessions
You can navigate between multiple sessions either from the ToolBar session menu or the session host menu, by using HotKeys 
or the ToolBar.  

MenuBar Session Menu
The current active session is indicated in the application Session menu as shown below.  Host addresses configured for each of 
the host sessions are indicated as part of the session names.

• Configured sessions are identified by the Host Address specified on the Connection tab.
• >> indicates the current active host session.  
• A checkmark indicates a connected session.
• When this menu is displayed, pressing 1 - 4 selects the corresponding session.

In the example above:

• Current Active Host Session is S1 and it is ready to be configured or to connect.
• S2 is connected.

Session Host Menu
The Session Host Menu can be enabled on the Status (page 2-17) tab by checking the Host Menu checkbox.
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• Configured sessions are identified by the Host Address and Host Name as specified on the Connection tab.
• >> indicates the current active host session.  
• C after the session ID indicates a connected session.  
• Current Active Host Session is S1.
• S2 is connected.
• When this menu is displayed, pressing 1 - 4 connects to the corresponding session (if that session is not already 

connected) or returns control to the corresponding session (if that session is already connected).
• When enabled, the Session Host Menu is automatically displayed on the idle RFTerm screen and dismissed when the 

active session is connected.
• Pressing [Ctrl] [Alt] [0] displays the Session Host Menu over top of a connected session Repeating the keypress 

sequence dismisses the menu over a connected session.

HotKey Session Selection
The following ToolBar items and HotKeys are available to switch between sessions:

ToolBar Session Selection
The following ToolBar items can be enabled on the Custom Bar (page 2-8) and used to switch between sessions:

[Ctrl] [Shift] [J] Jump to next connected session

[Ctrl] [Alt] [1] Jump to Session 1

[Ctrl] [Alt] [2] Jump to Session 2

[Ctrl] [Alt] [3] Jump to Session 3

[Ctrl] [Alt] [4] Jump to Session 4

[Ctrl] [Alt] [0] Display Session Host Menu (if enabled) over top of a connected session (see above for details)

Jump to next connected session

Jump to Session 1

Jump to Session 2

Jump to Session 3

Jump to Session 4



4 - 3

Password Protection
Access to the Session and Configure dialogs can be password protected.

• From the application menu, select File > Settings.  
• A Settings dialog box is displayed.  
• Select the Options tab.
• Press the Config Password button.
• Enter the password and verify.

Any attempt to open either the Settings or Configure dialogs will prompt the user for the password.

To remove password protection, first enter the password.  Use the Backspace key to erase the password.  Tap the OK button.  
Contact Technical Assistance (page 10-1) in the event of a lost or forgotten password.

Connecting / Disconnecting from Host
To connect to a host, configure the client session parameters and select “Connect” from the application menu.  Only discon-
nected sessions may be connected.  Once connected, you may disconnect the host session by selecting a “Disconnect” from 
the application menu.  

You must configure the host session prior to attempting a connection.  

From the application menu select Session > Connect to connect or Session > Disconnect to disconnect.  You may also tap 
the Connect / Disconnect button on the ToolBar.  

If the Host Session Menu is displayed on the desktop, pressing 1 - 4 connects to the corresponding session (if that session is 
not already connected) or returns control to the corresponding session (if that session is already connected).

If Session Start Control is enabled (see File > Settings > Status) a confirmation box is displayed before the connection is 
made.

Clicking OK or pressing [Enter] starts the indicated session.

Clicking Cancel or the X (depending on operating system) or pressing [Esc] exits without starting the indicated session.
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Device Name In Use
When RFTerm receives an incoming host message that indicates the device name is in use, a “Device Name in Use” dialog 
box is displayed.  The user clicks the OK button or the X button to close the dialog box.

SmartPads
Depending upon the terminal emulation type, certain keys may be required to navigate within the host application.  The Smart-
Pad is a soft keypad that provides access to all emulation specific keys.  You can invoke the SmartPad only if the session is con-
nected.  The correct SmartPad appears for the emulation type of the current active session.  

You can invoke the SmartPad from the application menu by selecting Display > SmartPad.  You may also tap the “SmartPad” 
button on the ToolBar.

You may use the SmartPad HotKey [Ctrl][Shift][P] to invoke this operation.

SmartPads are not configurable dynamically.  

Note: This option is not available on devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard 
operating system.

Configurable KeyBar
Most hand-held devices have a limited keypad.  They often rely upon their internal Soft Input Panel (SIP) to type in data.  How-
ever, the SIP usage is cumbersome and it does not provide any special host keys such as those needed in a terminal emulation 
program.

The configurable KeyBar allows users to customize a set of soft keys to invoke any host specific keys or emulator operations.  
Users can select from a set of pre-defined KeyBar templates.  In addition, they can also configure up to four Custom KeyBars of 
their own.  Users can navigate or “cycle” within a selected subset of KeyBars.

For CE devices, the KeyBar appears next to the application Menu and ToolBar.  You can le it on or off by pressing the KeyBar 
icon next to the application menu.  The emulator screen automatically adjusts to provide the maximum possible screen real 
estate.  

To configure the KeyBar, refer to the Options1 (page 2-6) section under Configuration.  Take some time to customize the KeyBar 
and become familiar with its use.  It will be time well spent.

When enabled, the KeyBar appears on “top” of either the application menu, application ToolBar or SIP, depending upon their vis-
ibility state.  Tap the arrow button on either end to cycle backward or forward through the configured KeyBars.

There are several pre-defined KeyBars that are provided with the application.  These serve as emulation specific or operation 
specific templates.  You may use these in addition to the customized KeyBars.  The following table shows these pre-defined 
KeyBar templates.

See Also

The bitmaps and associated action text for all the actions and operations that can be associated with the configurable keys can 
be found at RFTerm ToolBar (page 9-1).

KeyBar Name KeyBar Buttons
Base Keys

Special Keys

Scroll Keys

F1 - F8

F9 - F16

F17 - F24
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F25 - F32

F33 - F40

IBM 1

IBM 2

IBM 3

VT 1

VT 2

VT 3

UDK11 - UDK18

Digits 0 - 4

Digits 5 - 9

KeyBar Name KeyBar Buttons
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Print Setup
You can configure a printer for RFTerm.  

• From the application menu, select File > Print Setup.

This will bring up a popup dialog.  All options may not be present, depending on device configuration.

Note: Previous versions may display an alternate menu.  The Serial button is similar in function to the Direct Serial button on 
the newer interface.  The Windows button is similar in function to the Installed Printer button on the newer interface.

Print Method
Print Method is used to specify which print method you wish to use.

Installed Printer
If you select Installed Printer, a standard Microsoft Windows Print dialog box will appear.

Direct Serial
If you select Direct Serial, the following dialog is displayed:

This dialog contains parameters that are identical, except for the Pass thru CR checkbox, to the Com1 and Com2 
(page 2-20) dialog.  Review that section for Serial Data parameter details.  

Select the external COM Port for the device and click OK.  The device must have a serial printer attached to this COM 
port.  
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All RFTerm print commands will then send unformatted data to the serial printer.  A screen print can be performed by 
using the keyboard shortcut [Ctrl] [Alt] [P].

Com Port Error Dialog
Should RFTerm be unable to apply any of the COM Port settings, the following popup dialog will appear:

Cradle Printing via IR
When a mobile client with an IR port is docked in a cradle and COM2 is selected as the serial print port on the 
mobile client, RFTerm immediately takes control of the port and continues to listen for print requests from the 
mobile client.  RFTerm releases COM2 when the connection between the mobile client’s COM2 port and the cra-
dle is disconnected.  While RFTerm is polling and controlling the cradle connection, the connection cannot be 
used by another application.

Media Copy Command
The serial port is opened on the initial MC command, all data received is written and the serial port is closed upon 
receipt of the proper MC command.  Before the data is written to the serial port, the data is examined for carriage 
returns (CR / CR LF) within 80 bytes of the previous data stream.  If found, the counter is reset and line wrapping/
dropping does not occur.  

IP
If you select IP, you can specify the IP address of a printer.  The IP address can be specified in the textbox, for exam-
ple: 100.100.100.100

The default port value is 515.  By following the IP address with a colon ‘:’ and a port number, an alternative port num-
ber can be specified, for example: 100.100.100.100:516

Using a Bar Code to Input IP Address
The IP address of the printer can also be specified by scanning a special bar code.  To create the bar code, use 
any commercially available bar code software using the format %$.TP followed by the IP address desired.  

Example

1. Create a bar code from the string %$.TP100.100.100.100 where 100.100.100.100 is the IP address of the 
desired printer.

2. Print the bar code using a printer with a minimum 600x600 resolution.

3. With RFTerm running on the device, scan the bar code with an internal, ring or tethered scanner attached to an 
Honeywell computer.

4. The IP contents of the string, 100.100.100.100 in this case, are inserted in the IP textbox.  

Scanner Applet
If the mobile client running RFTerm supports Wedge Output, Scanner Applet can be selected.  

Not all COM port parameters supported in RFTerm can be supported by the mobile client Wedge due to the small form 
factor of the client.

Note: This option is only available if the mobile client supports Scanner Wedge output.  For mobile clients that do not 
support Wedge output, the Scanner Applet option is not available.
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Bluetooth
When the mobile device supports Bluetooth, the Print Setup tab contains a selection for a Bluetooth printer.

Note: You may need to pair with a Bluetooth printer before this option is available.

Print Type
Select the desired print buffering type.  The default is Normal.

• Normal - Printing is done synchronously, one character at a time.  Input is blocked until the print is completed.
• Buffer - RFTerm can accept scanner or keyboard input while serial printing.  This allows RFTerm to buffer the print data 

and perform the serial printing in a separate thread.
• MC dly1 - RFTerm buffers print, but delays approximately 100 milliseconds between consecutive media copy commands.
• MC dly2 - RFTerm buffers print, but delays approximately 300 milliseconds between consecutive media copy commands.
• MC dly3 - RFTerm buffers print, but delays approximately 500 milliseconds between consecutive media copy commands.
• MC dly4 - RFTerm buffers print, but delays approximately 1 second between consecutive media copy commands.

Note: Previous versions had a Buffer Print checkbox.  When checked print is buffered.  When unchecked print is normal.

Out of Range
There are configuration options for the behavior of RFTerm in case the mobile client loses contact with the host.  The Out of 
Range options described in this section are valid for both RF (802.11) and WWAN connections to the host.

Should the mobile client lose contact with the host, RFTerm can attempt to reconnect the active session.  To enable this feature, 
select Session > Configure > Connection and check the Retry on Signal Loss checkbox.  For more details, refer to 
Connection (page 3-1).

RFTerm can be configured monitor the network connection and provide an indication when the network connection is lost.  To 
enable this feature, select File > Settings > Options and check the Check Network Status checkbox.  If this option is disabled, 
RFTerm provides notification of the lost connection only after a data transmission has timed out.  The type of notification 
received depends on the option selected.  For more details, refer to Options1 (page 2-6).

Text InputTool
Note: This option is not available on devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard 

operating system.

The Text InputTool sends complete text strings to the display window at the current cursor location.  A user can cache a set of 
alphanumeric text strings in the input tool.  

You can invoke the InputTool from the application menu by selecting Display > InputTool.  You may also tap the InputTool but-
ton on the ToolBar.  

You can also invoke the Text InputTool by using the HotKey [Ctrl][Shift][I].  

You can build your cached list of text strings by pasting text from the clipboard (For example [Edit][Copy] in Microsoft WordPad) 
directly into the Text InputTool edit box.  You can also directly type a text string into the edit box using the system soft keypad.  
Lastly, you can initialize this list from an ASCII text file.

Command Description
Paste Tapping the Paste button will copy any text from the clipboard into the edit box.  
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Each entry in the list is preceded by an index value in the form “1”.  This index, including the first space after the period, is 
stripped before sending.  You can edit an existing list entry by selecting it, making your changes, then pressing Add.  The saved 
list entry replaces the existing entry contents with the new value.  If there is no leading index value, for example on a new entry, 
then Add will append a new list entry.

To create an entry, which begins with text similar to an index, first create a dummy entry, then edit it to include your desired text.  
For example, to create an entry with the contents “1.  My text”, first enter the text “new” and press Add.  Assume that this 
becomes the third entry.  Select the entry from the list and change “3.  new” to “3.  1.  My text”, then press Add again.

The index values are used to identify the text sent with the “Input n” keys on the KeyBar.  Be careful when deleting entries.  
Doing so may change the text sent via an Input key.

Special characters can also be entered in the text.  This can be especially useful under VT emulation when custom escape 
sequences are required.  The following special characters are available:

The Text InputTool also accepts characters specified by Hat Encoding (page 6-7).

Add Tapping the Add button adds any text in the edit box to the cache list.  If the text string is already is in the list, 
it is not added again.  Blank strings are not added.  

Del Tapping the Del button deletes the currently selected text string from the cache list.  
Clear Tapping the Clear button clears the edit box.  
File Tapping the File button opens a dialog to select a text file that can be read to initialize the list.  Each text string 

to be added to the list must be on a separate line delimited by a CRLF.  The following shows a sample input 
text file:
78438-8889-9494
Any text string here
Username
It is recommended that you create a file for initializing the list on the desktop and then ActiveSync it to the 
mobile client.  Each session has its own list.

Send The Send button sends the currently selected text string to the current cursor location on the client display.  
Enter Sends a carriage return keystroke to the TE application.
Tab Sends a Tab keystroke to the TE application.  
BTab Sends a back tab keystroke to the TE application.  This is equivalent to [Shift][Tab].  
Esc Sends an Escape keystroke to the TE application.  

Operator Meaning
\e ESC character/action
\n Newline character/action
\r Enter character/action
\t TAB character/action
\xDD Hexadecimal value of byte

Command Description
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HotSpots
A HotSpot is a field on the client screen where a user can tap with a stylus to execute a function.  This allows a user to interact 
with a host application without using physical keys or the KeyBar.  A simple example might be the use of PF Keys.  An operation 
associated with a PF key might be displayed on the client as “PF1 = Help”.  RFTerm emulators automatically detect this as a 
HotSpot and will send a PF1 key to the host when you tap on the PF1 text on the client display.  To invoke a HotSpot, tap any-
where on the text of that HotSpot.  HotSpots are not user configurable.

HotSpots are supported for 3270, 5250 and VT emulations.  The emulations share some forms of HotSpots, such as function 
keys and menus, but others depend on the type of emulation.  

The following table lists some text strings that are recognized as HotSpots.

Note:  Prior to using a “menu choice” HotSpot, the cursor must be in the input field where the menu choice is submitted.  (Applies 
to IBM emulation only.) 

Note: Reprogramming the functions keys using the Fn Keys tab under the Configure dialog alters the operation of a function key 
HotSpot.  

HotSpots are sensitive to the stylus calibration on the device.  To get accurate HotSpot taps, make sure your touch screen is 
correctly calibrated.  

HotSpot String Sends
PFx= Function key x.  where x is between 1..9
PFxx= For 3270, 5250 emulations: Function key x.  where x is between 10..24 

For VT emulations: Function key x.  where x is between 10..20
xx.  Menu option xx.  where xx is any one or two digit number
Fxx= Function key x.  where x is between 1..24
<Fxx>= Function key x.  where x is between 1..24
Enter Sends Enter key
“X.  Menu choice” Selects menu choice X
Double Tap Sends Enter key
+ Roll Up key (5250 only)
- Roll Down Key (5250 only)
More Roll Down AID (5250 only)
Bottom Roll Down AID (5250 only)
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Screen Panning 
Most host applications have been designed for the desktop screen form factor.  When viewing these applications from a hand-
held device, only a portion of the host screen is visible because of the smaller display of the hand-held device.  Horizontal and 
vertical scroll bars are typically used to set the virtual screen location.  As an alternative to scroll bars, the screen can be posi-
tioned by “dragging” the stylus.

Imagine the host application screen as a large sheet under the display on the hand-held device.  Screen Panning allows users 
to “tap” and “drag” this sheet in any direction to move hidden areas of the host display into view on the hand-held device without 
the use of scroll bars.  

Follow these steps to use panning:

• Connect to a host application
• With the stylus, “tap and hold” anywhere on the client screen.  Be careful not to tap on a HotSpot, if you do not also want a 

HotSpot action
• Drag the stylus, without lifting, to drag hidden areas of the screen into view

There is no configuration for Screen Panning.  It is enabled whenever HotSpots are enabled for touch screen devices.  

Access Control / Device Lockdown
In some cases, there is a need to prevent users from being able to change the emulator configuration.  Further there may be a 
requirement to prevent users from exiting the TE application or launching other applications on the device.  The Access Control 
features address these needs.  Refer to the Options1 (page 2-6) configuration section for details on configuring these features.

Note: Devices with a Windows XP, Windows 7, Windows 10, or Windows Embedded Standard operating system can 
additionally be locked down by configuring the OS.

Note: Devices with a Windows CE or Windows Mobile operating system can additionally be locked down using Honeywell's 
AppLock.  Details on configuring and using AppLock are contained in the equipment specific reference guide.

Access control functionality allows for the following:

• Administrators can add Password Protection (page 4-3) to the RFTerm session configuration settings.  This prevents users 
from changing the configuration:

• From within the application
• By loading another session
• Saving the current session (to then load onto another device)
• Prevent users from invoking another application by disabling the Start menu.  This prevents users from invoking another 

application while running the Terminal Emulation program.
• Prevent users from exiting the emulator by disabling the application exit feature.
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HotKey Shortcuts
RFTerm has several predefined HotKeys.  These may normally be used with devices that have a keypad.  The following table 
lists the default HotKeys.

Note: Depending on mobile client screen and font size constraints, the segment area used by a [Ctrl]+[Arrow] key sequence is 
approximately one-quarter of the total area available.  

HotKey Description
[Ctrl][Shift][N] Configure dialog box
[Ctrl][Shift][E] Settings dialog box
[Ctrl][Shift][C] Connect to the host
[Ctrl][Shift][Down Arrow] Decrease font size
[Ctrl][Shift][D] Disconnect a connected host session
[Ctrl][Shift][F] Displays dialog box for WWAN signal strength and connectivity status.
[Ctrl][Shift][H] Display or Hide horizontal scroll bar
[Ctrl][Shift][P] Display or Hide SmartPad

(Not supported on Windows XP, Windows 7, Windows 10, or Windows Embedded Standard)
[Ctrl][Shift][I] Display or Hide Text InputTool

(Not supported on Windows XP, Windows 7, Windows 10, or Windows Embedded Standard)
[Ctrl][Shift][L] Display or Hide all bars (Menu, Tool, Key)
[Ctrl][Shift][M] Display or Hide MenuBar (also see Reset Menu Bar Code (page 4-13)

(Not supported on Windows XP, Windows 7, Windows 10, or Windows Embedded Standard)
[Ctrl][Shift][T] Display or Hide ToolBar
[Ctrl][Shift][K] Display or Hide KeyBar 
[Ctrl][Shift][V] Display or Hide vertical scroll bar
[Ctrl][Shift][B] Display all bars at the bottom

(Not supported on Windows XP, Windows 7, Windows 10, or Windows Embedded Standard)
[Ctrl][Shift][X] Exit the emulator
[Ctrl][Shift][O] or [Alt][T] Hide and unhide status bar (OIA)
[Ctrl][Shift][Up Arrow] Increase font size
[Ctrl][Shift][S] Invoke the session save dialog.
[Ctrl][Shift][J] Jump to next connected host
[Ctrl][Alt][0] Display Host Menu
[Ctrl][Alt][1] Jump to Session 1
[Ctrl][Alt][2] Jump to Session 2
[Ctrl][Alt][3] Jump to Session 3
[Ctrl][Alt][4] Jump to Session 4
[Shift][Down Arrow] Scroll down one row
[Shift][Left Arrow] Scroll left one column
[Shift][Right Arrow] Scroll right one column
[Shift][Up Arrow] Scroll up one row
[Ctrl][Down Arrow] Scroll down one row segment (see Note below)
[Ctrl][Left Arrow] Scroll left one column segment (see Note below)
[Ctrl][Right Arrow] Scroll right one column segment (see Note below)
[Ctrl][Up Arrow] Scroll up one row segment (see Note below)
[Ctrl][Shift][1] le between bold and normal font
[Ctrl][Shift][2] Display or Hide status icons

(Not supported on Windows Mobile)
[Ctrl][Alt][P] Print the screen of the active session
[Ctrl][H] Display frequently used shortcuts.
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Shortcuts for Devices without Keypads
The Dolphin 70e Black does not have a traditional keypad.  Some shortcut icons have been added to the RFTerm MenuBar 
for this device.

Reset Menu Bar Code
For any device, but especially the wearable version of the Dolphin 70e Black which does not have a physical keyboard, the 
bar code below can be scanned to restore the Windows Start Menu if hidden via the Options1 (page 2-6) tab or the RFTerm 
MenuBar if hidden via the Display (page 2-1) tab.

Automatic Session Startup
You can automate startup of up to four host sessions when the TE application starts.  To do so, enable the Auto Login Enabled 
box in the Session > Configure > Auto Login tab, for each of the sessions that you want to automatically start.  Each of these 
sessions will attempt a connection to the configured host when the emulator is started.  If a connection cannot be established, 
the following popup dialog will appear, indicating the session number:

Display or Hide KeyBar (equivalent to [Ctrl][Shift][T] on a traditional keyboard)

Display or hide virtual keyboard

Toggle virtual keypad layout, also seeVirtual Keyboard (page 2-13)

Rotates the display 90º counter-clockwise, also see VK Orientation (page 2-13)



4 - 14



5 - 1

5
ANSI

ANSI Client Overview

Block Mode Communication
Block mode communication is a communication mode that enables the client to send an entire block of data to the host at 
one time.  Refer to Sending the Client Screen to the Host (page 5-2) for more details.  Block mode greatly reduces RF traffic 
by sending data in this way.  Block mode minimizes RF overhead better than the other modes.  Thus, block mode supports 
more users on an RF channel and allows faster response time.

Local echo is a process that allows each character to display locally at the client as the client user presses the keys.  The 
host does not see these characters until the user presses the [Enter] key.

Note: In most cases, operations using programming tools that include screen painters cannot use block mode 
communication.  Screen painters or designers usually come with programming tools such as Oracle, Ingress, 
Informix, and Powerhouse, which normally use character mode communications.

Block Mode Setup
Refer to the following rules for setting up block mode communication:

• The programmer must include the following commands in the command string for setting up block mode:

ESC[12l (turn local echo on in SRM)
ESC[=1l (turn block mode on in LXELM)

Note: If local echo is off in send-receive mode (SRM), the client operates in character mode while the scroll or 
block mode setting in LXELM is ignored.

• The programmer must send formatted screens to the client from the host.

Scroll Mode Communication
Scroll mode communication is a communication mode where the client allows data entry only on one line.  The client user 
can view the rest of the form, but the cursor returns to the line the host placed the cursor in whenever the user tries to enter 
data.

Scroll mode has the following advantages:

• Provides local protection of unformatted text.
• Protects all information on the screen except the command line, which is the line where the host positions the cursor.  

Character positions to the left of the cursor’s current position are also protected.
• Enables the client user to move the cursor around the screen with the arrow keys.  If the user moves the cursor, with the 

arrow keys, away from the command line and then tries to enter data, the cursor returns to the command line before 
accepting the data.

Note: Applications that edit individual characters do not perform well in scroll mode.

Scroll Mode Setup
Refer to the following rules for setting up scroll mode communications:

• The programmer must include the following commands in the command string for setting up scroll mode:

ESC[12l (turn on local echo in SRM)
ESC[=1h (turn on scroll mode in LXESM)

• The programmer must construct a form consisting of one unprotected field on one line.

Initialization
The ANSI TE powers up in char mode and stays that way until the host changes the TE’s mode.  The host must specify that 
scroll or block mode is to be used during the current session.



5 - 2

Sending the Client Screen to the Host
Character Mode
Since each keypress is sent to the host as it is pressed, there is no concept of sending the screen in character mode.  
Pressing the [Enter] key in this case will simply send a carriage return and/or line feed to the host.  No other sections of 
the Scroll Mode screen are sent as a result of pressing [Enter].

Scroll Mode
Scroll mode allows user input on only one line of the display at a time until the user presses [Enter].  When this hap-
pens, the cursor will jump back to the active position if necessary.  The cells between command start and command 
end will be sent to the host.  The GATM/SATM/MATM modes are ignored in scroll mode.  See Scroll Mode 
Communication (page 5-1) for more details.

Block Mode
Block mode allows the user to input in any unprotected area on the display until the client user presses [Enter].  When 
this happens, the client will look at the current settings of GATM, SATM and MATM to determine exactly which screen 
cells are transmitted back to the host.  The settings of these three modes yields 6 different combinations of cells (see 
the table below, “Sending The Screen In Block Mode”).

Protected cells are cells tagged with SPA (Start Protected Area) or DAQ 1 (Define Area Qualification).

Unprotected cells are cells that are neither SSA (Start Selected Area) nor SPA nor DAQ 1.

Note: DAQ 8 cells are considered unprotected.

To use the table, first decide which of the 6 cases is desired.  For example, to use case #6 set SATM and reset GATM.  
Since MATM is don’t care in this case, it does not need to be set either way.  Set up the screen so that it is marked pro-
tected or selected except where the client user will enter data.  Now when the user presses [Enter], all cells that are not 
SSA, not SPA and not DAQ1 will be sent back to the host.

Sending the screen always operates on the virtual screen so EBM (Editing Boundary Mode) is ignored.  Tab fields do 
not affect how the screen is sent.

When sending the screen, the “current/next” selected area means that if the cursor is currently on a selected area, that 
area will be sent.  If not, search forward in the screen to find one and use that one.  If none are found before the end of 
the screen, reset to the screen origin and look from there.  If the client returns to the cursor position without finding one, 
it sends nothing.

In all cases the screen is scanned starting from the origin and each cell is transmitted in the order in which it is pro-
grammed on the display.  For example, #5 means start at the origin and scan forward for all selected cells (type SSA 
only) sending them in the order they are found.  For case #4, the current/next selected area is found first based on the 
current cursor position and it is remembered.  However, the cells are still transmitted starting from the origin.  The 
selected area is simply transmitted when the client comes across it in the display.

Case # Description of Cells Sent Kind of Cells Sent
(x = don't care)

GATM SATM MATM

1 Entire screen All set
1h

set
17h

x

2 Current/next selected only 1 SSA set
1h

reset
17l

reset
15l

3 All selected and all unprotected SSA +
!(SPA/DAQ1)

reset
1l

reset
17l

set
15h

4 Current/next selected and all unprotected 1 SSA +
!(SPA/DAQ1/SSA)

reset
1l

reset
17l

reset
15l

5 All selected SSA set
1h

reset
17l

set
15h

6 All unprotected !SSA + 
!(SPA/DAQ1)

reset
1l

set
17h

x
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A single area separator (HT 0/9) byte is inserted into the transmit stream for each protected area on the screen (for 
case #3, 4, 5 and 6 only).  However, if the first or last area on the screen is protected, no separator byte is inserted.

For example, assume case #3 is in effect.  If the first few cells of the screen are defined as follows where p is a pro-
tected cell, s is an SSA selected cell and u is an unprotected cell:

p1 p1 p1 s1 s1 s1 p2 p2 p2 s2 s2 s2 p3 p3 p3 s3 s3 s3 u1 u1 u1 ...

yields a transmit stream of:

s1 s1 s1 HT s2 s2 s2 HT s3 s3 s3 u1 u1 u1...

Note: No separator is inserted for the first protected area on the screen.  No separator appears between s3 and u1 
since there are no protected cells between them.

If the last few cells on the same display are defined as follows:

...p4 p4 p4 p4 u2 u2 u2 u2 u2 p5 s4 s4 s4 s4 p6 p6

yields a transmit stream of:

...HT u2 u2 u2 u2 u2 HT s4 s4 s4 s4

Note: No separator is inserted for the last protected area on the screen.

To reduce traffic between the client and the host when sending the screen, use cases #3, #5 and #6.  Tag most of the 
screen as protected by using SPA or DAQ1.  Leave only the cells that the user will type/scan into as unprotected/
selected.  When the client user presses [Enter] to send the screen, only the unprotected/selected cells will be sent sep-
arated by tabs.

Tabbing
Three types of tabs are provided in the client:

• default
• area
• regular

Only one type of tab can be active at any time.  Previously set tabs may be suppressed by a tab type with a higher priority.  
However, the suppressed tabs are still defined in the client.

Block mode must be active for the [Tab] key to work.  If the [Tab] key is pressed in character mode, it will be transmitted 
back to the host.  It is up to the host to echo it back to actually perform the tab.  In scroll mode, pressing the [Tab] key is 
equivalent to pressing the [Spacebar] key.

The host may perform tabbing by sending the appropriate commands (i.e.  HT) to the client regardless of the mode it is in.

When a tab command is received or the client user presses the [Tab] key, the cursor will move forward until the next tab 
stop is found.  If none is found before the end of the display, the cursor will move to the origin of the virtual display and con-
tinue searching.  The client will not tab to a tab that is in a protected area.  Tabs are stationary and do not scroll when the 
screen does.  EBM is ignored when the client tabs.

Default Tabs
These tabs are present when the client is first powered up.  They appear on every line starting in column one and are 
spaced 8 columns apart (i.e.  1, 9, 17, etc.).  These tabs have the lowest priority and they can be neither set nor erased 
by the host.

Area Tabs
These tabs can be set by the DAQ, SSA, EPA and ESA commands.  They can be set by the host on any screen cell 
within the virtual display.  These tabs have a medium priority.  Setting one or more area tabs suppresses all of the 
default tabs.  They can be erased only by the ED (Erase in Display) and EL (Erase in Line) commands when ERM 
(ERasure Mode) is set.  If all of the area tabs are erased (and there are no regular tabs) the default tabs are restored.
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Regular Tabs
These tabs can be set by the HTS, CTC and DAQ 7 commands.  They can be set by the host on any screen cell within 
the virtual display.  These tabs have high priority.  Setting one or more regular tabs suppresses all default and area 
tabs.  Regular tabs can be erased by the CTC, HTS and TBC commands.  If all of the regular tabs are erased, any 
existing area tabs are restored.  If no area tabs exist, the default tabs are restored.

ANSI Control Codes
Control codes enable a programmer to control or modify a client and attached device.  ANSI control codes consist of 7-bit and 8-
bit control codes.  This section provides information for the programmer on formatting control codes for Honeywell equipment.  
All the control codes supported by Honeywell are listed in this section.  If a control code is not listed, Honeywell does not sup-
port it, and it is treated as a no operation (NOP).

Using the 8-Bit Code Table
The 8-bit code table has the same number of rows as the 7-bit code table, but twice as many columns.  The codes on the 
left half of the table (columns 0 - 7) are used in a 7-bit and 8-bit environment.  The eighth bit of these codes is 0.  The codes 
on the right half of the table (columns 8 - 15) have an eighth bit of 1.  These codes are used in an 8-bit environment and 
indirectly in a 7-bit environment.

The mnemonics in columns 0 and 1 are C0 (control 0) codes, which can be used in 7-bit environments.  The mnemonics in 
columns 8 and 9 are C1 (control 1) codes, which can be used in 8-bit environments and indirectly in 7-bit environments as 
escape sequences.

A code table is a tool used to group all the characters in a character set with their codes.

A mnemonic is an abbreviated name that can be a single control character, escape sequence, or a control sequence.

8-Bit Code Table
Refer to the 8-bit code table below that lists all the decimal, hexadecimal, and octal values for each character:
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C0 Codes: 7-Bit Control Codes
C0 codes are 7-bit control codes that enable the programmer to perform basic functions with Honeywell clients and 
attached devices.  This section lists all the C0 codes supported by Honeywell equipment.  The examples show applications 
for each control code.  Not all C0 codes are supported by Honeywell equipment.  If a code is not listed, Honeywell does not 
support it, and it is treated as a no operation (NOP).

BEL - Bell
Function
BEL causes the client to play the Good Sound.

Hexadecimal Value
07

Control Code
^G

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a BEL command in the C programming lan-
guage:

printf(“Alert the user to this message!”);
printf(“\007\007\007\007”); /*Beep 4 times*/

BS - Backspace
Function
BS moves the cursor one space to the left.  The cursor stops at the left margin of the virtual display.

Hexadecimal Value
08

Control Code
^H

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a BS command in the C programming language:

printf(“The cursor will backspace one space.”);
printf(“\010”); /*(Octal for hex 08)*/
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CR - Carriage Return
Function
CR returns the cursor to the left margin (of the virtual screen) of the row that the cursor is currently in.

Hexadecimal Value
0D

Control Code
^M

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CR command in the C programming language:

printf(“Return cursor to beginning of \n”);
printf(“this second line.”);
printf(“\015”); /*Octal for hex 0D*/

DC2 - Device Control 2
Function
DC2 is ignored by the client device while media copy is enabled.  The DC2 code will not be sent to the printer.

Hexadecimal Value
12

Control Code
^R

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an DC2 command in the C programming lan-
guage:

printf(“\033[5i”); /*Enables following text to copy to the RS-232 port*/
printf(“This message will copy to the RS-232 port.”);
printf(“\022”); /*Terminal ignores this code and does not send it to the RS-232 
port.*/
printf(“\033[4i”); /*Disables RS-232 port*/
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DC4 - Device Control 4
Function
DC4 is an alternative way to turn off media copy.

Hexadecimal Value
14

Control Code
^T

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an DC4 command in the C programming lan-
guage:

printf(“\033[5i”); /*Enables following text to copy to the RS-232 port*/
printf(“This message will copy to the RS-232 port.”);
printf(“\020”); /*Disables RS-232 port*/

DEL - Delete
Function
DEL erases a character in the data stream.  DEL is for client user use only.  The host does not send this com-
mand.

Hexadecimal Value
7F

Control Code
[Delete]

Modes that affect this code
None

Example
If an user enters a keystroke by mistake, the user can press [Del] causing the client to backspace, which deletes 
the last character.
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ENQ - Inquiry
Function
ENQ requests a response from the client.  The client responds with an answerback message.

Hexadecimal Value
05

Control Code
^E

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an ENQ command in the C programming lan-
guage:

printf(“Requesting client response now.”);
printf(“\005”); /*Octal for hex 05*/
gets(input_str); /*input_str = LXE/q/08/TERMS67001C/0010*/

ESC - Escape
Function
ESC extends the set of ANSI controls by acting as a code extension.

Hexadecimal Value
1B

Control Code
^[

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an ESC command in the C programming lan-
guage:

printf(“\033E”); /*Octal for hex 1B.  ESC E is a NEL command*/
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FF - Form Feed
Function
FF is processed as a line feed (LF) in Honeywell clients and advances the cursor down one line.  Refer to LF - Line 
Feed (page 5-12) control code for a more detailed description.

Hexadecimal Value
0C

Control Code
^L

Modes that affect this code
Scroll Region, LNM

Example
Refer to the following example on how a programmer can format an FF command in the C programming language:

printf(“This appears on line 1.\n”);
printf(“\014”); /*(Octal for hex 0C)*/
printf(“\014”);
printf(“This appears on line 4.”);

See Also
LF - Line Feed (page 5-12)

HT - Horizontal Tab
Function
HT moves the cursor to the next predetermined position (tab stop) to the right, within the virtual screen.

If there are no more tab stops after the cursor, it will jump to the origin of the screen and continue looking for the 
next tab stop from there.

Note: The cursor will not tab to any protected screen cells.

Hexadecimal Value
09

Control Code
^I

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format the HT command in the C programming lan-
guage:

printf(“\033[1;25H”); /*CUP-place cursor at 1,25*/
printf(“\033H”); /*HTS-Set Tab*/
printf(“\033[1;1H”); /*CUP-place cursor at 1,1*/
printf(“\011”); /*HT-tab to 1,25.  Octal for hex 09*/
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LF - Line Feed
Function
LF moves the cursor down one line.

If the cursor is outside the scrolling region when the Line Feed is received, it will not move past the bottom of the 
virtual screen.  Scrolling does not occur outside the scrolling region.

If the cursor is on the bottom row of the scrolling region when the Line Feed is received and the client is in scroll 
mode, a blank line is inserted at the cursor and the screen scrolls up one (1) row.

Hexadecimal Value
0A

Control Code
^J

Modes that affect this code
Scroll Region, LNM

Example
Refer to the following example on how a programmer can format an LF command in the C programming language:

print(“\033[20h”); /*Set LNM*/
printf(“This appears on line 1.\n”);
printf(“\012”); /*Octal for hex 0A*/
printf(“\012”);
printf(“This appears on line 4.”);

NUL - Null
Function
NUL acts as a space-fill or time-fill character.

Note: You can insert a NUL anywhere in the data stream without affecting the information content.

Hexadecimal Value
00

Control Code
^@

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a NUL command in the C programming lan-
guage:

printf(“There will \000not be any\n”);
printf(“extra \000characters here.”);
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VT - Vertical Tab
Function
VT is processed as a line feed (LF) in LXE clients and advances the cursor down one line.  Refer to the Line Feed 
control code for a more detailed description.

Hexadecimal Value
07

Control Code
^G

Modes that affect this code
Scroll Region, LNM

Example
Refer to the following example on how a programmer can format a VT command in the C programming language:

printf(“This appears on line 1.\n”);
printf(“\013”); /*(Octal for hex 0B)*/
printf(“\013”);
printf(“This appears on line 4.”);

See Also
LF - Line Feed (page 5-12)
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C1 Codes: 8-Bit Control Codes
C1 codes are 8-bit control codes that enable the programmer to perform various functions with Honeywell clients and 
attached devices.  Some environments operate in 7-bit code; therefore, 8-bit control codes also have 7-bit equivalents.  This 
section lists all the C1 codes supported by Honeywell equipment.  The examples show applications for each control code.  
Honeywell supports most of the C1 codes but not all of them.  If a code is not listed, Honeywell does not support it, and it is 
treated as a no operation (NOP).

CSI - Control Sequence Introducer
Function
CSI indicates the start of a control sequence.

Hexadecimal Value
9B

7-Bit Equivalent
ESC[

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CSI command in the C programming language:

printf(“\033[10C”); /*CUF moves cursor 10 spaces forward.  033[ represents hex 9B*/

EPA - End of Protected Area
Function
EPA indicates that the cursor’s position is the end of a string of character positions protected from alteration by the 
client and guarded against transmission back to the host.  The area from the cursor position forward is marked to 
accept all input as if a DAQ 0 command was issued from that position.

Hexadecimal Value
97

7-Bit Equivalent
ESC W

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an EPA command in the C programming lan-
guage:

printf(“\033V”); /*SPA*/
printf(“This is the start of a protected area\n”);
printf(“This is the end of a protected area”);
printf(“\033W”); /*EPA*/

See Also
SPA - Start of Protected Area (page 5-18) (which precedes an EPA command)
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ESA - End of Selected Area
Function
ESA indicates that the cursor position is the end of a string of character positions selected for transmission in a 
data stream to the host.  The area from the cursor position forward is marked to accept all input as if a DAQ 0 com-
mand was issued from that position.

Note: The ESA does not initiate the RF transmission.

Hexadecimal Value
87

7-Bit Equivalent
ESC G

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an ESA command in the C programming lan-
guage:

printf(“\033F”); /*SSA-start of selected area*/
printf(“This area is selected for transmission”);
printf(“\033G”); /*ESA-end of selected area*/

See Also
SSA - Start of Selected Area (page 5-19) (which precedes an ESA command).
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HTJ - Horizontal Tab with Justify
Function
HTJ shifts the characters between the preceding tab position and the left of the cursor position, up to the next tab 
position.  The screen cells to the left of the justified text will be space filled.

The cursor will also move to the left of the next tab stop.  If the cursor was on a tab stop when the HTJ command 
was received, the cursor will move to the next tab stop with no justification.  This command will act on regular tabs 
if they exist, otherwise it will act on default tabs.  HTJ will not act on area tabs.

Hexadecimal Value
89

7-Bit Equivalent
ESC I

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an HTJ command in the C programming lan-
guage:

printf(“\033[5;5H”); /*CUP-move cursor to 5;5*/
printf(“\033H”); /*HTS-tab set*/
printf(“\033[5;12H”); /*CUP-move cursor to 5;12*/
printf(“\033H”); /*HTS-tab set*/
printf(“\033[5;5H”); /*CUP-move cursor to 5;5*/
sleep(10); /*Wait for user to enter data*/
printf(“\033I”); /*HTJ-justify data to the tab set*/
gets(s); /*Wait for user to press <Enter> and read in data*/

HTS - Horizontal Tabulation Set
Function
HTS sets a tab position at the cursor position.

Hexadecimal Value
88

7-Bit Equivalent
ESC H

Modes that affect this code
TSM

Example
Refer to the following example on how a programmer can format an HTS command in the C programming lan-
guage:

printf(“\033[4,20H”); /*CUP-move cursor to 4,20*/
printf(“\033H”); /*HTS-Set Tab Stop*/
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IND - Index
Function
IND moves the cursor down one row without changing column position.

If the cursor is on the bottom row of the scrolling region, the display within the region will scroll up by one (1) row.

No scrolling occurs if the cursor is outside of the scrolling region.

Hexadecimal Value
84

7-Bit Equivalent
ESC D

Modes that affect this code
Scroll Region

Example
Refer to the following example on how a programmer can format an IND command in the C programming lan-
guage:

printf(“\033D”); /*Index-move down 1 row*/

NEL - Next Line
Function
NEL moves the cursor to the left margin on the next line.

If the cursor is on the bottom row of the scrolling region, the display within the region will scroll up by one (1) row.

No scrolling occurs if the cursor is outside of the scrolling region.

Hexadecimal Value
85

7-Bit Equivalent
ESC E

Modes that affect this code
Scroll Region

Example
Refer to the following example on how a programmer can format an NEL command in the C programming lan-
guage:

printf(“\033E”); /*NEL-down one line to the left margin*/
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RI - Reverse Index
Function
RI moves the cursor up one line without changing the column position.

If the cursor is on the top row of the scrolling region, the display within the region will scroll down by one (1) row.

No scrolling occurs if the cursor is outside the scrolling region.

Hexadecimal Value
8D

7-Bit Equivalent
ESC M

Modes that affect this code
Scroll Region

Example
Refer to the following example on how a programmer can format an RI command in the C programming language:

printf(“This prints on line 3.”);
printf(“\015”); /*Carriage Return.  Move to column 1*/
printf(“\033M”); /*RI-move up 1 line*/
printf(“This prints on line 2.”);

SPA - Start of Protected Area
Function
SPA indicates the start of a string of character positions protected from alteration by the client and guarded 
against transmission back to the host.  This command is equivalent to DAQ 1.

Hexadecimal Value
96

7-Bit Equivalent
ESC V

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an SPA command in the C programming lan-
guage:

printf(“\033V”); /*SPA*/
printf(“This is the start of a protected area\n”);
printf(“This is the end of a protected area”);
printf(“\033W”); /*EPA*/

See Also
EPA - End of Protected Area (page 5-14) (which follows the SPA command)
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SSA - Start of Selected Area
Function
SSA indicates the start of a string of character positions selected for transmission back to the host.  This com-
mand is similar to DAQ 8, except that SSA allows user input whereas DAQ 8 does not.

Note: The SSA does not initiate the RF transmission.

Hexadecimal Value
86

7-Bit Equivalent
ESC F

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an SSA command in the C programming lan-
guage:

printf(“\033F”); /*SSA-start of selected area*/
printf(“This area is selected for transmission”);
printf(“\033G”); /*ESA-end of selected area*/

See Also
ESA - End of Selected Area (page 5-15) (which follows the SSA command)
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ANSI Escape Sequences
This section provides information on coding ANSI escape sequences, which extend the functions available with the control 
codes.  If an ANSI escape sequence is not listed, Honeywell does not support it, and it is treated as a no operation (NOP).

CBT - Cursor Backward Tabulation
Function
CBT moves the cursor left, to the preceding tab position within the virtual screen.

If there are no tab stops before the cursor, it will jump to the lower right corner of the screen and continue looking back-
ward for the next tab stop.

Note: The cursor will not tab to any protected screen cells.

Escape Sequence
ESC[PnZ

where:

Pn is the number of tab positions the cursor moves to the left.

Z is the final character.

Parameter Values
Refer to the following table for the movement of the cursor according to the value that you enter:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CBT command in the C programming language:

printf(“\033[1;25H”); /*CUP-place cursor at row 1, column 25*/
printf(“\033H”); /*HTS-set tab set*/
printf(“\033[1;35H”); /*CUP-place cursor at row 1, column 35*/
printf(“\033[1Z”); /*CBT-move cursor back to tab set*/

When you enter... Then the cursor moves...

0 back one tab stop because the value defaults to 1 when you enter 0.

1 (default) back one tab stop.

a number greater than 1 back the number of tab stops the value indicates within the bounds of the virtual screen.
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CHA - Cursor Horizontal Absolute
Function
CHA moves the cursor to the column (on the current row) that the parameter indicates.  If a number greater that 80 is 
entered, the cursor will move to column 80 by default.

Note: Column number depends on the setting in Session Configuration.

Escape Sequence
ESC[PnG

where:

Pn is the column number the cursor moves to.

G is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CHA command in the C programming language:

printf(“\033[7G”); /*move cursor to column 7 of the current line*/

When you enter... Then the cursor moves...

0 to column one because the value defaults to 1 when you enter 0.

1 (default) to column one.

a number greater than 1 to the column the value indicates in the current line.
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CHT - Cursor Horizontal Tab
Function
CHT moves the cursor right, to the next tab position within the virtual screen.  If there are no tab stops found after the 
cursor, it will jump to the origin of the screen and continue looking for the next tab stop.

Note: The cursor will not tab to any protected screen cells.

Escape Sequence
ESC[PnI

where:

Pn is the number of tab positions the cursor moves to the right.

I is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CHT command in the C programming language:

printf(“\033[1;25H”); /*CUP-place the cursor at row 1, column 25*/
printf(“\033H”); /*HTS-tab stop*/
printf(“\033[1;1H”); /*CUP-move cursor up to row 1, column 1*/
printf(“\033[1I”); /*CHT-place cursor horizontal tab*/

When you enter... Then the cursor moves...

0 forward one tab position because the value defaults to 1 when you enter 0.

1 (default) forward one tab position.

a number greater than 1 forward the number of tab positions that the value indicates within the bounds of the 
virtual screen
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CNL - Cursor Next Line
Function
CNL moves the cursor down one or more lines to the left margin from the cursor’s current position.  The cursor will stick 
at the bottom margin if a large number is entered.

Escape Sequence
ESC[PnE

where:

Pn is the number of lines the cursor moves down.

E is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CNL command in the C programming language:

printf(“\033[1;20H”); /*CUP-place cursor at row 1, column 20*/
printf(“\033[1E”); /*CNL-move cursor to next line, column 1*/

When you enter... Then the cursor moves...

0 to the left margin on the next line from its current position because the value defaults to 
1 when you enter 0.

1 (default) to the left margin on the next line from its current position.

a number greater than 1 down, as many lines as the value indicates, to the left margin.
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CPL - Cursor Preceding Line
Function
CPL moves the cursor up one or more lines to the left margin from the cursor’s current position.  The cursor will stick at 
the top margin if a large number is entered.

Escape Sequence
ESC[PnF

where: 

Pn is the number of lines the cursor moves up.

F is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CPL command in the C programming language:

printf(“\033[3;20H”); /*CUP-move the cursor to row 3, column 20*/
printf(“\033[2F”); /*CPL-move the cursor up 2 lines*/

When you enter... Then the cursor moves...

0 up one line to the left margin because the value defaults to 1 when you enter 0.

1 (default) up one line to the left margin.

a number greater than 1 up, as many lines as the value indicates, to the left margin.
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CPR - Cursor Position Report
Function
CPR reports the cursor’s position to the host.  DECOM is ignored when reporting the cursor position.  The position 
reported is always relative to the origin of the virtual screen.

Note: This report is sent from the client to the host in response to a device status report 6 (DSR 6)

Escape Sequence
ESC[Pr,PcR

where:

Pr is the row position.

Pc is the column position.

R is the final character.

Example
Refer to the following example of a CPR sent from the client to the host:

printf(“\033[2;5H”); /*CUP-Place cursor*/
printf(“\033[6n”); /*DSR-Request cursor position*/
gets(s); /*String returned= “\033[2;5R”*/

Note: This example requires that the [Enter] key is pressed to exit from the gets command.

Modes that affect this code
None

See Also
DSR - Device Status Report (page 5-37) 
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CTC - Cursor Tabulation Control
Function
CTC sets or clears the horizontal tab positions.

Escape Sequence
ESC[PnW

where:

Pn is the tab position you want to set.

W is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s tab position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CTC command in the C programming language:

printf(“\033[5W”); /*clear all horizontal tab positions*/

When you enter... Then this parameter value...

0 (default) with TSM set, sets the tab stop at the cursor’s position.
with TSM reset, sets the tab stop at the cursor’s column, on all rows in the virtual screen.

1 Honeywell does not support this parameter value.

2 with TSM set, clears the tab stop at the cursor’s position.
with TSM reset, clears the tab stop at the cursor’s column, on all rows in the virtual screen.

3 Honeywell does not support this parameter value.

4 with TSM set, clears all of the tab stops on the cursor’s row in the virtual screen.
with TSM reset, clears all of the tab stops on the virtual screen.

5 with TSM set or reset, clears all of the tab stops on the virtual screen.

6 Honeywell does not support this parameter value.
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CUB - Cursor Back
Function
CUB moves the cursor one or more positions to the left, up to the left margin.  The cursor will stick at the left margin if 
a large number is entered.

Escape Sequence
ESC[PnD

where:

Pn is the number of character spaces the cursor moves to the left.

D is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
The following example illustrates how a programmer can format a CUB command in the C programming language:

printf(“\033[4D”); /*CUB-move cursor back 4 spaces*/

When you enter... Then the cursor moves...

0 to the left one space because the value defaults to 1 when you enter 0.

1 (default) to the left one space.

a number greater than 1 to the left the number of spaces the value indicates up to the left margin.
Each line contains 80 or 132 character positions depending on configuration.
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CUD - Cursor Down
Function
CUD moves the cursor down one or more lines, without changing the cursor’s column position.

If the cursor is outside the scrolling region when this command is received, it will not move past the bottom of the vir-
tual screen.

If the cursor is inside the scrolling region, it will not move past the bottom row of the scrolling region.

If Editing Boundary Mode (EBM) is set to the physical display, the scrolling region is ignored and the cursor will not 
move past the bottom of the physical display.

Note: Scrolling does not occur with this command.

Escape Sequence
ESC[PnB

where:

Pn is the number of lines the cursor moves down.

B is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CUD command in the C programming language:

printf(“\033[4B”); /*CUD-move cursor down 4 lines*/

When you enter... Then the cursor moves...

0 down one line in the same column because the value defaults to 1 when you enter 0.

1 (default) down one line in the same column.

a number greater than 1 down the number of lines the value indicates without changing column position.
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CUF - Cursor Forward
Function
CUF moves the cursor forward (to the right) one or more spaces up to the right margin.  The cursor will stick at the right 
margin if a large number is entered.

Escape Sequence
ESC[PnC

where:

Pn is the number of character positions the cursor moves to the right.

C is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CUF command in the C programming language:

printf(“\033[4C”); /*CUF-moves cursor forward 4 spaces*/

When you enter... Then the cursor moves...

0 one position to the right because the value defaults to 1 when you enter 0.

1 (default) one position to the right.

a number greater than 1 to the right the number of times the value indicates up to the right margin.
Each line contains 80 or 132 character positions depending on configuration.
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CUP - Cursor Position Absolute
Function
CUP moves the cursor to a specified row/column position.

If the row or column positions are out of range, the client will adjust them and be within range of the appropriate display.

Escape Sequence
ESC[Pr,PcH

where:

Pr is the row position.

Pc is the column position.

H is the final character.

Parameter Values
Refer to the following table for the values that you can enter for CUP:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CUP command in the C programming language:

printf(“\033[3;17H”); /*CUP-move cursor to row 3, column 17*/

Parameter Value

Pr 1-25 Line 25 is the status line.

Pc 1-80

If you enter 0 for Pr or Pc, the parameter defaults to 1.
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CUU - Cursor Up
Function
CUU moves the cursor up one or more lines, without changing the cursor’s column position.

Note: Scrolling does not occur with this command.

Escape Sequence
ESC[PnA

where:

Pn is the number of lines the cursor moves up.

A is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a CUU command in the C programming language:

printf(“\033[4A”); /*CUU-move cursor up 4 lines*/

CVT - Cursor Vertical Tab
Function
CVT is processed the same as the Cursor Next Line command (CNL).

Escape Sequence
ESC[PnY

where:

Pn is the number of lines the cursor moves down.

Y is the final character.

Modes that affect this code
None

See
CNL for more details.

When you enter... Then the cursor moves...

0 up one line because the value defaults to 1 when you enter 0.

1 (default) up one line.

a number greater than 1 up the number of lines the value indicates up to the top of the virtual screen.
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DAQ - Define Area Qualifications
Function
DAQ indicates that the cursor’s position is the start of a string of consecutive character positions that constitute a qual-
ified area.  The end of a qualified area is indicated by the beginning of the next qualified area.  A qualified area restricts 
the type of input the client user enters.

Escape Sequence
ESC[Pno

where:

Pn indicates the type of data that the client accepts.

o is the final character.

Multiple parameters may be sent in a single DAQ command if they are separated by semi-colons.

Parameter Values
Refer to the following table for the effect the value that you enter has on the qualified area:

Every new DAQ command that the client receives will always overwrite the existing DAQ attribute type from the cursor 
to the end of the area.

Note: Parameter types 6 and 9 are executed immediately and are not stored in the TE.

Rule
All DAQ parameters are supported in block mode.  Parameters 0, 2, 3, 4 and 10 are supported in scroll mode.  No 
parameters are supported in character mode.

However, if multiple DAQ parameters are specified in a single command, they will combine as described in the table 
below.

When you enter... Then the qualified area...

0 (default) accepts all data.

1 does not accept any input and is not selected to transmit.
Entering 1 for this value is equivalent to the 8-bit control code start of protected area (SPA) 
discussed in C1 Codes: 8-Bit Control Codes.

2 accepts only displayable characters, 20-7E hex.

3 accepts only numeric characters.

4 accepts only alphabetic characters.

5 right justifies the data.

6 is filled with zeros.

7 has a horizontal tab stop set at the start of area.

8 does not accept any input, but it is selected to transmit.

9 is filled with spaces.

10 accepts input, but the characters are invisible.

15 accepts only keyboard input.

Parameter in 
DAQ command +

Previous 
Parameter in 
DAQ command = Parameter Stored in TE

All data (0) + any = All data

Guarded (1) + any = Guarded

Displayable (2) + any = Displayable

Numeric (3) + Alphabetic = Alphanumeric
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For example, if the host specified ESC[1;5;0o, the client would mark the area as simply “All data” since 0 was the last 
parameter.  However, if the host specified ESC[3;4;5o, the client would mark the area as alpha-numeric and right justi-
fied.

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a DAQ command in the C programming language:

printf(“\033[1o”); /start of a protected area*/
printf(“Accept numeric character input only.\n”);
printf(“\033[3o”); /*Define numeric entry area start*/
printf(“____”); /*4 underscore characters*/
printf(“\033[1o”); /*define numeric entry area stop*/
printf(“\033[4D”); /*CUB-moves the cursor back 4 spaces*/
gets(s); /*string returned will be numeric value only*/

Numeric (3) + any other = Numeric

Alphabetic (4) + Numeric = Alphanumeric

Alphabetic (4) + any other = Alphabetic

Right Justify (5) + any = Previous+Right Justified
(If 5 is the only parameter received, the area will be an “All data, 
right justified” one.)

Regular Tab (7) + any = All data+Regular Tab Stop
(Ignores TSM)

Selected (8) + any = Selected

Parameter in 
DAQ command +

Previous 
Parameter in 
DAQ command = Parameter Stored in TE
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DCH - Delete Character
Function
DCH deletes the character(s) at the cursor position and shifts all the characters right of the cursor to the left (toward 
the cursor).

The client will not delete past the first protected screen cell to the right of the cursor.  If the cursor is on a protected cell 
when the DCH command is received, it will move one position to the right (i.e.  CUF 1).  No deletion takes place in this 
case.

Note: The vacated character position at the other end is erased.

Rule
Block mode must be enabled to use DCH.

Escape Sequence
ESC[PnP

where:

Pn is the number of characters to delete.

P is the final character.

Parameter Values
Refer to the following table for the effect the value that you enter has on the cursor’s position:

Modes that affect this code
SEM

Example
Refer to the following example on how a programmer can format a DCH command in the C programming language:

printf(“All X's on this XX line will be deleted”);
printf(“\033[23D”); /*CUB-23 spaces back*/
printf(“\033[2P”); /*DCH-deletes 2 x's*/
printf(“\033[12D”); /*CUB-12 spaces back*/
printf(“\033[1P”); /*DCH-deletes x's remaining*/

When you enter... Then the client...

0 deletes one character because the value defaults to 1 when you enter 0.

1 (default) deletes one character.

a number greater than 1 deletes the number of characters the value indicates.
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DL - Delete Line
Function
DL deletes the line the cursor is in and shifts all following lines up.  If the cursor is outside the scrolling region, this com-
mand is ignored.

Escape Sequence
ESC[PnM

where:

Pn is the number of lines the device deletes.

M is the final character.

Parameter Values
Refer to the following table for the number of lines the client deletes according to the value that you enter:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a DL command in the C programming language:

printf(“This line will be deleted.\n”);
printf(“This line will be deleted.\n”);
printf(“This line moves up and is not deleted.\n”);
printf(“\033[3A”); /*CUU-cursor moves up 3 lines*/
printf(“\033[2M”); /*DL-2 lines are deleted and remaining lines move up*/

When you enter... Then the client deletes...

0 one character because the value defaults to 1 when you enter 0.

1 (default) one line.

a number greater than 1 the number of lines the value indicates without going beyond the bottom of the virtual 
screen or the scrolling region.
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DMI - Disable Manual Input
Function
DMI disables keyboard and RS-232 input.  This command is equivalent to SM KAM.

Escape Sequence
ESC` (tilde)

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a DMI command in the C programming language:

printf(“\033`”); /* Keyboard and RS-232 now locked */
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DSR - Device Status Report
Function
DSR requests information or reports information.  DSR from the host requests information from the client receiving the 
sequence (Pn = 5, 6).  DSR from the client reports the status of the client (Pn = 0).

Escape Sequence
ESC[Pnn

where:

Pn is either a value that you enter (5 or 6) or it is a value returned from the client (0).

n is the final character.

Parameters Indicating a Request
Refer to the following table for the requests the host sends to a client according to the parameter value:

Note: Parameter 5 and 6 do not append a CR or LF to the response.  Parameters 90, 92 and 93 append CR and LF 
as if the [SEND] key was pressed.

Note: DSR 90 - 94 are useful for debugging host applications.

Response to a CPR Request
The client sends a CPR response when the host requests a CPR.  See CPR - Cursor Position Report (page 5-25).

Note: A carriage return (CR) and a line feed (LF) are not returned in the response to a CPR request.

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a DSR command that requests a client to send a sta-
tus report in C programming language:

printf(“\033[5n”);
gets (s); /*string returned is \033[0n for a ready status*/

Note: The example above requires that the [Enter] key be pressed at the client to exit from the gets command.

Parameter Report that the Host is Requesting

5 Status Report.
The client returns a CSI0n indicating ready status.

6 Cursor Position Report (CPR).

90 Sends the TE display, just as if the client user had pressed the [Enter] key.

92 Sends the TE display just as if the client user had pressed [Enter].  

93 Same as 90, except the TE does not lock its keyboard.

94 Sends the upper left and lower right coordinates of the physical display in the format
CSI?UL Row;UL Col;LR Row,LR Col R
The coordinates are 1-based.
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EA - Erase in Area
Function
EA erases characters in the qualified area where the active position (cursor’s position) resides according to the value 
that you enter.  This command will not erase the type of qualified area that the cursor is in.

Escape Sequence
ESC[PnO

where:

Pn indicates what portion of the area is erased.

O is the final character.

Parameter Value
Refer to the following table on how characters are erased in the qualified area:

Modes that affect this code
ERM

Example
Refer to the following example on how a programmer can format an EA command in the C programming language:

printf(“\033[6l”); /*Reset ERM*/
printf(“\033[1o”) /*DAQ-Start of protected area*/
printf(“This will not be erased.\n”);
printf(“\033[0o”); /*DAQ-Accepts all input*/
printf(“_ _ _ _ \033[1o”); /*DAQ-Accept no input*/
printf(“\033[4D”); /*CUB-4 spaces*/
printf(“\033[2O”); /*EA-Erase in Area-all*/

When you enter... Then the client ...

0 (default) erases characters from the cursor to the end of the qualified area.

1 erases characters from the start of the qualified area to the cursor.

2 erases all characters in the qualified area.
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ECH - Erase Character
Function
ECH erases the character at the cursor’s position and possibly other characters to the right of the cursor, depending on 
the value that you enter.  If a large number of characters to erase is specified, the erase will continue on succeeding 
lines.

Note: The active (cursor) position is unchanged.

Escape Sequence
ESC[PnX

where:

Pn is the number of characters to erase.

X is the final character.

Parameter Values
Refer to the following table on how the client erases characters according to the value that you enter:

Modes that affect this code
ERM

Example
Refer to the following example on how a programmer can format an ECH command in the C programming language:

printf(“This Z will be erased.”);
printf(“\015”); /*Carriage return*/
printf(“\033[5c”); /*Cursor forward 5 spaces*/
printf(“\033[1X”); /*Erase character Z*/

When you enter... Then the client ...

0 erases one character because the value defaults to 1 when you enter 0.

1 (default) erases one character.

a number greater than 1 erases the number of characters the value indicates.
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ED - Erase in Display
Function
ED erases some or all of the characters in the display according to the value that you enter.  This command will erase 
the type of qualified area that the cursor is in.  It will also erase qualified area boundaries.

If EBM is set to the virtual screen, every row that is completely erased will have its line attribute reset to single high and 
single wide.

Escape Sequence
ESC[PnJ

where:

Pn indicates what portion of the display is erased.

J is the final character.

Parameter Values
Refer to the following table on how the client erases characters according to the value that you enter:

Modes that affect this code
ERM

Example
Refer to the following example on how a programmer can format an ED command in the C programming language:

printf(“\033[2J”); /*Erases entire display*/

When you enter... Then the client ...

0 (default) erases characters starting with the cursor position to the end of the display.

1 erases the characters from the start of the display to the cursor.

2 erases all the characters on the display.  The cursor is moved to the origin of the physical 
display or virtual screen, depending on the EBM setting.
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EF - Erase in Field
Function
EF erases characters in the current field depending on the value that you enter.  This command will not erase the type 
of qualified area that the cursor is in.

Escape Sequence
ESC[PnN

where:

Pn indicates what portion of the current field is erased.

N is the final character.

Parameter Values
Refer to the following table on how the client erases characters in a field according to the value that you enter:

Modes that affect this code
EBM

Example
Refer to the following example on how a programmer can format an EF command in the C programming language:

printf(“\033[5W”); /*CTC-Clear all tabs*/
printf(“\033[0W”); /*CTC-Set a tab*/
printf(“_ _ _ _ \033[0W”); /*CTC-Set a tab*/
printf(“\033[3D”); /*CUB-3 spaces*/
printf(“\033[2N”); /*EF-Erases all of field*/

When you enter... Then the client ...

0 (default) erases characters from the cursor position to the end of the field.

1 erases characters from the beginning of the field to the cursor position.

2 erases the entire field that the cursor is in.
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EL - Erase in Line
Function
EL erases characters in the line the cursor is in according to the value that you enter.  This command will erase the 
type of qualified area that the cursor is in.  It will also erase qualified area boundaries.

Escape Sequence
ESC[PnK

where:

Pn indicates what portion of the current line is erased.

K is the final character.

Parameter Values
Refer to the following table on how the client erases characters according to the value that you enter:

Modes that affect this code
ERM

Example
Refer to the following example on how a programmer can format an EL command in the C programming language:

printf(“\033[6l”); /*Reset ERM*/
printf(“\033[1o”); /*DAQ-Start of protected area*/
printf(“This will not be erased.\n”);
printf(“\033[0o”); /*DAQ-Accepts all input*/
printf(“_ _ _ _ \033[1o”); /*DAQ-Accepts no input*/
printf(“\033[4D”); /*CUB-4 spaces*/
printf(“\033[2K”); /*Erase in Line*/

When you enter... Then the client ...

0 (default) erases characters from the cursor position to the end of line.

1 erases characters from the beginning of the line to the cursor.

2 erases the entire line that the cursor is in.
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EMI - Enable Manual Input
Function
EMI enables keyboard and RS-232 input.  This command is equivalent to RM KAM.

Escape Sequence
ESCb

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an EMI command in the C programming language:

printf(“\033b”); /* Keyboard and RS-232 now unlocked */

HVP - Horizontal Vertical Position
Function
HVP moves the cursor to the specified row/column position.  HVP is the same as the CUP command in Legacy clients.  
Refer to the CUP command for more details.  See CUP - Cursor Position Absolute (page 5-30).

Escape Sequence
ESC[Pr,Pcf

where:

Pr is the row position.

Pc is the column position.

f is the final character.

Parameter Values
Refer to the following table for the values that you can enter for HVP:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an HVP command in the C programming language:

printf(“\033[3;17f”); /*Move the cursor to row 3, column 17*/

Parameter Value

Pr 1 - 25(Line 25 is the status line.)

Pc 1 - 80

If you enter 0 for Pr or Pc, the parameter defaults to 1.
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ICH - Insert Character
Function
ICH shifts all characters from the cursor to the right and inserts a space character at the cursor position.

The client will not insert past the first protected screen cell to the right of the cursor.  If the cursor is on a protected cell 
when this command is received, it will move one position to the right (i.e.  CUF 1).  No insertion takes place in this 
case.

Escape Sequence
ESC[Pn@

where:

Pn is the number of character spaces the cursor shifts to the right.

@ is the final character.

Rule
Block mode must be enabled for ICH to work.

Parameter Values
Refer to the table below on how the characters move according to the value that you enter:

Modes that affect this code
SEM

Example
Refer to the following example on how a programmer can format an ICH command in the C programming language:

printf(“Insert space here”);
printf(“\015”); /*CR-carriage return*/
printf(“\033[6C”); /*CUF-cursor forward*/
printf(“\033[1@”); /*ICH-insert space character*/
printf(“\033[1C”); /*CUF-cursor forward*/
printf(“\033[1@”); /*ICH-insert space character*/

When you enter... Then the client shifts the characters...

0 one space to the right because the value defaults to 1 when you enter 0.

1 (default) one space to the right.

a number greater than 1 the number of spaces the value indicates to the right.
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IL - Insert Line
Function
IL inserts one or more blank lines at the cursor’s position and shifts all following lines down.  If the cursor is outside the 
scrolling region, this command is ignored.

Escape Sequence
ESC[PnL

where:

Pn is the number of blank lines inserted at the cursor’s position.

L is the final character.

Parameter Values
Refer to the following table on how to insert blank lines at the cursor’s position:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an IL command in the C programming language:

printf(“This line will move down 2 lines.”);
printf(“\015”); /*CR-carriage return*/
printf(“\033[2L”); /*Insert 2 lines*/

When you enter... Then the client inserts...

0 one blank line because the value defaults to 1 when you enter 0.

1 (default) one blank line.

a number greater than 1 the number of blank lines the value indicates at the cursor’s position.  The inserted lines 
do not go beyond the bottom of the virtual screen or the scrolling region.
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MC - Media Copy
Function
MC enables or disables the RS-232 port.  When enabled, the client sends received characters to the RS-232 port with-
out displaying them on the screen.  All characters (except: Nul, XON, XOFF, DC4, DC2, CSI5i and CSI4i) are sent to 
the port.  When disabled, the client sends received chars to the display.  MC has a higher priority than autoprint mode.

Note: An alternative way to disable MC is to send a DC4.

Escape Sequence
ESC[Pni

where:

Pn indicates whether the RS-232 port is off or on.

i is the final character.

Parameter Values
Refer to the table below on how to enable or disable the RS-232 port:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an MC command in the C programming language:

printf(“\033[5i”); /*Enables following text to copy to the RS-232 port*/
printf(“This message will copy to the RS-232 port.”);
printf(“\033[4i”); /*Disables RS-232 port*/

When you enter... Then the RS-232 port is ...

4 off.

5 on.
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REP - Repeat Character
Function
REP repeats the last character transmitted by the host the number of times indicated by the value.  Only characters are 
repeated.  Escape sequences are not repeated.

Escape Sequence
ESC[Pnb

where:

Pn is the number of times a character is repeated.

b is the final character.

Parameter Values
Refer to the table below on how many times the character is repeated according to the value that you enter:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an REP command in the C programming language:

printf(“The number 3 is repeated:\n);
printf(“4 times-3”);
printf(“\033[4b”); /*repeat 4 times*/

When you enter... Then the client repeats the character ...

0 once because the value defaults to 1 when you enter 0.

1 (default) once.

a number greater than 1 the number of time that the value indicates.
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RM - Reset Mode
Function
RM resets one or more modes for the device indicated by the value that you enter.  Several modes can be reset with 
the same command if the parameter values are separated by semicolons.  They can be sent in any order except #3.

Escape Sequence
ESC[Pn1

where:

Pn indicates which mode to reset.

 l (lower-case L) is the final character.

Parameter Values
Refer to the following table for the modes RM resets:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an RM command in the C programming language:

printf(“\033[4l”)/*reset IRM*/

See Also
Refer to SM - Set Mode (page 5-50) for more information on how to set the modes discussed in the previous table.

Parameter Mode to Reset Description

1 Guarded Area Transfer 
Mode (GATM)

Enables the client to transmit only the unguarded areas to the host and 
auxiliary device.  Refer to Sending the Client Screen to the Host (page 5-
2) for more details.

2 Keyboard Action Mode 
(KAM)

Unlocks the keyboard and RS-232 data entry.

4 Insert-Replace Mode 
(IRM)

Enables the client to replace the information during editing by overwriting 
the content of the line.

6 Erasure Mode (ERM) Determines that the editing commands such as EA cannot erase protected 
characters.

12 Send-Receive Mode 
(SRM)

Enables local echo in the client so that the client operates in scroll or block 
mode.  Character mode communication is disabled.

15 Multiple Area Transmit 
Mode (MATM)

Enables the client to transmit only the selected area containing the cursor.  
Refer to Sending the Client Screen to the Host (page 5-2) for more details.

17 Selected Area 
Transmit Mode (SATM)

Enables the client to transmit only the selected areas.  Refer to Sending 
the Client Screen to the Host (page 5-2) for more details.

18 Tab Stop Mode (TSM) Determines that the tab stop settings affect the entire virtual display.

20 Line Feed/New Line 
Mode (LNM)

Enables the client to perform only a line feed while the cursor remains in 
its current column.
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SEM - Select Editing Extent Mode
Function
SEM indicates the extent to which the delete character (DCH) command and the insert character (ICH) command 
affect the display window.

Escape Sequence
ESC[PnQ

where:

Pn indicates how much of the display window is affected by the editing commands.

Q is the final character.

Parameter Values
Refer to the following table for the affect that SEM has on the DCH and ICH editing commands:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an SEM command in the C programming language:

printf(“\033[3Q”); /*SEM-3*/

See Also
Refer to DAQ - Define Area Qualifications (page 5-32) for more information on define area qualification.  Refer to EPA 
- End of Protected Area (page 5-14) and SPA - Start of Protected Area (page 5-18) for more information on end of pro-
tected area and select protected area.

When you enter... Then DCH and ICH commands affect...

0 (default) the entire display.

1 only the row the cursor is in.

2 only the field containing the cursor (between horizontal tab stops).

3 only the selected area containing the cursor (defined by DAQ, SPA and EPA).
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SM - Set Mode
Function
SM sets one or more modes for the client as specified by the parameter.  Several modes can be set with the same 
command if the parameter values are separated by semicolons.  They can be sent in any order except #3.

Escape Sequence
ESC[Pnh

where:

Pn indicates the mode to set.

h is the final character.

Parameter Values
Refer to the following table for the modes SM sets:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an SM command in the C programming language:

printf(“\033[4h”); /*Set IRM*/

See Also
RM - Reset Mode (page 5-48) (for more information on how to reset the modes discussed in the previous table).

Parameter Mode to Set Description

1 Guarded Area Transfer 
Mode (GATM)

Enables the client to transmit the entire screen to the host or auxiliary 
device.  Refer to Sending the Client Screen to the Host (page 5-2) for 
more details.

2 Keyboard Action Mode 
(KAM)

Locks the keyboard and RS-232 data entry.  The keyboard cannot be 
unlocked from the client.

3 Control Representation 
Mode (CRM)

Enables the client to display the control codes.  This parameter value 
must immediately precede the final character.

4 Insert-Replace Mode 
(IRM)

Enables the client to insert the information while the contents of the line 
shift to the right.

6 Erasure Mode (ERM) Determines that the editing commands such as EA can erase protected 
characters.

12 Send-Receive Mode 
(SRM)

Disables local echo in the client so that the client operates in character 
mode.  Scroll or block mode communication is disabled.

15 Multiple Area Transmit 
Mode (MATM)

Enables the client to transmit all selected areas.  Refer to Sending the 
Client Screen to the Host (page 5-2) for more details.

17 Selected Area Transmit 
Mode (SATM)

Enables the client to transmit the entire virtual screen.  Refer to Sending 
the Client Screen to the Host (page 5-2) for more details.

18 Tab Stop Mode (TSM) Determines that the tab stop settings only affect the cursor’s row.

20 Line Feed/New Line 
Mode (LNM)

Enables the client to perform a line feed and carriage return, placing the 
cursor at the beginning of the next line.
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TBC - Tab Clear
Function
TBC clears one or more tab stops according to the value that you enter.

Escape Sequence
ESC[Png

where:

Pn is the type of tab stops to clear.

g is the final character.

Parameter Values
Refer to the following table on how TBC affects the tab stop positions:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a TBC command in the C programming language:

printf(“\033[0g”); /*Clear tab stop*/

When you enter... Then the parameter value ...

0 (default) with TSM set, clears the tab stop at the cursor’s position.
with TSM reset, clears the tab stop at the cursor’s column on all rows in the virtual screen.

1 Honeywell does not support this parameter.

2 with TSM set, clears all of the tab stops on the cursor’s row in the virtual screen.

3 with TSM set or reset, clears all of the tab stops on the virtual screen.

4 Honeywell does not support this parameter.
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DEC Private Escape Sequences
This section provides information for the programmer on how to code DEC private escape sequences for Honeywell equipment.  
All the private escape sequences supported by Honeywell are listed in this section.  If a DEC private escape sequence is not 
listed, Honeywell does not support it, and it is treated as a no operation (NOP).

APM - Auto Print Mode
Function
APM turns auto print mode on or off.  When auto print is on, the virtual screen row that the cursor is presently on prints 
when the cursor is moved off the line with a line feed, form feed, vertical tab or auto wrap.  The printed line ends with a 
carriage return and a line feed.  Trailing spaces on a screen row will not print.

Escape Sequence
ESC[?Pni

where:

Pn is the parameter value that indicates on or off.

i is the final character.

Parameter Values
Refer to the following table on the parameter values indicating the mode to set:

Modes that affect this code
None

DECRM - DEC Reset Mode
Function
DECRM resets the mode you choose.

Escape Sequence
ESC[?Pnl

where:

? is a constant.

Pn is the value of the mode to reset.

l (lowercase L) is the final character.

Parameter Values
Refer to the following table for the modes DECRM can reset:

Modes that affect this code
None

When you enter... Auto Print mode is turned ...

4 (default) off.

5 on.

Parameter Mode to Reset Description

18 Print Form Feed Mode 
(DECPFF)

Disables the terminating character (form feed) after print screen 
operations.  (Print full screen or scroll region with the PS command.)

19 Print Extent Mode 
(DECPEX)

Selects the scrolling region to print for each Print Screen (PS) command 
issued.



5 - 53

DECSCA - Select Character Attribute
Function
DECSCA indicates the start of a protected or unprotected string of character positions.

Escape Sequence
ESC[Pn"q

where: 

Pn is the parameter value that indicates the character attribute.

" and q are the final characters.

Parameter Values
Refer to the following table on the parameter values indicating the character attribute as protected or unprotected:

Modes that affect this code
None

Example
Refer to the example below on how a programmer can format a DECSCA command in the C programming language:

printf(“\033[1\”q”); /*DECSCA-1 cannot erase*/
printf(“This text is protected from erasure.\n”);
printf(“\033[0\”q”); /*DECSCA-0 can erase*/
printf(“This text is not protected.”);

When you enter... Then the character(s) is ..

0 (default) unprotected. This is the same as the EPA command.. See EPA - End of Protected Area 
(page 5-14).

1 protected. This is the same as the SPA command.  See SPA - Start of Protected Area 
(page 5-18).

2 unprotected. This parameter has the same effect as parameter 0.
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DECSED - Selective Erase in Display
Function
DECSED enables the programmer to erase some or all of the erasable characters in the display.  This command will 
not erase qualified area boundaries or the type of qualified area the cursor is in.

If EBM is set to the virtual screen, every row that is completely erased will have its line attribute reset to single high and 
single wide.

Escape Sequence
ESC[?PnJ

where: 

? is a constant.

Pn is the portion of the display to erase.

J is the final character.

Parameter Values
Refer to the following table on how the characters are erased according to the value that you enter:

Modes that affect this code
None

Example
Refer to the example below on how a programmer can format a DECSED command in the C programming language:

printf(“\033[0\”q”); /*DECSCA = 0*/
printf(“Text from this letter x to the end of \n”);
printf(“the display should be erased.\n”);
printf(“\033[2A”); /*CUU-Cursor up 2 lines*/
printf(“\033[22C”); /*CUF-Cursor Forward 22 to the x*/
printf(“\033[?0J”); /*Erase from x to the end of the display*/

When you enter... Then the characters are erased from ...

0 (default) the cursor through the end of the display.

1 the beginning of the display through the cursor.

2 the entire display.  The cursor is moved to the origin of the physical or virtual display 
depending on the EBM setting.
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DECSEL - Selective Erase in Line
Function
DECSEL enables the programmer to erase some or all of the erasable characters in a single line of text.  This com-
mand will not erase qualified area boundaries or the type of qualified area the cursor is in.

Escape Sequence
ESC[?PnK

where:

? is a constant.

Pn is the portion of the line to erase.

K is the final character.

Parameter Values
Refer to the following table on how the characters are erased in relation to the cursor:

Modes that affect this code
None

Example
Refer to the example below on how a programmer can format a DECSEL command in the C programming language:

printf(“\033[0\”q”); /*DECSCA = 0*/
printf(“Text from this letter x to the end of \n”);
printf(“the above line should be erased.\n”);
printf(“\033[2A”); /*CUU-Cursor up 2 lines*/
printf(“\033[22C”); /*CUF-Cursor forward 22*/
printf(“\033[0K”); /*Erase from x to the end of the line*/

When you enter... Then the characters are erased from ...

0 (default) the cursor through the end of the line.

1 the beginning of the line through the cursor.

2 the entire line.
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DECSM - DEC Set Mode
Function
DECSM sets the mode you choose.

Escape Sequence
ESC[?Pnh

where:

? is a constant.

Pn is the value of the mode to set.

h is the final character.

Parameter Values
Refer to the following table for the modes that DECSM can set:

Modes that affect this code
None

Parameter Mode to Reset Description

18 Print Form Feed Mode 
(DECPFF)

Enables the terminating character (form feed) after print screen 
operations.  (Print full screen with the PS command.)

19 Print Extent Mode 
(DECPEX)

Selects the full screen to print for each Print Screen (PS) command 
issued.
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DECDHL - Double-Height Line
Function
Makes the line with the cursor on it the top or bottom half of a double-height, double-width line.  Pairs of this command 
must be used on adjacent lines.

The same screen character must be used on both the top and bottom lines in that column to form a full character.

Note: When this command is received, the device will reset the right half of the virtual screen to spaces and remove 
any tabs or areas contained there.  If the cursor is in the right half, it will be moved to the last column in the left 
half.

Top Half 
Escape Sequence
ESC#3

Modes that affect this code
None

Bottom Half 
Escape Sequence
ESC#4

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a DECDHL command in the C programming lan-
guage:

printf(“\033#3 Double High Line\n”);
printf(“\033#4 Double High Line\n”);
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DECDWL - Double-Width Line
Function
Makes the line with the cursor on it double-width, single-height.

Note: When this command is received, the device will reset the right half of the virtual screen to spaces and remove 
any tabs or areas contained there.  If the cursor is in the right half, it will be moved to the last column in the left 
half.

Escape Sequence
ESC#6

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a DECDWL command in the C programming lan-
guage:

printf(“\033#6 Double-Width Line\n”);

G0/G1/G2/G3 - Designate G0/G1/G2/G3
Function
G0 designates one of the hard character sets (ASCII, DEC Supplemental Graphics, DEC Special Graphics, and 
National Replacement character sets) as G0 through G3.

where:

F is the final character from the following table.

For more information, refer to DEC Special Graphics - Code Table (page 6-10).

Escape Sequence To Designate

ESC(F G0

ESC)F G1

ESC*F G2

ESC+F G3

Character set to 
designate... Final character...

ASCII B

DEC Supplemental < 

DEC Special Graphics 0

National Replacement 
Character Sets

various final characters dependent upon mobile device operating system and device 
specific settings
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PL - Print Line
Function
PL prints the display line containing the cursor.  A carriage return and line feed are automatically printed after the line.

Escape Sequence
ESC[?1i

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a PL command in the C programming language:

printf(“\033[?1i”); /*Prints the line the cursor is on*/

PS - Print Screen
Function
PS prints the display to the RS-232 port.  A carriage return and line feed is automatically printed after each line.

Escape Sequence
ESC[Pni

where:

Pn is either 0 or omitted.

Modes that affect this code
DECPEX, DECPFF

Example
Refer to the following example on how a programmer can format a PS command in the C programming language:

printf(“\033[0i”); /*Causes the display to be printed*/

S7C1T - Select 7-Bit C1 Control Transmission
Function
S7C1T informs the client to convert all C1 codes to their 7-bit equivalent before sending them back to the host.

Note: The client will always accept either 7-bit or 8-bit control codes regardless of the state of this command.

Escape Sequence
ESC sp F

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a S7C1T command in the C programming language:

printf(“\033 F”); /*There is a single space between the 3 and the F*/
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S8C1T - Select 8-Bit C1 Control Transmission
Function
S8C1T informs the client to send all C1 codes back to the host without converting them to their 7-bit equivalent.

Note: The client will always accept either 7-bit or 8-bit control codes regardless of the state of this command.

Escape Sequence
ESC sp G

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format a S8C1T command in the C programming language:

printf(“\033 G”); /*There is a single space between the 3 and the G*/

SI - Shift In (Lock Shift G0)
Function
Invokes G0 character set into GL.

Example
Refer to the following example on how a programmer can format an SI command in the C programming language:

printf(“\033(0”); /* Designate DEC special graphics into G0.  */
printf(“\017”); /* Shift G0 into GL */
printf(“lqqk\n”); /* These two lines print a small box on the display.  */
printf(“mqqj”);

SO - Shift Out (Lock Shift G1)
Function
Invokes G1 character set into GL.

Example
Refer to the following example on how a programmer can format an SO command in the C programming language:

printf(“\033)0”); /* Designate DEC special graphics into G1.  */
printf(“\016”); /* Shift G1 into GL */
printf(“lqqk\n”); /* These two lines print a small box on the display.  */
printf(“mqqj”);

Hexadecimal Value Control Code

0F ^O

Hexadecimal Value Control Code

0E ^N
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Private Escape Sequences
Honeywell offers special escape sequences as well as command strings that modify terminal emulation functions, window 
parameters, and wild card local edit characters.  Honeywell also provides command strings for stored forms, using a backspace 
function with the [CLEAR] key, enabling an echo suppress, and a wide range of beep patterns.

This section describes the applications for each command string and information on how the programmer can code the escape 
sequences and command strings.

LXERM - Reset Mode
Function
LXERM resets the mode that you choose.

Escape Sequence
ESC[=Pnl

where:

= is a constant.

Pn is the value of the mode to reset.

l (lowercase L) is the final character.

Parameter Values
Refer to the following table for the modes LXERM can reset:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an LXERM command in the C programming lan-
guage:

printf(“\033[=3l”); /*Reset LXEAS- Reset autosend mode*/

Parameter Mode to Reset Description

1 Scroll/Block 
Mode (LXELM)

Enables block mode.
Rule: Send-receive mode (SRM) must be reset for LXELM to work.

2 New Line Echo 
Mode (LXENE)

Disables new line local echo.  If the client is in scroll/block mode, does not 
execute carriage return and line feed to the client display when the [Enter] key is 
pressed.

3 Autosend 
(LXEAS)

Disables autosend.  In other words, the client transmits only when the [Enter] key 
is pressed.
Rule: Send-receive mode (SRM) must be reset for LXEAS to work.
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LXESM - Set Mode
Function
LXESM sets the mode you choose.

Escape Sequence
ESC=Pnh

where:

= is a constant.

Pn is the value of the mode to set.

h is the final letter.

Parameter Values
Refer to the following table for the modes LXESM can set:

Modes that affect this code
None

Example
Refer to the following example on how a programmer can format an LXESM command in the C programming lan-
guage:

printf(“\033[=3h”); /*Set LXEAS-Set autosend mode*/

Parameter Mode to Set Description

1 Scroll/Block 
Mode (LXELM)

Enables scroll mode.
Rule: Send-receive mode (SRM) must be reset for LXELM to work.

2 New Line Echo 
Mode (LXENE)

Enables new line local echo.  If the client is in scroll/block mode, execute carriage 
return and line feed to the client display when the [Enter] key is pressed.

3 Autosend 
(LXEAS)

Enables autosend.  In other words, the client transmits the screen when the last 
field is filled with a bar code entry, keyboard entry or RS-232 port entry.
Rule: Send-receive mode (SRM) must be reset for LXEAS to work.
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Scanner Enable / Disable
Function
Enable or disable scanner input.

Disable Scanner
The scanner is disabled when this command is used:

• For devices with an internal or tethered scanner, the scan trigger is disabled.
• For devices with a tethered scanner, serial input received from the scanner is rejected and an error sound is 

produced.

Escape Sequence
ESC%0

Modes that affect this code
None

Enable Scanner
This command enables the scanner after it has been disabled with the command above.

Escape Sequence
ESC%1

Modes that affect this code
None

Keyboard Enable / Disable
Function
Enable or disable keyboard input.

Disable Keyboard
The keyboard is disabled when this command is used.  Any keystrokes entered are ignored and an error sound is pro-
duced.

Escape Sequence
ESC%0

Modes that affect this code
None

Enable Keyboard
This command enables the keyboard after it has been disabled with the command above.

Escape Sequence
ESC%1

Modes that affect this code
None
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Enable/Disable Bar Code Symbologies
The host computer can be used to enable or disable scanning of specified bar code symbologies.  If a bar code symbology is 
disabled with this feature, the scanner does not recognize that symbology.  The scanner sounds a bad scan beep (double beep 
sound is the default) when trying to scan the disabled symbologies.  Use the following example and table of values to see how a 
programmer can enable or disable symbologies with a command in the C programming language:

printf(“\033[xx+A”); /*Substitute the applicable xx value from the chart to enable or disable 
symbology*/

Specifying Bar Code, Keypad and Control Modes
This section discusses the elements of the command string that enable the programmer to set the bar code, keypad and control 
modes for the client.  The different settings for each parameter of the command string are discussed in detail.

Command String for Bar Code, Keypad and Control Modes
The programmer can specify bar code, keypad and control modes with the appropriate command string.  This section dis-
cusses elements of the command string and its structure.

Command String
Use the following command string for specifying bar code, keypad, and control modes:

CSIc1;p1;p2;p3;p4;p5;p6;p7;p8;p9;p10+E

Rule
Each parameter must be preceded by a semicolon (;).

You can use the semicolon as a placeholder if you want to change only one parameter.  For example, you can send the 
following string to change only p5 of the command string:

CSI1;;;;;1+E

Set xx to: Perform this action

65 (0x41) Enable Code 39

66 (0x42) Disable Code 39

67 (0x43) Enable Interleaved 2of5

68 (0x44) Disable Interleaved 2of5

75 (0x4B) Enable Codabar/Ames

76 (0x4C) Disable Codabar/Ames

77 (0x4D) Enable MSI

78 (0x4E) Disable MSI

79 (0x4F) Enable Code 93

80 (0x50) Disable Code 93

81 (0x51) Enable Code 128

82 (0x52) Disable Code 128

85 (0x55) Enable UPC-A

86 (0x56) Disable UPC-A

87 (0x57) Enable UPC-E

88 (0x58) Disable UPC-E

89 (0x59) Enable EAN/JAN

90 (0x5A) Disable EAN/JAN
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String Elements
The following table describes the different elements of the command string for specifying bar code, keypad, and control 
modes:

Left Justify Mode: p2
Left justify mode determines where the cursor appears in a field from one bar code entry to the next.  The programmer 
must decide if the cursor in a field justifies to the left each time a new bar code entry occurs or if the bar code entry appears 
at the end of the previous entry.

Rule
You must enable block mode to use left justify mode.

Parameter Values
Refer to the following table on how to set p2 of the command string to disable or enable left justify mode:

Left Justify Off
Left Justify Off enables a bar code read to appear in the next available cursor position of a field directly following a pre-
vious bar code entry.  For example, the first bar code entry fills the first five positions of the first field available as shown 
below:

The next bar code read is entered starting at the cursor’s position and proceeding to the next unprotected field.

String
Element Description

CSI ANSI control sequence introducer (Hex 9B for 8-bit code or Hex 1B5B for 7-bit code).

c1 A compatibility byte that ensures the terminal emulation understands the command string sent to it.  
The c1 is a revision level character for compatibility purposes, which increments with each revision.  
The original value for this parameter is 1.

; A required delimiter that must precede all parameter entries.

p2 Bar Code/RS-232 Input Left Justify Mode
  0 = Left Justify Mode Off
  1 = Left Justify Mode On
Left Justify Mode: p2 (page 5-65) discusses this parameter in more detail.

p3 Bar Code/RS-232 Input Clear Mode
  0 = Clear Off
  1 = Clear On
Clear Mode: p3 (page 5-66) discusses this parameter in more detail.

p4 Bar Code/RS-232 Input Truncate Mode
  0 = Truncate Off
  1 = Truncate On
Truncate Mode: p4 (page 5-66) discusses this parameter in more detail.

p5 Bar Code/RS-232 Input Advance Mode
  0 = Advance Off
  1 = Advance On
Advance Mode: p5 (page 5-67) discusses this parameter in more detail.

+E The final characters of the ANSI command string.  This combination indicates the end of the command 
string and identifies the command string as a bar code, keypad, and control mode command.

When you enter ... Then left justify is ...

0 off

1 (default) on
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Left Justify On
Left Justify On enables the cursor to left justify in a field each time a bar code read occurs.  For example, the following 
bar code read appears in the field and then the cursor left justifies when the next bar code entry occurs.  The next bar 
code read appears in the field starting at the B position:

Clear Mode: p3
Clear mode determines if a field is automatically cleared when the next bar code entry occurs or if the data in the field is 
overwritten by the new entry.

Note: If a field is not cleared after the data is transmitted to the host, there is a chance that some of the previous data will 
not be completely overwritten by the new entry.  If the data is not completely overwritten, it appears at the end of the 
new entry and is transmitted with the new entry to the host.

Rule
You must enable block mode to use clear mode.

Parameter Values
Refer to the following table on how to set p3 of the command string to disable or enable clear mode:

Clear Mode Off
When clear mode is off, the client does not clear the data in a field.  The new data entered overwrites portions of the 
left-over data.  An operation that has bar code entries with equal character lengths might choose clear mode off.

Clear Mode On
When clear mode is on, the client clears the data entered in a field each time a new bar code entry occurs.  An opera-
tion that has bar code entries with varying lengths would need to use clear mode on to ensure accurate transmission of 
each entry.

Truncate Mode: p4
Truncate mode determines whether the character positions of a bar code entry that exceeds the field length are simply 
dropped off or if the leftover characters are entered in the next available field.

Rule
You must enable block mode to use truncate mode.

Parameter Values
Refer to the following table on how to set p4 of the command string to disable or enable truncate mode:

Truncate Mode Off
When truncate mode is off, the character positions of a bar code entry exceeding the field length are entered in the 
next available field.  An operation that has two kinds of information in one bar code entry would use truncate mode off 
so that one bar code read can fill two fields on a form.

When you enter ... Then clear mode is ...

0 off

1 (default) on

When you enter ... Then truncate mode is ...

0 off

1 (default) on
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Truncate Mode On
When truncate mode is on, the character positions of a bar code entry exceeding the field length are dropped off.  If the 
field has 10 available character positions and the bar code entry has 22, the first 10 character positions of the entry are 
entered in the field and the remaining 12 character positions are dropped.  An operation that wants to ensure that a bar 
code entry from one field is not carried over into the next field would want to have truncate mode on.

Advance Mode: p5
Advance mode determines whether the cursor advances to the next field at the end of a bar code entry.  If the cursor does 
not advance to the next field, the next bar code entry is entered at the end of the previous bar code entry.

Rule
You must enable block mode to use advance mode.

Parameter Values
Refer to the following table on how to set p5 of the command string to disable or enable advance mode:

Advance Mode Off
When advance mode is off, the cursor does not advance to the next field at the end of a bar code entry.  The next bar 
code entry is entered directly following the previous bar code entry.

Advance Mode On
When advance mode is on, the cursor advances to the next field at the end of each entry regardless of whether the 
field is completely filled or not.  An operation that has bar code entries that do not always fill the field would use 
advance mode on.

If autosend (LXEAS) is also enabled, the client will automatically send the screen even if the last bar code entry did not 
completely fill the last field on the display.

Specifying Transmit and Screen Function Setup

Command String for Transmit and Screen Function Setup
You must specify the transmit and screen function setup with the appropriate command string.  This section discusses ele-
ments of the command string and its structure.

Command String
Use the following command string for the transmit and screen function setup:

CSIc1;p1;p2;p3;p4;p5;p6;p7;p8;p9;p10+F

Rule
Each parameter must be preceded by a semicolon (;).

You can use the semicolon as a placeholder if you want to change only one parameter.  For example, you can send the 
following string to change only p5 of the command string:

CSI1;;;;;1+F

When you enter ... Then advance mode is ...

0 off

1 (default) on



5 - 68

String Elements
The following table describes the different elements of the command string for the transmit and screen function setup:

String
Element Description Related Sections

CSI ANSI control sequence introducer (Hex 9B for 8-bit code or hex 1B5B for 7-
bit code).

-

c1 A compatibility byte that ensures the terminal emulation understands the 
command string sent to it.  The c1 is a revision level character for 
compatibility purposes, which increments with each revision.  The original 
value for this parameter is 1.

-

; A required delimiter that must precede all parameter entries. -

p1 Not used.

p2 8-Bit Code control from the host.
The client can always accept either 7-bit or 8-bit codes from the host.  The 
value of this parameter is therefore ignored.

8-Bit Code Table (page 
5-4)

p3 Auto Transmit Mode
  0 = Auto Transmit Mode is OFF.  The [Enter] key must be pressed to 
transmit the data.
  1 = Auto Transmit Mode is ON.  The data is automatically transmitted when 
the last field is filled with a bar code entry, an RS-232 port entry or keyboard 
entry.

LXEAS, see:
LXERM - Reset Mode 
(page 5-61)
LXESM - Set Mode 
(page 5-62)

p4 LF Transmission on Send
  0 = The [Enter] key places a carriage return in the data stream.
  1 = The [Enter] key places a carriage return and line feed in the data 
stream.

LNM, see:
RM - Reset Mode (page 
5-48)
SM - Set Mode (page 5-
50)

p5 Screen Mode
  0 = Screen Mode is Block Mode.
  1 = Screen Mode is Scroll Mode.

LXELM, see:
LXERM - Reset Mode 
(page 5-61)
LXESM - Set Mode 
(page 5-62)

p6 New Line Echo Mode
  0 = New Line Echo Mode OFF.
  1 = New Line Echo Mode ON.

LXENE, see:
LXERM - Reset Mode 
(page 5-61)
LXESM - Set Mode 
(page 5-62)

p7 Auto Wrap Mode
  0 = Auto Wrap Mode OFF.
  1 = Auto Wrap Mode ON.

DECAWM

p8 On Line Mode
  0 = Operate in On Line Mode.  The [Enter] key is enabled to send 
messages to the host through the RF link.
  1 = Operate in Local Mode.  The [Enter] key is disabled.

-

p9 Not used.

p10 Transmit Mode
  0 = Transmit in Block or Scroll Mode.
  1 = Transmit in Character Mode.

SRM, see:
RM - Reset Mode (page 
5-48)
SM - Set Mode (page 5-
50)

+F The final character of the ANSI command string.  This combination 
indicates the end of the command string and identifies the command string 
as a transmit and screen function mode.

-
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Local Edit Commands
Local edit commands enable a programmer to control data entry from the client.  This section discusses the two types of local 
edit commands and the command string elements for each.

Command String for Local Edit Match Field
A local edit match field restricts user data entry to exact match values or ranges of accepted values.  A programmer can 
use this feature to prevent incorrect part number or bin location entries.

Definitions
An exact match field is a field with predetermined values that must be matched exactly by user entry.

Local edit match field is a feature provided by Honeywell that enables the client to perform data comparisons between 
the match buffer in the client and the data entered by the client user.  In other words, the client locally edits information 
as the client user enters data instead of the host performing the edit.

A match buffer is an area of memory used by the local edit match field command to restrict data entry by the client 
user.

Rules
Refer to the following rules for using local edit match field:

• You must specify a local edit field by placing the cursor at the beginning of the appropriate field and sending the 
correct command string.

• You must place match data between two identical Honeywell local edit command strings.
• You must enable Local echo.  Refer to RM - Reset Mode (page 5-48) (parameter value 12) in this manual for more 

information on local echo.
• You must enable block mode.  If character mode or scroll mode is enabled, local edit match fields are ignored.
• Use characters entered into the match buffer field that do not match the local edit wildcard symbols (defaults: ?, $, 

#, +, *) as exact match characters.  

Command String
Use the following command string for specifying a local edit match field:

CSId+A

String Elements
The following table describes the different elements of the command string for specifying a local edit match field:

Example
Refer to the following example of a local edit match field command:

printf(“ _ _ _ _ _ _ ”); /*6 character fields*/
printf(“\033[6D”); /*CUB-move cursor back 6*/
printf(“\033[0+A”); /*turn on local edit setup mode*/
printf(“P?$$$$”); /*part number format*/
printf(“\033[0+A”); /*turn off local edit setup mode*/
printf(“\033[6D”); /*CUB-move cursor back 6*/
gets(s) /*wait for user to enter data*/

String
Element Description

CSI ANSI control sequence introducer (Hex 9B for 8-bit code or Hex 1B5B for 7-bit code).

d Keyboard Input
  0 (default) = Display the keyboard input if user entry matches the requirements of the match buffer.
  1 = Do not display the keyboard input if user entry matches the requirements of the match buffer.  Host 
input on these cells is displayed.

+A The final character of the ANSI command sequence.  This combination indicates the end of the 
command string and identifies the command string as a local edit match field.
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Command String for Local Edit Wildcard
Local edit wildcard enables the programmer to change the default match symbols.  Wildcard match values represent a 
range of acceptable user input.  The host may change the definition of a particular wildcard at any time without affecting any 
previously set local edit match fields.  (The TE stores the type of wildcard rather than the actual wildcard value.)

Command String
Use the following command string for local edit wildcard:

CSIc1;p1;p2;p3;p4;p5;p6+G

Rule
The values you enter for the symbols must be in their decimal equivalent forms.  Refer to the 8-Bit Code Table (page 5-
4) for these decimal values.

You can use the semicolon as a placeholder if you want to change only one parameter.  For example, you can send the 
following string to change only p5 of the command string:

CSI1;;;;;1+G

String Elements
The following table describes the different elements of the command string for specifying a local edit wildcard:

Using Local Edit
Using the local edit command enables the programmer to control data entry at the client.  The local edit field length can be 
as long as the virtual screen.

The client edits the field locally as data is entered and not when the field is exited.  During the editing of a field, if the data 
fails the match test, the cursor does not move.

Exception
When a bar code entry fails the match test, the cursor goes to the first position where the character did not match the 
test.  The remaining characters in the input field are checked against the match test.

String
Element Description

CSI ANSI control sequence introducer (Hex 9B for 8-bit code or Hex 1B5B for 7-bit code).

c1 A compatibility byte that ensures the terminal emulation understands the command string sent to it.  
The c1 is a revision level character for compatibility purposes, which will increment with each revision.  
The original value for this parameter is 1.

; A required delimiter that must precede all parameter entries.

p1 Not used.

p2 ?(Alpha Only Match)
Alpha only match includes the following characters: A-Z, a-z, comma, period, dash, space.

p3 $(Digits Only Match)
Digits only match includes the following characters: 0-9.

p4 #(Numeric Only Match)
Numeric only match includes the following characters: 0-9, plus, comma, period, dash, space.

p5 +(Alphanumeric Only Match)
Alphanumeric only match includes the following characters: A-Z, a-z, 0-9, plus, comma, period, dash, 
space.

p6 *(Match All)
Match all includes any GL or GR characters.

+G The final characters of the ANSI command sequence.  This combination indicates the end of the 
command string and identifies the command string as a local edit wildcard command.
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Programming Local Edit Fields
1. Position the cursor to the beginning of the local edit field.

2. Send the CSId+A command to put the TE in local edit setup mode.

3. Send the local edit match characters which could be either exact match or wildcards.  These are sent as regular GL 
or GR characters.  They will be stored internally in the TE and not displayed on the screen.  The cursor position will 
automatically be updated after each char is received.

Note: Setting a screen cell as a local edit cell overrides any previous DAQ/SPA/SSA settings for that cell and vice 
versa.

4. If desired, position the cursor to a new location and send more local edit match characters to define more fields.  
Repeat as necessary.

5. Send a matching CSId+A command to put the TE in normal mode.

6. If automatic tabbing is desired to the start of each field, the host must send the standard area or tab commands at 
the start of each local edit field.  This can be accomplished even when the TE is in local edit mode.

7. The TE user may now enter data through keyboard or RS-232 inputs.

If the user input passes the local edit checks, the data will be displayed (if the local edit field was set up as CSI0+A).  
The data will not be displayed if the local edit field was set up as CSI1+A.  In either case, the cursor position will 
advance by 1.

If the data does not pass the local edit checks, the TE will beep to inform the user and the cursor will not advance.

Requirements
The following requirements must be met for local edit to work properly:

• The client must be in block mode (LXELM).
• Local echo must be enabled in send-receive mode (SRM).
• The client must be an RFTerm client to have local edit capabilities.  
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VT Host Key Descriptions
Escape sequence values associated with various keys are noted for 7 bit ASCII mode and 8 bit ASCII mode.

Hold
Hld - This key has no current action.  

Enter
Ent - The Enter or Return key transmits either a carriage return (CR) character or a carriage return and line feed (LF) 
character, depending on the VT configuration.

See 8-Bit Code Table (page 5-4).

Compose Character
Cmp - The Compose Character key does not transmit a code.  Pressing the Compose character key starts a compose 
sequence which is used to generate characters that cannot be typed directly from the keyboard.  This key is not imple-
mented.

Tab
Tab - This key transmits a TAB character.

Delete
Del - This key transmits a DEL character.

Break
Brk - This key has no current action.

Cancel
Can - This key transmits a CAN character.

Answerback
Ans - This key sends an ENQ request to the host.

Find
Fnd - This key transmits the escape sequence:

 ESC [1 ~ (7 bit ASCII mode)

or 

CSI 1 ~ (8 bit ASCII mode)

Insert Here
Ins - This key transmits the escape sequence:

ESC [2 ~ (7 bit ASCII mode)

or 

CSI 2 ~ (8 bit ASCII mode)

Remove
Rem - This key transmits the escape sequence:

ESC [3 ~ (7 bit ASCII mode)

or 

CSI 3 ~ (8 bit ASCII mode)

Select
Sel - This key transmits the escape sequence:

ESC [4 ~ (7 bit ASCII mode)



5 - 73

or 

CSI 4 ~ (8 bit ASCII mode)

Previous Screen
Prv - This key generates an escape sequence:

ESC [5 ~ (7 bit ASCII mode)

or 

CSI 5 ~ (8 bit ASCII mode)

Next Screen
Nxt - This key transmits the escape sequence:

ESC [6 ~ (7 bit ASCII mode)

or 

CSI 6 ~ (8 bit ASCII mode)

Escape
Esc - This key sends an ESC character to the host.

Backspace
BS - This key sends a BS character to the host.

Line Feed
LF - This key sends a LF character to the host

PF Keys
PF1 - PF4 - The numeric keypad keys PF1 through PF5 keys transmit the following escape sequences.  The default 
action of Function Keys 1 through 4 is identical.

The 5 keys F1-F5 on a VT client are local function keys and do not send codes.  When a device has physical keys for 
F1-F5, we send PF1-PF4 for the corresponding F1-F4 and send a custom escape sequence for F5, the custom escape 
sequence depends on the device.

Function Keys
F1 - F40 - The Function keys F1 - F40 communicate with the host application.  They transmit the following default 
escape sequences or their 7-bit equivalent, unless reprogrammed by the user in the Function Key dialog.

PF Key 7 bit ANSI Mode 8 bit ANSI Mode VT 52 Mode

PF1 SS3 P ESC OP ESC P

PF2 SS3 Q ESC OQ ESC Q

PF3 SS3 R ESC OR ESC R

PF4 SS3 S or ESC OS ESC S

Function Key Default Value

F1 ESC OP

F2 ESC OQ

F3 ESC OR

F4 ESC OS

F5 none

F6 CSI 17~

F7 CSI 18~

F8 CSI 19~
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Custom VT220 Host Commands
The following host command strings can be sent to RFTerm to provide the designated action.

F9 CSI 20~

F10 CSI 21~

F11 (ESC) CSI 23~ (ESC in VT100 and VT 52)

F12 (BS) CSI 24~ (BS in VT 100 and VT 52)

F13 (LF) CSI 25~ (LF in VT 100 and VT 52)

F14 CSI 26~

F15 (HELP) CSI 28~

F16 (DO) CSI 29~

F17 CSI 31~

F18 CSI 32~

F19 CSI 33~

F20 CSI 34~

F21 CSI 25~

F22 CSI 26~

F23 CSI 28~

F24 CSI 29~

F25 CSI 31~

F26 CSI 32~

F27 CSI 33~

F28 CSI 34~

F29 through F40 none

Command String Action Notes

/cmd!1;3z/cmde RFTerm disables the scanner

/cmd!1;0z/cmde RFTerm enables the scanner

/cmd!1;2z/cmde RFTerm turns on the display backlight

/cmd!1;1z/cmde RFTerm turns off the display backlight

/cmd!1;4z/cmde RFTerm turns on vibration for 1 second
Only supported on mobile devices containing a vibration 
unit, such as MX7 Tecton, MX8 and MX9.  Vibration has 
no effect on other devices.

/cmd!1;5z/cmde RFTerm turns on vibration for 2 seconds

/cmd!1;6z/cmde RFTerm turns on vibration for 3 seconds

/cmd!1;7z/cmde RFTerm turns on vibration for 7 seconds

/cmd!2;00/cmde Do not display (or remove) virtual keyboard

Virtual keyboard is only supported on the Dolphin 70e 
Black.  See Virtual Keyboards (page 9-12).

/cmd!2;10/cmde Display virtual keyboard configuration 1
(Left Numeric), orientation 0

/cmd!2;20/cmde Display virtual keyboard configuration 2
(Right Numeric), orientation 0

/cmd!2;30/cmde Display virtual keyboard configuration 3
(Qwerty or SIP), orientation 0

/cmd!2;40/cmde Display virtual keyboard configuration 4
(HX2 Emulator), orientation 0

Function Key Default Value
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6
ANSI Quick Reference Guide

Functionality List

Notes
Reset mode terminating character is l, set mode is h.

C The configuration utility equivalent of this command.

M The modes that affect this command.

R The effect generated when this mode is reset.

S The effect generated when this mode is set.

BKC Bar code/Keypad Setup Private Sequence

CCT Character Collection Timer Private Sequence

DECOM DEC Origin Mode

DECPEX DEC Print Extent Mode

DECPFF DEC Print Form Feed Mode

DRM/SM DECRM/DECSM

EBM Editing Boundary Mode

ERM Erasure Mode

LNM Line Feed/New Line Mode

LRM/SM LXERM/LXESM

NRC National Replacement Character Sets

SEM Select Editing Extent Mode

SGR Select Graphic Rendition

SRM Send/Receive Mode

TSM Tab Stop Mode

TSS Transmit/Screen Setup Private Sequence
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Cursor Positioning

Cursor
Pos. Description Hex Value / Esc Seq Notes

BS Backspace 0x08 (^H)

CUB Cursor Back ESC[PnD M=None

CUF Cursor Forward ESC[PnC M=None

CUD Cursor Down ESC[PnB M=None

CUU Cursor Up ESC[PnA M=None

CUP Cursor Position ESC[Pr;PcH M=None

HVP Horizontal Vertical Pos ESC[Pr;Pcf M=None

CHA Cursor Horizontal Absolute ESC[PnG

CR Carriage Return 0x0d (^M)

LF Line Feed 0x0a (^J) M=Scroll Region, LNM

FF Form Feed 0x0c (^L) M=Scroll Region, LNM; Same as LF

VT Vertical Tab 0x0b (^K) M=Scroll Region, LNM; Same as LF

IND Index 0x84 (ESC D) M=Scroll Region

RI Reverse Index 0x8d (ESC M) M=Scroll Region

LNM Line Feed/New Line Mode ESC[20l (or h) R=LF, S=LF+CR (RM/SM);
See Transmission To Host (page 6-4)

LXENE New Line Echo Mode ESC[=2l (or h) R=neither, S=CR+LF (LRM/SM);Also TSS 6; 
C=EchoCrLf

CNL Cursor Next Line ESC[PnE

NEL Next Line 0x85 (ESC E) M=Scroll Region

CVT Cursor Vertical Tab ESC[PnY

CPL Cursor Previous Line ESC[PnF
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Forms

Forms Description Hex Value/
ESC Seq Notes

HT Horizontal Tab 0x09 (^I) No tab to protected cells

CHT Cursor Horizontal 
Tab

ESC[PnI No tab to protected cells

CBT Cursor Back Tab ESC[PnZ No tab to protected cells

HTJ Horizontal Tab w/
Justify

0x89 (ESC I) No tab to protected cells

HTS Horizontal Tab Set 0x88 (ESC H) M=TSM

CTC Cursor Tab Clear ESC[PnW (TSM reset/TSM set); 0,2=column/position,
4=all/row, 5=all/all

TBC Tab Clear ESC[Png (TSM reset/TSM set); 0=column/position,
2=all/row, 3=all/all

TSM Tab Set Mode ESC[18l (or h) R=virtual, S=curr line (RM/SM)

DAQ Define Area 
Qualification

ESC[Pno 0=all data, 1=prot, 2=display,3=num,
4=alpha, 5=right just, 6=zero filled, 7=tab, 8=selected, 
9=space filled,10=hidden,
15=keyboard input only

SPA Start Protected 
Area

0x96 (ESC V) Same as DAQ 1

EPA End Protected 
Area

0x97 (ESC W) Current area is all input

SSA Start Selected 
Area

0x86 (ESC F)

ESA End Selected Area 0x87 (ESC G) Current area is all input

EA Erase Area ESC[PnO 0=to end, 1=from start, 2=all; M=ERM Does not erase area 
type

EF Erase Field ESC[PnN 0=to end, 1= from start, 2=all; M=EBM; Does not erase 
area type

LEM Local Edit Match ESC[Pn+A R=display, S=hide

LEM Alpha 
WC

Alpha only 
wildcard

ESC[c1;;p2+G Matches A-Z, a-z, comma, period, dash, space; 
C=AlphaOnly

LEM Digits 
WC

Digits only 
wildcard

ESC[c1;;;p3+G Matches 0-9; C=DigitsOnly

LEM 
Numeric WC

Numeric only 
wildcard

ESC[c1;;;;p4+G Matches 0-9, plus, comma, period, dash, space; 
C=NumericOnly

LEM 
Alphanum 
WC

Alphanumeric only 
wildcard

ESC[c1;;;;;p5+G Matches A-Z, a-z, 0-9, plus, comma, period, dash, space; 
C = AlphaNumericOnly

LEM Match 
All WC

Match all wildcard ESC[c1;;;;;;p6+G All GL and GR; C=MatchAll
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Transmission To Host

Transmission
To Host Description Hex Value/

Esc Seq Notes

GATM Guarded Area Transmit 
Mode

ESC[1l (or h) R=unguarded, S=entire screen (RM/SM)

MATM Multiple Area Transmit 
Mode

ESC[15l (or h) R=cursor selected, S=all selected (RM/SM)

SATM Selected Area Transmit 
Mode

ESC[17l (or h) R=selected, S=virtual (RM/SM)

LXEAS Auto Send Mode ESC[=3l (or h) R=disable, s=enable (LRM/SM); SRM must be 
reset; Also TSS 3; C=AutoTransmit

SRM Send Receive Mode ESC[12l (or h) R=local echo, S=char (RM/SM); Also TSS 10; 
C=SendReceiveMode

LXELM Line Mode ESC[=1l (or h) R=block, S=scroll (LRM/SM);Also TSS 5; 
C=ScrollMode

DECSCL Select Operating Level ESC[62;Pn"p R=8 bit, S=7 bit

S7C1T Select 7 Bit Transmission ESC F A space (0x20) precedes F; C=EightBitMode

S8C1T Select 8 Bit Transmission ESC G A space (0x20) precedes G; C=EightBitMode

LNM Line Feed/New Line Mode ESC[c1;;;;p4+F R=CR, S=CR+LF; 
Also TSS 4; See Cursor Positioning (page 6-2); 
C=TransmitCR/LF

OLM Online Mode ESC[c1;;;;;;;;p8+F R=online, S=offline; Also TSS 8; 
C=OnlineMode
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Editing

Character Rendition

Editing Description Hex Value/
Esc Seq Notes

ECH Erase Character ESC[PnX M=ERM

DCH Delete Character ESC[PnP M=SEM 
Aborts at protected cells

ICH Insert Character ESC[Pn@ M=SEM 
Aborts at protected cells

SEM Select Editing
Extent Mode

ESC[PnQ 0=display, 1=row, 2=field, 3=area; M=None

DL Delete Line ESC[PnM M=None

IL Insert Line ESC[PnL M=None

ED Erase Display ESC[PnJ 0=to end, 1=from start, 2=all; M=ERM 
Erases area type/boundaries, homes cursor.

EL Erase Line ESC[PnK 0=to end, 1=from start, 2=all; M=ERM 
Erases area type/boundaries

DECSED DEC Selective Erase 
In Display

ESC[?PnJ 0=to end, 1=from start, 2=all; M=None
Never erases protected cells or area types/boundaries, homes 
cursor

DECSEL DEC Selective
Erase In Line

ESC[?PnK 0=to end, 1=from start, 2=all; M=None 
Never erases protected cells or area types/boundaries

ERM Erasure Mode ESC[6l (or 
h)

R=cannot erase prot, 
S=erase prot (RM/SM)

SD Scroll Down ESC[PnT M=Scroll Region

SU Scroll Up ESC[PnS M=Scroll Region

DECSTBM DEC Set Top/
Bottom Margins

ESC[Pt;Pbr M=DECOM; Must have full screen client to use; Min height of 
region is 2 rows, Homes cursor according to DECOM

IRM Insert/Replace Mode ESC[4l (or 
h)

R=overwrite,
S=insert (RM/SM)

Character 
Rendition Description

Hex 
Value/
Esc Seq

Notes

SGR Select Graphics Rendition ESC[Pnm 0=normal
1,22=bold
4,24=underline
5,25=blink
7,27=reverse
First number enables, second 
disables
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Bar Code

Reports / Status / Test

Printing

Bar code Description Hex Value/
Esc Seq Notes

Left Justify Left Justify ESC[c1;;p2+E R=off
S=on (BKC); Requires block mode
C=LeftJustify

Clear Clear ESC[c1;;;p3+E R=off
S=on (BKC); Requires block mode
C=ClearData

Truncate Truncate ESC[c1;;;;p4+E R=off
S=on (BKC); Requires block mode
C=TruncateData

Auto Advance Auto Advance ESC[c1;;;;;p5+E R=off
S=on (BKC); Requires block mode
C=AutoAdvance

Reports /Status/ Test Description Hex Value/
Esc Seq Notes

ENQ Enquire 0x05 (^E)

CPR Cursor Position Report ESC[Pr;PcR Only sent from client; Position relative to virtual 
display

DSR Device Status Report ESC[Pnn 5=status
6=CPR
26=keyboard

Printing Description Hex Value/
Esc Seq Notes

MC Media Copy ESC[Pni 4=off
5=on

DC2 Device Control 2 0x12 (^R) Ignored from host

DC4 Device Control 4 0x14 (^T) Same as MC4

APM Auto Print Mode ESC[?Pni 4=off
5=on

PL Print Line ECS[?1i

PS Print Screen ESC[0i

DECPFF DEC Print Form Feed Mode ECS[?18l (or h) h=enable terminating character
l=disable terminating character

DECPEX DEC Print Extent Mode ECS[?18l (or h) h=full screen
l=scrolling region
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Hat Encoding

Desired
ASCII Hex Value Hat 

Encoded
Desired
ASCII Hex Value Hat 

Encoded

NUL 00 ^@ × D7 ~W

SOH 01 ^A Ø D8 ~X

STX 02 ^B Ù D9 ~Y

ETX 03 ^C Ú DA ~Z

EOT 04 ^D Û DB ~[

ENQ 05 ^E Ü DC ~\\

ACK 06 ^F Ý DD ~]

BEL 07 ^G Þ DE ~\^

BS 08 ^H ß DF ~_ (Underscore)

HT 09 ^I à E0 ~`

LF 0A ^J á E1 ~a

VT 0B ^K â E2 ~b

FF 0C ^L ã E3 ~c

CR 0D ^M ä E4 ~d

SO 0E ^N å E5 ~e

SI 0F ^O æ E6 ~f

DLE 10 ^P ç E7 ~g

DC1 (XON) 11 ^Q è E8 ~h

DC2 12 ^R é E9 ~i

DC3 (XOFF) 13 ^S ê EA ~j

DC4 14 ^T ë EB ~k

NAK 15 ^U ì EC ~l

SYN 16 ^V í ED ~m

ETB 17 ^W î EE ~n

CAN 18 ^X ï EF ~o

EM 19 ^Y ð F0 ~p

SUB 1A ^Z ñ F1 ~q

ESC 1B ^[ ò F2 ~r

FS 1C ^\\ ó F3 ~s

GS 1D ^] ô F4 ~t
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RS 1E ^^ õ F5 ~u

US 1F ^_ (Underscore) ö F6 ~v

80 ~^@ ÷ F7 ~w

81 ~^A ø F8 ~x

82 ~^B ù F9 ~y

83 ~^C ú FA ~z

IND 84 ~^D û FB ~{

NEL 85 ~^E ü FC ~|

SSA 86 ~^F ý FD ~}

® AE ~.  (Period) þ FE ~~

¯ AF ~/ ÿ FF ~^?

° B0 ~0 (Zero) ESA 87 ~^G

± B1 ~1 HTS 88 ~^H

² B2 ~2 HTJ 89 ~^I

³ B3 ~3 VTS 8A ~^J

´ B4 ~4 PLD 8B ~^K

µ B5 ~5 PLU 8C ~^L

¶ B6 ~6 RI 8D ~^M

· B7 ~7 SS2 8E ~^N

¸ B8 ~8 SS3 8F ~^O

¹ B9 ~9 DCS 90 ~^P

º BA ~: PU1 91 ~^Q

» BB ~; PU2 92 ~^R

¼ BC ~< STS 93 ~^S

½ D ~= CCH 94 ~^T

¾ BE ~> MW 95 ~^U

¿ BF ~? SPA 96 ~^V

À C0 ~@ EPA 97 ~^W

Á C1 ~A 98 ~^X

Â C2 ~B 99 ~^Y

Ã C3 ~C 9A ~^Z

Desired
ASCII Hex Value Hat 

Encoded
Desired
ASCII Hex Value Hat 

Encoded
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Ä C4 ~D CSI 9B ~^[

Å C5 ~E ST 9C ~^\\

Æ C6 ~F OSC 9D ~^]

Ç C7 ~G PM 9E ~^^

È C8 ~H APC 9F ~^_ 
(Underscore)

É C9 ~I (no-break 
space)

A0 ~ (Tilde and 
Space)

Ê CA ~J ¡ A1 ~!

Ë CB ~K ¢ A2 ~”

Ì CC ~L £ A3 ~#

Í CD ~M ¤ A4 ~$

Î CE ~N ¥ A5 ~%

Ï CF ~O ¦ A6 ~&

Ð D0 ~P § A7 ~’

Ñ D1 ~Q ¨ A8 ~(

Ò D2 ~R © A9 ~)

Ó D3 ~S ª AA ~*

Ô D4 ~T « AB ~+

Õ D5 ~U ¬ AC ~,

Ö D6 ~V (soft hyphen) AD ~- (Dash)

Desired
ASCII Hex Value Hat 

Encoded
Desired
ASCII Hex Value Hat 

Encoded
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DEC Special Graphics - Code Table
Refer to the 8-bit code table below that lists all the decimal, hexadecimal, and octal values for each character:
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IS0 8859-1 Character Set
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7
IBM 3270

3270 Host Key Descriptions

Attention
Attn - The Attention key interrupts the host application.  

System Request
Srq - The System Request key gives context to the System Software such as the SSCP (System Services Control Point).

Clear
Clr - The Clear key causes a CLEAR Attention Identifier key to be sent to the host and the host responds according to the 
host application.  

Reset
Rst - The Reset key resets the mobile client.  Depending upon the current state, it removes the host application from a key-
board inhibit state, terminates the System Request functions and exits the mobile client from insert mode.

Erase Input
EIn - This key clears all unprotected input fields and moves the cursor to the beginning of the first input field.  

Erase to End of Field
Eof - This key erases all data in an input field from the current cursor location to the end of the input field.

Delete
Del - The Delete key deletes data from an input field.  When you press this key, the character at the cursor location is 
deleted, and all characters to the right of the cursor shift one position to the left.

Insert
Ins - This key les the insert mode on and off.  In insert mode, characters are inserted at the current cursor location if space 
is available.  The characters to the right of the cursor are shifted one character position to the right.

Home
Hm - This key repositions the cursor to the first input location of the first input field.

Tab or Next
Tb - This key moves the cursor forward to the next input field.  When the cursor is not on an input field it moves to the next 
input field from the current cursor location.

Backtab or Previous
BTb - This key moves the cursor back to the previous input field.  When the cursor is not on an input field, the cursor moves 
to the previous input field from the current cursor location.  This key is equivalent to [Shift][Tab].

Enter
Ent - The Enter key submits control to the host application.

New Line
NL - This function moves the cursor to the first input field on the next line.  
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Escape
Esc - The function is the same as the Reset command.

PA Keys
Pa1, Pa2, Pa3 - The PA1 through PA3 keys communicate with the host application.  Their use is defined by the host appli-
cation.

Function Keys
F1 -  F24 - The Function keys F1 - F24 communicate with the host application.  Their use is defined by the host application, 
unless their action has been programmed using the Function Key dialog.

3270 Commands

Printing a Field
You can print a field by sending a print command (*P) from the host to the client.  It must be preceded by a field attribute 
(FA) byte.  The printing ends when the next FA is encountered.  The value of the FA is ignored, but it must be present.

Beep
You can sound a beep by sending the beep command (*B) from the host to the client.  It must be preceded by a field attri-
bute (FA) byte.  When RFTerm encounters a beep command, by default it activates the Good sound.

Host initiated sounds can also be reassigned to produce the Bad or Alarm sounds by using the Sound Key field.  For exam-
ple entering $HA in the Sound Key field means to assign Host initiated sounds to the Alarm sound

Refer to Sounds (page 2-14) to review Good, Bad and Alarm sounds and for more instructions on using the Sound Key 
field.

Custom IBM 3270 Host Commands
The following host command strings can be sent to RFTerm to provide the designated action.

Command String Action Notes

/cmd!1;3z/cmde RFTerm disables the scanner

/cmd!1;0z/cmde RFTerm enables the scanner

/cmd!1;2z/cmde RFTerm turns on the display backlight

/cmd!1;1z/cmde RFTerm turns off the display backlight

/cmd!1;4z/cmde RFTerm turns on vibration for 1 second
Only supported on mobile devices containing a vibration 
unit, such as MX7 Tecton, MX8 and MX9.  Vibration has 
no effect on other devices.

/cmd!1;5z/cmde RFTerm turns on vibration for 2 seconds

/cmd!1;6z/cmde RFTerm turns on vibration for 3 seconds

/cmd!1;7z/cmde RFTerm turns on vibration for 7 seconds

/cmd!2;00/cmde Do not display (or remove) virtual keyboard

Virtual keyboard is only supported on the Dolphin 70e 
Black.  See Virtual Keyboards (page 9-12).

/cmd!2;10/cmde Display virtual keyboard configuration 1
(Left Numeric), orientation 0

/cmd!2;20/cmde Display virtual keyboard configuration 2
(Right Numeric), orientation 0

/cmd!2;30/cmde Display virtual keyboard configuration 3
(Qwerty or SIP), orientation 0

/cmd!2;40/cmde Display virtual keyboard configuration 4
(HX2 Emulator), orientation 0
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8
IBM 5250

5250 Host Key Descriptions

Attention
Attn - The Attention key interrupts the host application.

System Request
Srq - The System Request key gives context to the System Software such as the SSCP (System Services Control Point).

Clear
Clr - The Clear key causes a CLEAR Attention Identifier key to be sent to the host and the host responds according to the 
host application.  

Reset
Rst - The Reset key resets the client.  Depending upon the current state, it removes the host application from a keyboard 
inhibit state, terminates the System Request functions and exits the client from insert mode.

Erase Input
EIn - This key clears all unprotected input fields and moves the cursor to the beginning of the first input field.  

Erase to End of Field
Eof - This key erases all data in an input field from the current cursor location to the end of the input field.

Field Minus
F- - This key causes the cursor to advance to the next field and a minus sign is inserted in the last position of a signed 
numeric-only field.  

Field Plus
F+ - This key causes the cursor to exit an input field and insert null characters from the current cursor location to the end of 
the field.  

Field Exit
FEx - This key behaves similar to the Field Plus key.  It causes the cursor to exit an input field and insert null characters 
from the current cursor location to the end of the field.  

Duplicate
Dup - This DUP key is used to insert DUP characters in a field for host processing.  

Field Mark
Mrk - The Field Mark key is used to insert a Field Mark character in a field for host processing.

Delete
Del - The Delete key deletes data from an input field.  When you press this key, the character at the cursor location is 
deleted, and all characters to the right of the cursor shift one position to the left.

Insert
Ins - This key les the insert mode on and off.  In insert mode, characters are inserted at the current cursor location if space 
is available.  The characters to the right of the cursor are shifted one character position to the right.
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Home
Hm - This key moves the cursor to the first input location of the first input field.

Tab or Next
Tb - This key moves the cursor forward to the next input field.  When the cursor is not on an input field it moves to the next 
input field from the current cursor location.

Backtab or Previous
BTb - This key moves the cursor back to the previous input field.  When the cursor is not on an input field, the cursor moves 
to the previous input field from the current cursor location.  This key is equivalent to [Shift][Tab].

Enter
Ent - The Enter key submits control to the host application.

New Line
NL - This function moves the cursor to the first input field on the next line.  

Roll Up
RUp - This function sends a roll up request to the host, similar to a scroll up.  

Roll Down
RDn - This function sends a roll down request to the host, similar to a scroll down.  

Cursor Select
Sel - This function allows the user to select an input field using the keyboard.

Print
Prt - This function prints the current screen.

Function Keys
F1 -  F24 -The Function keys F1 - F24 communicate with the host application.  Their use is defined by the host application, 
unless their action has been programmed using the Function Key dialog.

5250 Commands

Input Device ID (*K)
The input device ID feature provides the host application developer with the ability to determine which Honeywell mobile cli-
ent user input device and which bar code symbology was utilized to enter data in any field on the screen.  When the 5250 
host application is programmed to request this data from the mobile client, and when the input device ID feature is enabled 
at the client, the client sends this information to the 5250 host emulation.  This feature can be used with the match field edit 
and scan and increment features, in addition to normal user input.

This feature is useful to monitor the use of automatic input devices to enforce the practice of not using the keyboard or key-
pad as an input device.

Description
There are two major components to this feature:

• The input ID field identifies the field that follows as an operator input field.  
• The operator input field is the area on the screen where information is returned to the host application.

Input ID Field
The input ID field:
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• must be preceded by a field attribute (FA) that designates the input ID field as unprotected (operator input capable).
• is designated with an * (asterisk) as the first character and a K as the second character.
• can have any display attribute including non-display.
• does not have to be on the same line as the operator input field, but it must be the first input field to precede it.
• cannot have any input fields defined on the screen map between it and its associated operator input field.
• must have the Modified Data Tag (MDT) set by the host application so it will return to the host when [Enter] is 

pressed.
• behaves exactly the same as any protected field on the Honeywell client device.

Terminal Operation
When the input ID feature is enabled in client setup, the RFTerm 5250 terminal emulation modifies the input ID field to 
behave as if it has the Bypass (protected) field attribute.  The user can place the cursor in the input ID field with the 
arrow keys, but input is not allowed.  If the user attempts input in this field, an error message will appear indicating that 
the field is protected.  If the input ID feature is not enabled at the client device, RFTerm will treat input ID fields as nor-
mal input fields.

Examples
Example 1
The example illustrates the input ID feature used with a normal input field.  In all cases, the field attribute (FA) pre-
ceding the input ID field (*K) designates an unprotected (input capable) field:

After keyboard entry (123456789), the contents of the input ID field and the operator input field become:

The input ID field is now 00, which indicates that the user utilized the keyboard or keypad to enter data.  In the 
event the user utilized a bar code scanner, the input ID field would contain a two-digit code identifying the bar code 
symbology.  (Refer to the list of input device types and their corresponding input ID codes at the end of this seg-
ment.)

Input device ID reports the last device utilized by the end-user to fill in the input field to the host.  If the user were 
to partially fill in an input field using a bar code scanner, and then finish filling in the input field with entry from the 
keyboard, the host application would report that entry for the field came from the keyboard or keypad.  The user 
cannot modify the contents of the input ID field.
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Example 2
Example 2 illustrates that protected fields can be present between the input ID field and the operator input field.  
The field attribute (FA) preceding ITEM: designates the prompt field as a protected field; the FA preceding the 
operator input field designates the last field as unprotected:

Input Identification Types
Here is a list of the numerical values that appear in the input ID field returned from the mobile client, designating the 
type of input device utilized by the end-user.  

Printing a Field
You can print a field by sending a print command (*P) from the host to the client.  It must be preceded by a field attribute 
(FA) byte.  The printing ends when the next FA is encountered.  The value of the FA is ignored, but it must be present.

Beep
You can sound a beep by sending the beep command (*B) from the host to the client.  It must be preceded by a field attri-
bute (FA) byte.  When RFTerm encounters a beep command, by default it activates the Good sound.  

Host initiated sounds can also be reassigned to produce the Bad or Alarm sounds by using the Sound Key field.  For exam-
ple entering $HA in the Sound Key field means to assign Host initiated sounds to the Alarm sound

Refer to Sounds (page 2-14) to review Good, Bad and Alarm sounds and for more instructions on using the Sound Key 
field.

Terminal Setup 
You can configure printing options by sending the Terminal Setup command (*E) from the host to the client.  These options 
apply when either the “Prnt” ToolBar button (IBM 3 or IBM 4 KeyBar) or the “Prt” button on the CE SmartPad is pressed.  
The Terminal Setup command has the following format, each parameter must be preceded by a semicolon (;) :

*Ecl;p1;p2;p3;p4;p5;p6;p7;p8;p9;p10;p11;p12

This command must be sent to the client in the screen definition of the first field on the screen.

Numerical Value Input Device Type

00 Keyboard / Keypad

01 Bar code Code 39

02 Bar code Code 128

03 Bar code Interleaved 2 of 5

04 Bar code UPC

05 Bar code EAN

06 Bar code Code 11

07 Bar code Discrete 2 of 5

08 Bar code MSI Plessey

50 RS-232

c1 A revision compatibility byte, currently not supported, use 1.

p1 Save to disk, currently not supported, use 0.
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Input Identification Types
Here is a list of the numerical values that appear in the input ID field returned from the mobile client, designating the 
type of input device utilized by the end-user.  

Custom Mapping
The method for creating EBCDIC character sets for countries other than the U.S.  is described below, and is followed by an 
example.

Custom Character Mapping
Upon loading, RFTerm first loads the standard character set , see IS0 8859-1 Character Set (page 6-11) (Latin 1).  RFTerm 
then searches for a plain text document file named EBCDIC.TXT in the \os dependent\LXE\RFTerm folder, which is the 
default install folder for the application.  If the file is found, RFTerm will read replacement character pairs from the EBC-
DIC.TXT file and place them in the substitution table for IBM emulations.

For example

0x40 0x52

will replace the default character whose value is 0x40 with the character whose value is 0x52 according to ISO Character 
Set 8859-1 (Latin 1).  Each occurrence of the character 0x40 will be replaced regardless of whether it originated from the 
host or from the client.

p2 Bar code left justify, currently not supported, use a semicolon as a place holder.

p3 Bar code input clear mode, currently not supported, use a semicolon as a place holder.

p4 Bar code input truncate mode, currently not supported, use a semicolon as a place holder.

p5 Bar code input truncate mode, currently not supported, use a semicolon as a place holder.

p6 Auto transmit after print.
  0 = Do not transmit an Enter command after a print (default)
  1 = Automatically transmit an Enter command after a print

p7 Print carriage return per line.
  0 = No carriage return per line on a screen print
  1 = Append a carriage return per line on a screen print (default)

p8 Print line feed per line.
  0 = No line feed per line on a screen print
  1 = Append a line feed per line on a screen print (default)

p9 Status line display mode, currently not supported, use a semicolon as a place holder.

p10 Input device ID, currently not supported, use a semicolon as a place holder.

p11 Swap Tab/Field Exit, currently not supported, use a semicolon as a place holder.

p12 Tab/Field Exit for advancing, currently not supported, use a semicolon as a place holder.

Numerical Value Input Device Type

00 Keyboard / Keypad

01 Bar code Code 39

02 Bar code Code 128

03 Bar code Interleaved 2 of 5

04 Bar code UPC

05 Bar code EAN

06 Bar code Code 11

07 Bar code Discrete 2 of 5

08 Bar code MSI Plessey

50 RS-232



8 - 6

Where the <white space> represents any number of spaces and/or tabs, and is used for clarity.  The first entry is the EBC-
DIC character position in hexadecimal in the default EBCDIC character table, and the second entry is the hexadecimal or 
decimal position in the ISO Character Set 8859-1 (Latin 1) table.

Custom Keyboard Mapping
RFTerm will also search for a KEYS.TXT file in the same folder.  It will contain character pairs of the same format as the 
EBCDIC.TXT file, however these substitutions will be made ONLY for characters originating from the keyboard.

Note: If both files are present, a key press will be modified by the KEYS.TXT substitution and then modified by the 
EBCDIC.TXT substitution.  Place a copy of the EBCDIC.TXT and KEYS.TXT files in the device operating system 
persistent folder.  This will ensure the files are saved instead of discarded if the device is rebooted.

Custom IBM 5250 Host Commands
The following host command strings can be sent to RFTerm to provide the designated action.

Command String Action Notes

/cmd!1;3z/cmde RFTerm disables the scanner

/cmd!1;0z/cmde RFTerm enables the scanner

/cmd!1;2z/cmde RFTerm turns on the display backlight

/cmd!1;1z/cmde RFTerm turns off the display backlight

/cmd!1;4z/cmde RFTerm turns on vibration for 1 second
Only supported on mobile devices containing a vibration 
unit, such as MX7 Tecton, MX8 and MX9.  Vibration has 
no effect on other devices.

/cmd!1;5z/cmde RFTerm turns on vibration for 2 seconds

/cmd!1;6z/cmde RFTerm turns on vibration for 3 seconds

/cmd!1;7z/cmde RFTerm turns on vibration for 7 seconds

/cmd!2;00/cmde Do not display (or remove) virtual keyboard

Virtual keyboard is only supported on the Dolphin 70e 
Black.  See Virtual Keyboards (page 9-12).

/cmd!2;10/cmde Display virtual keyboard configuration 1
(Left Numeric), orientation 0

/cmd!2;20/cmde Display virtual keyboard configuration 2
(Right Numeric), orientation 0

/cmd!2;30/cmde Display virtual keyboard configuration 3
(Qwerty or SIP), orientation 0

/cmd!2;40/cmde Display virtual keyboard configuration 4
(HX2 Emulator), orientation 0
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Key Maps

RFTerm ToolBar
The bitmaps and associated action text for all the actions and operations that can be associated with the configurable keys are 
in the table below.

Icon Function Icon Function

Previous KeyBar VT Do

Next KeyBar VT Escape

(Blank) no action VT Find

Enter key VT Help

Tab key VT Hold

Field Backspace (Backtab) VT Insert Here

Left arrow key VT Linefeed

Right arrow key VT Next

Up arrow key VT PF1

Down arrow key VT PF2

Jump to Session 1 (S1) VT PF3

Jump to Session 2 (S2) VT PF4

Jump to Session 3 (S3) VT Previous

Jump to Session 4 (S4) VT Remove

Jump to Next Connected Session VT Select

Connect Session VT Numpad 0

Font Increase VT Numpad 1

Font Decrease VT Numpad 2

Configure Session VT Numpad 3

Print Screen VT Numpad 4

Start Menu Toggle VT Numpad 5

SmartPad Toggle VT Numpad 6
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Text InputTool Toggle VT Numpad 7

Program Exit (Emulator) VT Numpad 8

F1 function key VT Numpad 9

F2 function key VT Numpad Comma

F3 function key VT Numpad Enter

F4 function key VT Numpad Minus

F5 function key VT Numpad Period

F6 function key ASCII 0

F7 function key ASCII 1

F8 function key ASCII 2

F9 function key ASCII 3

F10 function key ASCII 4

F11 function key ASCII 5

F12 function key ASCII 6

F13 function key ASCII 7

F14 function key ASCII 8

F15 function key ASCII 9

F16 function key ASCII +

F17 function key ASCII -

F18 function key VT UDK 6

F19 function key VT UDK 7

F20 function key VT UDK 8

F21 function key VT UDK 9

F22 function key VT UDK 10

F23 function key VT UDK 11

F24 function key VT UDK 12

Icon Function Icon Function
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F25 function key (VT only) VT UDK 13

F26 function key (VT only) VT UDK 14

F27 function key (VT only) VT UDK 15

F28 function key (VT only) VT UDK 16

F29 function key (VT only) VT UDK 17

F30 function key (VT only) VT UDK 18

F31 function key (VT only) VT UDK 19

F32 function key (VT only) VT UDK 20

F33 function key (VT only) Input 1 (Text InputTool)

F34 function key (VT only) Input 2 (Text InputTool)

F35 function key (VT only) Input 3 (Text InputTool)

F36 function key (VT only) Input 4 (Text InputTool)

F37 function key (VT only) Input 5 (Text InputTool)

F38 function key (VT only) Input 6 (Text InputTool)

F39 function key (VT only) Input 7 (Text InputTool)

F40 function key (VT only) Input 8 (Text InputTool)

IBM Attention Input 9 (Text InputTool)

IBM Backspace Input 10 (Text InputTool)

IBM Clear Input 11 (Text InputTool)

IBM Delete Input 12 (Text InputTool)

IBM Duplicate Input 13 (Text InputTool)

IBM Erase EOF Input 14 (Text InputTool)

IBM Erase Input Input 15 (Text InputTool)

IBM Escape key Input 16 (Text InputTool)

IBM Field + Input 17 (Text InputTool)

IBM Field - Input 18 (Text InputTool)

Icon Function Icon Function
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IBM Field Exit Input 19 (Text InputTool)

IBM Field Mark Input 20 (Text InputTool)

IBM Help (5250 only) Horizontal Scroll Toggle

IBM Home Vertical Scroll Toggle

IBM Insert Toggle Horizontal Scroll Left (Page)

IBM New Line Horizontal Scroll Right (Page)

IBM OIA Toggle Vertical Scroll Up (Page)

IBM Print (5250 only) Vertical Scroll Down (Page)

IBM PA1 key (3270 only) Horizontal Scroll Left (End)

IBM PA2 key (3270 only) Horizontal Scroll Right (End)

IBM PA3 key (3270 only) Vertical Scroll Up (End)

IBM Reset Vertical Scroll Down (End)

IBM Roll Up (5250 only) Scroll Upper Left quadrant

IBM Roll Down (5250 only) Scroll Upper Right quadrant

IBM System Request Scroll Lower Left quadrant

VT Answerback Scroll Lower Right quadrant

VT Backspace Scroll Center quadrant

VT Cancel Scroll Cursor Center

VT Delete Scroll Cursor Visible

Icon Function Icon Function
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RFTerm Functions 

Functions Not Supported
Some functions are not supported with certain operating systems.

Function Path
Connect to Host Session > Connect or ToolBar Button
Disconnect from Host Session > Disconnect or ToolBar Button
Hide / Display MenuBar File > Settings > Display > Hide Main Menu
Enable / Disable MenuBar (XP) File > Settings > Display > Disable MenuBar
Hide / Display ToolBar File > Settings > Display > Hide ToolBar
Hide / Display KeyBar File > Settings > Display > Hide KeyBar
Hide / Display All Bars
(Not supported on Windows Mobile)

File > Settings > Display > Hide All Bars

Toggle MenuBar Bottom / Top
(Not supported on Windows Mobile, Windows XP, Windows 7, 
Windows 10, or Windows Embedded Standard)

File > Settings > Display > Menu at Bottom

Configure Host Session Session > Configure 
Increase Font Size ToolBar Button: Capital A with Up Arrow 
Decrease Font Size ToolBar Button: Capital A with Down Arrow
Font Selection Session > Configure > Font > Font Weight combo box
Display / Hide SmartPad
(Not supported on Windows XP, Windows 7, Windows 10, or 
Windows Embedded Standard)

Display > SmartPad

Display / Hide InputTool
(Not supported on Windows XP, Windows 7, Windows 10, or 
Windows Embedded Standard)

Display > InputTool

Scroll Up Scroll Bars
Scroll Down Scroll Bars
Scroll Left Scroll Bars
Scroll Right Scroll Bars
Print Setup File > Print Setup
Exit RFTerm File > Exit

Function Not Supported with these operating systems

Display / Hide SmartPad Windows XP, Windows 7, Windows 10,,Windows Embedded Standard

Display / Hide InputTool Windows XP, Windows 7, Windows 10,,Windows Embedded Standard

Toggle MenuBar Bottom / Top Windows XP, Windows 7, Windows 10,,Windows Embedded Standard, 
Windows Mobile

Hide / Display All Bars Windows Mobile



9 - 6

Virtual Key Maps 
The Virtual Key tables indicate the key combinations that RFTerm looks for to perform each function.  These key combinations 
are provided for the convenience of users who wish to remap RFTerm functions to physical keys different from those provided by 
the default key map.  In most cases, the key combinations used by RFTerm are the same for each device type.  Exceptions are 
noted.  

RFTerm Functions - Virtual Keys
Important note for HX2 users:

When running an HX2 with an Alpha  Mode 3 Tap keypad, RFTerm hijacks virtual function keys F11 through F19 to perform 
the RFTerm functions indicated in the “HX2” column of this table.  This hijacking occurs only if the HX2 Function Key 
Enable (page 3-35) option is not selected.  If HX2 Function Key Enable is selected, the key map reverts to the standard 
RFTerm virtual key map (indicated in the column labeled “Virtual Key” in the table below).  

RFTerm Function Virtual Key HX2 RFTerm GUI Equivalent

Connect to Host Ctrl  Shift  C F17 Session > Connect

Disconnect from Host Ctrl  Shift  D F17 Session > Disconnect

Exit the Emulator
Alt  X

Escape File > Exit
Ctrl  Shift  X

Help Ctrl  H Ctrl  H N/A

Hide / Display All Bars
(See Note 1 below)

Ctrl  Shift  L F16 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctrl  Shift  M F15 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Ctrl  Shift  T F14 File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  Shift  K F13 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(See Note 2 below)

Ctrl  Shift  B Ctrl  Shift  B File > Settings > Display > Menu at Bottom

Configure Host Session Ctrl  Shift  N F18 Session > Configure

Next Session Ctrl  Shift  J Session > S1/S2/S3/S4

Application Settings Ctrl  Shift  E F19 File > Settings

Increase Font Size
Ctrl  Shift  Up 
Arrow

F12 Display > Font Up

Decrease Font Size
Ctrl  Shift  Down 
Arrow

F11 Display > Font Down

Toggle Font Bold / Normal Ctrl  Shift  1 Ctrl  Shift  1 Session > Configure > Font tab

Toggle Status
(See Note 3 below)

Ctrl  Shift  2 Ctrl  Shift  2 File > Settings > Status > Orientation

Toggle OIA Bar Ctrl  Shift  O Ctrl  Shift  O File > Settings > Display > Hide OIA Bar

Display / Hide SmartPad
(see Note 1 below)

Display > SmartPad

Display / Hide InputTool
(see Note 1 below)

Ctrl  Shift  I Ctrl  Shift  I Display > InputTool

Toggle Vertical Scroll Bars Ctrl  Shift  V Ctrl  Shift  V File > Settings > Display > Hide Vertical

Toggle Horizontal Scroll Bars Ctrl  Shift  H Ctrl  Shift  H File > Settings > Display > Hide Horiz

Print Screen Ctrl  Alt  P Ctrl  Alt  P File > Print Screen

Scroll Up One Row Shift  Up Arrow Shift  Up Arrow Scroll Bars

Scroll Down One Row Shift  Down Arrow
Shift  Down 
Arrow

Scroll Bars

Scroll Left One Column Shift  Left Arrow Shift  Left Arrow Scroll Bars
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Note 1
These RFTerm functions are not available with the following operating systems:

• Windows Embedded Standard, Microsoft Windows Embedded 7
• Windows XP, Windows 7, Windows 10,

Note 2
These RFTerm functions are not available with the following operating systems:

• Windows Mobile
• Windows Embedded Standard, Microsoft Windows Embedded 7
• Windows XP, Windows 7, Windows 10,

Note 3
These RFTerm functions are not available with the following operating systems:

• Windows Mobile

Scroll Right One Column Shift  Right Arrow Shift  Right Arrow Scroll Bars

RFTerm Function Virtual Key HX2 RFTerm GUI Equivalent
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ANSI Functions - Virtual Keys
Refer to the VT Host Key Descriptions (page 5-72) for explanations of the ANSI key functions.

 

If using an HX2 with the Alpha  Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad (page 
9-54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.

ANSI Function Virtual Key RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BKSP Display > SmartPad > BS

Delete Ctrl  D Display > SmartPad > Del

Exit Program
Alt  X

File > Exit
Ctrl  Shift  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  H

Local Echo On / Off Not Supported Session > Configure > Connection > VT Config > Screen > Local Echo

Print Screen Ctrl  Alt  P

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

F1 - F10 F1 - F10 KeyBar

F11 - F20 F11 - F20 KeyBar

F21 - F30 F21 - F30 KeyBar

F21 - F40 F31 - F40 KeyBar

!
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IBM 3270 Functions - Virtual Keys
When running the RFTerm IBM 3270 terminal emulator on the HX2 refer to the 3270 Host Key Descriptions (page 7-1) for 
explanations of the IBM 3270 functions.

 

If using an HX2 with the Alpha  Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad (page 
9-54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.

3270 Function Virtual Key RFTerm GUI Equivalent

Attention Ctrl  A Display > SmartPad > Attn

Backtab Shift  Tab Display > SmartPad > Btb

Clear Ctrl  C Display > SmartPad > Clr

Cursor Block / Underline Not Supported File > Settings > Cursor > Cursor Options

Delete Ctrl  D Display > SmartPad > Del

Erase Bksp Display > SmartPad > BSp

Erase Input Ctrl  Bksp Display > SmartPad > Ein

Error Reset Ctrl  R Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctrl  Shift  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  H

Home Key Not Supported Display > SmartPad > Hm

Insert Ctrl  I Display > SmartPad > Ins

New Line Key Ctrl  N Display > SmartPad > NL

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  P

Roll Up Not Supported IBM 3 KeyBar: Roll Up

Roll Down Not Supported IBM 3 KeyBar: Roll Dn

SW Rev Not Supported File > About

Send Not Supported Base KeyBar: Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctrl  Shift  O

System Request Ctrl  S Display > SmartPad > Srq

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

PA1 - PA3 Ctrl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 F11 - F20 KeyBar

F21 - F24 F21 - F24 KeyBar

!
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IBM 5250 Functions - Virtual Keys
Refer to the 5250 Host Key Descriptions (page 8-1) for explanations of the IBM 5250 functions.

 

If using an HX2 with the Alpha  Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad (page 
9-54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.

5250 Function Virtual key RFTerm GUI Equivalent

Attention Ctrl  A Display > SmartPad > Attn

Backtab Shift  Tab Base KeyBar: Btb

Char Backspace Bksp Display > SmartPad > BSp

Clear Ctrl  C Display > SmartPad > Clr

Cursor Block / Underline Not Supported File > Settings > Cursor > Cursor Options

Delete Ctrl  D Display > SmartPad > Del

Dup Ctrl  U Display > SmartPad > Dup

Erase Input Ctrl  Bksp Display > SmartPad > Ein

Error Reset or Reset Esc Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctrl  Shift  X

Field Exit Ctrl  Enter Display > SmartPad > Fex

Field Minus Ctrl  M Display > SmartPad > F-

Field Plus Ctrl  L Display > SmartPad > F+

Function Key Editor Not Supported Session > Configure > FNKeys

Home Key Not Supported Display > SmartPad > Hm

Help Ctrl  H

Insert Ctrl  I Display > SmartPad > Ins

New Line Key Ctrl  N Display > SmartPad > NL

Next or Field Advance or Tab Tab Base KeyBar: Tb

Print Screen Ctrl  Alt  P Display > SmartPad > Prt

Send or Enter CATV Enter Base KeyBar: Ent

Status Line Toggle
Alt  T

Special KeyBar: OIA
Ctrl  Shift  0

SW Rev Not Supported File > About

System Request Ctrl  S Display > SmartPad > Srq

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

F1 - F10 F1 - F10 KeyBar

F11 - F20 F11 - F20 KeyBar

F21 - F24 F21 - F24 KeyBar

!
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Optional F1 - F40 Key Maps
There are optional key maps for the F1 through F40 keys.  To access the option, select Session > Configure > Keybd.  If the 
Two-key Function Keys checkbox is unchecked, the standard function key keypresses listed for each piece of equipment apply.

If this checkbox is checked, the following key maps replace the standard key maps for F1 through F40:

 

F1 and... Produces Ctrl  or
F2 and... Produces F3 and... Produces F4 and... Produces

1 F1 1 F11 1 F21 1 F31
2 F2 2 F12 2 F22 2 F32
3 F3 3 F13 3 F23 3 F33
4 F4 4 F14 4 F24 4 F34
5 F5 5 F15 5 F25 5 F35
6 F6 6 F16 6 F26 6 F36
7 F7 7 F17 7 F27 7 F37
8 F8 8 F18 8 F28 8 F38
9 F9 9 F19 9 F29 9 F39

10 F10 10 F20 10 F30 10 F40

If using an HX2 with the Alpha  Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad (page 9-
54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.!
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Dolphin 70e Black Keymaps
The Dolphin 70e Black does not have a traditional keypad.  A virtual keyboard is used instead.

Virtual Keyboards
Multiple virtual keypads can be displayed on the device by commands issued from the host.  For example, the host can dis-
play a full QWERTY keypad if the user must input information such as a user name and password or just a numeric keypad 
if the user must input a quantity.  The following commands can be sent out as either ASCII or EBCIDIC strings:

/cmd!2;0z/cmde = Do not display (or remove) virtual keyboard
/cmd!2;1z/cmde = Display virtual keyboard Configuration 1
/cmd!2;2z/cmde = Display virtual keyboard Configuration 2
/cmd!2;3z/cmde = Display virtual keyboard Configuration 3
/cmd!2;4z/cmde = Display virtual keyboard Configuration 4

Predefined keypad layouts are installed on the Dolphin 70e Black. 

Virtual keypad layout can also be selected on the Options3 (page 2-12) tab.

Virtual Keypad Displayed Command Description Identifier on Options 3 tab

/cmd!2;00/cmde

VK off 
(or hide if 
currently 
displayed)

None

/cmd!2;10/cmde
VK layout 1
(Left Numeric)
Orientation 0

Left Numeric

/cmd!2;20/cmde
VK layout 2
(Right Numeric)
Orientation 0

Right Numeric

/cmd!2;30/cmde
VK layout 3
(Qwerty or SIP)
Orientation 0

Qwerty or SIP
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/cmd!2;40/cmde
VK layout 4
(HX2 Emulator)
Orientation 0

HX2 Emulator

Virtual Keypad Displayed Command Description Identifier on Options 3 tab
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Tecton and MX7 Key Maps

The MX7 Tecton keypads are shown above.  The MX7 keypad is similar except for the “Tecton” logo and the position of the 
“MX7” logo.

Note: The 55-key Primary Delete keypad has a primary delete key.  The 55-key Primary Backspace keypad has a primary 
backspace key.  All other keys are the same.

Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Unless otherwise noted, key maps in this section are valid for the MX7 Tecton with either a Microsoft Windows CE 6.0 or Win-
dows Mobile 6.5 operating system.

When using a sequence of keys that includes the Orange or Blue keys, press the color key first then the rest of the key 
sequence unless otherwise noted in the tables.  Ctrl, Alt, Shft, Blue and Orange keys are “sticky keys”.  They do not need to be 
held down before pressing the next (or desired) key.  It is valid to use combined modifiers on specific keys.

Alphabetic keys default to lower case letters.  Press the Shft key, then the alphabetic key for an uppercase letter.

Note: When the computer boots, the default condition of Caps (or CapsLock) is Off.  The Caps (or CapsLock) condition can be 
toggled with Blue plus Tab key sequence.

32-key Keypad
55-key Primary
Delete Keypad

55-key IBM 
5250 Keypad

55-key Primary 
Backspace Keypad

BkSp

Del
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RFTerm Functions - MX7 and MX7 Tecton
MX7 and MX7 Tecton 55-Key Keypad
The keymaps below apply to both the 55-key Primary Delete and 55-key Primary Backspace keypads.

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctl  Shft  C Session > Connect

Disconnect from Host Ctl  Shft  D Session > Disconnect

Hide / Display All Bars Ctl  Shft  L File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctl  Shft  M File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Ctl  Shft  T File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctl  Shft  K File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Mobile)

Ctl  Shft  B File > Settings > Display > At Bottom

Configure Host Session Ctl  Shft  N Session > Configure

Application Settings Ctl  Shft  E File > Settings

Increase Font Size Ctl  Shft  Up Arrow Display > Font Up

Decrease Font Size Ctl  Shft  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctl  Shft  1 Session > Configure > Font Tab

Display/Hide SmartPad Ctl  Shft  P Display > SmartPad

Display / Hide Text Input Ctl  Shft  I Display > InputTool

Help Ctl  H  

Scroll Up One Row Shft  Up Arrow Scroll Bars

Scroll Down One Row Shft  Down Arrow Scroll Bars

Scroll Left One Row Shft  Blue  Down Arrow Scroll Bars

Scroll Right One Row Shft  Blue  Up Arrow Scroll Bars

Exit the Emulator
Alt  X

File > Exit
Ctl  Shft  X
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MX7 and MX7 Tecton 32-Key Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Alph  Ctl  Shft  2  2  2 Session > Connect

Disconnect from Host Alph  Ctl  Shft  3 Session > Disconnect

Hide / Display All Bars Alph  Ctl  Shft  5  5  5 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Alph  Ctl  Shft  6 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Alph  Ctl  Shft  8 File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Alph  Ctl  Shft  5  5 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Mobile)

Alph  Ctl  Shft  2  2 File > Settings > Display > At Bottom

Configure Host Session Alph  Ctl  Shft  6  6 Session > Configure

Application Settings Alph  Ctl  Shft  3  3 File > Settings

Increase Font Size Ctl  Shft  Up Arrow Display > Font Up

Decrease Font Size Ctl  Shft  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctl  Shft  1 Session > Configure > Font Tab

Display/Hide SmartPad Alph  Ctl  Shft  7 Display > SmartPad

Display / Hide Text Input Alph  Ctl  Shft  4  4  4 Display > InputTool

Help Alph  Ctl  4  4  

Scroll Up One Row Shft  Up Arrow Scroll Bars

Scroll Down One Row Shft  Down Arrow Scroll Bars

Scroll Left One Row Shft  Blue  Down Arrow Scroll Bars

Scroll Right One Row Shft  Blue  Up Arrow Scroll Bars

Exit the Emulator Alph  Alt  9  9 File > Exit
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ANSI Functions - MX7 and MX7 Tecton
When running the RFTerm ANSI on the MX7 and MX7 Tecton refer to the VT Host Key Descriptions (page 5-72) for expla-
nations of the ANSI key functions.

Note: Physical keypad key presses and MX7 virtual keypad presses are the same.

MX7 and MX7 Tecton 55-Key Primary Delete Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Orange  Spc Display > SmartPad > BSp

Delete Del Display > SmartPad > DEL

Exit Program
Alt  X

File > Exit
Ctl  Shft  X

Help Ctl  H

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctl  Down Arrow Scroll Bars

Window Left Ctl  Blue  Down Arrow Scroll Bars

Window Right Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Print Screen Ctl  Alt  P
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MX7 and MX7 Tecton 55-Key Primary Backspace Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Bksp Display > SmartPad > BSp

Delete Orange  Spc Display > SmartPad > DEL

Exit Program
Alt  X

File > Exit
Ctl  Shft  X

Help Ctl  H

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctl  Down Arrow Scroll Bars

Window Left Ctl  Blue  Down Arrow Scroll Bars

Window Right Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Print Screen Ctl  Alt  P
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MX7 and MX7 Tecton 32-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Orange  Spc Display > SmartPad > BSp

Delete Delete Display > SmartPad > DEL

Exit Program Alph  Alt  9  9 File > Exit

Help Alph  Ctl  4  4

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shift  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctl  Down Arrow Scroll Bars

Window Left Ctl  Blue  Down Arrow Scroll Bars

Window Right Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Print Screen Alph  Ctl  Alt  7
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IBM 3270 Functions - MX7 and MX7 Tecton
When running the RFTerm IBM 3270 terminal emulator on the MX7 and MX7 Tecton refer to the 3270 Host Key 
Descriptions (page 7-1) for explanations of the IBM 3270 functions.

MX7 and MX7 Tecton 55-Key Primary Delete Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctl  A Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Clear Ctl  C Display > SmartPad > Clr

Delete Ctl  D Display > SmartPad > Del

Erase Orange  Spc Display > SmartPad > Bsp

Erase Input Ctl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Ctl  R Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctl  Shft  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctl  H

Homekey Not Supported Display > SmartPad > Hm

Insert Ctl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctl  Alt  P

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Up Arrow Scroll Bars

Window Left Ctl  Blue  Down Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctl  Shft  O

SYS_REQ Ctl  S Display > SmartPad > Srq

PA1 - PA3 Ctl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1- F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar
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MX7 and MX7 Tecton 55-Key Primary Backspace Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctl  A Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Clear Ctl  C Display > SmartPad > Clr

Delete Ctl  D Display > SmartPad > Del

Erase Bksp Display > SmartPad > Bsp

Erase Input Ctl  Bksp Display > SmartPad > EIn

Error Reset or Reset Ctl  R Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctl  Shft  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctl  H

Homekey Not Supported Display > SmartPad > Hm

Insert Ctl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctl  Alt  P

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Up Arrow Scroll Bars

Window Left Ctl  Blue  Down Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctl  Shft  O

SYS_REQ Ctl  S Display > SmartPad > Srq

PA1 - PA3 Ctl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1- F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar
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MX7 and MX7 Tecton 32-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Alph  Ctl  2 Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Clear Alph  Ctl  2  2  2 Display > SmartPad > Clr

Delete Alph  Ctl  3 Display > SmartPad > Del

Erase Orange  Space Display > SmartPad > Bsp

Erase Input Ctl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Alph  Ctl  7  7  7 Display > SmartPad > Rst

Exit Program Alph  Alt  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Help Alph  Ctl  4  4

Homekey Not Supported Display > SmartPad > Hm

Insert Alph  Ctl  4  4  4 Display > SmartPad > Ins

LDUB Not Supported

New Line Key Alph  Ctl  6  6 Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Alph  Ctl  Alt  7

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Up Arrow Scroll Bars

Window Left Ctl  Blue  Down Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Status Line Toggle Alph  Alt  8 File > Settings > Display > Hide OIA

SYS_REQ Alph  Ctl  7  7  7  7 Display > SmartPad > Srq

PA1 - PA3 Ctl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1- F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar
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IBM 5250 Functions - MX7 and MX7 Tecton
When running the RFTerm IBM 5250 terminal emulator on MX7 and MX7 Tecton devices refer to the 5250 Host Key 
Descriptions (page 8-1) for explanations of the IBM 5250 functions.

MX7 and MX7 Tecton 55-Key Primary Delete Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctl  A Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Char Backspace Bksp Display > SmartPad > BSp

Clear Ctl  C Display > SmartPad > Clr

Delete Ctl  D Display > SmartPad > Del

Dup Ctl  U Display > SmartPad > Dup

Erase Input Ctl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Blue  Alt Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctl  Shft  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctl  Enter

Display > SmartPad > FEx
Diamond 1

Field Minus Ctl  M Display > SmartPad > F-

Field Plus Ctl  L Display > SmartPad > F+

Help Ctl  H

Homekey Not Supported Display > SmartPad > Hm

Insert Ctl  I Display > SmartPad > Ins

New Line Key Ctl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctl  Alt  P Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Down Arrow Scroll Bars

Window Left Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctl  Shft  O

Sys_Req Ctl  S Display > SmartPad > Srq

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar
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MX7 and MX7 Tecton 55-Key Primary Backspace Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctl  A Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Char Backspace Orange  Spc Display > SmartPad > BSp

Clear Ctl  C Display > SmartPad > Clr

Delete Ctl  D Display > SmartPad > Del

Dup Ctl  U Display > SmartPad > Dup

Erase Input Ctl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Blue  Alt Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctl  Shft  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctl  Enter

Display > SmartPad > FEx
Diamond 1

Field Minus Ctl  M Display > SmartPad > F-

Field Plus Ctl  L Display > SmartPad > F+

Help Ctl  H

Homekey Not Supported Display > SmartPad > Hm

Insert Ctl  I Display > SmartPad > Ins

New Line Key Ctl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctl  Alt  P Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Down Arrow Scroll Bars

Window Left Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctl  Shft  O

Sys_Req Ctl  S Display > SmartPad > Srq

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft F1 - F5 KeyBar

F21 - F24 Ctl  Orange  F1 - F4 KeyBar
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MX7 and MX7 Tecton 32-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Alph  Ctl  2 Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Char Backspace Orange  Spc Display > SmartPad > BSp

Clear Alph  Ctl  2  2  2 Display > SmartPad > Clr

Delete Alph  Ctl  3 Display > SmartPad > Del

Dup Alph  Ctl  8  8 Display > SmartPad > Dup

Erase Input Ctl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Blue  Alt Display > SmartPad > Rst

Exit Program Alph  Alt  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctl  Enter

Display > SmartPad > FEx
Diamond 1

Field Minus Alph  Ctl  6 Display > SmartPad > F-

Field Plus Alph  Ctl  5  5  5 Display > SmartPad > F+

Help Alph  Ctl  4  4

Homekey Not Supported Display > SmartPad > Hm

Insert Alph  Ctl  4  4  4 Display > SmartPad > Ins

New Line Key Alph  Ctl  6  6 Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Alph  Alt  8 Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Down Arrow Scroll Bars

Window Left Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle Alph  Alt  8 File > Settings > Display > Hide OIA

Sys_Req Alph  Ctl  7  7  7  7 Display > SmartPad > Srq

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft F1 - F5 KeyBar

F21 - F24 Orange  Ctl  F1 - F4 KeyBar
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Thor VM1 Key Maps

Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Alphabetic keys default to lower case letters.  Press the Shift  key, then the alphabetic key for an uppercase letter.

Note: When the computer boots, the default condition of CapsLock is Off.  CapsLock can be toggled with 2nd plus Shift  key 
sequence.

12-key Keypad
Note: The 12-key keypad is available on a Thor VM1 

running Windows CE 6.0.

64-key ANSI Keypad

64-key IBM 5250 Keypad 64-key IBM 3270 Keypad

SYS

SSD
UPS

SYS

SSD
UPS

Dup

Fld-

Fld+

Field Exit

E-InpInsRst

Attn S el

Clr NL

DysReq

SYS

SSD
UPS
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RFTerm Functions - Thor VM1
Thor VM1 64-Key Keypad 

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  Shift  C Session > Connect

Disconnect from Host Ctrl  Shift  D Session > Disconnect

Hide / Display All Bars Ctrl  Shift  L
File > Settings > Display > Hide All 
Bars

Hide / Display MenuBar Ctrl  Shift  M
File > Settings > Display > Hide 
MenuBar

Hide / Display ToolBar Ctrl  Shift  T
File > Settings > Display > Hide 
ToolBar

Hide / Display KeyBar Ctrl  Shift  K
File > Settings > Display > Hide 
KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Embedded Standard)

Ctrl  Shift  B
File > Settings > Display > At 
Bottom

Configure Host Session Ctrl  Shift  N Session > Configure

Application Settings Ctrl  Shift  E File > Settings

Increase Font Size Ctrl  Shift  Up Arrow Display > Font Up

Decrease Font Size Ctrl  Shift  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  Shift  1 Session > Configure > Font Tab

Display/Hide SmartPad
(N/A with Windows Embedded Standard)

Ctrl  Shift  P Display > SmartPad

Display / Hide Text Input
(N/A with Windows Embedded Standard)

Ctrl  Shift  I Display > InputTool

Help Ctrl  H

Scroll Up One Row Shift  Up Arrow Scroll Bars

Scroll Down One Row Shift  Down Arrow Scroll Bars

Scroll Left One Row Shift  Left Arrow Scroll Bars

Scroll Right One Row Shift  Right Arrow Scroll Bars

Exit the Emulator
Ctrl  Shift  X

File > Exit
Alt  X
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Thor VM1 12-Key Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in RFTerm Functions - Virtual Keys (page 9-6).

Note: This keyboard is not available with the Microsoft Windows Embedded Standard operating system.

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Not Defined Session > Connect

Disconnect from Host Not Defined Session > Disconnect

Hide / Display All Bars Not Defined File > Settings > Display > Hide All Bars

Hide / Display MenuBar Not Defined File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Not Defined File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Not Defined File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top Not Defined File > Settings > Display > At Bottom

Configure Host Session Not Defined Session > Configure

Application Settings Not Defined File > Settings

Increase Font Size Not Defined Display > Font Up

Decrease Font Size Not Defined Display > Font Down

Toggle Font Bold / Normal Not Defined Session > Configure > Font Tab

Display/Hide SmartPad Not Defined Display > SmartPad

Display / Hide Text Input Not Defined Display > InputTool

Help Not Defined

Scroll Up One Row Not Defined Scroll Bars

Scroll Down One Row Not Defined Scroll Bars

Scroll Left One Row Not Defined Scroll Bars

Scroll Right One Row Not Defined Scroll Bars

Exit the Emulator Not Defined File > Exit
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ANSI Functions - Thor VM1
When running the RFTerm ANSI on the Thor VM1 refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

Note: Physical keypad key presses and Thor VM1 virtual keypad presses are the same.

Thor VM1 64-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BkSp Display > SmartPad > BSp

Delete 2nd .  (period) Display > SmartPad > DEL

Exit Program
Alt  X

File > Exit
Shift  Ctrl  X

Help Ctrl  H

F1 - F10 F1 - F10 KeyBar

F11 - F20 Shift  F1 - F10 KeyBar

F21 - F30 Alt  F1 - F10 KeyBar

F31 - F40 Ctrl  F1 - F10 KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Ctrl  Alt  P
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Thor VM1 12-Key Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in ANSI Functions - Virtual Keys (page 9-8).

Note: This keyboard is not available with the Microsoft Windows Embedded Standard operating system.

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Not Defined Display > SmartPad > BSp

Delete Not Defined Display > SmartPad > DEL

Exit Program Not Defined File > Exit

Help Not Defined

F1 - F10 F1 - F10 KeyBar

F11 - F20 Shift  F1 - F10 KeyBar

F21 - F30 Not Defined KeyBar

F31 - F40 Not Defined KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Not Defined Display > SmartPad > Ent

Window Down Not Defined Scroll Bars

Window Left Not Defined Scroll Bars

Window Right Not Defined Scroll Bars

Window Up Not Defined Scroll Bars

Print Screen Not Defined
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IBM 3270 Functions - Thor VM1
When running the RFTerm IBM 3270 terminal emulator on the Thor VM1 refer to the 3270 Host Key Descriptions (page 7-
1) for explanations of the IBM 3270 functions.

Thor VM1 64-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab 2nd  Tab Display > SmartPad > BTb

Clear
Ctrl  C

Display > SmartPad > Clr
ESC

Delete Ctrl  D Display > SmartPad > Del

Erase BkSp Display > SmartPad > Bsp

Erase Input Ctrl  BkSp Display > SmartPad > EIn

Error Reset or Reset Ctrl  R Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Shift  Ctrl  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  H

Homekey
Ctrl  Left Arrow

Display > SmartPad > Hm
2nd  Home

Insert Ctrl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  P

RDUB Not Supported

SW Rev Alt  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctrl  Shift  O

SYS_REQ Ctrl  S Display > SmartPad > Srq

PA1 - PA3 Ctrl  F1 - F3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Shift  F1 - F10 KeyBar

F21 - F24 Alt  F1 - F4 KeyBar
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Thor VM1 12-Key Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in IBM 3270 Functions - Virtual Keys (page 9-9).

Note: This keyboard is not available with the Microsoft Windows Embedded Standard operating system.

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Not Defined Display > SmartPad > Attn

Backtab Not Defined Display > SmartPad > BTb

Clear Not Defined Display > SmartPad > Clr

Delete Not Defined Display > SmartPad > Del

Erase Not Defined Display > SmartPad > Bsp

Erase Input Not Defined Display > SmartPad > EIn

Error Reset or Reset Not Defined Display > SmartPad > Rst

Exit Program Not Defined File > Exit

Function Key Editor Not Defined Session > Configure > FNKeys

Help Not Defined

Homekey Not Defined Display > SmartPad > Hm

Insert Not Defined Display > SmartPad > Ins

LDUB Not Defined

New Line Key Not Defined Display > SmartPad > Nl

Next or Tab Not Defined Display > SmartPad > Tb

Print Screen Not Defined

RDUB Not Defined

SW Rev Not Defined File > About

Window Down Not Defined Scroll Bars

Window Right Not Defined Scroll Bars

Window Left Not Defined Scroll Bars

Window Up Not Defined Scroll Bars

Status Line Toggle Not Defined File > Settings > Display > Hide OIA

SYS_REQ Not Defined Display > SmartPad > Srq

PA1 - PA3 Not Defined Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Shift  F1 - F10 KeyBar

F21 - F24 Not Defined KeyBar
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IBM 5250 Functions - Thor VM1
When running the RFTerm IBM 5250 terminal emulator on Thor VM1 devices refer to the 5250 Host Key Descriptions (page 
8-1) for explanations of the IBM 5250 functions.

Thor VM1 64-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11)for 
details.

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab 2nd  Tab Display > SmartPad > BTb

Char Backspace BkSp Display > SmartPad > BSp

Clear Ctrl  C Display > SmartPad > Clr

Delete Ctrl  D Display > SmartPad > Del

Dup Ctrl  U Display > SmartPad > Dup

Erase Input Ctrl  BkSp Display > SmartPad > EIn

Error Reset or Reset ESC Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctrl  Shift  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctrl  Enter

Display > SmartPad > FEx
2nd  Enter

Field Minus Ctrl  M Display > SmartPad > F-

Field Plus Ctrl  L Display > SmartPad > F+

Help Ctrl  H

Homekey 2nd  Home Display > SmartPad > Hm

Insert Ctrl  I Display > SmartPad > Ins

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen Ctrl  Alt  P Display > SmartPad > Prt

SW REV Alt  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctrl  Shift  O

Sys_Req Ctrl  S Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Shift  F1 - F10 KeyBar

F21 - F24 Alt  F1 - F4 KeyBar
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Thor VM1 12-Key Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in IBM 5250 Functions - Virtual Keys (page 9-10).

Note: This keyboard is not available with the Microsoft Windows Embedded Standard operating system.

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Not Defined Display > SmartPad > Attn

Backtab Not Defined Display > SmartPad > BTb

Char Backspace Not Defined Display > SmartPad > BSp

Clear Not Defined Display > SmartPad > Clr

Delete Not Defined Display > SmartPad > Del

Dup Not Defined Display > SmartPad > Dup

Erase Input Not Defined Display > SmartPad > EIn

Error Reset or Reset Not Defined Display > SmartPad > Rst

Exit Program Not Defined File > Exit

Function Key Editor Not Defined Session > Configure > FNKeys

Fastback Not Defined

Fastfwd Not Defined

Field Exit Not Defined Display > SmartPad > FEx

Field Minus Not Defined Display > SmartPad > F-

Field Plus Not Defined Display > SmartPad > F+

Help Not Defined

Homekey Not Defined Display > SmartPad > Hm

Insert Not Defined Display > SmartPad > Ins

New Line Key Not Defined Display > SmartPad > Nl

Next or Tab Not Defined Display > SmartPad > Tb

Print Screen Not Defined Display > SmartPad > Prt

SW REV Not Defined File > About

Window Down Not Defined Scroll Bars

Window Right Not Defined Scroll Bars

Window Left Not Defined Scroll Bars

Window Up Not Defined Scroll Bars

Send or Entercatv Not Defined Display > SmartPad > Ent

Status Line Toggle Not Defined File > Settings > Display > Hide OIA

Sys_Req Not Defined Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Shift  F1 - F10 KeyBar

F21 - F24 Not Defined KeyBar
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Thor VM2 Key Maps
Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Integrated Keypad

There are ten Programmable Keys on the Thor VM2 front bezel.  These keys may be programmed to an RFTerm function 
by the system administrator.

For pre-programmed functions, see:

• RFTerm Functions - Thor VM2 Integrated Keypad (page 9-36)
• ANSI Functions - Thor VM2 Integrated Keypad (page 9-36)
• IBM 3270 Functions - Thor VM2 Integrated Keypad (page 9-36)
• IBM 5250 Functions - Thor VM2 Integrated Keypad (page 9-36)

External 21-Key Numeric Keypad
The Thor VM2 supports the external 21-key numeric keypad.  See 21-Key Numeric Keypad (page 9-39) for RFTerm key-
maps for this optional keyboard.

External 95-Key Keyboard
The Thor VM2 supports the external 95-key keyboard.  This keyboard may be a USB or PS/2 keyboard (see the Thor VM2 
User’s Guide for hardware details).  See 95-Key Keyboard (page 9-40) for RFTerm keymaps for this optional keyboard.

External 60-Key Keyboard
The Thor VM2 supports the external 60-key keyboard.  See 60-Key Keyboard (page 9-44) for RFTerm keymaps for this 
optional keyboard.

P3 P8 P4 P9 P5 P10P6 P2 P7P1

SYS

SSD

Wi FiUPS
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RFTerm Functions - Thor VM2 Integrated Keypad
By default, no RFTerm functions are assigned to the integrated keypad.

ANSI Functions - Thor VM2 Integrated Keypad
When running RFTerm ANSI on the Thor VM2 refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

By default, no ANSI functions are assigned to the integrated keypad keys except as noted below:

IBM 3270 Functions - Thor VM2 Integrated Keypad
When running RFTerm IBM 3270 on the Thor VM2 refer to the 3270 Host Key Descriptions (page 7-1) for explanations of 
the IBM 3270 functions.

By default, no IBM 3270 functions are assigned to the integrated keypad keys except as noted below:

IBM 5250 Functions - Thor VM2 Integrated Keypad
When running RFTerm IBM 5250 on the Thor VM2 refer to the 5250 Host Key Descriptions (page 8-1) for explanations of 
the IBM 5250 functions.

By default, no IBM 5250 functions are assigned to the integrated keypad keys except as noted below:

VM2 Key Default Programmable Key Value

P1 F1

P2 F2

P3 F3

P4 F4

P5 F5

VM2 Key Default Programmable Key Value

P1 F1

P2 F2

P3 F3

P4 F4

P5 F5

VM2 Key Default Programmable Key Value

P1 F1

P2 F2

P3 F3

P4 F4

P5 F5
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Thor VM3 Key Maps
Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Integrated Keypad

There are fourteen Programmable Keys on the Thor VM3 front bezel.  These keys may be programmed to an RFTerm func-
tion by the system administrator.

For pre-programmed functions, see:

• RFTerm Functions - Thor VM3 Integrated Keypad (page 9-38)
• ANSI Functions - Thor VM3 Integrated Keypad (page 9-38)
• IBM 3270 Functions - Thor VM3 Integrated Keypad (page 9-38)
• IBM 5250 Functions - Thor VM3 Integrated Keypad (page 9-38)

External 21-Key Numeric Keypad
The Thor VM3 supports the external 21-key numeric keypad.  See 21-Key Numeric Keypad (page 9-39) for RFTerm key-
maps for this optional keyboard.

External 95-Key Keyboard
The Thor VM3 supports the external 95-key numeric keypad.  This keyboard may be a USB or PS/2 keyboard (see the Thor 
VM3 User’s Guide for hardware details).  See 95-Key Keyboard (page 9-40) for RFTerm keymaps for this optional key-
board.

External 60-Key Keyboard
The Thor VM3 supports the external 60-key keyboard.  See 60-Key Keyboard (page 9-44) for RFTerm keymaps for this 
optional keyboard.

P8P1 P14P7P13P6P12P5P11P4P10P3P9P2
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RFTerm Functions - Thor VM3 Integrated Keypad
By default, no RFTerm functions are assigned to the integrated keypad.

ANSI Functions - Thor VM3 Integrated Keypad
When running RFTerm ANSI on the Thor VM3 refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

By default, no ANSI functions are assigned to the integrated keypad keys except as noted below:

IBM 3270 Functions - Thor VM3 Integrated Keypad
When running RFTerm IBM 3270 on the Thor VM3 refer to the 3270 Host Key Descriptions (page 7-1) for explanations of 
the IBM 3270 functions.

By default, no IBM 3270 functions are assigned to the integrated keypad keys except as noted below:

IBM 5250 Functions - Thor VM3 Integrated Keypad
When running RFTerm IBM 5250 on the Thor VM3 refer to the 5250 Host Key Descriptions (page 8-1) for explanations of 
the IBM 5250 functions.

By default, no IBM 5250 functions are assigned to the integrated keypad keys except as noted below:

VM3 Key Default Programmable Key Value

P1 F1

P2 F2

P3 F3

P4 F4

P5 F5

VM3 Key Default Programmable Key Value

P1 F1

P2 F2

P3 F3

P4 F4

P5 F5

VM3 Key Default Programmable Key Value

P1 F1

P2 F2

P3 F3

P4 F4

P5 F5
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External Keyboards for Vehicle Mounted Computers
The following external keyboards may be available for vehicle mounted computers.

21-Key Numeric Keypad

The numeric keypad is pre-programmed for F1-F20 keys.

RFTerm Functions - External 21-Key Numeric Keypad
By default, no RFTerm functions are assigned to this keyboard.

ANSI Functions - External 21-Key Numeric Keypad
When running RFTerm ANSI on these devices refer to the VT Host Key Descriptions (page 5-72) for explanations of 
the ANSI key functions.

The following ANSI functions are supported on the numeric keypad:

IBM 3270 Functions - External 21-Key Numeric Keypad
When running RFTerm IBM 3270 on these devices refer to the 3270 Host Key Descriptions (page 7-1) for explanations 
of the IBM 3270 functions.

The following IBM 3270 functions are supported on the numeric keypad:

IBM 5250 Functions - Numeric Keypad
When running RFTerm IBM 5250 on these devices refer to the 5250 Host Key Descriptions (page 8-1) for explanations 
of the IBM 5250 functions.

The following IBM 5250 functions are supported on the numeric keypad:

ANSI Function Press these keys in this order

F1 - F10 Yellow  1 - 0

F11 - F20 Green  1 - 0

ANSI Function Press these keys in this order

F1 - F10 Yellow  1 - 0

F11 - F20 Green  1 - 0

ANSI Function Press these keys in this order

F1 - F10 Yellow  1 - 0

F11 - F20 Green  1 - 0
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95-Key Keyboard

For the external 95-key keyboard:

• Set the On/Off condition of NumLock before pressing a key sequence.
• When the computer boots, the default condition of CapsLock is Off.  The Caps condition can be toggled with a CapsLock 

key.

RFTerm Functions - External 95-Key Keyboard

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  Shift  C Session > Connect

Disconnect from Host Ctrl  Shift  D Session > Disconnect

Hide / Display All Bars Ctrl  Shift  L File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctrl  Shift  M
File > Settings > Display > Hide 
MenuBar

Hide / Display ToolBar Ctrl  Shift  T File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  Shift  K File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(Windows CE and Windows 
Embedded Compact only)

Ctrl  Shift  B File > Settings > Display > At Bottom

Configure Host Session Ctrl  Shift  N Session > Configure

Application Settings Ctrl  Shift  E File > Settings

Increase Font Size Ctrl  Shift  Up Arrow Display > Font Up

Decrease Font Size Ctrl  Shift  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  Shift  1 Session > Configure > Font Tab

Display/Hide SmartPad
(Windows CE and Windows 
Embedded Compact only)

Ctrl  Shift  P Display > SmartPad

Display / Hide Text Input
(Windows CE and Windows 
Embedded Compact only)

Ctrl  Shift  I Display > InputTool

Help Ctrl  H

Scroll Up One Row Shift  Up Arrow Scroll Bars

Scroll Down One Row Shift  Down Arrow Scroll Bars

Scroll Left One Row Shift  Left Arrow Scroll Bars

Scroll Right One Row Shift  Right Arrow Scroll Bars

Exit the Emulator
Ctrl  Shift  X

File > Exit
Alt  X

Esc F2 F3 F4 F5 F6 F7 F8 F9 F10 F11 F12 Print
Screen
SysRq

Scroll
Lock

Pause
Break
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ANSI Functions - External 95-Key Keyboard
When running RFTerm ANSI on these devices refer to the VT Host Key Descriptions (page 5-72) for explanations of 
the ANSI key functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BackSpace Display > SmartPad > BSp

Delete Del Display > SmartPad > DEL

Exit Program
Alt  X

File > Exit
Shift  Ctrl  X

Help Ctrl  H

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F30 Shift  F1 - F10 KeyBar

F31 - F40 Ctrl  F1 - F10 KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Ctrl  Alt  P
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IBM 3270 Functions - External 95-Key Keyboard
When running RFTerm IBM 3270 on these devices refer to the 3270 Host Key Descriptions (page 7-1) for explanations 
of the IBM 3270 functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab Shift  Tab Display > SmartPad > BTb

Clear
Ctrl  C

Display > SmartPad > Clr
Esc

Delete Ctrl  D Display > SmartPad > Del

Erase BackSpace Display > SmartPad > Bsp

Erase Input Ctrl  BackSpace Display > SmartPad > EIn

Error Reset or Reset Ctrl  R Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Shift  Ctrl  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  H

Homekey
Ctrl  Left Arrow

Display > SmartPad > Hm
Ctrl  Home

Insert Ctrl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  P

RDUB Not Supported

SW Rev Alt  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Shift  Ctrl  O

SYS_REQ Ctrl  S Display > SmartPad > Srq

PA1 - PA3 Ctrl  F1 - F3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F24 Shift  F1 - F4 KeyBar
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IBM 5250 Functions - External 95-Key Keyboard
When running RFTerm IBM 5250 on these devices refer to the 5250 Host Key Descriptions (page 8-1) for explanations 
of the IBM 5250 functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab Shift  Tab Display > SmartPad > BTb

Char Backspace BackSpace Display > SmartPad > BSp

Clear Ctrl  C Display > SmartPad > Clr

Delete Ctrl  D Display > SmartPad > Del

Dup Ctrl  U Display > SmartPad > Dup

Erase Input Ctrl  BackSpace Display > SmartPad > EIn

Error Reset or Reset Esc Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctrl  Shift  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit

Ctrl  Enter

Display > SmartPad > FExEnd

Pause

Field Minus Ctrl  M Display > SmartPad > F-

Field Plus Ctrl  L Display > SmartPad > F+

Help Ctrl  H

Homekey Home Display > SmartPad > Hm

Insert Ctrl  I Display > SmartPad > Ins

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  P Display > SmartPad > Prt

SW REV Alt  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctrl  Shift  O

Sys_Req Ctrl  S Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F24 Shift  F1 - F4 KeyBar
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60-Key Keyboard
The 60-key keyboard may offered in three variations depending on the device.  

60-key ANSI Keyboard

60-key 3270 Keyboard

60-key 5250 Keyboard

For the 60-key keyboard:

• When using a sequence of keys that includes the 2ND key, press the 2ND key first then the rest of the key sequence.
• Set the On/Off condition of NumLock before pressing a key sequence.  There is no visual indication of the condition of 

NumLock.
• When the computer boots, the default condition of Caps (or CapsLock) is Off.  The Caps (or CapsLock) condition can be 

toggled with a 2ND-F1 key sequence.  The CAPS LED is illuminated when CapsLock is On.  
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RFTerm Functions - 60-key Keyboard

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  SHIFT  C Session > Connect

Disconnect from Host Ctrl  SHIFT  D Session > Disconnect

Hide / Display All Bars Ctrl  SHIFT  L File > Settings > Display > Hide All Bars

Hide / Display ToolBar Ctrl  SHIFT  T File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  SHIFT  K File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(Windows CE and Windows 
Embedded Compact only)

Ctrl  SHIFT  B File > Settings > Display > At Bottom

Configure Host Session Ctrl  SHIFT  N Session > Configure

Application Settings Ctrl  SHIFT  E File > Settings

Increase Font Size Ctrl  SHIFT  Up Arrow Display > Font Up

Decrease Font Size Ctrl  SHIFT  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  SHIFT  1 Session > Configure > Font Tab

Display/Hide SmartPad
(Windows CE and Windows 
Embedded Compact only)

Ctrl  Shift  P Display > SmartPad

Display / Hide Text Input
(Windows CE and Windows 
Embedded Compact only)

Ctrl  Shift  I Display > InputTool

Help Ctrl  H

Scroll Up One Row SHIFT  Up Arrow Scroll Bars

Scroll Down One Row SHIFT  Down Arrow Scroll Bars

Scroll Left One Row SHIFT  Left Arrow Scroll Bars

Scroll Right One Row SHIFT  Right Arrow Scroll Bars

Exit the Emulator
Ctrl  SHIFT  X

File > Exit
ALT  X
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ANSI Functions - 60-key Keyboard
When running RFTerm ANSI on these devices refer to the VT Host Key Descriptions (page 5-72) for explanations of 
the ANSI key functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BKSP Display > SmartPad > BSp

Delete 2ND . (period) Display > SmartPad > DEL

Exit Program
ALT  X

File > Exit
SHIFT  Ctrl  X

Help Ctrl  H

F1 - F10 F1 - F10 KeyBar

F11 - F20 ALT  F1 - F10 KeyBar

F21 - F30 SHIFT  F1 - F10 KeyBar

F31 - F40 Ctrl  F1 - F10 KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send ENTER Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Ctrl  ALT  P
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IBM 3270 Functions - 60-key Keyboard
When running RFTerm IBM 3270 on these devices refer to the 3270 Host Key Descriptions (page 7-1) for explanations 
of the IBM 3270 functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab 2ND  Tab Display > SmartPad > BTb

Clear
Ctrl  C

Display > SmartPad > Clr
ESC

Delete Ctrl  D Display > SmartPad > Del

Erase BKSP Display > SmartPad > Bsp

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset Ctrl  R Display > SmartPad > Rst

Exit Program
ALT  X

File > Exit
SHIFT  Ctrl  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  H

Homekey
Ctrl  Left Arrow

Display > SmartPad > Hm
2ND  Home

Insert Ctrl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  ALT  P

RDUB Not Supported

SW Rev ALT  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle
ALT  T

File > Settings > Display > Hide OIA
Ctrl  SHIFT  O

SYS_REQ Ctrl  S Display > SmartPad > Srq

PA1 - PA3 Ctrl  F1 - F3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 ALT  F1 - F10 KeyBar

F21 - F24 SHIFT  F1 - F4 KeyBar
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IBM 5250 Functions - 60-key Keyboard
When running RFTerm IBM 5250 on these devices refer to the 5250 Host Key Descriptions (page 8-1) for explanations 
of the IBM 5250 functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab 2ND  Tab Display > SmartPad > BTb

Char Backspace BKSP Display > SmartPad > BSp

Clear Ctrl  C Display > SmartPad > Clr

Delete Ctrl  D Display > SmartPad > Del

Dup Ctrl  U Display > SmartPad > Dup

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset ESC Display > SmartPad > Rst

Exit Program
ALT  X

File > Exit
Ctrl  SHIFT  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctrl  ENTER

Display > SmartPad > FEx
2ND  ENTER

Field Minus Ctrl  M Display > SmartPad > F-

Field Plus Ctrl  L Display > SmartPad > F+

Help Ctrl  H

Homekey 2ND  Home Display > SmartPad > Hm

Insert Ctrl  I Display > SmartPad > Ins

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen Ctrl  ALT  P Display > SmartPad > Prt

SW REV ALT  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv ENTER Display > SmartPad > Ent

Status Line Toggle
ALT  T

File > Settings > Display > Hide OIA
Ctrl  SHIFT  O

Sys_Req Ctrl  S Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 ALT  F1 - F10 KeyBar

F21 - F24 SHIFT  F1 - F4 KeyBar
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Marathon Key Maps
Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

• There is no 2ND key on this keyboard.
• Set the On/Off condition of NumLock before pressing a key sequence. When NumLock is On, the NumLck key is backlit 

amber. When NumLock is Off, the NumLck key backlight is off.
• When the computer boots, the default condition of CapsLock is Off. The Caps condition can be toggled with the Shift  key. 

Press and hold the Shift  key for approximately 1.5 seconds to enter CapsLock mode. The blue LED on the Shift  key remains 
lit while in CapsLock mode.

ESC F4F1 F2 F5 F7 F8F3 F6 F9 F10 NUM
LCK

/
?

M
.

N

L
'

K
"

J
;

BVC
,

X
>

Z
<

H
:

G
\

F
+

D
=

S
-

A
_

Bk

64

98

5

7

*0.

321

-+

Tab Fn SPACE CTL ALT DEL

SHIFT

ENT

W E R P
)

O
(

I
@

U
&

Y
^

T
%$#*

Q
!



9 - 50

RFTerm Functions - Marathon

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctl  Shift  C Session > Connect

Disconnect from Host Ctl  Shift  D Session > Disconnect

Hide / Display All Bars Ctl  Shift  L File > Settings > Display > Hide All Bars

Hide / Display ToolBar Ctl  Shift  T File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctl  Shift  K File > Settings > Display > Hide KeyBar

Configure Host Session Ctl  Shift  N Session > Configure

Application Settings Ctl  Shift  E File > Settings

Increase Font Size Ctl  Shift  Up Arrow Display > Font Up

Decrease Font Size Ctl  Shift  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctl  Shift  1 Session > Configure > Font Tab

Display/Hide SmartPad Ctl  Shift  P Display > SmartPad

Display / Hide Text Input Ctl  Shift  I Display > InputTool

Help Ctl  H

Scroll Up One Row
Ctl  Down Arrow (NumLck off)

Scroll Bars
Ctl  Shift  2 (NumLck on)

Scroll Down One Row
Ctl  Left Arrow (NumLck off)

Scroll Bars
Ctl  Shift  4 (NumLck on)

Scroll Left One Row
Ctl  Right Arrow (NumLck off)

Scroll Bars
Ctl  Shift  6 (NumLck on)

Scroll Right One Row
Ctl  Up Arrow (NumLck off)

Scroll Bars
Ctl  Shift  8 (NumLck on)

Exit the Emulator
Ctl  Shift  X

File > Exit
Alt  X
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ANSI Functions - Marathon
When running the RFTerm ANSI on the Marathon refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

Alternative keypresses may be defined for F1 through F40. Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BkSp Display > SmartPad > BSp

Delete DEL Display > SmartPad > DEL

Exit Program
Alt  X

File > Exit
Shift  Ctl  X

Help Ctl  H

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F30 Shift  F1 - F10 KeyBar

F31 - F40 Ctl  F1 - F10 KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down
Ctl  Down Arrow (NumLck off)

Scroll Bars
Ctl  Shift  2 (NumLck on)

Window Left
Ctl  Left Arrow (NumLck off)

Scroll Bars
Ctl  Shift  4 (NumLck on)

Window Right
Ctl  Right Arrow (NumLck off)

Scroll Bars
Ctl  Shift  6 (NumLck on)

Window Up
Ctl  Up Arrow (NumLck off)

Scroll Bars
Ctl  Shift  8 (NumLck on)

Print Screen Ctl  Alt  P
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IBM 3270 Functions - Marathon
When running the RFTerm IBM 3270 terminal emulator on the Marathon refer to the 3270 Host Key Descriptions (page 7-1) 
for explanations of the IBM 3270 functions.

Alternative keypresses may be defined for F1 through F40. Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctl  A Display > SmartPad > Attn

Backtab Shift  Tab Display > SmartPad > BTb

Clear Ctl  C Display > SmartPad > Clr

Delete Ctl  D Display > SmartPad > Del

Erase BkSp Display > SmartPad > Bsp

Erase Input Ctl  BkSp Display > SmartPad > EIn

Error Reset or Reset Ctl  R Display > SmartPad > Rst

Exit Program
Alt  X 

File > Exit
Shift  Ctl  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctl  H

Homekey Ctl  Left Arrow Display > SmartPad > Hm

Insert Ctl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctl  Alt  P

RDUB Not Supported

SW Rev Alt  F  B File > About

Window Down
Ctl  Down Arrow (NumLck off)

Scroll Bars
Ctl  Shift  2 (NumLck on)

Window Right
Ctl  Left Arrow (NumLck off)

Scroll Bars
Ctl  Shift  4 (NumLck on)

Window Left
Ctl  Right Arrow (NumLck off)

Scroll Bars
Ctl  Shift  6 (NumLck on)

Window Up
Ctl  Up Arrow (NumLck off)

Scroll Bars
Ctl  Shift  8 (NumLck on)

Status Line Toggle Alt  T File > Settings > Display > Hide OIA

Shift  Ctl  O

SYS_REQ Ctl  S Display > SmartPad > Srq

PA1 - PA3 Ctl  F1 - F3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F24 Shift  F1 - F4 KeyBar
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IBM 5250 Functions - Marathon
When running the RFTerm IBM 5250 terminal emulator on the Marathon refer to the 5250 Host Key Descriptions (page 8-1) 
for explanations of the IBM 5250 functions.

Alternative keypresses may be defined for F1 through F40. Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctl  A Display > SmartPad > Attn

Backtab Shift  Tab Display > SmartPad > BTb

Char Backspace BkSp Display > SmartPad > BSp

Clear Ctl  C Display > SmartPad > Clr

Delete Ctl  D Display > SmartPad > Del

Dup Ctl  U Display > SmartPad > Dup

Erase Input Ctl  BkSp Display > SmartPad > EIn

Error Reset or Reset Esc Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctl  Shift  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit Ctl  Enter Display > SmartPad > FEx

Field Minus Ctl  M Display > SmartPad > F-

Field Plus Ctl  L Display > SmartPad > F+

Help Ctl  H

Homekey Ctrl  Home Display > SmartPad > Hm

Insert Ctl  I Display > SmartPad > Ins

New Line Key Ctl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctl  Alt  P Display > SmartPad > Prt

SW REV Alt  F  B File > About

Window Down
Ctl  Down Arrow (NumLck off)

Scroll Bars
Ctl  Shift  2 (NumLck on)

Window Right
Ctl  Left Arrow (NumLck off)

Scroll Bars
Ctl  Shift  4 (NumLck on)

Window Left
Ctl  Right Arrow (NumLck off)

Scroll Bars
Ctl  Shift  6 (NumLck on)

Window Up
Ctl  Up Arrow (NumLck off)

Scroll Bars
Ctl  Shift  8 (NumLck on)

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctl  Shift  O

Sys_Req Ctl  S Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F24 Shift  F1 - F4 KeyBar
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HX2 Key Maps

Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

When using a sequence of keys that includes the Blue, Orange, Green or Light Blue   key, press the color key first then the 
rest of the key sequence unless otherwise noted in the tables.  Ctrl, Shift, Blue, Light Blue and Orange keys (not all keys are 
present on each keyboard) are “sticky keys”.  They do not need to be held down before pressing the next (or desired) key.

By default, the Green key (when present) is not sticky.  However the Green key can be configured to be sticky via the Start > 
Settings > Control Panel > HX2-3 Options > Misc tab.

User defined keys can be set using Start > Settings > Control Panel > Keypad and selecting the Key Map tab.  Refer to the 
HX2 Reference Guide for details.

Important Note for Alpha  Mode 3 Tap Keypad
When running an HX2 with an Alpha  Mode 3 Tap keypad, RFTerm hijacks virtual function keys F11 through F19 to perform 
the RFTerm functions indicated in the HX2 Alpha Mode 3 Tap Keypad (page 9-57) key map for the Alpha  Mode 3 Tap key-
pad.  This hijacking occurs only if the HX2 Function Key Enable (page 3-35) option is not selected.  If HX2 Function Key 
Enable is selected, the key map reverts to the standard RFTerm virtual key map RFTerm Functions - Virtual Keys (page 9-
6).

Dual Alpha  Keypads

Triple Tap Keypads

Alpha  Mode 3 Tap Keypad
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MNOJ K LGHI

DE FAB C

ES
C
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RFTerm Functions - HX2
HX2 Dual Alpha  Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  SHIFT  Orange  2 Session > Connect

Disconnect from Host Ctrl  SHIFT  Light Blue  2 Session > Disconnect

Hide / Display All Bars Ctrl  SHIFT  Light Blue  6 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctrl  SHIFT  Orange  7 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Ctrl  SHIFT  Light Blue  Up Arrow File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  SHIFT  Orange 6 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top Ctrl  SHIFT  Light Blue  1 File > Settings > Display > At Bottom

Configure Host Session Ctrl  SHIFT  Light Blue  7 Session > Configure

Application Settings Ctrl  SHIFT  Orange  3 File > Settings

Increase Font Size Ctrl  SHIFT  Up Arrow Display > Font Up

Decrease Font Size Ctrl  SHIFT  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  SHIFT  1 Session > Configure > Font Tab

Display/Hide SmartPad Ctrl  SHIFT  Light Blue  8 Display > SmartPad

Display / Hide Text Input Ctrl  SHIFT  Orange  5 Display > InputTool

Help Ctrl  Light Blue  4

Scroll Up One Row SHIFT  Up Arrow Scroll Bars

Scroll Down One Row SHIFT  Down Arrow Scroll Bars

Scroll Left One Row SHIFT  Green  Up Arrow Scroll Bars

Scroll Right One Row SHIFT  Green  Down Arrow Scroll Bars

Exit the Emulator Green  Ctrl  Light Blue  BKSP File > Exit
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HX2 Triple Tap Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  SHIFT  Light Blue  2  2  2 Session > Connect

Disconnect from Host Ctrl  SHIFT  Light Blue  3 Session > Disconnect

Hide / Display All Bars Ctrl  SHIFT  Light Blue  5  5  5 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctrl  SHIFT  Light Blue  6 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Ctrl  SHIFT  Light Blue  8 File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  SHIFT  Light Blue  5  5 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top Ctrl  SHIFT  Light Blue  2  2 File > Settings > Display > At Bottom

Configure Host Session Ctrl  SHIFT  Light Blue  6  6 Session > Configure

Application Settings Ctrl  SHIFT  Light Blue  3  3 File > Settings

Increase Font Size Ctrl  SHIFT  Up Arrow Display > Font Up

Decrease Font Size Ctrl  SHIFT  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  SHIFT  1 Session > Configure > Font Tab

Display/Hide SmartPad Ctrl  SHIFT  Light Blue  7 Display > SmartPad

Display / Hide Text Input Ctrl  SHIFT  Light Blue  4  4  4 Display > InputTool

Help Ctrl  Light Blue  4  4

Scroll Up One Row SHIFT  Up Arrow Scroll Bars

Scroll Down One Row SHIFT  Down Arrow Scroll Bars

Scroll Left One Row SHIFT  Green Up Arrow Scroll Bars

Scroll Right One Row SHIFT  Green Down Arrow Scroll Bars

Exit the Emulator Green Ctrl  Light Blue  9  9 File > Exit
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HX2 Alpha  Mode 3 Tap Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified in RFTerm Functions - Virtual Keys (page 9-6).

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Blue  7 Session > Connect

Disconnect from Host Blue  7 Session > Disconnect

Hide / Display All Bars Blue  6 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Blue  5 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Blue  4 File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Blue  3 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top Not Defined File > Settings > Display > At Bottom

Configure Host Session Blue  8 Session > Configure

Application Settings Blue  9 File > Settings

Increase Font Size Blue  2 Display > Font Up

Decrease Font Size Blue  1 Display > Font Down

Toggle Font Bold / Normal Not Defined Session > Configure > Font Tab

Display/Hide SmartPad Not Defined Display > SmartPad

Display / Hide Text Input Not Defined Display > InputTool

Help Not Defined

Scroll Up One Row Not Defined Scroll Bars

Scroll Down One Row Not Defined Scroll Bars

Scroll Left One Row Not Defined Scroll Bars

Scroll Right One Row Not Defined Scroll Bars

Exit the Emulator Blue  Bksp File > Exit
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ANSI Functions - HX2
When running the RFTerm ANSI on the HX2 refer to the VT Host Key Descriptions (page 5-72) for explanations of the ANSI 
key functions.

HX2 Dual Alpha  Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BKSP Display > SmartPad > BSp

Delete Orange  Light Blue  1 Display > SmartPad > DEL

Exit Program Green  Ctrl  Light Blue  BKSP File > Exit

Help Ctrl  Light Blue  4

F1 - F10 Green  1 - 0 KeyBar

F11 - F20 SHIFT  Green  1 - 0 KeyBar

F21 - F24 SHIFT  Green  Light Blue  1 - 4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Green Up Arrow Scroll Bars

Window Right Ctrl  Green Down Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Green  Ctrl  Light Blue  8



9 - 59

HX2 Triple Tap Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BKSP Display > SmartPad > BSp

Delete Orange  Light Blue  1 Display > SmartPad > DEL

Exit Program Green  Ctrl  Light Blue  9  9 File > Exit

Help Ctrl  Light Blue  4  4

F1 - F10 Green  1 - 0 KeyBar

F11 - F20 SHIFT  Green  1 - 0 KeyBar

F21 - F24 SHIFT  Green  Light Blue  1 - 4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Green  Up Arrow Scroll Bars

Window Right Ctrl  Green  Down Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Green  Ctrl  Light Blue  7
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HX2 Alpha  Mode 3 Tap Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in the ANSI Functions - Virtual Keys (page 9-8) table.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

If using an HX2 with the Alpha Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad 
(page 9-54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.

ANSI Function Press these HX2 keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Bksp Display > SmartPad > BSp

Delete Not Defined Display > SmartPad > DEL

Exit Program Blue  Bksp File > Exit

Help Not Defined

F1 - F4 F1-F4 KeyBar

F5 - F8 Blue  F1 - F4 KeyBar

F9 Not Defined KeyBar

F10 Blue  0 KeyBar

F11 - F19 Not Supported KeyBar

F20 Not Defined KeyBar

F21 - F24 Not Defined KeyBar

F25 - F40 Not Defined KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Not Defined Scroll Bars

Window Left Not Defined Scroll Bars

Window Right Not Defined Scroll Bars

Window Up Not Defined Scroll Bars

Print Screen Not Defined

!
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IBM 3270 Functions - HX2
When running the RFTerm IBM 3270 terminal emulator on the HX2 refer to the 3270 Host Key Descriptions (page 7-1) for 
explanations of the IBM 3270 functions.

HX2 Dual Alpha  Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  Orange 1 Display > SmartPad > Attn

Backtab Green  TAB Display > SmartPad > BTb

Clear Ctrl  Orange 2 Display > SmartPad > Clr

Delete Ctrl  Light Blue  2 Display > SmartPad > Del

Erase BKSP Display > SmartPad > Bsp

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset Ctrl  Light Blue  9 Display > SmartPad > Rst

Exit Program Green  Ctrl  Light Blue  BKSP File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  Light Blue  4

Homekey Not Supported Display > SmartPad > Hm

Insert Ctrl  Orange  5 Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  Light Blue  7 Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen Green  Ctrl  Light Blue  8

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Green  Down Arrow Scroll Bars

Window Left Ctrl  Green Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle Green  Ctrl  Light Blue  Up Arrow File > Settings > Display > Hide OIA

SYS_REQ Ctrl  Orange  Up Arrow Display > SmartPad > Srq

PA1 - PA3 Ctrl  1-3 Display > SmartPad > Pa1 - Pa3

F1 - F10 Green  1 - 0 KeyBar

F11 - F20 SHIFT  Green  1 - 0 KeyBar

F21 - F24 SHIFT  Green  Light Blue  1 - 4 KeyBar
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HX2 Triple Tap Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  Light Blue  2 Display > SmartPad > Attn

Backtab Green  TAB Display > SmartPad > BTb

Clear Ctrl  Light Blue  2  2  2 Display > SmartPad > Clr

Delete Ctrl  Light Blue  3 Display > SmartPad > Del

Erase BKSP Display > SmartPad > Bsp

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset Ctrl  Light Blue  7  7  7 Display > SmartPad > Rst

Exit Program Green  Ctrl  Light Blue  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  Light Blue  4  4

Homekey Not Supported Display > SmartPad > Hm

Insert Ctrl  Light Blue  4  4  4 Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  Light Blue  6  6 Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen Green  Ctrl  Light Blue  7

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Green  Down Arrow Scroll Bars

Window Left Ctrl  Green  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle Green  Ctrl  Light Blue  8 File > Settings > Display > Hide OIA

SYS_REQ Ctrl  Light Blue  7  7  7  7 Display > SmartPad > Srq

PA1 - PA3 Ctrl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F10 Green  1 - 0 KeyBar

F11 - F20 SHIFT  Green  1 - 0 KeyBar

F21 - F24 SHIFT  Green  Light Blue  1 - 4 KeyBar
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HX2 Alpha  Mode 3 Tap Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in the IBM 3270 Functions - Virtual Keys (page 9-9) table.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

If using an HX2 with the Alpha Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad 
(page 9-54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Not Defined Display > SmartPad > Attn

Backtab Blue  Left Arrow Display > SmartPad > BTb

Clear Not Defined Display > SmartPad > Clr

Delete Not Defined Display > SmartPad > Del

Erase Bksp Display > SmartPad > Bsp

Erase Input Not Defined Display > SmartPad > EIn

Error Reset or Reset Not Defined Display > SmartPad > Rst

Exit Program Blue  Bksp File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Help Not Defined

Homekey Not Defined Display > SmartPad > Hm

Insert Not Defined Display > SmartPad > Ins

LDUB Not Supported

New Line Key Not Defined Display > SmartPad > Nl

Next or Tab Blue  Right Arrow Display > SmartPad > Tb

Print Screen Not Defined

RDUB Not Supported

SW Rev Not Defined File > About

Window Down Not Defined Scroll Bars

Window Right Not Defined Scroll Bars

Window Left Not Defined Scroll Bars

Window Up Not Defined Scroll Bars

Status Line Toggle Not Defined File > Settings > Display > Hide OIA

SYS_REQ Not Defined Display > SmartPad > Srq

PA1 - PA3 Not Defined Display > SmartPad > Pa1 - Pa3

F1 - F4 F1-F4 KeyBar

F5 - F8 Blue  F1 - F4 KeyBar

F9 Not Defined KeyBar

F10 Blue  0 KeyBar

F11 - F19 Not Supported KeyBar

F20 - F24 Not Defined KeyBar

!
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IBM 5250 Functions - HX2
When running the RFTerm IBM 5250 terminal emulator on HX2 devices refer to the 5250 Host Key Descriptions (page 8-1) 
for explanations of the IBM 5250 functions.

HX2 Dual Alpha  Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  Orange  1 Display > SmartPad > Attn

Backtab Green  TAB Display > SmartPad > BTb

Char Backspace BKSP Display > SmartPad > BSp

Clear Ctrl  Orange  2 Display > SmartPad > Clr

Delete Ctrl  Light Blue  2 Display > SmartPad > Del

Dup Ctrl  Orange  0 Display > SmartPad > Dup

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset ESC Display > SmartPad > Rst

Exit Program Green  Ctrl  Light Blue  BKSP File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit Ctrl  Enter Display > SmartPad > FEx

Field Minus Ctrl  Orange  7 Display > SmartPad > F-

Field Plus Ctrl  Light Blue  6 Display > SmartPad > F+

Help Ctrl  Light Blue  4

Homekey Not Supported Display > SmartPad > Hm

Insert Ctrl  Orange  5 Display > SmartPad > Ins

New Line Key Ctrl  Light Blue  7 Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen Green Ctrl  Light Blue  8 Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Green  Down Arrow Scroll Bars

Window Left Ctrl  Green  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle Green Ctrl  Light Blue  Up Arrow File > Settings > Display > Hide OIA

Sys_Req Ctrl  Orange Up Arrow Display > SmartPad > Srq

F1 - F10 Green  1 - 0 KeyBar

F11 - F20 SHIFT  Green  1 - 0 KeyBar

F21 - F24 SHIFT  Green  Light Blue  1 - 4 KeyBar
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HX2 Triple Tap Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  Light Blue  2 Display > SmartPad > Attn

Backtab Green  TAB Display > SmartPad > BTb

Char Backspace BKSP Display > SmartPad > BSp

Clear Ctrl  Light Blue  2  2  2 Display > SmartPad > Clr

Delete Ctrl  Light Blue  3 Display > SmartPad > Del

Dup Ctrl  Light Blue  8  8 Display > SmartPad > Dup

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset ESC Display > SmartPad > Rst

Exit Program Green  Ctrl  Light Blue  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit Ctrl  Enter Display > SmartPad > FEx

Field Minus Ctrl  Light Blue  6 Display > SmartPad > F-

Field Plus Ctrl  Light Blue  5  5  5 Display > SmartPad > F+

Help Ctrl  Light Blue  4  4

Homekey Not Supported Display > SmartPad > Hm

Insert Ctrl  Light Blue  4  4  4 Display > SmartPad > Ins

New Line Key Ctrl  Light Blue  6  6 Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen Green  Ctrl  Light Blue  7 Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Green  Down Arrow Scroll Bars

Window Left Ctrl  Green  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle Green  Ctrl  Light Blue  8 File > Settings > Display > Hide OIA

Sys_Req Ctrl  Light Blue  7  7  7  7 Display > SmartPad > Srq

F1 - F10 Green  1 - 0 KeyBar

F11 - F20 SHIFT  Green  1 - 0 KeyBar

F21 - F24 SHIFT  Green  Light Blue  1-4 KeyBar
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HX2 Alpha  Mode 3 Tap Keypad
The notation Not Defined in the following table indicates that no key combination provides this function in the default 
key map.  To obtain this function, some key (or combination of keys) must be remapped to provide key combination 
specified earlier in the IBM 5250 Functions - Virtual Keys (page 9-10) table.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

If using an HX2 with the Alpha Mode 3 Tap keypad, review the Important Note for Alpha Mode 3 Tap Keypad 
(page 9-54).  It contains important information on the function of keys F11 through F19 on this HX2 keypad.

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Not Defined Display > SmartPad > Attn

Backtab Blue  Left Arrow Display > SmartPad > BTb

Char Backspace Bksp Display > SmartPad > BSp

Clear Not Defined Display > SmartPad > Clr

Delete Not Defined Display > SmartPad > Del

Dup Not Defined Display > SmartPad > Dup

Erase Input Not Defined Display > SmartPad > EIn

Error Reset or Reset Not Defined Display > SmartPad > Rst

Exit Program Blue  Bksp File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit Blue  Enter Display > SmartPad > FEx

Field Minus Not Defined Display > SmartPad > F-

Field Plus Not Defined Display > SmartPad > F+

Help Not Defined

Homekey Not Defined Display > SmartPad > Hm

Insert Not Defined Display > SmartPad > Ins

New Line Key Not Defined Display > SmartPad > Nl

Next or Tab Blue  Right Arrow Display > SmartPad > Tb

Print Screen Not Defined Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Not Defined Scroll Bars

Window Right Not Defined Scroll Bars

Window Left Not Defined Scroll Bars

Window Up Not Defined Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle Not Defined File > Settings > Display > Hide OIA

Sys_Req Not Defined Display > SmartPad > Srq

F1 - F4 F1 - F4 KeyBar

F5 - F8 Blue  F1 - F4 KeyBar

F9 Not Defined KeyBar

F10 Blue  0 KeyBar

F11 - F19 Not Supported KeyBar

F20 - F24 Not Defined KeyBar

!
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MX3Plus, MX3X, VX3Plus and VX3X Key Maps

The MX3Plus keypad is shown above.  The MX3X keypad is similar except there is an “MX3X” logo above the F9 and F10 keys.

The VX3Plus keypad is shown above.  The VX3X keypad is similar except there is a “VX3X” logo above the F9 and F10 keys.

Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

When using a sequence of keys that includes the 2nd key, press the 2nd key first then the rest of the key sequence.  Set the On/
Off condition of NumLock before pressing a key sequence.  There is no visual indication of the condition of NumLock.  

Note: When the computer boots, the default condition of NumLock is On.

Note: When the computer boots, the default condition of Caps (or CapsLock) is Off.  The Caps (or CapsLock) condition can be 
toggled with a 2nd - F1 key sequence.  The CAPS LED is illuminated when CapsLock is On.
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/ - +
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[ ] >
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2nd ALT CTRL SHFT CAPS STAT
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RFTerm Functions - MX3Plus / MX3X / VX3Plus / VX3X

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  Shft  C Session > Connect

Disconnect from Host Ctrl  Shft  D Session > Disconnect

Hide / Display All Bars Ctrl  Shft  L File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctrl  Shft  M File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Ctrl  Shft  T File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  Shft  K File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top Ctrl  Shft  B File > Settings > Display > At Bottom

Configure Host Session Ctrl  Shft  N Session > Configure

Application Settings Ctrl  Shft  E File > Settings

Increase Font Size Ctrl  Shft  Up Arrow Display > Font Up

Decrease Font Size Ctrl  Shft  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  Shft  1 Session > Configure > Font Tab

Display/Hide SmartPad Ctrl  Shft  P Display > SmartPad

Display / Hide Text Input Ctrl  Shft  I Display > InputTool

Help Ctrl  H

Scroll Up One Row Shft  Up Arrow Scroll Bars

Scroll Down One Row Shft  Down Arrow Scroll Bars

Scroll Left One Row Shft  Left Arrow Scroll Bars

Scroll Right One Row Shft  Right Arrow Scroll Bars

Exit the Emulator
Ctrl  Shft  X

File > Exit
Alt  X
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ANSI Functions - MX3Plus / MX3X / VX3Plus / VX3X
When running the RFTerm ANSI on these devices refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BkSp Display > SmartPad > BSp

Delete 2nd  . (period) Display > SmartPad > DEL

Exit Program
Alt  X

File > Exit
Shft Ctrl  X

Help Ctrl  H

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F30 Shft  F1 - F10 KeyBar

F31 - F40 Ctrl  F1 - F10 KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Ctrl  Alt  P
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IBM 3270 Functions - MX3Plus / MX3X / VX3Plus / VX3X
When running the RFTerm IBM 3270 terminal emulator on these devices refer to the 3270 Host Key Descriptions (page 7-
1) for explanations of the IBM 3270 functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab 2nd  Tab Display > SmartPad > BTb

Clear Ctrl  C Display > SmartPad > Clr

Delete Ctrl  D Display > SmartPad > Del

Erase BkSp Display > SmartPad > Bsp

Erase Input Ctrl  BkSp Display > SmartPad > EIn

Error Reset or Reset Ctrl  R Display > SmartPad > Rst

Exit Program
Alt  X 

File > Exit
Shft Ctrl  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  H

Homekey Ctrl  Left Arrow Display > SmartPad > Hm

Insert Ctrl  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  P

RDUB Not Supported

SW Rev Alt  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Shft  Ctrl  O

SYS_REQ Ctrl  S Display > SmartPad > Srq

PA1 - PA3 Ctrl  F1 - F3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F24 Shft  F1 - F4 KeyBar
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IBM 5250 Functions - MX3Plus / MX3X / VX3Plus / VX3X
When running the RFTerm IBM 5250 terminal emulator on these devices refer to the 5250 Host Key Descriptions (page 8-
1) for explanations of the IBM 5250 functions.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  A Display > SmartPad > Attn

Backtab 2nd  Tab Display > SmartPad > BTb

Char Backspace BkSp Display > SmartPad > BSp

Clear Ctrl  C Display > SmartPad > Clr

Delete Ctrl  D Display > SmartPad > Del

Dup Ctrl  U Display > SmartPad > Dup

Erase Input Ctrl  BkSp Display > SmartPad > EIn

Error Reset or Reset Esc Display > SmartPad > Rst

Exit Program
Alt  X

File > Exit
Ctrl  Shft  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctrl  Enter

Display > SmartPad > FEx
2nd  Enter 

Field Minus Ctrl  M Display > SmartPad > F-

Field Plus Ctrl  L Display > SmartPad > F+

Help Ctrl  H

Homekey 2nd  Home Display > SmartPad > Hm

Insert Ctrl  I Display > SmartPad > Ins

New Line Key Ctrl  N Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  P Display > SmartPad > Prt

SW REV Alt  F  B File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Right Arrow Scroll Bars

Window Left Ctrl  Left Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  T

File > Settings > Display > Hide OIA
Ctrl  Shft  O

Sys_Req Ctrl  S Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Alt  F1 - F10 KeyBar

F21 - F24 Shft  F1 - F4 KeyBar
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MX8 Key Maps

Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Unless otherwise noted, key maps in this section are valid for the MX8 with either a Microsoft Windows CE 5.0 or Windows 
Mobile 6.1 operating system.

When using a sequence of keys that includes the Orange or Blue keys, press the color key first then the rest of the key 
sequence unless otherwise noted in the tables.  Ctrl, Alt, Shft, Blue and Orange keys are “sticky keys”.  They do not need to be 
held down before pressing the next (or desired) key.  It is valid to use combined modifiers on specific keys.

Alphabetic keys default to lower case letters.  Press the Shft key, then the alphabetic key for an uppercase letter.

Note: When the computer boots, the default condition of Caps (or CapsLock) is Off.  The Caps (or CapsLock) condition can be 
toggled with Blue plus Tab key sequence.

Triple Tap Keypad Alpha  Mode Keypad
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00

Enter

Ctrl DelAlph

Spc

F3 F4

F2 F5

F1 1

2 3

22

55

88

00

Enter

Alph

Shft

33

66

99

Del

Spc

1

Alt

Tab

11

44

77

Ctrl

2 3

F1

F2

F3

F5

F4
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RFTerm Functions - MX8
MX8 Triple Tap Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Alph  Ctrl  Shft  2  2  2 Session > Connect

Disconnect from Host Alph  Ctrl  Shft  3 Session > Disconnect

Hide / Display All Bars Alph  Ctrl  Shft  5  5  5 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Alph  Ctrl  Shft  6 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Alph  Ctrl  Shft  8 File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Alph  Ctrl  Shft  5  5 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Mobile)

Alph  Ctrl  Shft  2  2 File > Settings > Display > At Bottom

Configure Host Session Alph  Ctrl  Shft  6  6 Session > Configure

Application Settings Alph  Ctrl  Shft  3  3 File > Settings

Increase Font Size Ctrl  Shft  Up Arrow Display > Font Up

Decrease Font Size Ctrl  Shft  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  Shft  1 Session > Configure > Font Tab

Display/Hide SmartPad Alph  Ctrl  Shft  7 Display > SmartPad

Display / Hide Text Input Alph  Ctrl  Shft  4  4  4 Display > InputTool

Help Alph  Ctrl  4  4

Scroll Up One Row Shft  Up Arrow Scroll Bars

Scroll Down One Row Shft  Down Arrow Scroll Bars

Scroll Left One Row Shft  Blue  Down Arrow Scroll Bars

Scroll Right One Row Shft  Blue  Up Arrow Scroll Bars

Exit the Emulator Alph  Alt  9  9 File > Exit
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MX8 Alpha  Mode Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host Ctrl  Shft  Alph  F2 Session > Connect

Disconnect from Host Ctrl  Shft  Alph  F5 Session > Disconnect

Hide / Display All Bars Ctrl  Shft  Alph  2 File > Settings > Display > Hide All Bars

Hide / Display MenuBar Ctrl  Shft  Alph  3 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar Ctrl  Shft  Alph  Alt File > Settings > Display > Hide ToolBar

Hide / Display KeyBar Ctrl  Shft  Alph  1 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Mobile)

Ctrl  Shft  Alph  F4 File > Settings > Display > At Bottom

Configure Host Session Ctrl  Shft  Alph  4 Session > Configure

Application Settings Ctrl  Shft  Alph  F1 File > Settings

Increase Font Size Ctrl  Shft  Up Arrow Display > Font Up

Decrease Font Size Ctrl  Shft  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  Shft  1 Session > Configure > Font Tab

Display/Hide SmartPad Ctrl  Shft  Alph  6 Display > SmartPad

Display / Hide Text Input Ctrl  Shft  Alph  Tab Display > InputTool

Help Ctrl  Alph  Up Arrow

Scroll Up One Row Shft  Up Arrow Scroll Bars

Scroll Down One Row Shft  Down Arrow Scroll Bars

Scroll Left One Row Shft  Blue  Down Arrow Scroll Bars

Scroll Right One Row Shft  Blue  Up Arrow Scroll Bars

Exit the Emulator
Alt  Alph  Del

File > Exit
Ctrl  Shft  Alph  Del
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ANSI Functions - MX8
When running the RFTerm ANSI on the MX8 refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

Note: Physical keypad key presses and MX8 virtual keypad presses are the same.

Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

MX8 Triple Tap Keypad

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Orange  Spc Display > SmartPad > BSp

Delete Del Display > SmartPad > DEL

Exit Program Alph  Alt  9  9 File > Exit

Help Alph  Ctrl  4  4

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft F1 - F5 KeyBar

F21 - F24 Ctrl  Orange F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Alph  Ctrl  Alt  7
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MX8 Alpha  Mode Keypad

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace Orange  Spc Display > SmartPad > BSp

Delete Del Display > SmartPad > DEL

Exit Program
Alt  Alph  Del

File > Exit
Ctrl  Shft  Alph  Del

Help Ctrl  Alph  Up Arrow

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15
Blue  1 - 5

KeyBar
Blue  F1 - F5

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Ctrl  Orange  F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send Enter Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen Ctrl  Alt  Alph  6
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IBM 3270 Functions - MX8
When running the RFTerm IBM 3270 terminal emulator on the MX8 refer to the 3270 Host Key Descriptions (page 7-1) for 
explanations of the IBM 3270 functions.

MX8 Triple Tap Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Alph  Ctrl  2 Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Clear Alph  Ctrl  2  2  2 Display > SmartPad > Clr

Delete Alph  Ctrl  3 Display > SmartPad > Del

Erase Orange  Space Display > SmartPad > Bsp

Erase Input Ctrl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Alph  Ctrl  7  7  7 Display > SmartPad > Rst

Exit Program Alph  Alt  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Help Alph  Ctrl  4  4

Homekey Not Supported Display > SmartPad > Hm

Insert Alph  Ctrl  4  4  4 Display > SmartPad > Ins

LDUB Not Supported

New Line Key Alph  Ctrl  6  6 Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Alph  Ctrl  Alt  7

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle Alph  Alt  8 File > Settings > Display > Hide OIA

SYS_REQ Alph  Ctrl  7  7  7  7 Display > SmartPad > Srq

PA1 - PA3 Ctrl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1- F5 KeyBar

F11 - F21 Blue  F1 - F5 KeyBar

F16 - F20 Shft F1 - F5 KeyBar

F21 - F24 Ctrl  Orange  F1 - F4 KeyBar
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MX8 Alpha  Mode Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  Alph  F3 Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Clear Ctrl  Alph  F2 Display > SmartPad > Clr

Delete Ctrl  Alph  F5 Display > SmartPad > Del

Erase Orange  Spc Display > SmartPad > Bsp

Erase Input Ctrl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Ctrl  Alph  8 Display > SmartPad > Rst

Exit Program
Alt  Alph  Del

File > Exit
Ctrl  Shft  Alph  Del

Function Key Editor Not Supported Session > Configure > FNKeys

Help Ctrl  Alph  Up Arrow

Homekey Not Supported Display > SmartPad > Hm

Insert Ctrl  Alph  Tab Display > SmartPad > Ins

LDUB Not Supported

New Line Key Ctrl  Alph  4 Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  Alph  6

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle
Alt  Alph  Alt

File > Settings > Display > Hide OIA
Ctrl  Shft  Alph  5

SYS_REQ Ctrl  Alph  9 Display > SmartPad > Srq

PA1 - PA3 Ctrl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1- F5 KeyBar

F11 - F21
Blue  1 - 5

KeyBar
Blue  F1 - F5

F16 - F20 Shft F1 - F5 KeyBar

F21 - F24 Ctrl  Orange  F1 - F4 KeyBar
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IBM 5250 Functions - MX8
When running the RFTerm IBM 5250 terminal emulator on MX8 devices refer to the 5250 Host Key Descriptions (page 8-1) 
for explanations of the IBM 5250 functions.

MX8 Triple Tap Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Alph  Ctrl  2 Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Char Backspace Orange  Spc Display > SmartPad > BSp

Clear Alph  Ctl  2  2  2 Display > SmartPad > Clr

Delete Alph  Ctl  3 Display > SmartPad > Del

Dup Alph  Ctl  8  8 Display > SmartPad > Dup

Erase Input Orange  Ctl  Spc Display > SmartPad > EIn

Error Reset or Reset Blue  Alt Display > SmartPad > Rst

Exit Program Alph  Alt  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit
Ctl  Enter

Display > SmartPad > FEx
Diamond 1

Field Minus Alph  Ctl  6 Display > SmartPad > F-

Field Plus Alph  Ctl  5  5  5 Display > SmartPad > F+

Help Alph  Ctl  4  4

Homekey Not Supported Display > SmartPad > Hm

Insert Alph  Ctl  4  4  4 Display > SmartPad > Ins

New Line Key Alph  Ctl  6  6 Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Alph  Alt  8 Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctl  Down Arrow Scroll Bars

Window Right Ctl  Blue  Down Arrow Scroll Bars

Window Left Ctl  Blue  Up Arrow Scroll Bars

Window Up Ctl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle Alph  Alt  8 File > Settings > Display > Hide OIA

Sys_Req Alph  Ctl  7  7  7  7 Display > SmartPad > Srq

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15 Blue  F1 - F5 KeyBar

F16 - F20 Shft F1 - F5 KeyBar

F21 - F24 Orange  Ctl  F1 - F4 KeyBar
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MX8 Alpha  Mode Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn Ctrl  Alph  F3 Display > SmartPad > Attn

Backtab Orange  Tab Display > SmartPad > BTb

Char Backspace Orange  Spc Display > SmartPad > BSp

Clear Ctrl  Alph  F2 Display > SmartPad > Clr

Delete Ctrl  Alph  F5 Display > SmartPad > Del

Dup Ctrl  Alph  0 Display > SmartPad > Dup

Erase Input Ctrl  Orange  Spc Display > SmartPad > EIn

Error Reset or Reset Orange  Alt Display > SmartPad > Rst

Exit Program
Alt  Alph  Del

File > Exit
Ctrl  Shft  Alph  Del

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit Ctrl  Enter Display > SmartPad > FEx

Field Minus Ctrl  Alph  3 Display > SmartPad > F-

Field Plus Ctrl  Alph  2 Display > SmartPad > F+

Help Ctrl  Alph  Up Arrow

Homekey Not Supported Display > SmartPad > Hm

Insert Ctrl  Alph  Tab Display > SmartPad > Ins

New Line Key Ctrl  Alph  4 Display > SmartPad > Nl

Next or Tab Tab Display > SmartPad > Tb

Print Screen Ctrl  Alt  Alph  6 Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv Enter Display > SmartPad > Ent

Status Line Toggle
Alt  Alph  Alt

File > Settings > Display > Hide OIA
Ctrl  Shft Alph  5

Sys_Req Ctrl  Alph  9 Display > SmartPad > Srq

F1 - F5 F1 - F5 KeyBar

F6 - F10 Orange  F1 - F5 KeyBar

F11 - F15
Blue  1 - 5

KeyBar
Blue  F1 - F5

F16 - F20 Shft  F1 - F5 KeyBar

F21 - F24 Orange  Ctl  F1 - F4 KeyBar
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MX9 Key Maps

Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Unless otherwise noted, key maps in this section are valid for the MX9 with either a Microsoft Windows CE 5.0 or Windows 
Mobile 6.5 operating system.

When using a sequence of keys that includes the Orange or Blue keys, press the color key first then the rest of the key 
sequence unless otherwise noted in the tables.  Ctrl, Alt, Shift, Blue and Orange keys are “sticky keys”.  They do not need to 
be held down before pressing the next (or desired) key.  It is valid to use combined modifiers on specific keys.

Alphabetic keys default to lower case letters.  Press the Shift  key, then the alphabetic key for an uppercase letter.

Note: When the computer boots, the default condition of Caps (or CapsLock) is Off.  The Caps (or CapsLock) condition can be 
toggled with Blue plus Tab key sequence.

38-key Keypad 62-key Keypad
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F4 F5

F6 F8 F9 F10

F3

ENTER

1 2 3
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RFTerm Functions - MX9
MX9 38-Key Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host ALPHA  Ctrl  SHIFT  2  2  2 Session > Connect

Disconnect from Host ALPHA  Ctrl  SHIFT  3 Session > Disconnect

Hide / Display All Bars ALPHA  Ctrl  SHIFT  5  5  5 File > Settings > Display > Hide All Bars

Hide / Display MenuBar ALPHA  Ctrl  SHIFT  6 File > Settings > Display > Hide MenuBar

Hide / Display ToolBar ALPHA  Ctrl  SHIFT  8 File > Settings > Display > Hide ToolBar

Hide / Display KeyBar ALPHA  Ctrl  SHIFT  5  5 File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Mobile)

ALPHA  Ctrl  SHIFT  2  2 File > Settings > Display > At Bottom

Configure Host Session ALPHA  Ctrl  SHIFT  6  6 Session > Configure

Application Settings ALPHA  Ctrl  SHIFT  3  3 File > Settings

Increase Font Size Ctrl  SHIFT  Up Arrow Display > Font Up

Decrease Font Size Ctrl  SHIFT  Down Arrow Display > Font Down

Toggle Font Bold / Normal Ctrl  SHIFT  1 Session > Configure > Font Tab

Display/Hide SmartPad ALPHA  Ctrl  SHIFT  7 Display > SmartPad

Display / Hide Text Input ALPHA  Ctrl  SHIFT  4  4  4 Display > InputTool

Help ALPHA  Ctrl  4  4

Scroll Up One Row SHIFT  Up Arrow Scroll Bars

Scroll Down One Row SHIFT  Down Arrow Scroll Bars

Scroll Left One Row SHIFT  Blue  Down Arrow Scroll Bars

Scroll Right One Row SHIFT  Blue  Up Arrow Scroll Bars

Exit the Emulator ALPHA  ALT  9  9 File > Exit
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MX9 62-Key Keypad

RFTerm Function Press these keys in this order RFTerm GUI Equivalent

Connect to Host CTL  SHFT  C Session > Connect

Disconnect from Host CTL  SHFT  D Session > Disconnect

Hide / Display All Bars CTL  SHFT  L File > Settings > Display > Hide All Bars

Hide / Display MenuBar CTL  SHFT  M File > Settings > Display > Hide MenuBar

Hide / Display ToolBar CTL  SHFT  T File > Settings > Display > Hide ToolBar

Hide / Display KeyBar CTL  SHFT  K File > Settings > Display > Hide KeyBar

Toggle MenuBar Bottom / Top
(N/A with Windows Mobile)

CTL  SHFT  B File > Settings > Display > At Bottom

Configure Host Session CTL  SHFT  N Session > Configure

Application Settings CTL  SHFT  E File > Settings

Increase Font Size CTL  SHFT  Up Arrow Display > Font Up

Decrease Font Size CTL  SHFT  Down Arrow Display > Font Down

Toggle Font Bold / Normal CTL  SHFT  1 Session > Configure > Font Tab

Display/Hide SmartPad CTL  SHFT  P Display > SmartPad

Display / Hide Text Input CTL  SHFT  I Display > InputTool

Help CTL  H

Scroll Up One Row SHFT  Up Arrow Scroll Bars

Scroll Down One Row SHFT  Down Arrow Scroll Bars

Scroll Left One Row SHFT  Blue  Down Arrow Scroll Bars

Scroll Right One Row SHFT  Blue  Up Arrow Scroll Bars

Exit the Emulator
ALT  X

File > Exit
CTL  SHFT  X
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ANSI Functions - MX9
When running the RFTerm ANSI on the MX9 refer to the VT Host Key Descriptions (page 5-72) for explanations of the 
ANSI key functions.

Note: Physical keypad key presses and MX9 virtual keypad presses are the same.

MX9 38-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BKSP Display > SmartPad > BSp

Delete
Orange  BKSP

Display > SmartPad > DEL
Ctrl  D

Exit Program ALPHA  ALT  9  9 File > Exit

Help ALPHA  Ctrl  4  4

F1 - F10 F1 - F10 KeyBar

F11 - F20 Blue  F1 - F10 KeyBar

F21 - F24 SHIFT  F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send ENTER Display > SmartPad > Ent

Window Down Ctrl  Down Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Print Screen ALPHA  Ctrl  Alt  7
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MX9 62-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

ANSI Function Press these keys in this order RFTerm GUI Equivalent

Answerback Not Supported Display > SmartPad > Ans

Backspace BS Display > SmartPad > BSp

Delete
Orange  BS

Display > SmartPad > DEL
CTL  D

Exit Program
ALT  X

File > Exit
CTL  SHFT  X

Help CTL  H

F1 - F10 F1 - F10 KeyBar

F11 - F20 Blue  F1 - F10 KeyBar

F21 - F24 SHFT  F1 - F4 KeyBar

F25 - F40 Not Supported KeyBar

Function Key Editor Not Supported Session > Configure > FNKeys

Send ENTER Display > SmartPad > Ent

Window Down CTL  Down Arrow Scroll Bars

Window Left CTL  Blue  Down Arrow Scroll Bars

Window Right CTL  Blue  Up Arrow Scroll Bars

Window Up CTL  Up Arrow Scroll Bars

Print Screen CTL  ALT  P
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IBM 3270 Functions - MX9
When running the RFTerm IBM 3270 terminal emulator on the MX9 refer to the 3270 Host Key Descriptions (page 7-1) for 
explanations of the IBM 3270 functions.

MX9 38-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn ALPHA  Ctrl  2 Display > SmartPad > Attn

Backtab
Orange  TAB

Display > SmartPad > BTb
SHIFT  TAB

Clear ALPHA  Ctrl  2  2  2 Display > SmartPad > Clr

Delete
ALPHA  Ctrl  3

Display > SmartPad > Del
Orange  BKSP

Erase BKSP Display > SmartPad > Bsp

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset ALPHA  Ctrl  7  7  7 Display > SmartPad > Rst

Exit Program ALPHA  ALT  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Help ALPHA  Ctrl  4  4

Homekey Orange  SHIFT  Down Arrow Display > SmartPad > Hm

Insert ALPHA  Ctrl  4  4  4 Display > SmartPad > Ins

LDUB Not Supported

New Line Key ALPHA  Ctrl  6  6 Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen ALPHA  Ctrl  ALT  7

RDUB Not Supported

SW Rev Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Up Arrow Scroll Bars

Window Left Ctrl  Blue  Down Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Status Line Toggle ALPHA  ALT  8 File > Settings > Display > Hide OIA

SYS_REQ ALPHA  Ctrl  7  7  7  7 Display > SmartPad > Srq

PA1 - PA3 Ctrl  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Blue  F1 - F10 KeyBar

F21 - F24 SHIFT  F1 - F4 KeyBar
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MX9 62-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

3270 Function Press these keys in this order RFTerm GUI Equivalent

Attn CTL  A Display > SmartPad > Attn

Backtab
Orange  TAB

Display > SmartPad > BTb
SHFT  TAB

Clear CTL  C Display > SmartPad > Clr

Delete
CTL  D

Display > SmartPad > Del
Orange  BS

Erase BS Display > SmartPad > Bsp

Erase Input CTL  BS Display > SmartPad > EIn

Error Reset or Reset CTL  R Display > SmartPad > Rst

Exit Program
ALT  X

File > Exit
CTL  SHFT  X

Function Key Editor Not Supported Session > Configure > FNKeys

Help CTL  H

Homekey Orange  SHFT  Down Arrow Display > SmartPad > Hm

Insert CTL  I Display > SmartPad > Ins

LDUB Not Supported

New Line Key CTL  N Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen CTL  ALT  P

RDUB Not Supported

SW Rev Not Supported File > About

Window Down CTL  Down Arrow Scroll Bars

Window Right CTL  Blue  Up Arrow Scroll Bars

Window Left CTL  Blue  Down Arrow Scroll Bars

Window Up CTL  Up Arrow Scroll Bars

Status Line Toggle
ALT  T

File > Settings > Display > Hide OIA
CTL  SHFT  O

SYS_REQ CTL  S Display > SmartPad > Srq

PA1 - PA3 CTL  1 - 3 Display > SmartPad > Pa1 - Pa3

F1 - F10 F1 - F10 KeyBar

F11 - F20 Blue  F1 - F10 KeyBar

F21 - F24 SHFT  F1 - F4 KeyBar
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IBM 5250 Functions - MX9
When running the RFTerm IBM 5250 terminal emulator on MX9 devices refer to the 5250 Host Key Descriptions (page 8-1) 
for explanations of the IBM 5250 functions.

MX9 38-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn ALPHA  Ctrl  2 Display > SmartPad > Attn

Backtab
Orange  Tab

Display > SmartPad > BTb
SHIFT  Tab

Char Backspace BKSP Display > SmartPad > BSp

Clear ALPHA  Ctrl  2  2  2 Display > SmartPad > Clr

Delete
ALPHA  Ctrl  3

Display > SmartPad > Del
Orange  BKSP

Dup ALPHA  Ctrl  8  8 Display > SmartPad > Dup

Erase Input Ctrl  BKSP Display > SmartPad > EIn

Error Reset or Reset ESC Display > SmartPad > Rst

Exit Program ALPHA  ALT  9  9 File > Exit

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit Ctrl  ENTER Display > SmartPad > FEx

Field Minus ALPHA  Ctrl  6 Display > SmartPad > F-

Field Plus ALPHA  Ctrl  5  5  5 Display > SmartPad > F+

Help ALPHA  Ctrl  4  4

Homekey Orange  SHIFT  Down Arrow Display > SmartPad > Hm

Insert ALPHA  Ctrl  4  4  4 Display > SmartPad > Ins

New Line Key ALPHA  Ctrl  6  6 Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen ALPHA  Ctrl  ALT  8 Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down Ctrl  Down Arrow Scroll Bars

Window Right Ctrl  Blue  Down Arrow Scroll Bars

Window Left Ctrl  Blue  Up Arrow Scroll Bars

Window Up Ctrl  Up Arrow Scroll Bars

Send or Entercatv ENTER Display > SmartPad > Ent

Status Line Toggle ALPHA  ALT  8 File > Settings > Display > Hide OIA

Sys_Req ALPHA  Ctrl  7  7  7  7 Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Blue  F1 - F10 KeyBar

F21 - F24 SHIFT  F1 - F4 KeyBar
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MX9 62-Key Keypad
Alternative keypresses may be defined for F1 through F40.  Refer to Optional F1 - F40 Key Maps (page 9-11).

5250 Function Press these keys in this order RFTerm GUI Equivalent

Attn CTL  A Display > SmartPad > Attn

Backtab
SHFT  Tab

Display > SmartPad > BTb
Orange  Tab

Char Backspace BS Display > SmartPad > BSp

Clear CTL  C Display > SmartPad > Clr

Delete
CTL  D

Display > SmartPad > Del
Orange  BS

Dup CTL  U Display > SmartPad > Dup

Erase Input CTL  BS Display > SmartPad > EIn

Error Reset or Reset ESC Display > SmartPad > Rst

Exit Program
ALT  X

File > Exit
CTL  SHFT  X

Function Key Editor Not Supported Session > Configure > FNKeys

Fastback Not Supported

Fastfwd Not Supported

Field Exit CTL  ENTER Display > SmartPad > FEx

Field Minus CTL  M Display > SmartPad > F-

Field Plus CTL  L Display > SmartPad > F+

Help CTL  H

Homekey Orange  SHFT X Display > SmartPad > Hm

Insert CTL  I Display > SmartPad > Ins

New Line Key CTL  N Display > SmartPad > Nl

Next or Tab TAB Display > SmartPad > Tb

Print Screen CTL  ALT  P Display > SmartPad > Prt

SW REV Not Supported File > About

Window Down CTL  Down Arrow Scroll Bars

Window Right CTL  Blue  Down Arrow Scroll Bars

Window Left CTL  Blue  Up Arrow Scroll Bars

Window Up CTL  Up Arrow Scroll Bars

Send or Entercatv ENTER Display > SmartPad > Ent

Status Line Toggle
ALT  T

File > Settings > Display > Hide OIA
CTL  SHFT  O

Sys_Req CTL  Blue  S Display > SmartPad > Srq

F1 - F10 F1 - F10 KeyBar

F11 - F20 Blue  F1 - F10 KeyBar

F21 - F24 SHFT  F1 - F4 KeyBar
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VX6 and VX7 Key Maps
Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

VX6 60-key Keyboard
The VX6 integrated keyboard functions the same as the external 60-key keyboard  See 60-Key Keyboard (page 9-44) for 
RFTerm keymaps for this keyboard.

VX7 External 60-Key Keyboard
The VX7 supports the external 60-key keyboard.  See 60-Key Keyboard (page 9-44) for RFTerm keymaps for this optional 
keyboard.

VX7 External 95-Key Keyboard
The VX7 supports the external 95-key keyboard.  See 95-Key Keyboard (page 9-40) for RFTerm keymaps for this optional 
keyboard.

Thor VX8 and Thor VX9 Key Maps
Note: All RFTerm shortcut keys are directly accessible through the RFTerm user interface.

Thor VX8 and Thor VX9 External 60-Key Keyboard
The Thor VX8 and Thor VX9 support the external 60-key keyboard.  See 60-Key Keyboard (page 9-44) for RFTerm key-
maps for this optional keyboard.

Thor VX8 and Thor VX9 External 95-Key Keyboard
The Thor VX8 and Thor VX9 support the external 60-key keyboard. See 95-Key Keyboard (page 9-40) for RFTerm key-
maps for this optional keyboard.
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10
Customer Support

Product Service and Repair
Honeywell International Inc. provides service for all of its products through service centers throughout the world.  To obtain war-
ranty or non-warranty service, please visit www.honeywellaidc.com and select Support > Contact Service and Repair to see 
your region’s instructions on how to obtain a Return Material Authorization number (RMA #).  You should do this prior to return-
ing the product.

Technical Assistance
If you need assistance installing or troubleshooting your device, please contact us by using one of the methods below:

Knowledge Base: www.hsmknowledgebase.com

Our Knowledge Base provides thousands of immediate solutions.  If the Knowledge Base cannot help, our Technical Support 
Portal (see below) provides an easy way to report your problem or ask your question.

Technical Support Portal: www.hsmsupportportal.com

The Technical Support Portal not only allows you to report your problem, but it also provides immediate solutions to your techni-
cal issues by searching our Knowledge Base.  With the Portal, you can submit and track your questions online and send and 
receive attachments.

Web form: www.hsmcontactsupport.com

You can contact our technical support team directly by filling out our online support form.  Enter your contact details and the 
description of the question/problem.

Telephone: www.honeywellaidc.com/locations

For our latest contact information, please check our website at the link above.

Limited Warranty
Refer to www.honeywellaidc.com/warranty_information for your product’s warranty information.

http://www.hsmknowledgebase.com/
http://www.hsmsupportportal.com/
http://www.honeywellaidc.com/
http://www.honeywellaidc.com/
http://www.hsmcontactsupport.com/
http://www.honeywellaidc.com/locations
http://www.honeywellaidc.com/warranty_information
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