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Customer Support 

Technical Assistance
To search our knowledge base for a solution or to log in to the Technical Support 
portal and report a problem, go to honeywell.com/PSStechnicalsupport.
Dolphin Power Tools 12.x User Guide ix

https://honeywell.com/PSStechnicalsupport


x Dolphin Power Tools 12.x User Guide



CHAPTER

1

Dolphin Power To
INTRODUCTION
Overview
Honeywell handheld computers include Power Tools apps and utilities you can use 
to perform standard system tasks and advanced computer customization and 
configuration. The apps and utilities included vary depending on the computer 
model, operating system (OS) and the Power Tools version installed. 
To see a brief summary about each software app, see page 2.

Honeywell also offers advanced EZConfig for Mobility software for your 
workstation computer (e.g., desktop or laptop). The advanced software package is 
used to export custom configuration XML files and generate barcodes when you 
need to update multiple Honeywell computers with the same configuration set. 
To learn how to download and install EZConfig for Mobility, see page 27.

About Graphic and Hardware References Included in this Guide
The screen captures and icons illustrated in this guide may differ from what 
appears on your handheld computer since variations occur depending on the 
computer hardware, OS, and software application versions. 

The following navigation commands can be found either on the computer touch 
screen or on the hardware buttons. The icons vary depending on the model and OS.

Access All Apps
To access the all apps screen from the Home screen on the computer, swipe up 
from the bottom of the screen.

Home Recent Search Back

Icons
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Software Requirements

Handheld Computers
Power Tools version 12.x is designed to work with Honeywell handheld computers 
powered by Android 12 or higher.

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools .

3. Touch Diagnostic Information .

4. Touch SysInfo. The version number is located under “Power Tools and Demos 
Info”.

Workstation Computers
The optional EZConfig for Mobility software suite is designed to work with the 
following Microsoft® operating systems: Microsoft Windows® XP, Microsoft 
Windows 2000, Microsoft Windows NT, Microsoft Windows Vista®, Microsoft 
Windows 7, Microsoft Windows 8, Microsoft Windows 10, and Microsoft.NET 
Framework 2.0.

How to Access the Power Tools
1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools .

3. Touch an app icon to open the tool.

About the Power Tools
Note: The tools provided may vary depending on your computer model, OS version, and 

Power Tools version.

Icon Description Page

BattMon provides information on the charge status and health of the 
battery, and provides access to activate battery status notifications and 
battery charging history logs.

75

ConfigApps enables or disables applications and application
updates.

79
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Exit the Power Tools
Touch Back or Home to exit Power Tools. For information on button locations, 
consult the user guide specific to your handheld computer model. Product guides 
are available for download from sps.honeywell.com.

About Software Updates
Cyber security best practices include keeping your device apps and OS up to date. 
To help, Honeywell offers maintenance patches, security updates and operating 
system upgrades through our Honeywell Edge services.

Availability and cost depend on the following:

• Date of purchase of the device or software app.

• Warranty status.

• Service agreement status (devices) or Maintenance plan status (apps).

To learn more about Honeywell Edge Services, go to https://sps.honeywell.com/
us/en/services/productivity/support-services.

o

Configure Autorun provides the ability to set applications to 
automatically run after a reboot. 

53

EZConfig supports advanced customization and configuration of the 
handheld computer. EZConfig includes a standard XML editor and 
configuration barcode scanner feature.

49

Diagnostic Information provides access to system statistics, 
notifications and version information about the computer.

76

Use Honeywell OBDQuickLink to write, erase, or update the NFC 
connection between a handheld computer and a vehicle dock. This app 
does not receive any data from the On-Board Diagnostics (OBD) system 
adapter.

73

The WiFi Diagnostic app provides a central location to view data about 
connected and available Wi-Fi network access points within range of the 
integrated WLAN radio in the handheld computer. The app includes a 
built-in Ping utility that can be used for troubleshooting and testing 
connections and an IPConfig utility that can be used to assign a static IP 
Address. 

70

WirelessTether provides the ability to enable range tracking and 
customized out-of-range alerts for Bluetooth devices paired and 
tethered to your handheld computer.

69

Icon Description Page
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About Provisioning Mode
Once you complete the out-of-box initial setup process, Provisioning mode is 
automatically turned Off (disabled) to improve device security against unwanted 
modifications to the system.

When Provisioning mode is turned off (disabled):

• Configuration barcodes do not scan and process.

• \honeywell\ folders are inaccessible.

Note: To learn more about network and security for Honeywell handheld computers with 
Android operating systems, see the Network and Security Guide available for 
download from honeywell.com/SPS-cyber-security.

Enable Provisioning Mode
1. Swipe up from the bottom of the Home screen to access all apps.

2. Tap Settings  > Provisioning mode under Honeywell Settings.

3. Tap the button to toggle Provisioning mode On.

Software Downloads
Product support is available online through Technical Support. Software updates 
can be accessed through the Software Downloads portal. You will need to create a 
login account for portal access. Additional information such as purchased date, 
service agreement number, maintenance plan number, or software license number 
may be required for downloads.

1. Go to honeywell.com/PSSsoftware-downloads.

2. Create a login account if you have not already created one.

3. Install the Honeywell Download Manager tool. See “Note” on the portal page. 
This tool is required for downloads.

4. Locate the app or upgrade you want to download in the Software directory.

5. If prompted, enter additional information, and click Submit. 

6. Select Download. Follow the prompts to download the file.

About Transferring Files via USB Connection
If you plan on using a USB connection to transfer the upgrade files to the handheld 
computer, make sure you set the USB connection to allow file transfers. To learn 
more, see the user guide for your handheld computer model.
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Install Software Updates with AutoInstall
Important: The handheld computer must have power for the entire length of the upgrade process 

or it could become unstable. Do not attempt to remove the battery during the process.

1. Swipe up from the bottom of the Home screen to access all apps.

2. Tap Settings  > Honeywell Settings > Provisioning mode.

3. Tap the toggle button to turn Provisioning mode On.

4. Save the upgrade file (*.zip or *.apk) in one of the following folders on the 
handheld computer:

• Internal shared storage\honeywell\autoinstall
Software upgrades saved to this folder for installation, do not persist when a 
Full factory reset or Enterprise data reset is performed. 

• IPSM card\honeywell\autoinstall
Files placed in this folder will be installed only after performing an Enterprise 
reset. Software upgrades saved to this folder do not persist when a Full 
factory reset is performed.

5. Swipe up from the bottom of the Home screen to access all apps.

Note: To manually install the upgrade using AutoInstall Settings, follow steps 6 to 8. You 
can also reboot the device, and AutoInstall will install the upgrade after the device 
boots up.

6. To manually install the upgrade, tap AutoInstall Settings  and verify 
Autoinstall is enabled .

7. Tap Packages Update from the AutoInstall Settings screen. 

The computer automatically initiates a reboot and installs the 
software upgrade. The system update screen appears during the upgrade pro-
cess. When the update is finished, the lock screen appears.

8. Once installation is complete, turn Provisioning mode Off.

Note: Some updates do not require the computer to reboot before installation. 

Optional microSD Card Method
The handheld computer comes equipped with a microSD card socket. You can 
install an upgrade from a microSD card you insert in the computer.

Upgrades from a microSD card will be installed following either an Enterprise reset 
or Factory reset.
Dolphin Power Tools 12.x User Guide 5



If files are placed in both IPSM/honeywell/autoinstall and micro sd/honeywell/
autoinstall, when an Enterprise reset is performed, the files in IPSM/honeywell/
autoinstall will take priority and get installed.

Important: The handheld computer must have power for the entire length of the upgrade process 
or it could become unstable. Do not attempt to remove the battery during the process.

1. On the handheld computer, swipe up from the bottom of the Home screen to 
access all apps.

2. Tap Settings  > Honeywell Settings > Provisioning mode.

3. Tap the toggle button to turn Provisioning mode On.

4. Tap AutoInstall Settings . Verify Autoinstall is enabled .

5. Press and hold the Power button, and then tap Power off.

6. On your workstation (e.g., laptop, desktop computer), format the microSD card 
and create a \honeywell\autoinstall folder on the root of the card. 

7. Save the upgrade file in the autoinstall folder. 

8. Install the microSD card in the computer, and then press the Power button. 

The computer automatically runs the upgrade found in the autoinstall folder on 
the card. The system update screen appears during the upgrade process. When 
the upgrade is finished, the lock screen appears.

9. Once installation is complete, turn Provisioning mode Off.

About the Honeywell Upgrader
Use the Honeywell Upgrader app (HUpgrader) to check for and install OTA updates 
and view the current OTA version installed on the computer. 

Install OTA Updates
To use the HUpgrader to install an Over-the-Air (OTA) update file downloaded from 
the Technical Support Downloads Portal:

1. On the handheld computer, swipe up from the bottom of the Home screen to 
access all apps.

2. Tap Settings  > Honeywell Settings > Provisioning mode.

3. Tap the toggle button to turn Provisioning mode On.

4. Save the OTA file (*.zip) in the following folder on the handheld computer:

• Internal shared storage\Download

5. Tap HUpgrader  to open the Honeywell Updater app.
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6. Tap , and then tap Select OTA from storage.

7. Select the storage location (i.e., Internal Storage) where you saved the file.

8. Tap the OTA update file. The computer examines the file, and then starts the 
installation.

9. Once the installation is complete (100%), select OK when prompted to Reboot 
the computer. The computer reboots and finishes the update.
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CHAPTER

2

Dolphin Power To
ABOUT FILE STORAGE ON THE 
COMPUTER
Overview
Honeywell handheld computers running Android 7 or higher utilize XML 
configuration files to define the default settings that persist after a simple Reboot 
(restart) or Enterprise data reset. The storage location and name of an XML file 
defines the parameters the computer uses for operations. You can copy and edit 
the files to change the default settings of the computer but you should never 
delete, rename or move an XML file from its native location. 

More Information
• To learn how to use the standard editor on the handheld computer to modify 

XML files, see page 23.

• To learn how to install and use the optional advanced EZConfig Editor,
see page 27.

• To see an example of how to Configure the Computer Using the Standard Editor, 
see page 16.

• To see an example of how to Configure the Computer Using the Advanced Editor 
and AutoInstall, see page 17 

• To see an example of how to Configure the Computer Using the Advanced Editor 
and Barcodes, see page 19.

Default XML Storage Locations on the Computer
On the handheld computer, the location where an XML file is stored determines 
whether the configuration file should be implemented after a Reboot or Enterprise 
data reset.

Important: File paths are case sensitive.
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About File Directories
This section describes the file directories on the mobile device. Honeywell mobile 
computers have the following top-level directories:

• Internal shared storage - This folder is populated when the mobile 
computer is set up at the factory. If an Enterprise data reset is performed, all 
data in Internal shared storage is erased, including modifications to XML 
files.

• IPSM card (Internal Persistent Storage Manager) - Data or programs stored 
in IPSM are not affected when the operating system is upgraded. Files stored 
in the IPSM card directory persist after a reboot or an Enterprise data reset. 
The IPSM card directory is not automatically populated. To save the XML 
files so that the settings are applied after an Enterprise reset, copy the XML 
files to IPSM card/honeywell/persist.

• SD card - If one or more SD cards are installed in the device, a directory will 
be displayed for each card (model-dependent). 

Note: Provisioning mode must be turned On (enabled) to view and modify the files in the 
directories noted in this section. 

Viewing File Directories
When viewing files via a file browser (e.g., File Explorer or Windows Explorer) over a 
USB or Ethernet connection, the directory paths are:

• <device name>/Internal shared storage/

• <device name>/IPSM card/

The following image shows an example of the computer’s file browser view when 
connected to a Honeywell CT40 mobile computer via USB.

File Browser View

Directory Descriptions
/Internal shared storage/honeywell/ezconfig

Directory Characteristics:

• This folder is created and populated when the Power Tools software is 
initially installed on the computer at the factory.
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• The XML files stored in the directory contain default settings that persist 
after a reboot or Enterprise data reset unless otherwise specified. 

• If a Full factory reset is performed, the files in this directory revert back to 
their factory state.

/Internal shared storage/honeywell/ezconfig/generated
Directory Characteristics:

• This folder is automatically created and populated when you select the 
Generator option in the EZConfig Power Tool app. See About the Generator 
in the EZConfig App on page 23 fore more information.

• When the XML files in the folder are generated, they include any custom 
configurations that have been implemented and saved in the /Internal 
shared storage/honeywell folder.

• The XML files stored in this directory do not persist after an Enterprise data 
reset. 

/IPSM card/honeywell/ezconfig/generated
Directory Characteristics:

• You can copy files to this folder from Internal shared storage/
honeywell/ezconfig.

• The XML files stored in this directory persist after a reboot or an Enterprise 
data reset. 

• If a Full factory reset is performed, the files in this directory are deleted.

/IPSM card/honeywell/persist
Directory Characteristics:

• The XML files in this directory are applied only when an Enterprise data reset 
is performed.

• If a Full factory reset is performed, the persist folder is deleted.

/Internal shared storage/honeywell/persist
Directory Characteristics:

• This folder is created the first time EZConfig barcodes are scanned to 
configure the computer.

• The XML files located in the folder are automatically created from the 
content of the scanned barcodes.

• If an Enterprise data reset or a Full factory reset is performed, the persist 
folder is deleted.

• To apply the updated settings in XML after a reboot, the XML files can be 
copied to this folder.

To learn more about default XML configuration files on the computer and their 
storage locations, see page 12.
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About the AutoInstall Folders
On standard handheld computers the AutoInstall feature is enabled by default. 
When Provisioning mode is turned on (enabled) and the AutoInstall feature is 
enabled, during the power-up boot or reboot process, the following folders are 
searched for Android application packages (.apk) or .zip files containing 
applications.

• Internal shared storage\honeywell\autoinstall
• IPSM card\honeywell\autoinstall
• sdcard\honeywell\autoinstall on a microSD card if one is installed in the 

computer

Each apk file found is then compared to the applications already installed on the 
handheld computer:

• If the application is not installed, AutoInstall installs the application.

• If the application is already installed, AutoInstall compares the versions. 
If the version in the autoinstall folder is newer than what is already on the 
computer, the application is installed.

When AutoInstall is turned off (not enabled), the contents of the autoinstall 
folders on the computer and on the optional microSD card are ignored. 

To change the AutoInstall setting:

1. Swipe up from the bottom of the home screen to access all apps.

2. Touch AutoInstall Settings .

3. Touch Enable AutoInstall to toggle AutoInstall on or off.

XML File Descriptions and Locations for Power Tools 
12.x

This table lists the common XML files on Honeywell mobile computers. 

Files with a location of /Internal shared storage/honeywell/ezconfig/ are 
present by default.

Files with a location of /Internal shared storage/honeywell/ezconfig/
generated are created when Generator is run in the EZConfig app.

Additional XML configuration files may be created in these directories depending 
on the apps installed on the mobile device.

Important: File paths are case sensitive.
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XML File Configuration 
Settings for . . . Location

AppsConfig.xml /Internal shared storage/
honeywell/ezconfig/

BatteryOptimizer.xml /Internal shared storage/
honeywell/ezconfig/generated

BattMon.xml BattMon app
(see page 75)

/Internal shared storage/
honeywell/ezconfig/

BluetoothLeash.xml WirelessTether app /Internal shared storage/
honeywell/ezconfig/

BTPrintDemo.xml BTPrintDemo app /Internal shared storage/
honeywell/ezconfig/

DataCollectionService.xml Scanning /Internal shared storage/
honeywell/ezconfig/generated

DeviceConfig.xml General settings 
(e.g., personal, system, 
wireless and networks, 
feedback, sound and 
battery).

/Internal shared storage/
honeywell/ezconfig/generated

EnterpriseBrowser.xml Enterprise Browser /Internal shared storage/
honeywell/ezconfig/generated

EZConfig.xml EZConfig app /Internal shared storage/
honeywell/ezconfig/

IPConfig.xml /Internal shared storage/
honeywell/ezconfig/

Ping.xml /Internal shared storage/
honeywell/ezconfig/generated

Provisioner.xml Template file used to 
create instructions to 
install files for initially 
staging the computer.

/Internal shared storage/
honeywell/ezconfig/generated

ScanDemo.xml ScanDemo app /Internal shared storage/
honeywell/ezconfig/

ScannerEdge.xml Scanner Edge app /Internal shared storage/
honeywell/ezconfig/

ScanZone.xml /Internal shared storage/
honeywell/ezconfig/

Signature.xml SignatureDemo app /Internal shared storage/
honeywell/ezconfig/

SSClient.xml /Internal shared storage/
honeywell/ezconfig/generated

te_settings BasicTE /Internal shared storage/
honeywell/ezconfig/generated

WebInterface.xml APIs for web apps /Internal shared storage/
honeywell/ezconfig/generated

wifidiagnostic.xml /Internal shared storage/
honeywell/ezconfig/
Dolphin Power Tools 12.x User Guide 13
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CHAPTER

3

Dolphin Power To
HOW TO CONFIGURE THE 
HANDHELD COMPUTER
Overview
Honeywell handheld computers running Android 7 or higher utilize a set of XML 
files stored on the device, which define the default settings that persist after a 
restart or an Enterprise data reset. By editing the XML files, you can customize the 
computer configuration to meet your specific application needs. 

To support customization, the computers come with an EZConfig app as part of the 
standard Honeywell Power Tools software package. The app has a built-in editor 
you can use to make quick and easy real time modifications to the XML files 
located on the computer. The EZConfig app also includes a scan feature you can 
use to implement configuration changes by scanning barcodes generated with the 
optional advanced editor that is part of the Honeywell EZConfig for Mobility 
software suite. 

EZConfig for Mobility software runs on a workstation computer (e.g., desktop or 
laptop) and is available for download from sps.honeywell.com. The advanced 
EZConfig editor not only delivers the ability to create and export XML files but also 
the means to generate configuration barcodes you can use for updating multiple 
Honeywell handheld computers with the same configuration set. 

More Information
• To learn how to use the standard editor in the EZConfig app on the handheld 

computer, see page 23.

• To learn how to install and use the advanced editor in EZConfig for Mobility,
 see page 27.

• To learn more about default XML configuration files and their storage locations, 
see page 9.
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Configure the Computer Using the Standard Editor
You can configure the computer by generating the XML files, editing the XML 
setting(s) you want to change, then applying the new configuration.

The following example shows how to configure the default Wi-Fi radio setting 
(e.g., enable or disable) using the standard editor provided on the handheld 
computer.

This example is based on the assumption the computer is powered by Android 12 
and is running an up-to-date Power Tools version (12.x).

1. Tap Settings > Honeywell Settings > Provisioning mode.

2. Tap the toggle button to turn Provisioning mode On then close the Settings 
app.

3. Swipe up from the bottom of the Home screen to access all apps. 

4. Tap Power Tools  > EZConfig .

5. Tap  next to “EZConfig”.

6. Tap Generator. 

7. Tap DeviceConfig  to open the file in the editor.

8. Tap DeviceConfig then tap Wireless and networks > WiFi > WiFi Settings. 

As you select each item, the tree structure expands to show the additional sub-
sections. Tap the item again and the structure collapses.

9. Locate WifiEnable in the Key list, and then tap in the Value column to edit the 
field. 

10. Type either 3 to enable Wi-Fi or 1 to disable Wi-Fi.

11. Tap the Back button to dismiss the keyboard. 
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12. Tap the three vertical dots  in the upper right corner of the screen.

13. Tap Save.

14. Tap the dots  again, and then select Update Configure. 

15. Reboot the computer to apply the changes.

Configure the Computer Using the Advanced Editor and 
AutoInstall 

The following example shows how to configure the default Wi-Fi radio setting 
(e.g., enable or disable) using the optional advanced editor provided with the 
EZConfig for Mobility software suite. To learn how to download and install 
EZConfig for Mobility, see page 27.

This example is based on the following assumptions: 

• The computer is powered by Android 12 and is running an up-to-date Power 
Tools version (12.x).

• EZConfig for Mobility has been installed on your workstation computer. 

• An active communication connection has been established between the 
handheld computer and the workstation computer.

1. On the handheld computer, tap Settings > Honeywell Settings > Provisioning 
mode.

2. Tap the toggle button to turn Provisioning mode On and then select Back twice.

3. Generate a copy of the XML file you want to change. 

a. Swipe up from the bottom of the Home screen to access all apps. 

b. Tap Power Tools  > EZConfig .

c. Tap  next to “EZConfig”.
d. Tap Generator.

4. Copy the generated XML file from the handheld computer to the workstation 
computer.

a. Open your workstation file browser (e.g., File Explorer or Windows Explorer).
b. Locate the handheld computer in the directory tree, and then browse to the 

Internal shared storage\honeywell\ezconfig\generated folder.
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c. Copy the DeviceConfig.xml file to the workstation. You can use the copy and 
paste or drag and drop commands.

5. Open the XML file in the advanced EZConfig Editor on your workstation 
computer.

a. Click Start > Honeywell >  EZConfig Editor.

b. Click File Open . 

c. Select the DeviceConfig.xml file you copied to the workstation, and then 
click Open.

d. Click OK to continue if a message appears warning you the file was created 
with an older tool. 

6. Modify the XML file.

a. Click Wireless and networks > WiFi> WiFi Settings. 
If necessary, click on the “+” to expand and access.

b. Locate WifiEnable in the Key list, and then double-click in the Value column 
to edit the field. 

c. Type either 3 to enable Wi-Fi or 1 to disable Wi-Fi as the default.
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7. Select File > Save or the save icon . 

Verify the file is was saved as an .xml file and not an .exm file.

8. Open your workstation file browser (e.g., File Explorer or Windows Explorer).

9. Save a copy of the modified DeviceConfig.xml into the 
Internal shared storage\honeywell\persist folder on the handheld 
computer. Do not rename the file. 

• If the honeywell folder does not appear in the Internal shared storage 
directory, make sure Provisioning mode is turned On (enabled) on the 
handheld computer.

10. Reboot the handheld computer to apply the changes.

Configure the Computer Using the Advanced Editor and 
Barcodes

The following example shows how to configure the default Wi-Fi radio setting 
(e.g., enable or disable) using the optional advanced editor provided with the 
EZConfig for Mobility software suite. To learn how to download and install 
EZConfig for Mobility, see page 27.

This example is based on the following assumptions: 

• The handheld computer is powered by Android 12 and is running an up-to-date 
Power Tools version (12.x).

• EZConfig for Mobility has been installed on your workstation computer. 

• An active communication connection has been established between the 
handheld computer and the workstation computer. 

1. On the handheld computer, tap Settings > Honeywell Settings > Provisioning 
mode.

2. Tap the toggle button to turn Provisioning mode On and then select Back twice.

3. Generate a copy of the XML file you want to change. 

a. Swipe up from the bottom of the Home screen to access all apps.

b. Tap Power Tools  > EZConfig .

c. Tap  next to “EZConfig”.

d. Tap Generator. 
4. Copy the generated XML file from the handheld computer to the workstation.

a. Open your workstation file browser (e.g., File Explorer or Windows Explorer).
b. Locate the handheld computer in the directory tree, and then browse to the 

Internal shared storage\honeywell\ezconfig\generated folder.
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c. Copy the DeviceConfig.xml file to the workstation. You can use the copy and 
paste or drag and drop commands.

5. Open the XML file in the advanced EZConfig Editor on the workstation.

a. Select Start > Honeywell >  EZConfig Editor.

b. Select File Open . 
c. Select the DeviceConfig.xml file you copied to the workstation, and then 

click Open.
d. Click OK to continue if a message appears warning you the file was created 

with an older tool. 

6. Modify the XML file.

a. Select Wireless and networks > WiFi> WiFi Settings. 
If necessary, click on the “+” to expand and access.

b. Find WifiEnable in the Key list, and then double-click in the Value column 
to edit the field. 

c. Type either 3 to enable Wi-fi or 1 to disable Wi-Fi as the default.
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7. (Optional) Select File > Save or the save icon  if you want to keep a copy of 
the modified file on the workstation. 

Verify the file was saved as an .xml file and not an .exm file.

8. Create and print the EZConfig barcode(s).

a. Tap the barcode  icon in the tool bar.
b. Tap Full Contents instead of Simplified under “Options” for this example.

c. Tap Print. The default scale factor is 2. The lower the scale factor, the larger 
the barcode size printed.

For more information on barcodes, see About Creating EZConfig Barcodes 
from XML Files on page 41.

9. Scan the EZConfig barcode(s) with the handheld computer.

a. Aim the scanner at the first configuration barcode, and then tap Scan or 
press any Scan button.

EZConfig opens. Upon a successful scan, the display is updated to reflect 
the total number of configuration barcodes in the set and the code(s) that 
have been scanned. 

b. Scan the remaining barcode(s) in the set. 

After the last barcode has been scanned, the display reads, “Decode 
success, try to configure”. 

10. Reboot the computer to apply the changes.

The new configuration is saved in:

• Internal shared storage\honeywell\persist\DeviceConfig.xml
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CHAPTER

4

Dolphin Power To
ABOUT THE EZCONFIG STANDARD 
EDITOR AND GENERATOR
Overview
This chapter details the standard generator and editor that is part of the EZConfig 
app included on your handheld computer. You can use the generator in 
conjunction with the standard editor to create custom XML files that persist after a 
reboot or Enterprise data reset. The standard editor gives you the ability to edit and 
save XML configuration files on the computer without the need for additional 
devices or software. 

More Information
• To learn how to install and use the optional advanced EZConfig Editor,

see page 27.

• To see an example of how to Configure the Computer Using the Standard Editor 
and generator, see page 16.

• To learn more about default XML configuration files on the computer and their 
storage locations, see page 9.

About the Generator in the EZConfig App
The generator is used in conjunction with the standard editor in EZConfig when 
you want to create a custom XML configuration based off the current default XML 
files stored on the computer. 

When the Generator is accessed from inside the EZConfig Power Tools app, the 
default XML files stored in the \Internal shared 
storage\honeywell\ezconfig folder are automatically copied and saved in the 
\Internal shared storage\honeywell\ezconfig\generated folder. In 
addition to the copies, a DeviceConfig.xml file is also created and saved in the 
folder. When you select a file from the Generator screen, the copy opens in the 
standard editor. 
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You can either use the standard editor to make changes and deploy the new 
configuration right on the handheld computer or you can save the copy of the 
generated file and export it to your workstation computer where it can be edited 
with the advanced EZConfig Editor. To learn more about the advanced EZConfig 
Editor, see page 27.

Note: The generated folder is automatically created the first time you select the Generator 
option in the EZConfig app. If you edit the XML files in the generated folder, those 
changes will be kept when Generator is selected again. If settings were manually 
changed, EZConfig will fetch the latest values from the device and apply them in the 
XML file. For example, if WiFiEnable is set to “3” (enable) in DeviceConfig.xml and the 
user manually disables Wi-Fi in the Settings app then selects the Generator option in 
EZConfig, the new DeviceConfig.xml file that is generated will have WiFiEnable set to 
“1” (disabled).

How to Use the Generator to Create a Custom XML File
To create a custom XML file that persists after a reboot or Enterprise data reset 
using the Generator and standard Editor:

1. Swipe up from the bottom of the Home screen to access all apps.

2. Touch Power Tools  > EZConfig .

3. Touch  next to “EZConfig”.

4. Touch Generator. 

5. Select the XML file to edit. A copy of the XML file opens in the standard 
EZConfig Editor.

6. Customize the XML file. 

7. Touch  and then select Save. 

8. Touch  again and then select Update Configure. If prompted, reboot the 
computer to apply the changes.

How to Open an XML File in the Standard Editor
To open an XML in the standard Editor without using the Generator:

1. Swipe up from the bottom of the Home screen to access all apps.

2. Touch Power Tools  > EZConfig .

3. Touch  next to “EZConfig”.

4. Touch Editor.
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5. Touch OPEN XML and browse to the storage location of the XML file. 
To view descriptions and file locations for XML files on the handheld computer, 
see page 12.

6. Touch the name to open the XML file for editing. 

About the XML File Structure and Standard Editor
The XML file format is comprised of sections and keys. The keys contain the values 
that configure the handheld computer. A multi-level, hierarchical, tree structure is 
supported. The computer reads the highest level (section) first, and then reads the 
key values in each subsection. In general, the section keys located at the beginning 
of the XML file identify the XML file. The section keys at the end identify the 
application version. The key values for file identification and version cannot be 
edited. 

Keys that contain configurable parameters are located in the section(s) between 
the read only keys at the beginning and end of the XML file. When you select a key 
from the section tree, the key name, current value, and description appear in the 
bottom half of the screen. Key fields that can be edited are selectable.

How to Edit an XML File
1. Open the XML file in the standard Editor (see page 24).

2. Touch the + icon to expand the sections and locate the key you want to edit.

3. Touch the key in the section tree, and then select inside one of the Key, Value, or 
Desc fields to edit the information. 

Key name, value and description 
appear in the bottom half of the 
window. 

Sections appear in the top half of 
the screen. Touch the “+” or “-” 
icon to expand or collapse a 

Touch  to 
open menu.

Touch  to return 

The selected key and/or section 
path appears at the top.
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A selected field is underlined in green. If a field is shaded in gray, the text can-
not be edited (see example below).

4. Edit the text. If you want to close the on-screen keyboard and edit another field, 
use the Back button, and then select the other field.

5. Touch  and then select Save. Saving does not apply the changes to the 
application.

6. Touch  again and then select Update Configure. If prompted, reboot the 
computer to apply the changes.

About Launching Associated Applications
Some XML files have application associations. To automatically save the XML file 
and launch the associated application while the XML file remains open:

1. With the XML file open in the standard Editor, touch .

2. Select Launch Associated App. This option is enabled only when there is an 
application associated with the XML file. 

WifiEnable is the 
selected Key.The Key name is not 

editable (gray).

The Value field is 
selected.

Brief description of 
available options.
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CHAPTER

5

Dolphin Power To
ABOUT THE ADVANCED EZCONFIG 
EDITOR
Overview
This chapter details the advanced EZConfig Editor that is part of the optional 
EZConfig for Mobility software suite, available for download from 
sps.honeywell.com. Unlike the standard editor on the handheld computer, the 
advanced EZConfig Editor runs on your workstation computer (e.g., desktop or 
laptop). 

The advanced editor not only delivers the ability to create, edit and export XML files 
but also the means to generate configuration barcodes that you can use for 
updating multiple handheld computers with the same configuration set.

Note: The EZConfig Editor can be used with EXM files and XML files. This document 
concentrates on the XML files for handheld computers powered by Android 7. Some 
functions of the EZConfig Editor on the workstation are not applicable to devices with 
Android and are not covered here.

More Information
• To learn how to use the standard editor on the handheld computer, see page 23.

• To see an example of how to Configure the Computer Using the Advanced Editor 
and AutoInstall, see page 17 

• To see an example of how to Configure the Computer Using the Advanced Editor 
and Barcodes, see page 19.

• To learn more about default XML configuration files on the handheld computer 
and their storage locations, see page 9.
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How to Install EZConfig for Mobility
Follow these steps to install EZConfig on your workstation.

1. Go to the downloads portal at honeywell.com/PSSsoftware-downloads.

2. Create an account if you have not already created one. You must login to 
download the software.

3. Install the Honeywell Download Manager tool on your PC prior to trying to 
download any files.

4. Navigate to Software > Software and Tools > EZConfig for Mobility.

5. Touch the EZConfig for Mobility software file (*.zip).

6. Touch Download. Follow the prompts to download the file (*.zip).

7. Double-click on the downloaded EZConfig for Mobility.zip file.

8. Double-click on the Setup.exe file.

9. Touch OK. Follow the prompts to install EZConfig for Mobility. 
The default installation folder is 
C:\Program Files (x86)\Honeywell\EZConfig for Mobility. 

How to Open an XML File in the Advanced Editor
To open an XML file stored on your workstation (e.g., laptop or desktop):

1. Open the EZConfig Editor on your workstation PC. 
Select Start > Honeywell >  EZConfig Editor.

2. Select File Open .

3. Browse to the location of the XML file.

4. Select the file and click Open. 

5. Click OK to continue if a message appears warning you the file was created with 
an older tool.

To open an XML file stored on the handheld computer:

1. Establish an active communication connection (e.g., USB, Ethernet) between 
the workstation computer and the handheld computer. 

If you are using a USB connection, you must enable the USB Transfer files 
option on the handheld computer. See the product user guide for more infor-
mation about the setting.

2. Open the EZConfig Editor on your workstation PC. 
Select Start > Honeywell >  EZConfig Editor.
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3. Click Open File .

4. Select the handheld computer (e.g., CT60) in the directory tree. 

5. Browse to the location of the XML file. To learn about default file storage 
locations on the computer, see page 9.

6. Select the file and click Open.

7. Click OK to continue if a message appears warning you the file was created with 
an older tool.

About the Toolbar and Menus
Menus and a command toolbar are located at the top of the EZConfig Editor 
screen. When a file is open, all the toolbar commands appear. If no file is open, 
some of the icons appear gray.

File Menu
The following table describes each File menu option and provides the equivalent 
toolbar icon, if applicable.

Menu Item Icon Description

New Creates a new document. There are two types of documents:

• Configuration Document 
See How to Create a New XML Configuration Document 
(page 40). 

• Registry Document
This option is not relevant for devices running Android.

Open Opens an XML file located on either the workstation computer or 
the handheld computer. 

• To open a file on the handheld computer, you must first 
establish an active communication channel between the 
workstation and handheld computer. When using a USB 
connection, the USB Transfer file option must be enabled 
on the handheld computer. See the product user guide for 
more information.

Recent Files Lists the recent files opened with the advanced EZConfig Editor. 

Open from Device Menu item not available. Use Open instead.

Save Saves the open file to a location you select on the workstation. 
This menu item is disabled for new and imported files; use Save As 
instead. 
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Edit Menu
For Edit menu options, see How to Work with Sections on page 32. 
For Key Edit menu options, see How to Work with Keys on page 37.

View Menu
The following table describes View menu options and provides the equivalent 
toolbar icon, if applicable.

Tools Menu
The following table describes Tools menu options.

Save As Saves the open file with a new name (optional) to the location you 
select on the workstation or the handheld computer.

• When you are using the Save As command, make sure you 
add “.xml” as the file extension at the end of the name or the 
file is automatically saved with an “.exm” file extension.

Save to Device As Menu item not available. Use Save As instead.

Create EZConfig 
Bar Code 

Embeds the open XML file in an Aztec barcode. 
To learn more, see How to Generate EZConfig Barcodes from an 
XML File on page 41.

Properties Shows the associated application path and arguments of the open 
XML file. 

Exit Closes the advanced EZConfig Editor. 

Menu Item Icon Description

Menu Item Icon Description

Show Locks Shows or hides the icons indicating if a subsection or key is locked. 

To learn more about locks, see How to Read the Status Bar on page 
32.

The lock icon means the 
section’s subsections are 
locked. 

The key icon means 
that the section’s 
keys are locked. 

Menu Item Description

Launch Associated 
Application

Menu item not available.
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View Open XML Files in the Advanced EZConfig Editor
When you open a file in the EZConfig Editor, the XML file content appears in 
several sections on the screen. Each part of the screen contains content specific to 
the folder selected in the root node section tree located in the top left quadrant of 
the screen. When you select a folder, the other areas of the screen update to reveal 
the content and parameters of the selected section. The folder color indicates the 
status. 

To learn more about color indicators, see About Section-Level Merge Modes on 
page 35.

EZConfig Editor with DeviceConfig.xml Open

Simplify Document

Important:
You cannot undo 
this action!

Simplifies the XML file to make it smaller in size. This option should be used 
with caution. Simplifying permanently removes:

• Disabled sections and keys 

• Descriptions

• Barcode settings

Instead of using this option, consider using the simplify option when you 
generate configuration barcodes. You can simplify the file embedded in the 
barcode without affecting the open XML file. This reduces the size of the 
barcode package yet keeps the disabled sections, descriptions and barcode 
settings in the open XML file for future reference. 

To learn more, see Simplified (page 44) on the About the EZConfig Bar Code 
Window. 

Warm Boot Device Menu item not available.

Factory Reset 
Device

Menu item not available.

Menu Item Description

File Name

Root Node

Sections

Description 
of Touched 
Section. 
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EZConfig Editor with Key Selected 

How to Read the Status Bar
The Status Bar appears at the bottom of the window. Information about the 
selected section or key appears in the following locations.

Status Bar When a Section is Touched

To learn more, see About Section-Level Merge Modes and About Section Locks on 
page 35.

Status Bar When a Key is Touched

To learn more, see About Key Lock Types on page 39.

How to Work with Sections
The XML file format supports a multi-level hierarchal (tree) structure that appears 
in the top left quadrant of the window. The root node identifies the XML file. When 
you click on the root node, “Root” appears in the name and description area below 
the tree structure. 

Sections appear under the root node and can be expanded or collapsed by 
selecting the “+” or “-” sign. You can select a section by clicking on name. Only one 
section can be selected at a time. When a section folder is selected, the keys for the 
section appear in the upper right quadrant of the screen. 

Touched 
Section

Keys & Values in 
Touched Section 

Description of 
Touched KeyStatus of 

Touched 
Key

Touched Key

Section 
Name

Merge 
Mode

Locks on Subsections and Keys

Key 
Name

Enabled 
or 
Disabled

Read 
Only 

Encrypted Key Locked by Section 
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About the Edit Menu Commands for Sections
Touch a section and either click Edit to see the available options or right-click to 
view a pop-up menu of edit commands. 

Menu Item Description

Rename Activates the name so that you can rename the section. 

You cannot modify the name if the section is locked; see About Section Locks 
on page 35.

Cut Cuts a selected section. 

Copy Copies a selected section. 

Paste Pastes the section that was just cut or copied into a new location at the same 
level as the original cut or copied section. The pasted section is added above 
any selected section. 

Paste as Child Pastes the section that was just cut or copied as a child of the selected section. 

You can cut, copy and paste sections within an XML file or across XML files 
(see page 34). 

Delete Deletes a selected section. 

Because you cannot undo a delete, consider disabling the section (see Disable 
All on page 33) instead of deleting. 

Enable Enables sections that were previously disabled. You can enable a section only 
if the parent section is enabled. Sections are enabled by default. 

To enable all the keys inside a selected section:

•  Hold down the SHIFT button, right-click and then select Enable All.

Disable All Disables sections and all of its keys. 

Disabled sections remain in the file and appear as a gray folder. If you disable a 
section that has child sections, all of the child sections and their keys are 
automatically disabled. The child section folders also appear in gray. 

When reading the XML file, the handheld computer behaves as though 
disabled sections are not there and moves on to read the next enabled section.
 
Disabled sections can be removed from the XML file permanently using the 
Simplify Document (see page 31) option. If you want to keep the disabled 
sections in the XML file on the workstation but not in the file deployed to the 
handheld computer, use the Simplified option (see page 44) when creating the 
EZConfig barcode package. 

Disabled 
Section
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How to Modify a Section Name
1. Double-click on the section or select Edit > Rename with the section selected.

2. Type in the new name. 

3. Press Enter. 

Note: You cannot modify the name if the section is locked or disabled; see About Section 
Locks on page 35.

How to Modify a Section Description
Descriptions are not required to process key values but do help document the XML 
file and often contain valuable information. 

1. Click on the section.

2. Click inside the section description box (lower left quadrant of the screen).

3. Type the new description. 

Note: You cannot modify descriptions of locked sections. 

How to Move a Section
To move sections within an XML file, use the drag and drop method. By default, 
sections are dropped at the same level in the tree. 

For additional functionality when using drag and drop, press and hold: 

• ALT to move a section as a child section. 

• CTRL to copy a section and drop the copy at the same level in the tree. 

• CTRL + ALT to copy a section and drop the copy as a child section. 

Note: You can select only one section at a time.

How to Copy Sections Between Two XML Files
1. Open two instances of the EZConfig Editor. One instance for each XML file.

2. Touch the section you want to copy.

Insert Section Inserts a new section above the selected section. You can also press the Insert 
key (INS). 

If you want to add a section directly under the root node, use the Append Child 
Section since all sections are child sections of the root node.

Append Child 
Section

Adds a new child section to a selected section. The new child section is 
inserted below the previous section. 

Menu Item Description
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3. Right-click and select Copy or select Edit > Copy. 

4. Touch a section in the target XML.

5. Do one of the following:

• Right-click and select Paste if you want the section added above the 
selected section. 

• Right-click and select Paste Child if you want the section added to the target 
section as a child (subsection).

Note: To paste the first section into a new file, you would use the Paste Child option since 
all sections are child sections of the root node.

About Section Locks
The status bar, at the bottom of the window, indicates what type of lock is applied to 
a selected section. 

Note: All locks are applied to each individual section and are not recursive. Only text that 
appears in blue can be modified. 

About Section-Level Merge Modes
Note: The Merge mode option is available in EZConfig editor; however, these options are 

only valid for Windows handheld devices. Android devices will ignore these flags.

Merge modes determine how sections are handled when an updated XML file is 
deployed to a device where an existing version of the XML file already exists. At the 
time of shipment, all XML files saved on handheld computers have section-level 
merge modes defined according to the content of the sections.

Lock Type Status Bar 
Indicator Description Effect

Read Only The section name and 
description are locked as 
read-only. They appear in 
red. 

Section name and description 
cannot be modified. 

Lock Name The child section name is 
locked by the parent 
section. 

Section name and description 
cannot be modified. 

The section name is locked 
individually. 

Name and Description cannot be 
modified. 

Lock Key All keys are locked. Key names and descriptions 
cannot be modified. Keys cannot 
be added, moved, or deleted 
within the section. 

Lock 
SubSection 

All immediate subsections 
are locked. 

Immediate subsection names and 
descriptions cannot be modified. 
Immediate subsections cannot be 
added, moved, or deleted. 
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Merge modes are indicated by the color of the folder icon and in the Status Bar at 
the bottom of the window. 

How to Change a Section-Level Merge Mode
1. Touch a section.

2. Right-click to access the Edit menu. A check mark appears next to the current 
Section-Level Mode.

3. Touch a section-level merge mode (i.e., Set to Delete + Add, Set to Add only, Set 
to Disable + Add). The folder color and merge mode indicator in the status bar at 
the bottom of the window changes immediately after selection. 

Mode Description Merge Effect

 Delete + Add
Deletes non-common children elements (i.e., subsections 
and keys) in the target file, and then adds the new 
information from the barcode. The new section replaces 
the old section. 

This is the default merge mode for new sections. The 
section folder appears yellow.

Exclusive

 Disable + Add
Disables non-common children elements (i.e., 
subsections and keys) in the target file, and then adds the 
new information from the barcode. The section folder 
appears orange.

Disabled sections and keys removed from the simplified 
barcode end up as disabled in the target file. 

Exclusive

 Add Only
Adds new information (i.e., sections and keys) to the 
existing section. If this is a brand new section, the new 
section is added to the existing XML file. The section 
folder appears blue.

Disabled sections removed from the simplified barcode 
are not modified in the target file. 

Inclusive
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How to Work with Keys
Keys reside inside sections and have a Name, a Description, and a Value. 

About the Edit Menu Commands for Keys
Touch a key and either click Edit to see the available options or right-click on your 
mouse to view a pop-up menu that includes the edit commands. 

Menu Item Description

Rename Activates the key name so that you can rename the key. 

Rename is disabled if the key is locked or disabled; see About Key Lock Types 
(page 5-39). 

Cut Cuts the selected key.

Copy Copies the selected key. 

Paste Pastes the key just cut or copied into the selected section. Disabled keys can 
be pasted only as children of a section. 

Paste as Child Pastes the key just cut or copied into the selected section. Keys are not multi-
level; all keys paste at the same level within a section. 

You can cut, copy and paste keys within an XML file or across XML files. 

Delete Deletes the selected key. 

You cannot undo a delete; you might want to consider disabling the key rather 
than deleting. 

Enable Enables keys that were disabled. When a key is enabled, the client application 
can read and apply the key value. When you enable a key, make sure to specify 
a value for that key. Do not leave the value blank. 

To enable a key, its parent section must be enabled. 

Disable Disables keys. Keys appear gray if they have been disabled. 

The computer does not read disabled keys, and disabled keys are deleted if the 
file is simplified; see Simplify Document on page 31.

Disabling a key is not the same as setting the Key Value to “0” or “Disable”.
When you disable a key, the handheld computer behaves as if the key is not 
there when reading the file and simply moves on to read the next enabled key.

An enabled key, with a value set to “Disabled” or “0” is still recognized when the 
handheld computer reads the file. 

Insert New Key Inserts a new key above the selected key. You can also press the Insert key 
(INS). 

Disabled Key
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How to Modify Key Names
1. Double-click on the key or select the key and click Edit > Rename.

2. Type in the new name. 

3. Press ENTER. 

Note: You cannot modify the description if the key is locked; see About Key Lock Types on 
page 39. Only text that appears in blue can be modified. 

How to Modify Key Values
1. Double-click on the value for the key or select the value for the key and click 

Edit > Rename. 
If no value shows, click in the value column next to the key name.

2. Type in the new value. 

3. Press ENTER. 

How to Modify Key Descriptions
Descriptions are not required to process key values but do help document the XML 
file and often contain valuable information. 

1. Click on the key.

2. Click inside the key description box (lower right quadrant of the screen).

3. Type the new description. 

Note: You cannot modify the description if the key is locked; see About Key Lock Types on 
page 39.

How to Move Keys
To move keys within an XML file, use the drag and drop method. Press and hold the 
CTRL key to drag and drop a copy of the key to the new location. 

Note: You cannot move a key if it is locked by its section. 

How to Copy Keys Between Two XML Files
To copy keys between XML files:

1. Open two instances of the EZConfig Editor. You will need one instance for each 
XML file.

2. In the first window, select the key you want to copy.

3. Right-click and select Copy. 

4. In the second window, select the target section where you want to add the key.
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5. Right-click and select Paste. 

Note: Keys are always added at the same level within a section. 

About Key Lock Types
The status bar, at the bottom of the window, indicates what type of lock is applied to 
a selected key. 

Note: Locked and Read-Only properties are not recursive. Properties are applied to each 
individual key. Only text that appears in blue can be modified. 

How to Change a Key Lock Type
1. Select a key.

2. Right-click to access the edit menu.

3. Select a lock type (i.e., Encrypt/Decrypt 40-Bit, Encrypt/Decrypt 128-Bit, Set/
Remove Read Only, Lock/Unlock Name). The color of the key text changes 
depending on your selection.

Save an XML File Directly to the Handheld Computer
1. Establish an active communication connection (e.g., USB, Ethernet) between 

the workstation computer and the handheld computer. 

If you are using a USB connection, make sure the USB Transfer File setting is 
enable on the handheld computer. See the product user guide for more infor-
mation about the setting.

2. Open the file in the advanced EZConfig Editor on your workstation.

3. Click File > Save As.

4. Select the handheld computer in the directory tree (e.g., CT60). 

Lock 
Type

Status Bar 
Indicator Description Effect

Name Lock Keys are locked by the 
section. 

Name and Description cannot be 
modified. Keys cannot be added, 
moved, or deleted within the section. 

The key name is locked 
individually. 

Name and Description cannot be 
modified. These keys can be moved. 

Read Only Read-only keys cannot 
be modified in any way. 
They appear in red. 

Name, Description, and Value cannot 
be modified. Keys cannot be added, 
moved, or deleted within the section. 

Encrypted The key value appears as 
asterisks (*) for added 
security. 

Encrypted keys are also stored 
encrypted in the XML file. If you open 
the XML file in a text editor, you won't 
see the data as clear text. 
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5. Browse to where you want to save the XML file. To learn about default XML file 
storage locations on the computer, see page 9.

6. Select the target folder and click Save. The file is downloaded directly to the 
handheld computer. 

How to Create a New XML Configuration Document
To create new XML files that are configuration documents, you can open an 
existing XML file and save it with a new name or create a new XML file from 
scratch. 

To create a new XML file from scratch:

1. Click File > New > Configuration Document. The root node is created and 
appears as the top level section. 

2. Click File > Save As. 

3. Type the new file name. Include an “.xml” extension in the name 
(e.g., ConfigurationB.xml). If you do not include “.xml”, the software defaults to 
an “.exm” file extension.

4. Click Save. The root node name and description automatically update to match 
the file name.

5. To create the first subsection, select the root node, right-click, and then select 
Append Child Section. 

6. Type a name for the section, and then press Enter or click outside the text field.

7. (Optional) Double-click on the section description to edit or add information.

8. Continue to add sections as needed. 

• To add a new section at the same level, right-click, and then select Insert 
Section. 

• To add a new section one level down, right-click, and then select Append 
Child Section. 

Root Section 
Name & 
Description 

File Name

Root Node
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9. To add keys, select a section. 

10. Right-click in the key value section, and then select Append Key. 

11. Type a name for the Key and press Enter. You can also click outside the text field 
to leave the text input field.

12. (Optional) Double-click on the key description if you want to edit or add 
information.

13. Continue adding sections and keys. 

14. If necessary, associate the XML file with an application. To learn how see About 
Creating EZConfig Barcodes from XML Files (page 41). 

15. Click File > Save. 

About Creating EZConfig Barcodes from XML Files
When you generate EZConfig barcodes from within the advanced editor, the 
software embeds the open XML file into a package of Aztec barcodes. The codes 
can then be scanned, decoded and deployed with the EZConfig app on the 
handheld computer. This allows the quick and easy configuration of one or 
multiple handheld computers with the same configuration set without the need to 
connect the devices to a workstation computer. 

This section explains how to generate EZConfig Barcodes from within the 
advanced EZConfig Editor. You can also generate barcode packages from the 
EZConfig Packager utility. Both the advanced EZConfig Editor and the EZConfig 
Packager are part of the EZConfig for Mobility software suite. The EZConfig 
Packager utility provides the ability to add more than one XML file to an EZConfig 
barcode package. To learn more about the EZConfig Packager utility, see the user 
guide provided with the software.

How to Generate EZConfig Barcodes from an XML File
When creating a barcode, the advanced editor automatically encrypts and 
compresses the data in the XML file. The XML file is stamped with the time and 
date the moment EZConfig Editor creates the barcode. The amount of data in the 
XML file determines how many barcodes are generated in the package and the 
physical size of each barcode. More data means a larger quantity of barcodes and 
a larger barcode size. You must scan all the barcodes to deploy the package on the 
computer. To learn more about changing the quantity and code size, see page 42.

To generate a barcode package:

1. Open the XML file you want to generate as barcodes in the advanced EZConfig 
Editor.

2. Click File > Create EZConfig Bar Code or select the  icon on the toolbar. 
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The advanced editor generates the barcode(s) and opens the EZConfig Bar 
Code window. Details of the barcode package appear in the window.

3. (Optional) Modify the package settings. To learn how, see About the Bar Code 
Tab Settings on page 43 or About the Advanced Tab Settings on page 44.

4. Select how you want the barcodes exported. 

• Export a barcode sheet containing the generated barcodes. The sheet can be 
printed from a laser printer, copied to the clipboard, or saved as an HTML file. 
To learn more, see About the Print and Save Options on page 47.

• Export individual barcode(s) as .tif or .png graphic files that can then be 
emailed or printed. To learn more, see About the EZConfig Bar Code Window 
on page 43.

How to Change the Barcode Size and Quantity
The amount of data in the XML file determines how many barcodes are generated 
and the physical size of each barcode. More data means a larger quantity of 
barcodes and a larger barcode size. You must scan all the barcodes to deploy the 
package on the handheld computer. EZConfig Editor offers four ways to control 
how many barcodes are produced and adjust the size of each barcode. 

You can: 

• Set the byte size limits to determine how much data each barcode can contain; 
see Max bar code size on page 45. 

• Split the data across a specified number of barcodes; see # Bar codes to 
generate on page 44.

• Simplify the XML file in the barcode; see Simplified on page 44.

• Scale the barcodes on the barcode sheet; see Bar Code Scaling Factor on page 
47.
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About the EZConfig Bar Code Window
The EZConfig Bar Code window is broken into two tabs: the Bar Codes tab and the 
Advanced tab. The Bar Codes tab previews and customizes the generated 
barcode(s). The Advanced tab contains settings that tell the EZConfig app how to 
process the XML file on the handheld computer. 

The following information is provided at the bottom of either tab:

• Package Size
The total size of the barcode package. 

• Compression and Encryption
Notifies you that compression and encryption are both turned On. Compression 
and encryption are always turned On by default. EZConfig Editor uses 128-bit 
encryption automatically. 

• Bar Codes
The total number of barcodes generated. This number changes as you move the 
slider on the Bar Codes tab. 

 About the Bar Code Tab Settings

Field/Option Description

Display Indicates which barcode appears in the preview area. The default value 
is “1”; the first barcode in the package. If more than one barcode was 
generated, you can use the up and down arrows to scroll through the 
barcodes. 

(___ bytes) Displays the exact byte size of the barcode displayed in the preview 
area. The total Package Size appears at the bottom of the window. 
The sum of barcode size is typically larger than the package size. 

Remote Path Defines the name and active storage location of the XML file. The active 
storage location is where you want the XML file deployed on the 
handheld computer. You can modify the field by clicking on it and 
typing in a new file name and location.
For example: \storage\IPSM\honeywell\deviceconfig.xml
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About the Advanced Tab Settings

Full Contents
(Radio button located 
under “Options”)

When selected, includes the full content of the XML file in the barcode, 
without simplifying. 

Simplified
(Radio button located 
under “Options”)

When selected, simplifies the XML file in the barcode, which removes 
disabled sections, description information, and barcode settings (if 
any). Simplification decreases the size of the barcodes without 
simplifying the XML file. Only the barcodes are affected by this option. 
Simplified is selected by default. 
The Package Size field at the bottom of the window displays the 
differences in total package size. Individual barcode size can be seen in 
the Display field. 

# Bar codes to generate This adjustment is active only if the Always use minimum # bar codes 
(page 45) option is not selected on the Advanced tab. 
When the slider is active, click and drag the slider toward minimum 
(Min) or maximum (Max) to change the number of barcodes generated. 
As you move the slider, the barcode preview and the number located 
next to “Bar Codes”, at the bottom of the window, update to show the 
change.

Copy to Clipboard Copies the barcode in the preview area to the clipboard. 
Use this option to paste the barcode into another application. 

Save Saves the barcode in the preview area as a graphic file (.png or .tif). 
By default, the name of the graphic file is the same as the name of the 
open XML file. You can enter a different name when saving. 

Save All Saves all barcodes in the package as individual graphic files. 
By default, the graphic files are saved with the same name as the open 
XML file and sequential numbering at the end to distinguish the 
individual graphic files from each other (e.g., DeviceConfig0001.png 
and DeviceConfig0002.png).

Print Opens the printing window where you can select print options and print 
the barcode package. To learn more, see About the Print and Save 
Options on page 47.

Field/Option Description
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Bar Code Options
These options determine some of the basic barcode parameters. 

Field Description

Max bar code 
size

Sets the maximum amount of data (in bytes) one barcode can contain. The lower 
the number of bytes, the smaller the barcode. Use the up or down arrows to adjust 
the amount.
The total number of barcodes created and the total package size (in bytes) 
appears at the bottom of the screen.

Always use 
minimum # bar 
codes

By default, this option is enabled. The data is calibrated to minimize the quantity 
of barcodes generated for the package. This option disables the barcode 
adjustment slider on the Bar Codes tab. 

Use custom 
password

Enables password-protection for the barcode package generated. 
If you enable the password requirement, the same password must be entered on 
the handheld computer or the barcode data does not process. If the passwords 
do not match, a message stating, “This config file is not supported” appears on 
the screen. 
To enable password-protection, check the box next to “Use custom password”, 
and then enter the password in the field provided. The password must contain 16 
characters and is only visible as long as the EZConfig Bar Code window is open. If 
you close the window and reopen it, the password no longer appears due to the 
encryption.
To learn how to enter the password on the handheld computer, see How to Set a 
Custom Password for EZConfig Barcodes on page 50. 

Full screen 
progress dialog

This option runs the deployment progress dialog box on the handheld computer 
in full screen mode so that the user cannot open another application while the 
barcodes are being deployed on the computer. 

Warm boot 
after finished

This option is not supported for Android devices.
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Deployment Options
These options determine how to deploy the XML file on the handheld computer. 

Field Description

Replace remote 
file

Replaces the existing file; no section-level merge modes are applied. This option 
determines how the XML file should be deployed if an XML file of the same name 
and location exists on the handheld computer. 

When selected, the following options are available under “If already exists, 
deploy”:

• Always
Touch to always replace the existing file. 

• Only if newer
Touch to replace the existing file only if the file in the barcode is newer 
than the existing. 

• Never
Do not deploy the new file; this preserves the existing file. 

• Prompt
EZConfig Client asks the user if they want to overwrite the existing file 
during deployment. 

Merge each 
section…
(Default 
selection)

Deploys information according to the section-level merge mode settings; see 
About Section-Level Merge Modes on page 35.

When selected, the following options are available under “If already exists, 
deploy”:

• Always
The section-level merge mode settings are always used. 

• Only if newer
The section-level merge mode settings are only used if the sections are 
newer than the existing files on the computer. 

Temporary Temporarily deploys the XML file with a temporary name and then deletes the file 
after processing is finished. If the handheld computer contains a previous XML 
file with the same name, the previous XML file is preserved. 

When you enable the Temporary option, you should also enable the “Wait until 
finished” option in the documents Properties form. 

Warning: Applications that stay in the background (e.g., Scanwedge or Rasman) 
should not be used with temporary files.
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Persist Bar Code Settings
This option determines if the EZConfig Bar Code build settings are stored within 
the XML file and barcodes. 

About the Print and Save Options
On the Bar Codes tab, when you click Print, a barcode printing window opens 
offering you a number of printing options. 

Field Description

Persist bar 
code 
settings

When enabled ( ) the settings from the Bar Codes and Advanced tabs are stored 
within the XML file so that the same barcode settings are applied the next time a 
barcode is created. This increases the size of both the XML file and the 
barcode(s). 
If the Simplified option on the Bar Code tab is selected, barcode setting 
information is not included in the barcode but remains in the open XML file. 

Field/Option Description

Preview Area This is the largest section of the tab window and provides a preview of the 
barcode sheet. Use the scroll bars to see all the barcodes. 

Header Type in a custom header for the page. 

Footer Type in a custom footer for the page. 

Bar Code Scaling 
Factor

Adjusts the size of each barcode by scaling all of them up or down, which 
determines how many barcodes can fit on each page. This does not change 
the amount of data in each barcode, just the size of the barcode on the 
page. 

Save Saves the barcode sheet as an HTML file. 

Preview Select to see a print preview. Click Print on this window to print your 
barcodes. 
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CHAPTER

6

Dolphin Power To
ABOUT THE SCAN FEATURE IN THE 
EZCONFIG APP
Overview
The scan wedge feature in the EZConfig app on the handheld computer decodes 
configuration barcodes created in the advanced EZConfig Editor and updates the 
computer to the embedded configuration. If an application is associated with the 
XML file embedded in the barcode(s), the EZConfig app launches the application 
to process the decoded data.

The scan wedge feature in the EZConfig app decodes barcodes with 40-bit and 
128-bit encryption.

More Information
The scan wedge feature is managed through the Settings app. Swipe up from the 
bottom of the Home screen to access all apps and then select Scanning under 
Honeywell Settings. 

To learn more about managing the Scanning settings, see the user guide for your 
handheld computer model.

How to Scan EZConfig Barcodes
1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > EZConfig .

3. Aim the scanner at the first configuration barcode, and then select Scan on the 
screen. The total number of barcodes in the configuration set and the total 
number of barcodes successfully scanned appear on the screen. 

4. Scan the remaining barcode(s) in the set. The barcodes can be scanned in any 
order. 
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After the last barcode has been scanned, a “Decode success, try to configure” 
message appears indicating the new configuration has been saved in 
Internal shared storage\honeywell\persist\DeviceConfig.xml 

5. Reboot the computer to apply the changes.

Note: The XML files saved in the persist folders on the computer include the data 
embedded in the barcodes. The name of the files are the same as the name of the 
XML file used to generate the barcodes in the advanced EZConfig Editor. 

About Multiple Barcode Packages
Some XML files generate more than one barcode. If multiple barcodes were 
generated, the EZConfig app recognizes that there is more than one barcode in the 
package and tracks each barcode scanned and decoded. Barcodes can be scanned 
in any order, but the data is not deployed until all the barcodes in the package have 
been scanned. 

About the EZConfig Scan Window
The following information appears on the app screen when you scan an EZConfig 
barcode:

How to Set a Custom Password for EZConfig Barcodes
When you use the advanced EZConfig Editor to generate barcodes, you have the 
option to enable password-protection (page 45). If you enable the password 
requirement, the same password must be entered on the handheld computer or 
the barcode data does not process. 

Field Description

Is EZConfig barcode Identifies the scanned barcode as an EZConfig barcode. 

Total barcodes Displays the total number of barcodes in the set. 

Current barcode Identifies the last barcode scanned. 

Scanned barcodes Identifies all barcodes in the set that have been scanned. 
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To enable the password on the computer:

1. Touch  and then tap Set custom password. 

2. Check the Set custom password box.

3. Touch the entry field (green line) and enter the password. 

Passwords are case sensitive and must match the password created in the 
advanced EZConfig Editor when the barcode package was generated.

4. Touch outside the password box to exit the screen. 

Note: If the password entered does not match the password used when the barcode was 
created, the “This config file is not supported” message appears on the handheld 
computer. 

To remove the password:

1. Touch  and then tap Set custom password. 

2. Touch the box next to Set custom password to remove the check mark.

Touch  to open menu.
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CHAPTER

7

Dolphin Power To
ABOUT THE CONFIGURE AUTORUN 
AND AUTOINSTALL APPS
Overview
Two apps affect how the computer behaves on startup:

• Configure Autorun
Set the applications you want automatically launched after a computer reboot.

• AutoInstall 
Specify if files located in honeywell\autoinstall folders are automatically 
installed after a computer reboot.

About the Configure Autorun App
The Configure Autorun app is used to specify the applications you want 
automatically launched after a computer reboot. Applications that can be set to 
run automatically are listed on either the Normal screen or the Autorun screen. 
You can toggle between the two screens by selecting the heading. The heading that 
the app appears under indicates if it has been set to automatically run after a 
reboot. If an application is set to auto-run, it is moved from the Normal screen to 
the Autorun screen. 

How to Configure an App to Autorun
1. Swipe up from the bottom of the home screen to access all apps.

2. Touch Power Tools  > Configure Autorun .

3. Touch Normal if it is not already selected. 

4. Touch and hold an app. 

5. Touch OK to confirm. The app now appears on the Autorun tab instead of the 
Normal tab.

You can use the same method in reverse to remove an app from the Autorun list:
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1. Touch the Autorun tab if it is not selected. 

2. Touch and hold the app on the list you want to remove from the Autorun list. 

3. Touch OK to confirm. The app now appears on the Normal tab instead of the 
Autorun tab.

About the AutoInstall App
Note: AutoInstall requires Provisioning mode be turned On. To learn more see, About 

Provisioning Mode on page 4.

The AutoInstall feature is enabled by default. When AutoInstall is enabled, during 
the power-up boot or reboot process, the following folder is searched for zip files 
containing applications:

• \Internal shared storage\honeywell\autoinstall on the computer

Each zip file found is then compared to the applications already installed on the 
handheld computer and:

• If the application is not installed, AutoInstall installs the application.

• If the application is already installed, AutoInstall checks to see if the zip file 
contains a newer version of the application and then installs the newer version. 

• If the application is already installed and there is not a newer version, AutoInstall 
ignores the installation file.

When AutoInstall is not enabled, the contents of the autoinstall folders on the 
computer and on the SD card (if installed) are ignored.

How to Disable File AutoInstall 
1. Swipe up from the bottom of the home screen to access all apps.

2. Touch AutoInstall Settings .

3. Remove the check mark from the Enable AutoInstall box to disable the option.

About App Verification
The Verify apps feature is enabled by default in the AutoInstall app. This feature is 
used to protect against the installation of apps that may cause harm to the 
handheld computer. Upgrade files containing apps that are identified as possibly 
unsafe for the computer are either disallowed or a warning appears before the 
installation giving you a chance to prevent the install. 
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How to Manually Initiate an Upgrade Package
1. Swipe up from the bottom of the home screen to access all apps.

2. Touch AutoInstall Settings  .

3. Touch Packages update to load any upgrade packages in the autoinstall folder.
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CHAPTER

8

Dolphin Power To
ABOUT EZCONFIG BARCODES AND 
PROVISIONING
Overview
Create and scan EZConfig barcodes with the computer to automatically install 
applications, files and settings specific to your business environment.

When scanned, the barcode(s) instruct the handheld computer to download and 
install files from a network location set up by the device administrator. The source 
location defined in the barcode is typically a URL. The file types on the network can 
be software updates, software applications, licenses, XML configuration files or 
general files you want to copy to the computer. 

EZConfig barcodes are created using the advanced EZConfig Editor that runs on a 
workstation computer (e.g., laptop or desktop computer). The editor allows you to 
customize a Provisioner.xml file that defines the source location of the files and the 
action desired. After editing the Provisioner.xml file, you can generate barcode(s) 
from within the advanced editor, and then scan the code(s) with the handheld 
computer to implement the instructions.

More Information
• To learn how to download, install and use the optional advanced EZConfig 

Editor, see page 27.

• To learn more about default XML configuration files on the computer and their 
storage locations, see page 9.

Before you Start
Before you can create a custom Provisioner.xml file, you need to:

1. Identify the files you want installed on the computer. For each file you need to 
know the source location (network URL) and the action you want to perform.

Source Location (Network URL) Requirements and Guidelines

• Supported protocols are HTTP, HTTPS and FTP.
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• The source location must be accessible to the handheld computer (e.g., an 
active network connection is required).

• The source location cannot require a login. If a login is required by the server, 
the computer is unable to reach the files.

Possible Actions

• Install a software update.

• Install an Android software application.

• Install settings with an XML file.

• Install a license.

• Copy a file to a specific location on the computer.

• Run - send an Intent, start an Activity or Process

• Rename file or directory

• Create file or directory

• Delete file or directory

• Empty directory

• Reboot device

• Enterprise data reset device

• Full factory reset device

• setDeviceOwner

• Delay

• Install certificate

• wait for intent

• wait for network

• wait for reboot

2. Download and install EZConfig for Mobility on your workstation computer. The 
advanced EZConfig Editor is part of the EZConfig for Mobility software suite. 

To learn how to download and install EZConfig for Mobility, see page 27.

Note: In addition to EZConfig for Mobility, Honeywell also offers Enterprise Provisioner, 
which is a desktop application used to provision Honeywell Android devices that 
provides a more advanced and user-friendly experience than EZConfig for Mobility. 
Enterprise Provisioner can be downloaded from  honeywell.com/PSSsoftware-
downloads. 

3. Establish an active communication connection that allows file transfers 
between the handheld computer and your workstation computer.
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How to Edit the Provisioner.xml File 
1. Copy the generated Provisioner.xml file from the handheld computer to the 

workstation computer.

a. Open a file browser on your workstation (e.g., File Explorer or Windows 
Explorer).

b. Browse to the Internal shared 
storage\honeywell\ezconfig\generated folder on the handheld 
computer.

c. Copy the Provisioner.xml file to the workstation computer. You can use copy 
and paste or drag and drop commands.

2. Open the XML file in the advanced EZConfig Editor on your workstation 
computer.

a. Click Start > Honeywell >  EZConfig Editor.

b. Click File Open . 
c. Touch the Provisioner.xml file you copied to the workstation, and then click 

Open.
d. Click OK to continue if a message appears warning you the file was created 

with an older tool. 

3. Click on the Task section. You may need to click the plus “+” icon to expand the 
sections.

Each Task defines a set of instructions for a single file. How you edit the key 
values in the task determines the actions taken when the barcode is scanned. 
You can add more than one Task to the Provisioner.xml file if you have more 
than one file that requires instructions. To learn how to add additional tasks, 
see page 65. 
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4. Double-click on the Action key Value to open and select an action for the Task. 

5. Edit the relevant Value fields for the Source, Destination and Launch keys.

6. (Optional) Click File Save  if you want to keep a copy of the modified file on 
the workstation. 

About the Task Keys

Key Purpose

Action Sets how the file is processed after it is downloaded. 
Most Tasks handle one file and the Action value specifies how a file is 
processed after it is downloaded. For detailed information on each 
value, see About Action Values on page 61.

Source Specifies the source location of the file. The Source could be a URL or a 
local file depending on the Action value selected.
The URL specified must be accessible from the handheld computer via 
an active network connection and include the protocol used to access 
the file on a server (e.g., http:// or https://). Supported protocols are 
HTTP, HTTPS and FTP. 
The source location cannot require a log-in. If a log-in is required by the 
server, the handheld computer is unable to reach the files.

Destination The Destination key value is only relevant for the following Action 
values: Install File, Copy, Rename, Create File. The Destination key value 
is ignored for any other Action values.

Launch If the Action value is set to APK, the Launch value is the name of an 
application package that is opened after the installation completes. 
The Launch value is optional.

Reboot Forces a reboot after the file is installed. This option is not typically used 
since the device reboots as needed to complete an installation.
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About Action Values

DownloadRetryCount Specifies the number of minutes, as an integer, that the device will wait 
to retry downloading a file if there is an error, network error, server down 
issue, etc. 

The default is 60 minutes (one hour). This key can be used to specify a 
different amount of time.

For example, to retry in ten minutes specify this key as:
<Section name=’Tasks’>

<Section name=’Task’>
<Key name=’Action’>InstallApk</Key>
<Key name=’Source’>http://discovery.awmdwm.com/
mobileenrollment/airwatchagent.apk</Key>
<Key name=’DownloadRetryCount’>10</Key>

</Section>
</Section>

nvp Specifies the key value pairs. This is most often used in the 
setDeviceOwner task to specify the enrollment ID, server URL,password, 
etc.

Example:
<Section name=’Task’>

<Key name=’Action’>SetDeviceOwner</Key>
<Key name=’Destination’>com.airwatch.androidagent/
com.airwatch.agent.DeviceAdminstratorReceiver</Key>
<Key name=’nvp’ type=’string’>”serverurl”:”techp.awmdm.com”</
Key>
<Key name=’nvp’ type=’string’>”gid”:”RSAW”</Key>
<Key name=’nvp’ type=’string’>”un”:”RSAWTEST”</Key>
<Key name=’nvp’ type=’string’>”pw”:”Honeywell@2022”</Key>

</Section>

Key Purpose

Action Value XML Value File or 
Directory Type

Effect after downloading 
the file

Software Update InstallOta Over the Air (OTA) 
software update 
(*.zip)

Reboots the handheld computer 
and initiates the software update.

Install APK InstallApk Android application 
(*.apk)

Stores the file in non-volatile 
storage, reboots the computer, and 
then initiates application 
installation.
(Optional) The Launch value 
defines the package name to 
launch after the .apk installation. 
To learn more see About Launch 
Values.

Install License InstallLicense Honeywell Android 
application (*.xml)

Installs the license in secure 
storage.

Install Settings InstallExm Honeywell settings 
(*.xml)

Applies the settings in the file.
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Install File InstallFile Any file Copies the file to a specific location 
on the computer. The Destination 
value specifies full path and file 
name where the file is to be located.

Run Run Uses the Launch value to perform 
an action.

Copy Copy Any File or Directory Copies the local files and/or folder 
on the computer from one location 
to another. 
If the Source value is a folder, then 
the Destination value is treated as 
a folder.
If the Source value is a file and the 
Destination value ends in “/”, then 
the Destination is treated as a 
folder and the file is copied into the 
folder.
If the Source value is a file and the 
Destination value is a file, then the 
contents are copied to the 
destination file.

Rename Rename Any File or Directory Renames the local file or directory 
on the computer.

Create File CreateFile Any File Creates a new file.
Destination value defines the 
name of the file to be created.
Source value defines the content of 
the new file. For an empty file leave 
the field blank.

Create Directory CreateDirectory Any Directory Creates a new directory. The Source 
value defines the path of the 
directory to be created.

Delete File DeleteFile Any File Deletes the file specified in the 
Source value field.

Delete Directory DeleteDirectory Any Directory Deletes the directory specified in 
the Source value field.

Empty Directory EmptyDirectory Any Directory Deletes the contents of a directory 
but leaves the directory in place. 
The Source value defines the path 
of the directory to be emptied.

Reboot Reboot Reboots the device.

Full factory reset FactoryReset Resets the device to the factory 
state.

wait for intent Waits until the specified intent in 
source key is broadcast and before 
executing the next task.

wait for reboot Waits to execute the next task until 
after a reboot is done.

Action Value XML Value File or 
Directory Type

Effect after downloading 
the file
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About Launch Values
When Install APK or RUN is selected for the Action, you have the option to define a 
Launch key value. The Launch value must be the package name of the activity you 
want to automatically open after the install. Here are two methods for finding the 
package name of an application:

• If the application is installed on a computer and you use the Android Debug 
Bridge (ADB), run the command: adb shell pm list packages -f.

• If you developed the application, look in the AndroidManifest.xml file.

The following Launch values may be used for Install APK and Run actions.

How to Generate EZConfig Barcodes 
This section explains how to generate EZConfig Barcodes from within the 
advanced EZConfig Editor. You can also generate barcode packages from the 
EZConfig Packager utility. Both the advanced EZConfig Editor and the EZConfig 
Packager are part of the EZConfig for Mobility software suite. The EZConfig 
Packager utility provides the ability to add more than one XML file to an EZConfig 
barcode package. To learn more about the EZConfig Packager utility, see the user 
guide provided with the software.

wait for network Waits until the device is connected 
to a network before executing the 
next task.

install certificate Installs a certificate specified in the 
source path.

setDeviceOwner Sets the component name (i.e., 
Destination mentioned) mentioned 
as Device Owner. The destination 
value defines the component name.

Delay Specified in milliseconds. The 
device waits for the specified time 
and then executes the next task, if 
present.

Action Value XML Value File or 
Directory Type

Effect after downloading 
the file

Launch Value Action Taken Details

Starts with "am " Start an activity, start 
a service, or 
broadcast an intent.

See the Android documentation for the "am" android 
shell command.

Is a valid 
package name

Opens the front-door 
activity of an 
application. 

See the Android documentation for 
PackageManager.getLaunchIntentForPackage
(packageName).
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1. When you are finished editing the Provisioner.xml file, click the barcode  
icon in the tool bar.

2. Click Full Contents under “Options (apply to barcode only)”. 

3. Click Print. The default scale factor is 2. The lower the scale factor the larger the 
barcode size printed.

To learn more about generating barcodes with the advanced EZConfig Editor, see 
About Creating EZConfig Barcodes from XML Files on page 41.

How to Scan EZConfig Barcodes
Once you have generated barcodes based on the modified Provisioner.xml file, use 
the EZConfig app on the handheld computer to scan and implement the 
installation instructions.

Note: You may not need to manually open EZConfig. Some Honeywell handheld computers 
have the scanner enabled by default. Try pressing one of the scan buttons on the 
computer to activate and scan the barcode(s). If the scanner is already enabled, 
EZConfig automatically opens when you scan the first barcode.

1. Aim the scanner at the first configuration barcode, and then select Scan or 
press any Scan button (model dependent). 

The EZConfig app opens. Upon a successful scan, the display is updated to 
reflect the total number of configuration barcodes in the set and the total 
amount of code(s) that have been successfully scanned. 

2. Scan the remaining barcode(s) in the set. When all the barcodes in the package 
have been scanned, EZConfig deploys the installation instructions. 

To learn more, see About the Scan Feature in the EZConfig App on page 49.

How to Check the Status from the Notification Panel
A  notification icon appears in the status bar at the top of the screen when 
Provisioning actions are started. You can view additional status details by 
accessing the Notification Panel and the Provisioning Status screen. 

1. Swipe down from the top of the screen to open the Notification Panel.

2. Select the Provisioning notification.

3. The Setup Details screen displays the list of tasks and the task status.
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Clear the Status Screens and Hide the Provisioning Notification
1. Touch  in the upper right corner of the Provisioning status screen. 

2. Touch Clear Complete and Errors to clear the history and hide the provisioning 
notification.

About Boot and Enterprise Reset Tasks
If the Provisioner.xml file contains an EnterpriseResetTasks section, then all tasks 
in the section are saved and activated after subsequent Enterprise data resets. The 
section replaces all previously saved EnterpriseResetTasks sections.

If the Provisioner.xml file contains a BootTasks section, then all tasks in the section 
are saved and activated after subsequent reboots once the EnterpriseResetTasks 
have been completed. The BootTasks section replaces all previously saved 
BootTasks sections. 

How to Add a Task to the Provisioner.xml File
Each Task defines a set of instructions for a single file. 

1. Open the custom Provisioner.xml file in the advanced EZConfig Editor.

2. Right-click on an existing  Task.

3. Click Copy.

4. Right-click the  Task again, and then select Paste. 

5. Update the key Values for the new  Task.

How to Delete a Task in the Provisioner.xml File
1. Open the custom Provisioner.xml file in the advanced EZConfig Editor.

2. Right-click the  Task.

3. Click Delete.

Samples
The examples in this section are represented in XML. The XML file is compatible 
with the EZConfig for Mobility utility.
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Sample Pattern: Persist on Device
Purpose 

Install an application and maintain a backup copy on the device. 

Summary

• When the network is available, download the APK to persistent storage and 
install it.

• After Enterprise data reset, reinstall the APK from persistent storage.

Example of Provisioner.xml File

The table below shows how the tasks would be defined in the Provisioner.xml file 
using the editor in EZConfig for Mobility.

Sample Pattern: Persist on Server
Purpose 

Install an application and maintain a backup copy on the server. 

Summary

• Download and install the APK.

• After Enterprise data reset, re-download and install the APK.

Task

Section Key Value Task Summary

Task Action Install APK When the network (Source) is 
available, download the 
SampleApp.apk (Source) from 
the server to the computer’s 
persistent storage 
(Destination) as the same 
name, install the APK (Action), 
and then start its front-door 
activity (Launch).

Source http://my_server_url/SampleApp.apk

Destination %ipsm%/my_apks/SampleApp.apk

Launch com.example.SampleApp

EnterpriseResetTask

Section Key Value Task Summary

Task Action Install APK After Enterprise data reset, 
install APK (Action and 
Source) into Android, and 
then start its front-door 
activity (Launch). No 
Destination is required since 
the .apk file is located on the 
device.

Source %ipsm%/my_apks/SampleApp.apk

Destination

Launch com.example.SampleApp
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Example of Provisioner.xml File

The table below shows how the tasks would be defined in the Provisioner.xml file 
using the editor in EZConfig for Mobility.

Sample Pattern: Two-stage Provisioning
Purpose

To keep the initial barcode package small when provisioning many files.

Summary

Use the EZPackager utility to create a small barcode package that includes two 
XML files:

• DeviceConfig.xml
This file configures the device network settings for access to the source 
server where the full Provisoner.xml file should be located.

• Provisioner.xml 
This file includes a single task. The task should define the action to download 
the full Provisioner.xml file from the server to the computer and then Launch 
the XML configuration. The full Provisioner.xml file that resides on the server 
lists the complete steps of the installation.

Note: The EZPackager utility is part of the EZConfig for Mobility software suite. To learn 
more about how to use EZPackager, see the user guide provided with the software.

Task

Section Key Value Result

Task Action Install APK When the network (Source) is 
available, download the 
SampleApp.apk (Source) from 
the server to the computer’s 
persistent storage, install the 
APK (Action), and then start 
its front-door activity 
(Launch).

Source http://my_server_url/SampleApp.apk

Destination

Launch com.example.SampleApp

EnterpriseResetTask

Section Key Value Result

Task Action Install APK After Enterprise data reset, 
download the SampleApp.apk 
(Source) from the server to 
the computer’s persistent 
storage, install the APK 
(Action), and then start its 
front-door activity (Launch).

Source http://my_server_url/SampleApp.apk

Destination

Launch com.example.SampleApp
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How to Clear Old Provisioning Tasks on a Test Computer
While developing and testing Provisioner.xml files, you may need to clear the 
provisioning tasks from your test computer. Tasks can be cleared using a 
Provisioner.xml file. The results of the prior provisioning tasks remain intact, such 
as installed applications and files. 

You can generate a barcode that contains Provisioning commands to clear all 
current tasks and empty the Enterprise-reset tasks. Create the barcode using 
EZConfig for Mobility with the following XML file:

<?xml version="1.0" encoding="UTF-8"?>
<ConfigDoc name="Provisioner">
  <Section name="CommandTask">
    <Key name="Action">ClearAllTasks</Key>
  </Section>
  <Section name="EnterpriseResetTasks">
  </Section>
  <HHPReserved name="Tool Version">
    <Key name="EXMVersion" flags="16">1.0.1</Key>
  </HHPReserved>
</ConfigDoc>
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CHAPTER

9

Dolphin Power To
ABOUT THE NETWORK APPS
Overview
The WirelessTether app gives you the ability to enable range tracking and 
customize out-of-range alerts for Bluetooth devices paired and tethered to your 
handheld computer. To learn more, see About the WirelessTether App on page 69.

The WiFi Diagnostic app provides a central location to view diagnostic information 
about connected and available Wi-Fi networks within range of the WLAN radio in 
the computer. Additional utilities within the WiFi Diagnostic app mirror command 
prompt functions (DOS-prompts) used on your workstation computer. To learn 
more, see About the WiFi Diagnostic App on page 70.

The OBDQuickLink app can write, erase, or update the NFC connection between a 
handheld computer and a vehicle dock. To learn more, see About OBDQuickLink on 
page 73.

About the WirelessTether App
Once you pair Bluetooth devices (e.g., printers, scanners, and headsets) with your 
handheld computer, you can use the WirelessTether app to set up custom 
out-of-range tracking alerts for the devices. You can set a custom alert for each 
device being tracked by configuring the following settings:

• Alert type
Set the alert type to either Alert dialog or Notification/Toast.

• Vibration
Turn vibration feedback on or off for an out-of-range alert.

• Sound
Turn sound feedback on or off for an out-of-range alert. 
When sound is enabled, select from the list of available sound options. 
If multiple devices are tethered to the computer, device identification is easy 
when you set a different sound for each device tethered to the computer. 
ols 12.x User Guide 69



Enable and Configure Bluetooth Device Out-of-Range Alerts 
Note: Before using the WirelessTether app, you must pair the Bluetooth device with your 

handheld computer and the device must be in Bluetooth communication range. To 
learn how, see the user guide for your handheld computer model.

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > WirelessTether .

3. Touch a device from the Paired devices list. 

Once the link is established, the device appears under Tethered devices. 

4. (Optional) Touch the settings icon  next to the tethered device to customize 
the out-of-range alert.

a. Select a notification type (i.e., Alert dialog or Notification/Toast).

b. Turn Vibration feedback on  or off .

c. Turn Sound feedback on  or off .
d. Select an alert Sound from the list. Swipe up or down to scroll through the 

options.

5. Touch the Back button to return to the Wireless Tether screen.

How to Untether a Device

1. Open the WirelessTether  app.

2. Touch a device from the Tethered devices list. 

3. Touch OK to confirm you want to untether the device from the computer.

About the WiFi Diagnostic App
The WiFi Diagnostic app provides a central location to view data about connected 
and available Wi-Fi network access points within range of the integrated WLAN 
radio in the mobile computer. You can also troubleshoot a network connection 
using the built-in Ping utility or assign a static IP Address with the IPConfig utility. 

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > WiFi Diagnostic . 

3. Select one of the following:

• WIFI INFO — View information on the active WI-FI network connection, 
including the WiFi NIC (IP and MAC address), the access point (Status, ESSI, 
and BSSID), the configuration used (Cipher, Group Ciphers, and Protocol) 
and RF signal information (RSSI, Link and Channel).
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• SCAN — Scan for available network access points within range of the WLAN 
radio. A list of network access points appears with specifications for each, 
including MAC address, channel, encryption, band and RSSI value. You can 
change the network scan behavior by selecting the TimerScan On/Off 
button. The default scan time is 2 seconds.

• PING — Select to access the ping utility. To learn more, see How to Use the 
Ping Utility in the WiFi Diagnostic App on page 72.

• RSSI — Select to view Received Signal Strength Indicator (RSSI) for the 
current AP network connection.

View Computer Network Adapter Information
1. Swipe up from the bottom of the Home screen to access all apps. 

2. Open the WiFi Diagnostic  and then select WIFI INFO. 

3. Touch  and then select IPConfig.

Listed under each onboard network adapter name (e.g., wlan0) are specifica-
tions relevant for that specific adapter, including the following:

• MAC Addr — MAC address of the network adapter. 

• IP Addr — IP address of the network adapter. 

• Subnet Mask — Subnet mask for the IP address of the network adapter.

• Flags — Interface flags.

Configure a Network Adapter Interface to Use a Static IP Address
Built into the WiFi Diagnostic app is an IPConfig utility that displays and modifies 
IP parameters for the onboard network adapters in the computer. You can use the 
IPConfig utility to configure the onboard network adapter to use a static IP 
address.

1. Open the WiFi Diagnostic app  and then select WIFI INFO. 

2. Touch  and then select IPConfig.

3. Touch the adapter you want to configure.

4. Check the Use static IP box. 

5. Touch one of the following and enter the appropriate information in IP address 
format.

• IP address — Set static IP Address

• Gateway — Set gateway Address

• DNS1 — Set preferred Domain Name Server Address
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• DNS2 — Set alternate Domain Name Server Address

6. Touch  to dismiss the keyboard, and then OK.

7. Touch Apply to save configuration.

How to Use the Ping Utility in the WiFi Diagnostic App
Built into the WiFi Diagnostic app is a Ping utility that provides a GUI-based 
version of the traditional command line ping utility. Pinging sends out an echo 
request from the mobile computer to a specific computer on a network. Use the 
Ping utility to test communication links or to verify a specific IP address is working. 

1. Open the WiFi Diagnostic app .

2. Select PING.

3. Input the destination (IP Address) using the keypad or virtual keyboard. 

On computer models with only a touch screen, select  to dismiss the 
keyboard.

4. Touch  to initiate the ping utility. The ping statistics appear on the screen.

5. Touch  to stop the ping utility.

6. (Optional) Touch  and then select Clear to delete the results from the screen.

Modify the Ping Utility

1. Open the WiFi Diagnostic app .

2. Select PING.

3. Touch  and then select Settings.

4. Touch and modify any of the following settings: 

• Timeout — Set the time (seconds) to wait for a response.

• Send packet size — Set the packet size (data bytes) to be sent. The default is 
64. 

• Send count — Set the number of ECHO_REQUEST packets to send. Infinite 
is the default. 

• TTL — Set the Time To Live (TTL). TTL is the maximum number of times a 
packet is allowed to travel through the network before it is discarded. 

• TOS — Set the Type of Service (TOS); it should be eight bits broken into five 
subfields. 
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• MTU discovery — Select the path Maximum Transmission Unit (MTU) 
discovery. 

• Wait seconds — Indicate the wait interval between sending each packet.

5. If applicable, select  to dismiss the keyboard, and then select OK.

6. Touch Back to return to the Ping utility screen.

View Route Information in the WiFi Diagnostic App
Built into the WiFi Diagnostic app is a Route utility that allows you to view the rules 
that govern how packets destined for various subnets are routed. These rules 
define gateways on an interface subnet that the computer may use to route 
packets to hosts on other subnets when a connection is established. Use the app to 
view IP Address route information, including: Destination, Gateway, Mask, Iface 
and Metric.

1. Open the WiFi Diagnostic app  and then select WIFI INFO. 

2. Touch  and then select Route. 

 About OBDQuickLink
Use Honeywell OBDQuickLink to write, erase, or update the NFC connection 
between a handheld computer and a vehicle dock. This app does not receive any 
data from the On-Board Diagnostics (OBD) system adapter.

Connect to a Vehicle Dock
Follow these steps to establish the NFC connection between a mobile computer 
and a vehicle dock. Refer to the quick start guide for the vehicle dock for specific 
information for that model.

1. Insert the mobile computer into the vehicle dock.

2. Swipe up from the bottom of the Home screen to access all apps.

3. Tap Power Tools > OBDQuickLink.

4. Available OBD Devices are listed. If you do not see the vehicle dock listed, tap 
Re-Scan.

5. Select the vehicle dock OBD device and tap Write to NFC.

6. The mobile computer is now connected to the vehicle dock.
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CHAPTER

10

Dolphin Power To
BATTERY AND DIAGNOSTIC 
INFORMATION
Overview
Important system and battery diagnostic information is available through the 
BattMon app (see below) and Diagnostic Information app (see page 76) on the 
handheld computer. Use ConfigApps to enable or disable applications and 
application updates.

 About the BattMon App
Use the BattMon app to view information on the charge status and health of the 
battery or to activate battery status notifications and enable recording the battery 
charging history. When you open the app, the following information appears on the 
screen:

• The battery charge level (%) is indicated in text format.

• The battery health appears under the charge level.

• The wallpaper contains a battery icon that is shaded blue in 20% increments to 
correspond to the level of battery charge.

• The battery icon displays a lightning bolt graphic when external power is 
attached.

Note: To start BattMon automatically after each reboot, move the BattMon app from the 
Normal list to the Autorun list in the Config Autorun app (see page 53). 

How to Record and View the Battery Charging History
1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > BattMon .
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3. Touch the on /off  switch to toggle recording the battery charging 
history. The default setting for this option is off. 

4. To view the log, select  at the top of the app screen.

5. Touch  to return to the BattMon screen.

How to Delete All Charging Records

1. Open the BattMon app , and then select  at the top of the app screen.

2. Touch .

3. Touch OK to confirm deleting all records.

4. Touch  to return to the BattMon screen.

How to Enable or Disable Battery Status Notifications
1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > BattMon .

3. Touch the on /off  switch to toggle battery status notifications on or off. 
The default setting for this option is off. 

A BattMon icon  appears in the status bar at the top of the screen and a 
“BattMon is working” notification shows if you swipe down from the top of the 
screen.

 About the Diagnostic Information App
The Diagnostic Information app provides a central location to find important 
diagnostic and system information about the handheld computer. The main 
dashboard shows general Notifications about the battery charge level, the battery 
health, and WLAN AP associations. Wi-Fi and Phone signal strengths are listed 
along with the percentage of charge remaining on the battery. Touch Connections, 
System Memory, SysInfo, Devices, or Information from the dashboard to view 
detailed statistics about an item.

How to View Connection Information
To view the status of any Ethernet, USB, or ActiveSync (if supported) connection:
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1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > Diagnostic Information .

3. Touch Connections to view information on each connection type.

4. Touch  to return to the Diagnostic Information screen.

Note: To refresh the information, tap .

How to View System Memory Statistics
To view used, free and total space statistics about the Storage, Flash Memory or 
Physical Memory:

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > Diagnostic Information .

3. Touch System Memory.

4. Touch  to return to the Diagnostic Information screen.

Note: To refresh the information, tap .

How to View SysInfo
To view a detailed compilation of information on firmware versions, application 
versions, system parameters, as well as network and radio information:

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > Diagnostic Information .

3. Touch SysInfo. Swipe up or down to scroll through the information.

4. (Optional) Touch  and then Save to generate a SYSINFO.txt file under the 
Internal shared storage\honeywell\sysinfo folder on the computer.

5. Touch  to return to the Diagnostic Information screen.

The information displayed is not editable from the System Info screen. Only 
changes made to the computer configuration affect the System Info list. 
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How to View Information About Integrated and Connected Devices
To access additional links to statistics on any integrated devices (e.g., scanner, 
camera, GPS, Bluetooth, USB) or wired devices connected to the computer:

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > Diagnostic Information .

3. Touch Devices. 

4. Touch a device on the list to view detailed information. 

For example, if Scanner is selected, you can view the Scanner ID, Scanner 
Name, Frame Width, Frame Height, Full Decoder Version, Fast Decoder Version, 
and Control Logic Version.

5. Touch  to return to the Diagnostic Information screen.

Note: To refresh the information, tap .

How to View Information About the Computer
1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > Diagnostic Information .

3. Touch Information. Swipe up or down to scroll through the following:

• Model Number

• Device Name

• Android version

• Processor info

• Build Number

• Serial Number

• OEM Information

• Hardware configuration

• Wi-Fi Mac Address

• Bluetooth Mac Address

4. Touch  to return to the Diagnostic Information screen.

Note: To refresh the information, tap .
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 About ConfigApps
ConfigApps allows you to enable or disable applications on the device without 
removing them. You can also uninstall updates to applications.

Enable or Disable Applications
Follow these steps to enable or disable apps that are installed on the device. When 
an app is disabled, it will not appear on the screen to select.

1. Swipe up from the bottom of the Home screen to access all apps. 

2. Touch Power Tools  > ConfigApps .

3. Tap an app in the list to turn it on or off. The check box indicates if the app is 
enabled or disabled.

Uninstall Updates
Follow these steps to uninstall updates that have been installed on a selected app.

1. Swipe up from the bottom of the Home screen to access all apps.

2. Touch Power Tools  > ConfigApps .

3. Select Uninstall Updates.

4. Tap an app in the list.

5. The system displays a prompt to verify that you want to uninstall updates. Tap 
Uninstall Updates.
A message indicates if the updates have been uninstalled successfully or not.
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APPENDIX

A

Dolphin Power To
REFERENCE CHARTS
ASCII Conversion Chart (Code Page 1252)
Note: This table applies to U.S. style keyboards. Certain characters may differ depending on 

your Country Code/PC regional settings.

Non-Printable Characters

DEC HEX Character (Code) DEC HEX Character (Code)

0 00 NULL (NUL) 16 10 DATA LINK ESCAPE (DLE)

1 01 START OF HEADING (SOH) 17 11 DEVICE CONTROL 1 (DC1)

2 02 START OF TEXT (STX) 18 12 DEVICE CONTROL 2 (DC2)

3 03 END OF TEXT (ETX) 19 13 DEVICE CONTROL 3 (DC3)

4 04 END OF TRANSMISSION 
(EOT)

20 14 DEVICE CONTROL 4 (DC4)

5 05 END OF QUERY (ENQ) 21 15 NEGATIVE 
ACKNOWLEDGEMENT (NAK)

6 06 ACKNOWLEDGE (ACK) 22 16 SYNCHRONIZE (SYN)

7 07 BEEP (BEL) 23 17 END OF TRANSMISSION 
BLOCK (ETB)

8 08 BACKSPACE (BS) 24 18 CANCEL (CAN)

9 09 HORIZONTAL TAB (HT) 25 19 END OF MEDIUM (EM)

10 0A LINE FEED (LF) 26 1A SUBSTITUTE (SUB)

11 0B VERTICAL TAB (VT) 27 1B ESCAPE (ESC)

12 0C FORM FEED (FF) 28 1C FILE SEPARATOR (FS) RIGHT 
ARROW

13 0D CARRIAGE RETURN (CR) 29 1D GROUP SEPARATOR (GS) 
LEFT ARROW

14 0E SHIFT OUT (SO) 30 1E RECORD SEPARATOR (RS) 
UP ARROW

15 0F SHIFT IN (SI) 31 1F UNIT SEPARATOR (US) 
DOWN ARROW
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Printable Characters

DEC HEX Character DEC HEX Character DEC HEX Character 

32 20 <SPACE> 64 40 @ 96 60 `

33 21 ! 65 41 A 97 61 a

34 22 " 66 42 B 98 62 b

35 23 # 67 43 C 99 63 c

36 24 $ 68 44 D 100 64 d

37 25 % 69 45 E 101 65 e

38 26 & 70 46 F 102 66 f

39 27 ' 71 47 G 103 67 g

40 28 ( 72 48 H 104 68 h

41 29 ) 73 49 I 105 69 i

42 2A * 74 4A J 106 6A j

43 2B + 75 4B K 107 6B k

44 2C , 76 4C L 108 6C l

45  2D - 77 4D M 109 6D m

46 2E . 78 4E N 110 6E n

47 2F / 79 4F O 111 6F o

48 30 0 80 50 P 112 70 p

49 31 1 81 51 Q 113 71 q

50 32 2 82 52 R 114 72 r

51 33 3 83 53 S 115 73 s

52 34 4 84 54 T 116 74 t

53 35 5 85 55 U 117 75 u

54 36 6 86 56 V 118 76 v

55 37 7 87 57 W 119 77 w

56 38 8 88 58 X 120 78 x

57 39 9 89 59 Y 121 79 y

58 3A : 90 5A Z 122 7A z

59 3B ; 91 5B [ 123 7B {

60 3C < 92 5C \ 124 7C |

61 3D = 93 5D ] 125 7D }

62 3E > 94 5E ^ 126 7E ~

63 3F ? 95 5F _ 127 7F <DEL>

Extended ASCII Characters

DEC HEX Character DEC HEX Character DEC HEX Character

128 80 € 171 AB « 214 D6 Ö
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129 81 172 AC ¬ 215 D7 ×

130 82 ‚ 173 AD 216 D8 Ø

131 83 ƒ 174 AE ® 217 D9 Ù

132 84 „ 175 AF ¯ 218 DA Ú

133 85 … 176 B0 ° 219 DB Û

134 86 † 177 B1 ± 220 DC Ü

135 87 ‡ 178 B2 ² 221 DD Ý

136 88 ˆ 179 B3 ³ 222 DE Þ

137 89 ‰ 180 B4 ´ 223 DF ß

138 8A Š 181 B5 ? 224 E0 à

139 8B ‹ 182 B6 ¶ 225 E1 á

140 8C Œ 183 B7 · 226 E2 â

141 8D 184 B8 ¸ 227 E3 ã

142 8E Ž 185 B9 ¹ 228 E4 ä

143 8F 186 BA º 229 E5 å

144 90 187 BB » 230 E6 æ

145 91 ‘ 188 BC ¼ 231 E7 ç

146 92 ’ 189 BD ½ 232 E8 è

147 93 “ 190 BE ¾ 233 E9 é

148 94 ” 191 BF ¿ 234 EA ê

149 95 • 192 C0 À 235 EB ë

150 96 – 193 C1 Á 236 EC ì

151 97 — 194 C2 Â 237 ED í

152 98 ˜ 195 C3 Ã 238 EE î

153 99 ™ 196 C4 Ä 239 EF ï

154 9A š 197 C5 Å 240 F0 ð

155 9B › 198 C6 Æ 241 F1 ñ

156 9C œ 199 C7 Ç 242 F2 ò

157 9D 200 C8 È 243 F3 ó

158 9E ž 201 C9 É 244 F4 ô

159 9F Ÿ 202 CA Ê 245 F5 õ

160 A0   203 CB Ë 246 F6 ö

161 A1 ¡ 204 CC Ì 247 F7 ÷

162 A2 ¢ 205 CD Í 248 F8 ø

163 A3 £ 206 CE Î 249 F9 ù

164 A4 ? 207 CF Ï 250 FA ú

165 A5 ¥ 208 D0 Ð 251 FB û

166 A6 ¦ 209 D1 Ñ 252 FC ü

Extended ASCII Characters (Continued)

DEC HEX Character DEC HEX Character DEC HEX Character
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Symbology Chart

167 A7 § 210 D2 Ò 253 FD ý

168 A8 ¨ 211 D3 Ó 254 FE þ

169 A9 © 212 D4 Ô 255 FF ÿ

170 AA ª 213 D5 Õ

Extended ASCII Characters (Continued)

DEC HEX Character DEC HEX Character DEC HEX Character

Symbology Code ID (hex)

All Symbologies  (0x99)

Australian Post A  (0x41)

Aztec Code z  (0x7A)

British Post B  (0x42)

Canadian Post C  (0x43)

China Post Q  (0x51)

Chinese Sensible Code (Han Xin Code) H  (0x48)

Codabar a  (0x61)

Codablock A V  (0x56)

Codablock F q  (0x71)

Code 11 h  (0x68)

Code 128 j  (0x6A)

GS1-128 I  (0x49)

Code 32 Pharmaceutical (PARAF) <  (0x3C)

Code 39 (supports Full ASCII mode) b  (0x62)

Code 49 l  (0x6C)

Code 93 and 93i i  (0x69)

Data Matrix w (0x77)

EAN-13 (including Bookland EAN) d  (0x64)

EAN-13 with Add-On d   (0x64)

EAN-13 with Extended Coupon Code d   (0x64)

EAN-8 D (0x44)

EAN-8 with Add-On D    (0x44)

GS1 Composite y  (0x79)

GS1 DataBar y  (0x79)

GS1 DataBar Limited {  (0x7B)

GS1 DataBar Omnidirectional y  (0x79)

GS1 DataBar Expanded }  (0x7D)

InfoMail ,  (0x2c)
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Intelligent Mail Bar Code M  (0x4D)

Interleaved 2 of 5 e  (0x65)

Japanese Post J  (0x4A)

KIX (Netherlands) Post K  (0x4B)

Korea Post ?  (0x3F)

Matrix 2 of 5 m  (0x6D)

MaxiCode x  (0x7 8)

MicroPDF417 R  (0x52)

MSI g  (0x67)

NEC 2 of 5 Y (0x59)

OCR MICR (E 13 B) O  (0x4F)

OCR SEMI Font O  (0x4F)

OCR-A O  (0x4F)

OCR-B O  (0x4F)

PDF417 r (0x72)

Planet Code L  (0x4C)

Postal-4i N  (0x4E)

Postnet P  (0x50)

QR Code and Micro QR Code s  (0x73)

Straight 2 of 5 IATA f  (0x66)

Straight 2 of 5 Industrial f  (0x66)

TCIF Linked Code 39 (TLC39) T  (0x54)

Telepen t (0x54)

UPC-A c (0x63)

UPC-A with Add-On c    (0x63)

UPC-A with Extended Coupon Code c   (0x63)

UPC-E E  (0x45)

UPC-E with Add-On E    (0x45)

UPC-E1 E    (0x45)

Symbology Code ID (hex)
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Country Codes
For the latest information on ISO 3166, International Standard for country codes 
and codes for their subdivisions, go to www.iso.org/iso/country_codes.

Country Name Alpha-2 
Code Country Name Alpha-2 

Code

Afghanistan AF Liberia LR

Åland Islands AX Libya LY

Albania AL Liechtenstein LI

Algeria DZ Lithuania LT

American Samoa AS Luxembourg LU

Andorra AD Macao MO

Angola AO Macedonia, the former Yugoslav 
Republic of

MK

Anguilla AI Madagascar MG

Antarctica AQ Malawi MW

Antigua and Barbuda AG Malaysia MY

Argentina AR Maldives MV

Armenia AM Mali ML

Aruba AW Malta MT

Australia AU Marshall Islands MH

Austria AT Martinique MQ

Azerbaijan AZ Mauritania MR

Bahamas BS Mauritius MU

Bahrain BH Mayotte YT

Bangladesh BD Mexico MX

Barbados BB Micronesia, Federated States of FM

Belarus BY Moldova, Republic of MD

Belgium BE Monaco MC

Belize BZ Mongolia MN

Benin BJ Montenegro ME

Bermuda BM Montserrat MS

Bhutan BT Morocco MA

Bolivia, Plurinational State of BO Mozambique MZ

Bonaire, Sint Eustatius and Saba BQ Myanmar MM

Bosnia and Herzegovina BA Namibia NA

Botswana BW Nauru NR

Bouvet Island BV Nepal NP

Brazil BR Netherlands NL

British Indian Ocean Territory IO New Caledonia NC
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Brunei Darussalam BN New Zealand NZ

Bulgaria BG Nicaragua NI

Burkina Faso BF Niger NE

Burundi BI Nigeria NG

Cambodia KH Niue NU

Cameroon CM Norfolk Island NF

Canada CA Northern Mariana Islands MP

Cape Verde CV Norway NO

Cayman Islands KY Oman OM

Central African Republic CF Pakistan PK

Chad TD Palau PW

Chile CL Palestine, State of PS

China CN Panama PA

Christmas Island CX Papua New Guinea PG

Cocos (Keeling) Islands CC Paraguay PY

Colombia CO Peru PE

Comoros KM Philippines PH

Congo CG Pitcairn PN

Congo, the Democratic Republic 
of the

CD Poland PL

Cook Islands CK Portugal PT

Costa Rica CR Puerto Rico PR

Côte d'Ivoire CI Qatar QA

Croatia HR Réunion RE

Cuba CU Romania RO

Curaçao CW Russian Federation RU

Cyprus CY Rwanda RW

Czech Republic CZ Saint Barthélemy BL

Denmark DK Saint Helena, Ascension and 
Tristan da Cunha

SH

Djibouti DJ Saint Kitts and Nevis KN

Dominica DM Saint Lucia LC

Dominican Republic DO Saint Martin (French part) MF

Ecuador EC Saint Pierre and Miquelon PM

Egypt EG Saint Vincent and the Grenadines VC

El Salvador SV Samoa WS

Equatorial Guinea GQ San Marino SM

Eritrea ER Sao Tome and Principe ST

Estonia EE Saudi Arabia SA

Country Name Alpha-2 
Code Country Name Alpha-2 

Code
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Ethiopia ET Senegal SN

Falkland Islands (Malvinas) FK Serbia RS

Faroe Islands FO Seychelles SC

Fiji FJ Sierra Leone SL

Finland FI Singapore SG

France FR Sint Maarten (Dutch part) SX

French Guiana GF Slovakia SK

French Polynesia PF Slovenia SI

French Southern Territories TF Solomon Islands SB

Gabon GA Somalia SO

Gambia GM South Africa ZA

Georgia GE South Georgia and the South 
Sandwich Islands

GS

Germany DE South Sudan SS

Ghana GH Spain ES

Gibraltar GI Sri Lanka LK

Greece GR Sudan SD

Greenland GL Suriname SR

Grenada GD Svalbard and Jan Mayen SJ

Guadeloupe GP Swaziland SZ

Guam GU Sweden SE

Guatemala GT Switzerland CH

Guernsey GG Syrian Arab Republic SY

Guinea GN Taiwan, Province of China TW

Guinea-Bissau GW Tajikistan TJ

Guyana GY Tanzania, United Republic of TZ

Haiti HT Thailand TH

Heard Island and McDonald 
Islands

HM Timor-Leste TL

Holy See (Vatican City State) VA Togo TG

Honduras HN Tokelau TK

Hong Kong HK Tonga TO

Hungary HU Trinidad and Tobago TT

Iceland IS Tunisia TN

India IN Turkey TR

Indonesia ID Turkmenistan TM

Iran, Islamic Republic of IR Turks and Caicos Islands TC

Iraq IQ Tuvalu TV

Ireland IE Uganda UG

Country Name Alpha-2 
Code Country Name Alpha-2 

Code
88 Dolphin Power Tools 12.x User Guide



Isle of Man IM Ukraine UA

Israel IL United Arab Emirates AE

Italy IT United Kingdom GB

Jamaica JM United States US

Japan JP United States Minor Outlying 
Islands

UM

Jersey JE Uruguay UY

Jordan JO Uzbekistan UZ

Kazakhstan KZ Vanuatu VU

Kenya KE Venezuela, Bolivarian Republic of VE

Kiribati KI Viet Nam VN

Korea, Democratic People's 
Republic of

KP Virgin Islands, British VG

Korea, Republic of KR Virgin Islands, U.S. VI

Kuwait KW Wallis and Futuna WF

Kyrgyzstan KG Western Sahara EH

Lao People's Democratic Republic LA Yemen YE

Latvia LV Zambia ZM

Lebanon LB Zimbabwe ZW

Lesotho LS

Country Name Alpha-2 
Code Country Name Alpha-2 

Code
Dolphin Power Tools 12.x User Guide 89



90 Dolphin Power Tools 12.x User Guide





™ 

Honeywell 
855 S. Mint St.
Charlotte, NC  28202

sps.honeywell.com

PTL-A-EN-UG Rev B
1/23

https://sps.honeywell.com

	Power Tools
	Customer Support
	Technical Assistance

	Introduction
	Overview
	About Graphic and Hardware References Included in this Guide
	Access All Apps

	Software Requirements
	Handheld Computers
	Workstation Computers

	How to Access the Power Tools
	About the Power Tools
	Exit the Power Tools

	About Software Updates
	About Provisioning Mode
	Enable Provisioning Mode

	Software Downloads
	About Transferring Files via USB Connection

	Install Software Updates with AutoInstall
	Optional microSD Card Method

	About the Honeywell Upgrader
	Install OTA Updates


	About File Storage on the Computer
	Overview
	More Information

	Default XML Storage Locations on the Computer
	About File Directories
	Viewing File Directories
	Directory Descriptions


	About the AutoInstall Folders
	XML File Descriptions and Locations for Power Tools 12.x

	How to Configure the Handheld Computer
	Overview
	More Information

	Configure the Computer Using the Standard Editor
	Configure the Computer Using the Advanced Editor and AutoInstall
	Configure the Computer Using the Advanced Editor and Barcodes

	About the EZConfig Standard Editor and Generator
	Overview
	More Information

	About the Generator in the EZConfig App
	How to Use the Generator to Create a Custom XML File

	How to Open an XML File in the Standard Editor
	About the XML File Structure and Standard Editor
	How to Edit an XML File
	About Launching Associated Applications


	About the Advanced EZConfig Editor
	Overview
	More Information

	How to Install EZConfig for Mobility
	How to Open an XML File in the Advanced Editor
	About the Toolbar and Menus
	File Menu
	Edit Menu
	View Menu
	Tools Menu

	View Open XML Files in the Advanced EZConfig Editor
	How to Read the Status Bar
	How to Work with Sections
	About the Edit Menu Commands for Sections
	How to Modify a Section Name
	How to Modify a Section Description
	How to Move a Section
	How to Copy Sections Between Two XML Files
	About Section Locks
	About Section-Level Merge Modes
	How to Change a Section-Level Merge Mode

	How to Work with Keys
	About the Edit Menu Commands for Keys
	How to Modify Key Names
	How to Modify Key Values
	How to Modify Key Descriptions
	How to Move Keys
	How to Copy Keys Between Two XML Files
	About Key Lock Types
	How to Change a Key Lock Type


	Save an XML File Directly to the Handheld Computer
	How to Create a New XML Configuration Document
	About Creating EZConfig Barcodes from XML Files
	How to Generate EZConfig Barcodes from an XML File
	How to Change the Barcode Size and Quantity
	About the EZConfig Bar Code Window
	About the Bar Code Tab Settings
	About the Advanced Tab Settings
	About the Print and Save Options



	About the Scan Feature in the EZConfig App
	Overview
	More Information

	How to Scan EZConfig Barcodes
	About Multiple Barcode Packages
	About the EZConfig Scan Window
	How to Set a Custom Password for EZConfig Barcodes


	About the Configure Autorun and AutoInstall Apps
	Overview
	About the Configure Autorun App
	How to Configure an App to Autorun

	About the AutoInstall App
	How to Disable File AutoInstall
	About App Verification
	How to Manually Initiate an Upgrade Package


	About EZConfig Barcodes and Provisioning
	Overview
	More Information

	Before you Start
	How to Edit the Provisioner.xml File
	About the Task Keys

	How to Generate EZConfig Barcodes
	How to Scan EZConfig Barcodes
	How to Check the Status from the Notification Panel
	Clear the Status Screens and Hide the Provisioning Notification

	About Boot and Enterprise Reset Tasks
	How to Add a Task to the Provisioner.xml File
	How to Delete a Task in the Provisioner.xml File
	Samples
	Sample Pattern: Persist on Device
	Sample Pattern: Persist on Server
	Sample Pattern: Two-stage Provisioning

	How to Clear Old Provisioning Tasks on a Test Computer

	About the Network Apps
	Overview
	About the WirelessTether App
	Enable and Configure Bluetooth Device Out-of-Range Alerts
	How to Untether a Device


	About the WiFi Diagnostic App
	View Computer Network Adapter Information
	Configure a Network Adapter Interface to Use a Static IP Address
	How to Use the Ping Utility in the WiFi Diagnostic App
	Modify the Ping Utility

	View Route Information in the WiFi Diagnostic App

	About OBDQuickLink
	Connect to a Vehicle Dock


	Battery and Diagnostic Information
	Overview
	About the BattMon App
	How to Record and View the Battery Charging History
	How to Delete All Charging Records
	How to Enable or Disable Battery Status Notifications

	About the Diagnostic Information App
	How to View Connection Information
	How to View System Memory Statistics
	How to View SysInfo
	How to View Information About Integrated and Connected Devices
	How to View Information About the Computer

	About ConfigApps
	Enable or Disable Applications
	Uninstall Updates


	Reference Charts
	ASCII Conversion Chart (Code Page 1252)
	Symbology Chart
	Country Codes



